12 Kwietnia 2024 14:48:13
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· dodatkowe złącza s...
· Szukam zaproszenia n...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [Howto] Xpenology na...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· Jaki USB hub do syno...
· [S] Karta sieciowa Q...
Najpopularniejsze obecnie wątki
· Szukam zaproszeni... [10]
· RT-N18U - nie mo... [3]
· dodatkowe złącz... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.238.174.191
Zobacz wątek
 Drukuj wątek
Nextcloud konfiguracja fttps
pelermo
Pytanie nr.1
Czy jest ktoś w stanie mi pomóc z konfiguracja https w nextcloud ?

Jeśli wchodzę w ustawienia administracyjne to mam taką informację:

Cytat:
Występują błędy dotyczące konfiguracji.
Niebezpieczny dostęp do witryny przez HTTP. Zdecydowanie zalecamy skonfigurowanie serwera tak, aby wymagał protokołu HTTPS, zgodnie z opisem w wskazówkach dotyczących bezpieczeństwa ↗. Bez tego niektóre ważne funkcje internetowe, takie jak "kopiuj do schowka" lub "pracownicy usług" nie będą działać!


Chciałbym skonfigurować to ponieważ niektóre funkcję nie są dostępne. Próbowałem sam coś ogarnąć ale nic mi nie wychodzić, ustaliłem tylko że zamiast korzystać z apache korzystam z Nginx Wink

Pytanie nr.2
Mam miniPC na którym jest zainstalowany omv największym jego minusem jest posiadanie tylko jednego portu sata. Obecnie mam dysk HDD podłączony do sata i na nim system a drugi dysk HDD na dane podłączony pod USB. Czy lepszym rozwiązaniem byłoby kupienie np. Dysku 1tb SSD i żeby służył jako systemowy oraz na dane ? Jeśli rozchodzi się o awaryjność to trudno nie przechowuje tam danych za którymi bym płakał przy awarii Wink
 
Adooni
pytanie 2. nie Smile lepiej to system OMV postaw na USB nawet mozesz na kacie SD/TF w OMV jest moduł który zmniejsza używanie dysku systemowego przewidzieli to. Moesz tam nawet zrobic backup karty SD i jakby padla podmieniasz na 2. Ja mialem w jednej lokalizacji OMV na pendrive przez 5lat. Przeciez nie robi dużej róznicy czy po resecie OMV wstanie w 5 czy 30s Smile NAS pracuje 24/7

a dane na SATA aby dobry tranfer miec
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
pelermo
Zainstalowałem na pendrive system ogólnie to masakra instalował się, 1.5h po instalacji nie mogłem się zalogować przez panel www nawet długo trwało logowanie się przez, ssh więc postanowiłem zainstalować system na jednym dysku lecz nie wiem jak mam podzielić go na partycje. Jedna partycja na system reszta na dane. Przy instalacji omv wyświetla mi że automatycznie może mi podzielić na partycje lecz jeśli chce zrobić to ręcznie mam wybrać "nie" wybieram "nie" i cały czas to polecenie się zapętla.

Już sobie poradziłem, użyłem gparted ustawiłem takie partycje jakie chciałem i jest git Wink ale i tak dziękuję za odpowiedź
Edytowany przez pelermo dnia 04-02-2024 23:29
 
shibby
nextclouda masz jak postawionego? Tradycyjne apache+php+mysql czy w dockerze?
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
Adooni
hm ciekawe np na mailce dużo ludiz tak robi https://www.reddit.com/r/OpenMediaVau...?rdt=64053

sam kiedys OMV 5 tak stawialem i nie było problemu chyba ze cos nei tak jest z penem
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
pelermo
Wczoraj kupiłem i włożyłem nowy dysk, wybór padł na ssd WD as500 producent twierdzi że jest to dysk przeznaczony do serwerów NAS więc z czasem zobaczymy jego awaryjność Wink ale do rzeczy, zainstalowałem nowy system no i oczywiście już się po aktualizacji pozmieniało. Żeby zainstalować omv extrs korzystałem z tego poradnika https://forum.openmediavault.org/index.php?thread/48797-16-steps-to-install-the-new-compose-plugin-and-add-portainer/

Miałem problem ponieważ jak chciałem zainstalować portainer to wywalało mi błąd error 500 później pozmieniałem lokalizację plików i jakoś poszło. Ogólnie muszę się trochę pobawić ponieważ niby jest łatwo i tak samo po aktualizacji ale tak nie jest Wink więc jeśli macie jakieś porady co do instalacji omv extras, docker oraz portainer to z chęcią z nich skorzystam
 
zakk87
w nowej wersji OMV nie potrzebujesz portainer'a ponieważ zaimplementowano natywną obsługę którą masz w usługach. nazywa się Compose.
Freshtomato 2024.1 AIO @ RT-AC66U_B1
OpenWRT 23.05 @ DIR-878
NAS OMV [CoolerMaster ELITE 110] [J1900I-C] [4GB RAM] [Toshiba HDWD130 + Hitachi 5K3000]
 
pelermo
Czyli w compose wybieram z listy np. Nextcloud lub qbittorrent i instaluje się z automatu ?
 
zakk87
nie, tak to nie działa. Musisz w Files wkleić konfigurację kontenera pobraną z hub.docker.com
np. wyszukujesz transmission/qbittorrent czy co tam Cię interesuje, kopiujesz config, wklejasz w okienku dodawania w compose i edytujesz ścieżki, hasło itp.
Później dajesz zapisz, Up albo pull i dzieje się magia.
Ogólnie jest dużo tutoriali na yt jak ogarnąć dockera.
Edytowany przez zakk87 dnia 06-02-2024 13:51
Freshtomato 2024.1 AIO @ RT-AC66U_B1
OpenWRT 23.05 @ DIR-878
NAS OMV [CoolerMaster ELITE 110] [J1900I-C] [4GB RAM] [Toshiba HDWD130 + Hitachi 5K3000]
 
pelermo

shibby napisał:

nextclouda masz jak postawionego? Tradycyjne apache+php+mysql czy w dockerze?


Kolego shibby jesteś w stanie mi pomóc ? Właśnie postawiłem świeży, zaktualizowany system i zainstalowałem tylko nextcloud w najnowszej wersji. Instalacje przeprowadziłem przez "prawdopodobnie przez docker" compose wklejając :

version: '2'

services:
  db:
    image: mariadb:10.5
    restart: always
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
    volumes:
      - /srv/dev-disk-by-uuid-6a796bd0-28b5-4169-9b10-884794038368/nextcloud/Nextcloud_Database:/var/lib/mysql
    environment:
      - MYSQL_ROOT_PASSWORD=xxx
      - MYSQL_PASSWORD=xxx
      - MYSQL_DATABASE=xxx
      - MYSQL_USER=xxx

  app:
    image: nextcloud
    restart: always
    ports:
      - xxx:xxx
    links:
      - db
    volumes:
      - /srv/dev-disk-by-uuid-6a796bd0-28b5-4169-9b10-884794038368/nextcloud/Nextcloud_Application:/var/www/html
    environment:
      - MYSQL_PASSWORD=xxx
      - MYSQL_DATABASE=nextcloud
      - MYSQL_USER=xxx
      - MYSQL_HOST=db


W 100% nie jestem pewien ale zamiast apache używam nginx. Pomożesz ?
Edytowany przez pelermo dnia 07-02-2024 22:10
 
shibby
nie stawiałem nextcloud przez dockera. Nie lubię tego typu rozwiązania bo jest ono ciężkie do późniejszej aktualizacji - nextcloud można podnosić max 2 wersje do góry. Jeżeli więc np mając dziś wgraną wersję 28 za rok będziesz chciał podnieść do np 36 to łatwiej ci będzie zaorać wszystko i postawić na nowo niż próbować to migrować przez kolejne wersje

Druga moja rada to zamiast dysków dockerowych przy volumenach lepiej mapować katalog bo w razie "w" masz bezpośredni dostęp do danych.

W powyższym przykładzie wydaje mi się że najłatwiej będzie użyć reverse proxy by szyfrować połączenia, np “Nginx Proxy Manager" - również do postawienia w dockerze.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
pelermo
cały czas walczę z https w nextcloud. Zleciłem to komuś z pewnej grupy na Fb lecz straciłem tylko pieniądze ponieważ gość niby ustawił połączenie https lecz coś zrobił nie tak bo połączenie było niestabilne i zrywało. Musiałem zabrać się samemu za to, udało mi się wygenerować certyfikaty cerbot'em lecz nie mam pojęcia jak je wdrożyć do nextcloud. Wydaje mi się że nextcloud jest zainstalowany w innym miejscu niż docelowe i trzeba wskazać gdzieś ścieżkę dostępu ale nie mam pojęcia gdzie to się robi. Jeśli jest ktoś w stanie mi pomóc proszę o krótką informacje co i jak.
 
shibby
pisałem już

Cytat

W powyższym przykładzie wydaje mi się że najłatwiej będzie użyć reverse proxy by szyfrować połączenia, np “Nginx Proxy Manager" - również do postawienia w dockerze.


Ew. musisz przekazać wygenerowane certyfikaty do dockera i w contenerze dockerowym zmodyfikować plik serwera www (apache lub nginx) tam by obsługiwał dla tej domeny szyfrowane połączenia

Pierwszy lepszy wynik z google
https://help.nextcloud.com/t/howto-ru...ker/101973
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
pelermo
Udało się przekierować połączenie z http na https przez nginx proxy manager lecz jest jeden mały problem. Po przekierowaniu połączenia https na nextcloud to inne usługi po wpisaniu domena: port nie chcą się ładować. ładują się tylko w trybie incognito. Wyjątkiem jest tylko ten nextcloud ponieważ po wpisaniu samej domeny bez portu strona się ładuje
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 9

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

tamtosiamto
19-03-2024 19:50
@Adooni 'Only one set is available for 1 band' i tak mam-1 set dla 2.4ghz i 1 dla 5ghz-czy czegos nie rozumiemW drugiej sieci goscinnej nie ma opcji wyboru Ruter only/ All nodes

Adooni
19-03-2024 19:14
no to przeczytaj to 2 pod - 1 stet z kazdego pasma jest dopuszczony na nody. zrob 2 siec jako goscinna na danym pasmie i wtedy sprawdz

71,004,650 unikalnych wizyt