14 Czerwca 2024 17:55:35
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [HOWTO] OpenVPN serv...
· [MOD] FreshTomato-AR...
· [S] edgerouter er-12
· [MOD] Tomato64 (x86-64)
· Dostęp do urządzen...
· Switch zasilany prze...
· Brak dostępu do ust...
· Takedown 2000
· [MOD] FreshTomato-MI...
· [Howto] Xpenology na...
· [HOWTO] Kompilacja "...
· nju swiatło pytania
· konfiguracja router ...
· Asus TUF-AX3000_V2 p...
· Jaki router kupić? ...
· Szukam zaproszenia n...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Firewall nie zawsze ...
· Optware na CIFS
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [881]
· [HOWTO] OpenVPN s... [14]
· [S] edgerouter er-12 [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [217 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 417
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.236.116.27
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] Tomato64 (x86-64)
H3x
A ten WAN miałeś na passthrough czy bridge? Ja mam mostek i obawiam się, że to może być wina OMV albo KVM.
 
shibby
Bridge ale na potrzeylby vlanow musiał zrobić mostek ovs z tego co pamietam
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
dragmar
Tomato to zawsze był system GUI. Jak zmienić br0 z konsoli, aby mieć dostęp do gui.

Wiem że dostęp do gui to 192.168.1.1. ale chce go zmienić

Scalony z 30 stycznia 2024 12:59:21:
Rozumiem, że pytanie było .....
Ale poradziłem sobie, zmiania to wpis :

nvram set lan_ipaddr=x.x.x.x
Edytowany przez dragmar dnia 30-01-2024 12:59
W8/Linux
 
gandalf

djwujek napisał:

Próbuję odpalić to na virtualboxie ale cały czas wyskakuję mi że eth1=cmd13 non suported o co kaman ?


Mam to samo w proxmox'ie. Ta sama wersja tomato64.
Asus RT-AC68U Asuswrt-Merlin 384.9
+ HDD 1TB --- OwnCloud 8.0.11
APC UPS 700
QNAP 251 (16GB RAM) - 12TB
 
shibby
Powiedziałbym że wszystko w porządku Smile
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
cold_demon
Witam, jest szansa ze pojawi się FreshTomato w wersji x86 ?
 
shibby
Tomato x86 jest branchem z FreshTomato Smile
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
cold_demon
Tak jeszcze dla pewności zapytam, Tomato x86 wersja do instalacji na PC to z tego adresu pozycja 2 ?

https://github.com/tomato64/tomato64/releases/tag/2024.1

Czy jest jakaś inna strona tego projektu ?
 
shibby
to jest oficjalna strona projektu: https://tomato64.org/

ale jak wejdziesz sobie w sources to zobaczysz, że link prowadzi to tego repozytorium do którego ty się odwołujesz.

plik img wypadasz na pendrive i w sumie tyle, bo z pendrive wtedy bootujesz całe tomato (nie potrzebujesz dysku).

BTW nie wiem czy czytaliście, tomato64 dostało obsługę do 8 bridge i do 8miu interfejsów LAN, wraz z autodetekcją ile interfejsów LAN mamy podpiętych - jak ktoś ma wirtualkę z 2ma interfejsami (1 port WAN i 1 port LAN) to interfejs się dostosuje do tego. Ale jak ktoś sobie kupi chińczyka z 6ma LANami albo zbuduje kompa z 8ma to też mu ładnie to zadziała Smile Zmiana bardzo na plus, zważywszy na to, że dotychczas tomato miało na sztywno 5 interfejsów (wan i 4x lan)
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
cold_demon
Dzięki shibby za odpowiedź Smile

Fajnie że pojawiło się Tomato64 bo mój Asus RT-N18U ma już swoje lata i może w każdej chwili zakończyć żywot, a nowych routerów pod Tomato coraz mniej do wyboru.
Do tej pory miałem w rezerwie kompa z Gargoyle a teraz będę mógł sobie zrobić porządny sprzęt na Tomato z 4 lub 8 portami LAN i pozbyć się jednego switcha.

Macie jakieś sprawdzone karty 4xLAN 1 Gbit i 2.5 Gbit od chińczyków ? W przypadku 2.5 Gbit to wiem ze trzeba kupować sprzęt na i226.
 
gandalf
Ostatnio udało mi się uruchomić na proxmoxie tomato64.
Trochę potestowałem, przypomniałem sobie parę rzeczy.
Na koniec wyłączyłem wszystko. Dzisiaj chciałem przeprowadzić próbę aktualizacji.
Jednak z jakiegoś powodu straciłem dostęp do interfejsu www proxmoxa.
Asus RT-AC68U Asuswrt-Merlin 384.9
+ HDD 1TB --- OwnCloud 8.0.11
APC UPS 700
QNAP 251 (16GB RAM) - 12TB
 
shibby
Musiałbyś rozwinąć problem. Głównie jak miałeś interfejsy ustawione dla tomato64 w proxmoxie

Scalony z 31 marca 2024 15:11:41:
Btw, no i nie wiem czy czytałeś info w nowym wydaniu gdzie przed aktualizacją trzeba było wykonać jakieś komendy by dostosować interfejsy do nowej funkcjonalnosci.

Mam wirtualne przygotowana sprzed kilku miesięcy to spróbuję ją podnieść jak wrócę ze świątecznego wyjazdu.
Edytowany przez shibby dnia 31-03-2024 15:11
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
gandalf
Tomato64 mam postawione na moim testowym serwerku.
Dzisiaj trochę posiedziałem i doszedłem do tego, że dostęp do interfejsu proxmoxa mam ale tylko na jednym z czterech portów rj45.
Asus RT-AC68U Asuswrt-Merlin 384.9
+ HDD 1TB --- OwnCloud 8.0.11
APC UPS 700
QNAP 251 (16GB RAM) - 12TB
 
shibby
zrób tak:
- domyślnie pod proxmoxem masz interfejs vmbr0 i na nim IP do zarządzania - wepnij tu pozostałe interfejsy (po spacji) pomijając jeden który chcesz by był WANem
- następnie stwórz pod proxmoxem vmbr1 i wepnij tu jeden port - to będzie twój WAN
- zaaplikuj zmiany
- w wirtualce tomato64 dodaj dwie sieciówki: najpierw vmbr1 (wan)!! i jako drugą vmbr0 (lan) - wan musi być pierwszy jeżeli nie chcesz później mieszać w tomato.
- w ten sposób tomato będzie widziało tylko 2 interfejsy (wan i lan) a spinaniem interfejsów LAN w bridge będzie zajmował się proxmox.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
gandalf

shibby napisał:

zrób tak:
- domyślnie pod proxmoxem masz interfejs vmbr0 i na nim IP do zarządzania - wepnij tu pozostałe interfejsy (po spacji) pomijając jeden który chcesz by był WANem
- następnie stwórz pod proxmoxem vmbr1 i wepnij tu jeden port - to będzie twój WAN
- zaaplikuj zmiany
- w wirtualce tomato64 dodaj dwie sieciówki: najpierw vmbr1 (wan)!! i jako drugą vmbr0 (lan) - wan musi być pierwszy jeżeli nie chcesz później mieszać w tomato.
- w ten sposób tomato będzie widziało tylko 2 interfejsy (wan i lan) a spinaniem interfejsów LAN w bridge będzie zajmował się proxmox.


Czyli już wiem gdzie popełniłem błąd. Dzięki bardzo za wskazówki.
Testuję dalej i może niedługo uda się połączyć tomato z ubiquiti.
Asus RT-AC68U Asuswrt-Merlin 384.9
+ HDD 1TB --- OwnCloud 8.0.11
APC UPS 700
QNAP 251 (16GB RAM) - 12TB
 
arkadyj
Cześć

Może ktoś będzie miał pomysł jak rozwiązać mój problem z Tomato64. Mam mini komputer z celerona J4125 wraz z dwiema kartami sieciowymi RTL8168/8111. Na dysk wrzuciłem obraz Tomato. Wszystko działa dobrze z jednym, dosyć dużym zastrzeżeniem. Połączenie WAN z Orange co chwila jest rozłączane i zestawiane ponownie ( otrzymuje adresy, raz nawet udało mi się wykonać speedtest). Miał ktoś podobny problem i udało się go rozwiązać? A może macie jakieś sugestie co mógłbym sprawdzić.
 
shibby
sprawdź w /var/log/messages oraz w (komenda) dmesg czy sterownik do sieciówki jakimiś błędami nie sypie.

Jak masz podłączony ten Orange? On idzie z funboxa czy z ONT? Jak masz WAN ustawiony? DHCP czy PPPoE na VLANie 35. Jak VLAN to pokaż jego konfigurację.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
arkadyj
Udało się. Dziś lub przed kilkoma dniami wyszła wersja 2024.2 i to ją wrzuciłem na dysk. Musieli coś w niej poprawić bo już nie mam problemu z rozłączaniem Internetu.

Jedyne co nie działa to DDNS. Zwykle jako serwis wybierałem Custom URL, wpisywałem adres z danymi połączenia i działało. Teraz natomiast cokolwiek bym nie wybrał, nic się nie zmienia. Nie pojawia się żadne pole do wpisania czegokolwiek. To ciekawe, ponieważ na FreshTomato działało to bardzo dobrze.

Dziękuję Ci shibby, że się zainteresowałeś moim postem. Gdyby nie Ty, pewnie nie chciało by mi się ponownie wrzucać obraz na dysk i testować.
 
shibby
zobacz pod F12 w przeglądarce czy strona DDNS nie generuje ci błędu, bo może jest jakaś literówka w kodzie podczas używania custom URL.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
arkadyj
Następnego dnia wszystko wróciło do normy, więc naprawdę super.

Mam nadzieję, że projekt przetrwa. TomatoAnon pokazuje jedynie 27 zarejestrowanych urządzeń. W końcu mogę wykorzystać w pełni możliwości łącza. Wcześniej na AC56U bez CTF na 800MHz CPU osiagałem jedynie 270Mb/s. Po podkręceniu do 1200MHz było to 340Mb/s. Trochę nowszy AC88U potrafił osiągnąć 540Mb/S. Aktualnie na Celeron(R) J4125 CPU @ 2.00GHz jest to trochę ponad 900Mb/s

Jestem ciekaw jak wygląda zarządzaniem CPU w przypadku Tomato64. Na zakładce Overview jest napisane szybkość CPU 800MHz. Zapewne wynika z tego, że jest to minimalna prędkość na jakiej CPU może pracować. Jednak, gdy obciążam router do np 40% taktowanie CPU nie rośnie. I teraz pytanie czy MHz nie rosną, ponieważ nie ma takiej potrzeby, czy Tomato ustawia CPU na 800MHz i już nie podbija zegarów wyżej.
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 38

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
03-06-2024 16:24
poszlo w koncu -najpierw przez restoration jakies stare ddwrt, potem z menu update plik ac66u z art o zmianie 868l->ac66u

tamtosiamto
02-06-2024 21:44
trx size 44560384 > memory size 33554432 nigdy czegos takiego nie widzialem podczas flashowania rutera

tamtosiamto
02-06-2024 21:37
wgrywanie ddwrt z opisu zmiany softu z dlinka na asusa nic nie daje, dalej startuje tomato, wgranie ddwrt dla ac66u wchodzi, ale z niego tez nie da sie wgrac ofw asusa i merlina, kicha

tamtosiamto
02-06-2024 19:57
Probowal ktos wrocic z tomata do OFW ASAUSa na przerowbionym DIR868l -> rt-ac66u ? Ni cholery nie moge dac sobie rady.

RaTaJ
10-05-2024 15:43
Czy intel n100 4x 3,40Ghz z Intel HD i DDR5 byłby dobry, widziałem za 550zł z 8gb ram i ssd 512gb?

Adooni
26-04-2024 14:41
jaki router RMerlin nie pociagne, tomato/ openwrt tak non hilink,

tamtosiamto
23-04-2024 12:35
modem bez smilocka?

man1
22-04-2024 23:27
Czy próbował ktoś uzywac karty voice (z nolimit GB) od tmobile w modemie /routerze? Da się jakoś to zrobić? Bo u mnie neta brak. E3372 Sad

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

72,998,211 unikalnych wizyt