04 Grudnia 2022 02:08:48
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Asus RT-AX56U i dzwi...
· [ARM] po włączeniu...
· Połączenie site 2 ...
· ASUS RT-AX88U wgrywa...
· airport extreme Mode...
· [MOD] FreshTomato-AR...
· Asus RT-AC66U (mips)...
· Moze ktoś z was ma ...
· Problem z wejście d...
· Asus Merlin
· Huawei B818-263 jaka...
· Huawei B818-263 czy ...
· Reanimacja ASUS RT-A...
· NordVPN - zrywa poł...
· Router
· [S] Unifi U6-PRO acc...
· Black Week od shibby
· [S] Sprzedam Router ...
· Rozszerzenie pokryci...
· Internet w Orange......
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [744]
· Reanimacja ASUS R... [12]
· Moze ktoś z was ... [7]
· ASUS RT-AX88U wgr... [6]
· Problem z wejści... [6]
· Huawei B818-263 c... [6]
· Połączenie site... [2]
· NordVPN - zrywa p... [2]
· Asus RT-AX56U i d... [1]
· [ARM] po włącze... [1]
· Asus Merlin [1]
· airport extreme M... [0]
· Asus RT-AC66U (mi... [0]
· Huawei B818-263 j... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [149 głosów]

Broadcom ARM
Broadcom ARM
52% [210 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
3% [14 głosów]

Ogółem głosów: 407
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
35.172.224.102
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-ARM - wątek deweloperski
KuteK

Adooni napisał:

a czy to samo masz na FireFox - edge tak samo jak chrome niby ze bazuja na chromium obie sa warte mniej niz zero. Jak juz chcesz cos podobnego do Edge/ Chrome to pocecam SRWare Iron

ogolnie to jest zasada ze jak cos nie dziala na przegladarce X to sprawdza sie czy to samo jest na Firefox - i dopiero wtedy wiemy czy jest wyzwanie czy nie.


Tak jak wspominałem wcześniej sprawdzałem na różnych kompach i przeglądarkach. Sprawdzałem na świeżo zainstalowanej operze i wisiało, teraz na świeżo zainstalowanym firefoxie też wisi:
i.postimg.cc/kGnW7Yf1/firefox.png

amikot napisał:

Nawet jeśli to zadziała na Firefox, to wcale nie oznacza że błędu nie ma.

Problemem jest to, że błąd wydaje się występować tylko u kol. KuteK.

Nie jestem jedyny - chwilę wyżej kolega qwerty321 wspomniał o identycznym problemie.

Jeżeli to ma pomóc to problem pojawił się w okolicy wersji 2021.1 albo 2021.2 - gdzieś gdzie w changelogu było info o modyfikacjach zakładki basic.
 
amikot
A ja właśnie zauważyłem inny błąd.
Od wieków nie zmieniałem ustawień WiFi, ale dzisiaj postanowiłem to zrobić i zauważyłem że mój Linksys EA6900 dla Radia 5GHz odmawia ustawienia kanału innego niż 36 (sideband lower) lub 44 (upper). Nie ma przy tym znaczenia szerokość pasma - tak samo się dzieje przy 20Mhz jak i przy 40Mhz.
80Mhz można wybrać i po zapisaniu pokazuje że jest 80Mhz (kanał Auto - nie ma wyboru), ale de facto każdy network scanner pokazuje szerokość 40Mhz jedynie. Mimo że sieci sąsiadów wykrywa szerokie na 80Mhz.
W takiej sytuacji mam problem, bo kanały 36 i 44 są u mnie dość mocno obsadzone.
Problem ten nie występuje na drugim routerze - znaczy na WNDR4500 - no ale on jest na Tomato z gałęzi MIPS.

Scalony z 20 sierpnia 2021 14:56:32:
OK... Niewazne - to był zły region ustawiony. Musialem zapomnieć przy którymś apdejcie zmienić.
Edytowany przez amikot dnia 20-08-2021 14:56
Virgin Media Hub 3
Linksys EA6900 v1.1 - Fresh Tomato 2022.3 AIO
Netgear WNDR4500 - Fresh Tomato 2021.5 AIO
Xpenology HP Microserver N54L - DSM 7.0.1
 
Bb
DualWan też mi się wieszał jak u kolegów wyżej. Ale myślałem że to coś z moim komputerem i odpuściłem temat. Wy po czyszczeniu nvram nie musicie w failsafe dodawać wpisu httpusername? Jeśli nie to jak się logujecie?

Co można zrobić z żałosną wydajnością OpenVPN? Routery RT-N18U, na WAN po 100MBit. Cipher wybrany na AES-128-CBC. Serwer i client na tych routerach. Wydajność tunelu to max 5Mbit. Kompresja wyłączona, obciążenie CPU max 10%.
 
Adooni
nic, najnowszy router AX86U (proc 1.8 GHz arm i wspomaganie sprzetowe) wyciaga na OpenVPN 200-250Mbit. OpenVPN dziala na 1 rdzeniu tylko. N18U - 800MHz i brak wspomagania sprzetowego. Jka nic innego N18U nie robi to OpenVPN moze wyciagnie 25-50Mb (nigdy nie testowalem)- zakladajac ze RT-N16 wyciagal 10Mbit.

dual WAN to nie wiem w czym problem ale AsusWRT i RMErlin tez to nie dziala jak powinno tz dziala WAN + USB ale nie WAN + LAN(jako 2 WAN)
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 22.7.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
Bb
No ok, tylko że obciążenie CPU w czasie transferu tych 5MBit/s sięga max 10% więc zapas jest. Router w zasadzie nic innego nie robi poza zbieraniem statystyk i funkcją serwera dhcp i dns. Rozumiem że CPU jest ograniczeniem, ale co innego jakby dobijał do 100%, tutaj tak nie jest. 25MBit byłoby zupełnie wystarczające. Czy PPTP będzie wydajniejsze?
 
Adooni
to jest watek developerski wiec raczej nie miejsce na takie pytania - poczytaj sobie w dziale Ubiquiti (EdgeRouter, Unifi) i zmien router Smile
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 22.7.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
Bb
Ok, zatem pytanie o pptp wycofuję. W wątku developerskim chyba można zgłaszać problemy z wydajnością OpenVPN czy problem po czyszczeniu nvram. Zmień router - hmmm, na pewno? Skoro CPU się nudzi? Może warto się temu przyjrzeć skoro nie tylko ja mam taki problem a temat niskiej wydajności mimo braku obciążenia CPU ciągnie się odkąd wrzucono openvpn do Tomato. Tyle że w N18U jest wyjątkowo słabo. Większe prędkości miałem na stareńkim GL1600 z CPU 240MHz.
 
Adooni
tutaj masz odpowiedz https://eko.one.pl/forum/viewtopic.ph...p?id=17025
post byl na naszym forum warto uzyc szukania https://openlinksys.info/forum/viewth...d_id=21631
tutaj ktos uzyskal 13Mbit a na ori sofcie 20Mbit wiec to wszystko co sie da. Na alternatywnym sofcie zawsze jest wolniej gdyz nie ma dostepu do nowszego kernela itd.
chesz sprawdzic VPN to podlacz pod router tylko PC, wylacz wi-fi - przeciez w RT-N18U nie ma oddzielnego procka wi-fi itd
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 22.7.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
Bb
Ok, dziękuję za odpowiedź. Zatem niewykorzystanie mocy procesora nie jest błędem tylko właściwością tego rozwiązania? Dziwne to trochę. Choć 13Mbps już by było lepsze niż 5. Chyba że obciążenie CPU jest źle wskazywane. No ogólnie jednak coś jest nie tak z integracją openvpn w Tomato.

PS. Wifi jest wyłączone.
 
pedro
Ale co chcesz "integrować"?
OpenVPN działa w userspace i możesz zapomnieć o większej wydajności na procesorze nawet 1GHz, pamiętając również że nawet na takim RT-AC3200 (którego m.in. posiadam [ovpn max ~45Mbits]) gdzie jest 2x1GHz, wykorzystywany jest i tak jeden rdzeń (pretensje kierować do deweloperów OpenVPN). I jeszcze brak akceleracji sprzętowej AES-NI...

Natomiast jeśli na RT-N18U uzyskujesz 5Mbits max, to na pewno masz włączoną kompresję, która jeszcze bardziej (niepotrzebnie + niebezpiecznie -> poczytaj o CVE na to) obciąża system.

Dużo też zależy od wybranego szyfrowania, ale to wciąż nie jest temat tego wątku.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Bb

pedro napisał:

to na pewno masz włączoną kompresję, która jeszcze bardziej (niepotrzebnie + niebezpiecznie -> poczytaj o CVE na to) obciąża system.
[/b].


Kompresja wyłączona. Bez zmian w wydajności niezależnie od tego czy włączona czy wyłączona.

Wiem że to nie temat tego wątku, ale sądziłem że to jest problem z Tomato więc go zgłaszam.

pedro napisał:


OpenVPN działa w userspace i możesz zapomnieć o większej wydajności na procesorze nawet 1GHz, pamiętając również że nawet na takim RT-AC3200 (którego m.in. posiadam [kopn max ~45Mbits]) gdzie jest 2x1GHz, wykorzystywany jest i tak jeden rdzeń (pretensje kierować do deweloperów OpenVPN). I jeszcze brak akceleracji sprzętowej AES-NI...


OpenVPN wykorzystuje 1 rdzeń - ok. Tu mam zegar 800MHz, niechby choć 20MBps było....

Scalony z 30 sierpnia 2021 19:15:31:
RX 1.68 Mbit/s
(0.21 MB/s) Avg 3.17 Mbit/s
(0.39 MB/s) Peak 182.65 Mbit/s
(22.30 MB/s) Total 32.66 GB
TX 0.04 Mbit/s
(0.00 MB/s) Avg 0.06 Mbit/s
(0.01 MB/s) Peak 0.07 Mbit/s
(0.01 MB/s) Total 620.47
Statystyki tunelu z ostatnich 24 godzin. Leci tym rsync między serwerami. połączone bez tunelu rsync idzie z pełną prędkością WAN. Ten peak to jakiś błąd.
Edytowany przez Bb dnia 30-08-2021 19:15
 
pedro
Tyle co mogę Ci powiedzieć, to gdy głównym routerem był u mnie RT-N18U, to miałem coś ok. 20Mbits z OpenVPN.
Więc polecam założyć nowy temat, z problemem co masz w ustawieniach nie tak.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
turbopecet
Witam, mam dwie lokalizacje połączone po vpn w trybie TAP. Rutery EA6900 obecnie wgrane FT2021.5. Nowe ertyfikaty z OVPN 2.5.3. Problem pojawił się gdzieś od wersji 2021.1 lub 2021.2 a polega on na tym, że ruter pełniący rolę serwera vpn po pewnym czasie przestaje odpowiadać na ping i nie mogę dostać się do panelu konfiguracyjnego. Tunel jest nadal połączony, komputery widzą się po obu stronach. Wystarczy, że na chwilę wyłączę server lub clienta vpn i połączę ponownie wtedy serwer vpn zaczyna odpowiadać. W logach znalazłem jedynie to:

client1 kern.warn kernel: net_ratelimit: 88 callbacks suppressed

Ogólnie mam cztery rutery EA6900 do testów, próbowałem je zamieniać miejscami, niestety nic to nie dało. Czyszczę nvram przed i po wgraniu nowego softu. Raczej niemożliwe, że wszystkie są uszkodzone. Konfiguracja vpn praktycznie bez zmian od tomato by Shibby.
 
jurekk
Na oryginalnym cfe (taki bios routera) zle funkcjnuje firmware trzecich firm .
Dotyczy to i tomato.
To specjalny zabieg producenta.
Jest bardzo mało mijsca na nvram (ograniczono je)
trzeba w ryzykownej procedurze podmienić cfe lub używać wersje vpn nie aio i właczac tylko takie opcje w toamto kotre sa koniecznie potrzebne. Zajecie nvram powyzej 32k powoduje rozne artefakty do miekkiego uceglenia wlacznie.
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh, amtm
 
Bb
O, ciekawe co piszesz. Coś więcej? Poza tym że średnio co rok muszę od nowa ustawiać Tomato bo routing zdycha to nie widzę nic niepokojącego. A być może właśnie to jest powodem takiego zachowania tego softu. W RT-n18u jest 64kB nvram, wolnego miejsca mam ok 1kB we wszystkich (Klucze client/server OpenVPN). Stabilność wzorcowa. Ostatnio restartowałem jeden z routerów po 250 dniach uptime - po 400GB/mc, z tego ok 50GB przez OpenVPN. A restartowałem nie z potrzeby a dla testu skryptu startowego.
 
turbopecet
CFE wgrane od XVortex na wszystkich ruterach. Na dwóch zaktualizowane do wersji 1307. Aktualnie mam zajęte ok. 40kB nvram.
 
jurekk

Bb napisał:

wolnego miejsca mam ok 1kB we wszystkich (Klucze client/server OpenVPN).

kojarze że ludzie trzymali klucze na JFFS lub na usb jak brakowało nvrm
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh, amtm
 
qrs
wgrałem 2021.5 K26ARM USB AIO-64K i mam 2 małe błędy:

1. przy DDNS

images91.fotosik.pl/535/a4f683daba281c8cmed.jpg

2. przy macvendors.com

images92.fotosik.pl/536/dc35e1fa99fadcb6.jpg

wszystko inne poza IPv6 (6in4) działa

Scalony z 07 września 2021 17:28:57:
próbowałem rozwiązać 1 problem poprzez dodanie

nvram set ddnsx0_cache=1477968571,XXX.XXX.XXX.XXX

ale bez skutku :(

Scalony z 07 września 2021 17:41:03:
błąd 1 naprawiony :D
Edytowany przez qrs dnia 07-09-2021 17:41
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
ovner
@qrs odnośnie drugiego błędu miałem to samo i powodem było to, że bawiłem się routerem bez podłączonego WAN.
www.my-navia.pl/images/signatures/6922773954991dec6ca370.gif
www.speedtest.net/result/6386887502.png
 
pedro
...Albo router jest w WDS, zgadza się?
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 18

· Użytkowników online: 0

· Łącznie użytkowników: 24,114
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

PixelPL
03-12-2022 16:29

tamtosiamto
02-12-2022 07:37
https://tiny.pl/wf
7d6
Okazja do pozbycia sie c+ bez kar umownych

Maniek91PL
16-11-2022 19:59
po ile realnie są edgerouter ER-6P ? i edgeswitch 10x ?

tamtosiamto
16-11-2022 07:19
Przeczytaj uwaznie, o co pytalem, a raczej co stwierdzilem

Adooni
14-11-2022 23:04
przeciez napisalem ze juz nie ma w Orange umowy bez FB

tamtosiamto
14-11-2022 09:16
Adooni nie chodzi o opcje z fb czy bez, tylko w umowie ma byc cena podana za dzierzawe, jak byla i wziales to musisz niestety placic

belliash
14-11-2022 08:13
(...) z prawem. Wielu operatorów już się przejechało na dokładaniu do umowy niechcianych usług na siłę.

belliash
14-11-2022 08:12
Ja za FB akurat nei płacę, ale też z niego nie korzystam - leży w pudełku. Wystarczy mi ONT. Niemniej zastanowić się należy, czy takie wciskanie urządzenia na siłę za dodatkową opłatą jest zgodne z pr

Adooni
13-11-2022 21:31
nie ma w orange opcji bez FB.

tamtosiamto
13-11-2022 19:31
Jak nie bylo w umowie wzmianki o 3.99 to zerwac umowe, a jak byla, ale czytac sie nie chcialo to cierpiec do konca umowy

57,843,637 unikalnych wizyt