21 Października 2021 15:58:02
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [MOD] FreshTomato-AR...
· Przepustowość łą...
· Problemy z WiFi
· [S] ASUS RT-AC66U
· Jaki router wybrać-...
· [HOWTO] Kompilacja "...
· [MOD] FreshTomato-MI...
· Włączenie interfej...
· Własny NAS na Xpeno...
· pi-hole na tomato?
· Słaby zasięg Synol...
· IPS i EoIP
· Asus RT-AX55 vs RT-A...
· Udostępnienie inter...
· Proxmox pytania
· niepoprawny timestam...
· OpenVPN - problem z ...
· nie odtwarza po LAN
· Połączenie bez zew...
· [Zapowiedź] Kompute...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [632]
· [MOD] FreshTomato... [331]
· Jaki router wybra... [55]
· Własny NAS na Xp... [41]
· Przepustowość ... [8]
· [S] ASUS RT-AC66U [4]
· [HOWTO] Kompilacj... [4]
· Problemy z WiFi [2]
· Włączenie inter... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [146 głosów]

Broadcom ARM
Broadcom ARM
52% [204 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 393
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.80.3.192
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-ARM - wątek deweloperski
qrs
odnośnie Bootloader (CFE) - jeśli można go zaktualizować ale do max wersji na której będzie działać Tomato to właśnie do której wersji można go zaktualizować?
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jurekk
Co do zasady bootloaderów sie nie aktualizuje. Sa następne wersje wydane przez asusa ale one sie nie aktualizują, miałem ac56u i był stary loader mimo ze wyszły już nowsze . Można to zrobić ręcznie. Staszek tu ćwiczył temat kiedyś.
Zauważ , ze uwalenie bootloadera trwale ucegla router. Jedyny sposób to przeprogramowanie mu pamieć (rom) identycznie do płyt głównych . Ale to by trzeba być elektronikiem i mieć kopie pamięci z innego routera.
W przypadku R7000 mamy do czynienia z zastopowaniem cfe Netgera przez cfe xvortex ( zmodyfikowane Asusa z dystrybucji amerykańskiej).
To cfe ma plus taki jak asus nie można go uwalić i odratujesz router przez asus restoration tool czy mini web . Xvortex ustawia region na #a i daje kilka innych ficzersow typu aimesh na XVRT.
Jeśli ktoś nie grzebał przy cfe to ma cfe ofw.
Grzebanie przy cfe może zrobić całkowita cegłę z routera.
Edytowany przez jurekk dnia 12-05-2020 11:22
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh
 
qrs
ok, zatem porzucam pomysł Smile
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jurekk
To jest ciekawe jak masz r7000 lub routery ea6700,6900, 6500v2 Linksysa i chcesz sobie na ich bazie zrobic aimesh i używać klona Rmerlina to nie jest głupie.
Używki linksysów trafiają sie w atrkacyjnych cenach. Sa m taką upolowałem.
Ale nie mam aimesh , mam ap tradycyjne z modemorouterem z dwoma radiami.
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh
 
qrs
nie mam takich potrzeb na swoich 55m2 Smile
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
jurekk
Ogólnie jest stagnacja bo na m te arm routery starczają już z 5 lat co najmniej i generalnie nówki w sklepach tez cenę utrzymują.
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh
 
amikot
Od wczoraj zacząłem doświadczać dziwnego zachowania routera. Niby jest uptime już prawie 3 doby ale co chwilę mam dziwne disconnecty. Nie wiem czy to tylko kwestia problemów dostawcy który podobno ma spore problemy w ostatnich dniach, być może, ale z drugiej strony kiedy się to dzieje, stacjonarny komputer też się rozłącza od routera i nawet na stronę routera wejść nie mogę.
Nie wiem czy to windows10 tak działa, że jak nie ma dostępu do internetu to próbuje się rozłączyć i połączyć z lanem czy to router wariuje.
Virgin Media Hub 3
Linksys EA6900 v1.1 - Fresh Tomato 2021.5 AIO
Netgear WNDR4500 - Fresh Tomato 2021.5 AIO
Xpenology HP Microserver N54L - DSM 6.2.3
 
dupajasia
Drodzy forumowicze, pacjent to Netgear R8000. Był oficjalny firmware, a więc wrzuciłem "freshtomato-R8000-2020.3-initial-64K.chk", poszło ładnie i gładko, auto reboot. Następnie już w initali wrzucam "freshtomato-R8000-ARM-2020.3-VPN-64K.trx", niby poszło, ale już po auto restarcie nie wstaje. Widzę tylko, że co 30 sekund zaplają się wszystkie diody, jakby dostał boot loopa. Wszystkie sumy MD5 sprawdzane przed wrzucaniem. Jak wyjść z tej sytuacji, gdy nawet ping do 192.168.1.1 nie idzie?
 
qwerty321
Did you...?

!!!IMPORTANT (applies to all routers)!!!
- Due to the new WL driver and the required changes in NVRAM, for the update process select a new image AND CHECK "Delete all data from NVRAM after flashing". DO NOT use backups!

Czy 30/30/30 próbowałeś?
 
jurekk
Z arm routerami lepszy efekt daje wps reset. Czyli trzymanie przycisku wps w trakcie włączenia routera aż do mignięcia wszystkich diod.
ax56u Rmerlin Aimesh
ea6500v2 cfe xvortex (custom) Rmerlin node Aimesh
 
dupajasia
@jurekk I tak właśnie zrobiłem. Kolejną rzeczą trzymałem reset podczas włączania routera (jakieś pół minuty i nagle router) wyszedł z boot loopa. Dzięki.
 
qrs
przydałoby się rozszerzyć dodawanie statycznych numerów IP o IPv6

obecnie próba dodania kończy się komunikatem o błędnym numerze IP
qrs załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
amikot
Właśnie zauważyłem, że nie ma nigdzie opcji zrestartowania DHCP. Chodzi mi konkretnie o to, aby uwolnić wszystkie IP i od nowa przypisać je według listy stałych IP.
Zauważyłem to po tym, jak przypadkowo wsadziłem wtyczkę do drugiego portu LAN w moim NASie. DHCP przypisał inny IP bo każdy port ma inny MAC adres. Oczywiście dodałem drugi MAC adres do DHCP tak aby oba wskazywały na to samo IP, ale niestety nie spowodowało to żadnej zmiany. Nawet ręczne uwolnienie adresu (klik na lease time w "Device List") nie pomogło. NAS nie dostał sygnału, że jest rozłączony i nie wysłał nowej prośby do DHCP o przyznanie nowego adresu.
Wiem, że reset routera pomoże, ale fajnie by było gdyby był jakiś od tego przycisk, bo głupio tak resetować router za każdym razem kiedy się konfiguruje nowe urządzenie.
Jest to w ogóle możliwe? Może to kwestia bardziej sprzętowa?
Virgin Media Hub 3
Linksys EA6900 v1.1 - Fresh Tomato 2021.5 AIO
Netgear WNDR4500 - Fresh Tomato 2021.5 AIO
Xpenology HP Microserver N54L - DSM 6.2.3
 
Marco76
Próbowałeś restart samego dnsmasq?
[small]Pozdrawiam, Monter
Asus RT-N18 + FreshTomato 2019.3 K26ARM USB AIO-64K-NOSMP + ILHM v2
HTPC Chieftec FLYER FI-02BC-U3 + GA-H61N-USB3 + i3-3225 + 4GB RAM + LibreELEC + Xbox DVD Remot
 
amikot
Probowałem z konsoli to robić, ale może nieprawidłowo bo nie pomogło.
W końcu zrestartowałem router, bo potrzebowałem dostępu do NASa.
Virgin Media Hub 3
Linksys EA6900 v1.1 - Fresh Tomato 2021.5 AIO
Netgear WNDR4500 - Fresh Tomato 2021.5 AIO
Xpenology HP Microserver N54L - DSM 6.2.3
 
dyfer
Ja niestety jestem leniwy i nie chce mnie się co upgrade wyklikiwać na nowo konfigurację, więc zazwyczaj tylko update bez czyszczenia NVRAM. Tym razem myślałem że tak samo przejdzie .. i przeszło. Wszystko działa tylko teraz nie mogę się zalogować, niepoprawne hasło ale cała reszta działa poprawnie. Nigdy wcześniej tego nie miałem. Wbić się pewnie już nie uda więc pozostaje hard reset :/
Uprzedzając pytanie: używam menadżera haseł, więc nie jest to "palcówka" Wink

------------------
MAM
------------
po upgrade zmienił mi login z admin na root,
zalogowałem się i bangla

Pozdrawiam
Edytowany przez dyfer dnia 16-05-2020 09:35
 
bigl

Cytat

dyfer napisał(a):

Ja niestety jestem leniwy i nie chce mnie się co upgrade wyklikiwać na nowo konfigurację, więc zazwyczaj tylko update bez czyszczenia NVRAM. Tym razem myślałem że tak samo przejdzie .. i przeszło. Wszystko działa


Jaki router? Pytam bo niee ukrywam, że też jestem dość leniwy a konfiguracji jest nieco. Do tego mam serwer OpenVPN i już zdarzało mi się, że zanim wpisałem ją od nowa i zrobiłem restart to już niektórzy klienci (zwłaszcza jeden na Merlinie) rezygnowali z prób połączeń i musiałem prosić o reboot ręczny, co bywa kłopotliwe.
Router: Netgear R7000 + FreshTomato
VoIP: Linksys PAP2 (modded to SPA1001) + FW 3.1.19(SE)
NAS + Player: AsRock BeeBox Fanless + Ubuntu 18.04 Server + Kodi + WD My Book Essential 8TB
 
pedro
Jak jesteście leniwi i pomimo wyraźnego zaznaczenia w logu/na forum (rzadko tak jest przy kolejnych wydaniach), że trzeba zrobić clean install a tego nie zrobicie i wszystko potem działa - dobra wasza.

Tylko nie zgłaszajcie potem bugów/problemów/bricków na takim sofcie w routerze.

Jeden user z forum LI już się na tym przejechał: "Wszystko jest dobrze, zrobiłem update bez czyszczenia, wszystko działa, nie wiem po co czyścić?"
Na drugi/trzeci dzień wywrócił mu się router.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
dyfer
@Pedro od lat obserwuję Waszą pracę, którą mega szanuję.
WieRny jestem tomato od czasów shibbiego, którego montowałem na pierwszych WRT-kach 54 (powiało nostalgią)
W życiu by mi nie przyszło pisać posta, że coś nie bangla bez czyszczenia.
Generalnie nie udzielam się na forum i staram się sam rozwiązywać problemy szukając po forach.
Dzisiaj podzieliłem się nietypową sytuacją, można powiedzieć pierdołą, ale nie jest to błąd. (może wiosna, tak działa Smile )
Sorki jeżeli "zaśmiecam forum"
Jeszcze raz dzięki i kłaniam się nisko!

PS: Kiedyś tak się zastanawiałem, że skoro nie można przywracać z backup, to fajnie byłoby otworzyć konsolę wpisywać z ręki polecenia i tak całą konfigurację przejść. W notatniku miałbym wszystkie gotowe polecenia, przeklejam i puszczam je z ręki. [nie mam OptWare]
Niestety pisanie takich komend to sporo roboty i chyba to nie mój level.
Może jest gdzieś log, gdzie po wyklikaniu na formatce konfiguracji i kliknięciu zapisz, w logu zapisuje się całe polecenie, które zostało puszczone.
Wszystkie polecenia z loga przeklejam sobie do notatnika i mam na przyszłość Smile
Router: RT Asus AC56U
 
Ampersand
Wystarczy, że pobierzesz sobie dump-a (Download NVRAM Dump) z zakładki Debugging i tam wszystko masz. Ja tak robię od dawna, że mam skrypt shell-owy z tym co zajmuje najwięcej czasu do konfiguracji (VPN, statyczne DHCP itd.). Wystarczy skopiować i dodać "nvram set":

Przykład:

Cytat


#!/bin/sh
...
nvram set vpn_server1_sn="10.2.1.0"
nvram set vpn_server1_nm="255.255.255.248"
nvram set vpn_server1_digest="SHA512"
nvram set vpn_server1_hmac="0"
nvram set vpn_server1_ncp_enable="2"
nvram set vpn_server1_rgw="1"
nvram set vpn_server1_pdns="1"
nvram set vpn_server1_comp="-1"
nvram set vpn_server1_userpass="1"
...

Netgear R7000: FreshTomato 2021.3 K26ARM USB AIO-64K [TomatoAnon]
Linksys E4200: FreshTomato 2021.3 RT-N5x-MIPSR2 Mega VPN
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 5

· Użytkowników online: 0

· Łącznie użytkowników: 24,040
· Najnowszy użytkownik: mucha76
Czat
Musisz się zalogować, aby opublikować wiadomość.

AdrianAdi
05-10-2021 23:03
Przymierzam się do kupna takiego i mam kilka pytań z tym zwoązanych

AdrianAdi
05-10-2021 23:02
Jest tu kto?

AdrianAdi
05-10-2021 22:59
Witam mam pytanie odnośnie routerów gamingowych do ps4 czyli konsoli

Maniek91PL
04-09-2021 10:34
Wink super ! Dzięki ! Adooni ! już testuje co i jak

Adooni
04-09-2021 06:31
sprawdzasz w status - overview, a zmieniasz w Basic - Network

Maniek91PL
03-09-2021 22:37
jak sprawdzić i zmienić kanał w wifi 2.4 w tomato ? Shock

goof3r
23-07-2021 16:21
Mi chodziło w sekcji VPN bo w WAN to nic mi nie da jak zmienie....

Adooni
22-07-2021 21:34
nie mam pod reka FT ale powinno to byc w WAN Settings -Type - L2TP. Jest tam tez pole L2TP Server

goof3r
22-07-2021 20:08
Witam, takie małe pytanie mam, czy w najnowszej wersji freshtomato jest możliwosć postawienia serwera/klienta VPN L2TP ?

Maniek91PL
20-07-2021 13:55
potwierdzam, wyczyściłem przeglądarkę, działa teraz prawidłowo na najnowszym freshtomato ! Dzięki jeszcze raz

45,565,714 unikalnych wizyt