22 Stycznia 2022 18:44:43
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Własny NAS na Xpeno...
· RT-N18U - ARM z jedn...
· LACP, czyli Link Agg...
· [MOD] FreshTomato-AR...
· [S] ASUS RT-AC66U
· [S] NETGEAR WNR3500L...
· Self-hosted Photo Co...
· Asus RT-AX55 vs RT-A...
· OpenVPN - słaba wyd...
· nowosci Ubiquiti
· static DHCP/ARP/ITP
· [S] Sprzedam Asus SC...
· CCTV jakie kupic
· Dywagację na temat ...
· E2500 v3 I Fresh Tomato
· [MOD] FreshTomato-MI...
· Mini /Macro ATX / HTPC
· Wake On Lan (WOL) Op...
· Router Linksys LRT214
· Web serwer i PHP na ...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [663]
· RT-N18U - ARM z j... [318]
· Własny NAS na Xp... [48]
· OpenVPN - słaba ... [11]
· nowosci Ubiquiti [9]
· LACP, czyli Link ... [8]
· Asus RT-AX55 vs R... [8]
· [S] Sprzedam Asus... [8]
· Self-hosted Photo... [7]
· [S] ASUS RT-AC66U [4]
· static DHCP/ARP/ITP [1]
· [S] NETGEAR WNR35... [0]
· CCTV jakie kupic [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [146 głosów]

Broadcom ARM
Broadcom ARM
52% [207 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 397
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.81.172.77
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-MIPS - wątek deweloperski
esem
Nie rozumiem: w jednej sieci masz dwa routery?
Moim zdaniem ma być jeden Router i kilku Clientów.
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
najmar11

esem napisał:

Nie rozumiem: w jednej sieci masz dwa routery?
Moim zdaniem ma być jeden Router i kilku Clientów.


Router VPN10.6.0.14 (LAN192.168.2.2) działa jako klient.
I na niego próbuję się zalogować przez router działający jako serwer VPN10.6.0.1 (LAN192.168.3.3)

Jeżeli FreshTomato ma zablokowane logowanie przez adres z VPN to może ktoś mi podpowie w jaki sposób dodać trasę do tabeli routingu na routerze działającym jako serwer VPN, tak bym mógł sie logować na kliencie przez jego adres LAN 192.168.2.2?
 
Adooni
na takie pytania to zaklada sie nowy watek a nie wypisuje w watku developerskim
UPC 300/25 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.3_2+amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED, SSD,
 
najmar11

Adooni napisał:

na takie pytania to zaklada sie nowy watek a nie wypisuje w watku developerskim

No to pytanie do developerów:
Czy we FreshTomato w sekcji Administration/Admin Access/Web Admin
oprócz opcji - Local Access, Remote Access, Wirless Access,
nie powinna znaleźć się dodatkowa opcja VPN Access?

Bez tej opcji nie ma możliwości zdalnego zalogowania się do FreshTomato pracującego jako OpenVPN Client w trybie TUN.

no, przynajmniej ja nie umiem Frown
 
maciej2
Witam.

Dlaczego w ssh wycięto opcję -R? Potrzebuje zrobić odwrócony tunel, a bez tego nie jestem wstanie nic zrobić. Chyba, ze istnieje jakiś inny sposób. Muszę wykonać następujące polecenie:
ssh -NT -f -R 123:localhost:123 user@serwer

Jakieś pomysły?
Posiadam wersję FreshTomato Firmware 2021.7 MIPSR1 K26 USB VPN
ASUS RT-AC66U v B1 - Asuswrt-Merlin
ASUS WL-500gP v2 - FreshTomato
 
pedro
FreshTomato-MIPS 2021.8 jest gotowe do pobrania. Więcej info w pierwszym poście

Wesołych Świąt i Szczęśliwego Nowego Roku!
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Ampersand
Przeszedłem z wersji freshtomato-E4200USB-NVRAM60K_RT-N5x-MIPSR2-2021.5-Mega-VPN na freshtomato-E4200USB-NVRAM60K_RT-N5x-MIPSR2-2021.8-Mega-VPN i niestety statusy portów są skopane jeśli się dokona zmian we VLAN. Wygląda mi na przesunięcie o jedno przy wyłączonym Invert. Statusy przy standardowych ustawieniach, bez zmiany we Vlan (kable wpięte w WAN, 2 i 3) - patrz załącznik nr 1.
Wystarczy, że umieszczę port WAN we Vlan 1 aby użyć go jako dodatkowy port switch-a i wygląda to tak jak na załączniku nr 2. W tym drugim przypadku kabel wpięty do WAN to teraz LAN3.
Ampersand załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
pedro
Wyczyściłeś nvram i wprowadziłeś ustawienia z palca na nowo?
Przejście z 2021.5 to duża zmiana, wiele się zmieniło w tym czasie, spróbuj jak napisałem powyżej.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Ampersand
Tak robiłem w tym przypadku bo tam nie mam dużo do konfigurowania. Wyczyszczę raz jeszcze i dam znać.

Scalony z 08 stycznia 2022 08:27:24:
To samo. Załącznik 3 przed wrzuceniem WAN do VLAN1 i załącznik 4 po. Status generalnie nie jest problemem, kwestia czy ma to też wpływ na VLAN-y.
Ampersand załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez Ampersand dnia 08-01-2022 08:27
Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
pedro
A jak wyglądają ikony na advanced-vlan.asp?
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Ampersand
W tym momencie jestem w trybie z obrazka nr 4 i ikony wyglądają tak samo w Statusie jak i VLAN i tak samo reagują na wypięcie kabla.
Edytowany przez Ampersand dnia 08-01-2022 19:12
Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
qart
Cześć,
Z tej okazji, że jest to mój pierwszy post na forum, to serecznie witam się z Wami forumowiczami i po stokroć dzięki Pedro za Twój poświęcony czas i świetną robotę w rozwoju Tomato! Smile

Niestety po migracji z wersji 2021.6 na 2021.8 (dokładnie freshtomato-K26USB-NVRAM32K_RT-N5x-MIPSR2-2021.8-Max) nie mogę korzystać z internetu, ponieważ nie mogę ustawić fabrycznego adresu mac na WAN0 port. Podczas inicjalizacji generowany jest jakiś adres (:84), którego nie da się zmienić na domyślny (:75). Co ciekawe bez problemów mogę zmienić go na losowy adres i zapisać (np. F6:0E:B1:82:21:2B), ale gdy chcę wrócić do "default", to w formularzu pojawia się prawidłowy mac (:75), natomiast po zapisaniu i odświeżeniu strony wraca do tego pierwotnego adresu (:84). Nigdy czegoś takiego nie widziałem. Ta jakby się mogło wydawać błahostka, jest dla mnie bardzo istotna, ponieważ u dostawcy internetu mam przypisany publiczny adres ip do adresu mac routera, więc bez tego domyślnego adresu mac (:75) nie dostaję dzierżawy adresu publicznego. Na koniec dodam, że do upgrade ustawiłem czyszczenie NVRAM.
qart załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.
 
Adooni
a po czyszczeniu nvram nie przywracales ustawien czego nie mozna robic i trzeba wszystko ustawic jeszcze raz recznie? czy czysciles cache przegladarki alboprobowales zrobic te zmiany uzywajac Firefox?

sprawdz jeszcze czy nie jest to zwiazane z problemem zgloszonym w tym poscie #347 i #349 - ustaw jak tam potem roboot i wtedy ustaw swoj WAN
Edytowany przez Adooni dnia 09-01-2022 10:11
UPC 300/25 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.3_2+amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED, SSD,
 
qart

Adooni napisał:

a po czyszczeniu nvram nie przywracales ustawien czego nie mozna robic i trzeba wszystko ustawic jeszcze raz recznie? czy czysciles cache przegladarki alboprobowales zrobic te zmiany uzywajac Firefox?

sprawdz jeszcze czy nie jest to zwiazane z problemem zgloszonym w tym poscie #347 i #349 - ustaw jak tam potem roboot i wtedy ustaw swoj WAN


Dzięki za odpowiedź.

Nie przywracałem ustawień. Korzystam z Tomato już od wielu lat (jeszcze od czasów fork by Shibby), więc wiem że taka operacja często powoduje problemy. Ustawiłem wszystko ręcznie. Co do cache przeglądarki, to używam firefox'a z czyszczeniem wszystkich prywatnych danych oraz cache, do tego mam jeszcze skrypt "doczyszczający" przed uruchomieniem przeglądarki, więc nie szukałbym tu przyczyny. Mogę zmienić adres WAN0 port na dowolny i go zapisać, oprócz... oprócz fabrycznego, bo wtedy pojawia się ten generowany adres z końcówką :84 . To jest naprawdę dziwne. W każdym razie muszę mieć ten router działający, więc wróciłem z powrotem do wersji 2021.6 i tam ten problem nie występuje.

Co do zbieżności z #347 i #349, to nie widzę podobieństwa naszych problemów. Mam porty ustawione na "invert" ale w statusie pokazują mi się prawidłowo.
Edytowany przez qart dnia 09-01-2022 12:47
 
Ampersand
Spróbuj ręcznie podmienić jeśli Ci się chce bawić. Pobierz nvram z seksji Debug i zobacz jak to tam wygląda w obecnej wersji bo nie wiem czy wartość "wan_hwaddr" też ulega zmianie przy zapisie w webif. Potem możesz sobie spróbować zmiany w ten sposób (wartość ma być w cudzysłowie):


nvram set wan_mac="MAC_ADRES"
nvram commit
reboot


Ewentualnie dodatkowo to samo dla "wan_hwaddr" jeśli trzeba. Tu nie mam pewności.
Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
qart
@Ampersand
Coś mnie dziś tknęło żeby manualnie pogrzebać w plikach i nawet zacząłęm pisać edit'a do poprzedniego posta, ale uprzedziłeś mnie, więc przekleję to do tego posta. Smile

W każdym razie zrobiłem to w ten sposób:
Odpakowałem i przejrzałem config, zapisany przed downgrade'm, w którym znalazłem 2 miejsca gdzie widniał adres z końcówką :84 . Poprawiłem te miejsca na :75 , ponownie spakowałem i zrobiłem upgrade routera do 2021.08 . Na świeżo ponownie powtórzyła się sytuacja z posta #352 i dodatkowe czyszczenie nvram oraz czyszczenie cache przeglądarki nic nie zmieniło. Zatem wgrałem poprawiony przeze mnie ręcznie config i udało się, internet teraz działa, adres mac na WAN0 port jest fabryczny (:75). Aczkolwiek jest to taki "dirty workaround", więc pewnie przy kolejnych upgrade'ach sytuacja będzie się powtarzać.
W każdym razie dziękuję bardzo za Twą pomoc. Smile
 
pedro
Nie będzie się powtarzać, bo bug został naprawiony przez inicjującego problem - @M_ars.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Ampersand
Odnośnie wersji 8 i wspomnianego przeze mnie problemu z portami to jeszcze dorzucę Wireless Client Mode, które mi nie działa w tej wersji. Spędziłem nad tym 2 dni i wróciłem do wersji 5 i tam wszystko tak jak powinienem mieć. Nie wiem czy to jest powiązane z portami ale informacyjnie wrzucam.
Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
pedro
To znaczy gdzie ten tryb nie działa?
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
Asus RT-AC3200 + freshtomato AIO-128K
Asus RT-N18U + freshtomato AIO-64K-NOSMP
Asus RT-N66U + freshtomato AIO-64K
 
Ampersand
W tej wersji 8, w której znalazłem problem z przesunięciem portów. Przy użyciu Wireless Client Mode i DHCP w ogóle mi się nie łączy a przy statycznych ustawieniach tak ale brak internetu.
Netgear R7000: FreshTomato 2021.8 AIO-64K
Linksys E2000: FreshTomato NVRAM60K_RT-MIPSR2-2021.8-Max
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 24

· Użytkowników online: 0

· Łącznie użytkowników: 24,064
· Najnowszy użytkownik: bbieszkowski
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
01-01-2022 22:34
dziala, dziekuje Smile

shibby
01-01-2022 15:08
@tamtosiamto - IP usuniety z blacklisty. Widze ze automatycznie sie IPki dodaja ale pozniej nie kasuja z automatu...

tamtosiamto
31-12-2021 15:37
'Your public IP address 91.188.125.113 is not in our database ' mimo to redirect do googli przy probie wejscia na ol Smile

shibby
29-12-2021 22:54
zobacz czy IP z jakim wychodzisz przez VPN nie widnieje na stopforumspam

tamtosiamto
27-12-2021 14:43
zapewne tak Wink ale czemu?

pedro
26-12-2021 15:41
No zapewne są na blackliście, skoro przekierowuje na gugla...

tamtosiamto
24-12-2021 23:55
shibby czy moglbys zerknac, dlaczzego podczas polaczenia przez vpn ( https://www.mydevi
l.net/vpn.html) nie da sie wejsc na ol? Jestem przekierowywany na google, czy domeny mydevil sa na blackli

maxikaaz
21-11-2021 17:35
@man1 to puść sobie to światło do piwnicy, stamtąd wypuść skrętkę jakimś pionem wentylacyjnym do mieszkania.

man1
21-11-2021 12:55
juz mam odpowiedz - w przypadku uslugi ftth 900/300 na laczach Orange nie moga tego puscic oficjalnie konwerterem na skretke.

man1
19-11-2021 20:25
czy są tu posiadacze ftth od tmobile? Mieszkam w starym bloku i nie moge wprowadzic swiatlowodu do lokalu, wiec chcialbym by uzyli konweretra na skretke. A tego zrobic podobno nie mogą...

47,998,034 unikalnych wizyt