21 Kwietnia 2024 10:32:31
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· konfiguracja router ...
· Szukam zaproszenia n...
· [Howto] Xpenology na...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· Jaki USB hub do syno...
Najpopularniejsze obecnie wątki
· [Howto] Xpenology... [21]
· Szukam zaproszeni... [16]
· dodatkowe złącz... [4]
· konfiguracja rout... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.238.71.155
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-MIPS
templar70
Dziękuję za odpowiedź i sugestię. Smile Dopiero dziś miałem dostęp do tego routera. Sprawdziłem, faktycznie był jakiś problem z buforem przeglądarki (Firefox). Po resecie opcje zapisały się prawidłowo.

Nie ma lekko... gdy wszystkie parametry były już zapisane, okazało się że zostało mi 0 z 32KB NVRAM. Sad Zaraz po reboocie routera co prawda zgłasza się wolne 8 z 32, ale szybko znika. Próba uruchomienia serwera VPN kończy się niepowodzeniem, zapis w logu jest taki:

Cytat

Aug 25 14:10:34 RT-cc40d08300ac daemon.err openvpn[833]: Options error: Unrecognized option or missing or extra parameter(s) in config.ovpn:8: cipher (2.4.7)
Aug 25 14:10:34 RT-cc40d08300ac daemon.warn openvpn[833]: Use --help for more information.
Aug 25 14:12:42 RT-cc40d08300ac daemon.err openvpn[1105]: Options error: Unrecognized option or missing or extra parameter(s) in config.ovpn:8: cipher (2.4.7)
Aug 25 14:12:42 RT-cc40d08300ac daemon.warn openvpn[1105]: Use --help for more information.


Możliwe że to z powodu deficytu NVRAM. I teraz pytanie... mam zainstalowany pakiet 118.beta-AIO, ale wyłączone usługi dodatkowe typu AdBlock, QoS, Captive Portal, "USB and NAS" i inne. Mam za to około 30 wpisów w filtrze MAC-adresów WiFi oraz podobną ilość statycznych wpisów w DHCP.

Czy w tej sytuacji aby odzyskać trochę NVRAM powinienem zainstalować mniejszy pakiet (118-beta-VPN)? Ewentualnie co zrobić? A może dałoby się zwiększyć ilość dostępnej pamięci NVRAM (WNR3500Lv2 ma 128MB pamięci RAM i 128MB pamięci Flash, dlaczego z całej tej pamięci na NVRAM przypada tylko 32KB)?
 
Steel_Rat
Bo niestety tyle jest. Masz takie mozliwosci:
1. Spróbować wersję tą tylko v VPN
2. zamontować pena w USB i przenieś certyfikaty na niego.
Niestety te 32KB na NVRAM to już mało.
WRT3200ACN (WRT32X) + OpenWRT 18.06+światełko 150/150 Mb/s
Asus RT-AC68UvE1 + RMerlin + Entware
Netgear WNR3500Lv2 + DDWRT
 
templar70
No dobrze, to teraz po kolei opiszę co się działo od ostatniego czasu...

Idąc za pierwszą poradą Steel_Rata zainstalowałem na moim WNR3500Lv2 wersję okrojoną (2019.3.118-beta-VPN). Ponieważ czas mnie naglił, zabrałem router do domu i podłączyłem kaskadowo do innego routera (sieć główna 192.168.1.1, ten router podłączony jako sieć 192.168.2.1). Następnie zacząłem go konfigurować.

Niestety klucze nadal się nie mieściły, więc zastosowałem poradę drugą. Wpiąłem pendriva, wgrałem klucze, wpisałem ścieżkę do plików w ustawieniach zaawansowanych. Potem wpiąłem kompa w sieć nadrzędną (192.168.1.1) i próbowałem się połączyć. Okazało się, że po kilku drobnych problemach związanych z ustawieniami po stronie klienta na kompie WSZYSTKO RUSZYŁO. Grin Dzięki Steel_Rat!

Życie okazało się jednak troszkę bardziej skomplikowane, gdy ponownie próbowałem podłączyć router w lokalizacji zdalnej. Jak już wspomniałem, mam tam połączenie poprzez PPPoE (internet z Netii). Nagle okazało się, że router nie łączy się z internetem. Sad I to pomimo poprawnie wpisanych danych logowania i pozostałych parametrów. W logach routera pojawiło się:

Cytat

Jan 1 01:12:38 RT-cc40d08300ac daemon.info pppd[6395]: Using interface ppp0
Jan 1 01:12:38 RT-cc40d08300ac daemon.notice pppd[6395]: Connect: ppp0 <--> vlan2
Jan 1 01:12:38 RT-cc40d08300ac daemon.info pppd[6395]: Remote message: permission denied
Jan 1 01:12:38 RT-cc40d08300ac daemon.err pppd[6395]: PAP authentication failed
Jan 1 01:12:38 RT-cc40d08300ac daemon.notice pppd[6395]: Connection terminated.


W tym momencie przypomniałem sobie że kieeeedyś, daaawno temu w którymś z firmwarów (Tomato Shibby? DD-WRT?) był błąd polegający na tym, że PPPoE nie akceptował długich loginów użytkownika. Hmmm...

Mój login użytkownika jest według schematu: user123@net24.com.pl (zachowana długość loginu) a hasło ma długość 8 znaków. Może to?

Zrobiłem kolejny test. Zainstalowałem wersję AIO (2019.3.118-beta_AIO) i pracowicie odtworzyłem konfigurację, włącznie z ustawieniami VPN. Podłączyłem... Jeeeeest! Śmiga!

Wygląda na to, że wersja AIO działa z PPPoE, a wersja VPN nie.

Mam dwie hipotezy. Jedna jest taka, że w wersji VPN niechcący "wycięto" coś, co ma znaczenie dla połączeń PPPoE. Druga hipoteza jest taka, że obie wersje powielają dawny błąd obsługi PPPoE (ucinanie nazwy loginu użytkownika), przy czym w AIO nadmiar trafia w jakąś nieużywaną przeze mnie przestrzeń parametryzacji i dlatego jest poprawnie przekazywany do operatora (nie są nigdzie zamazywane elementy nazwy, znak końca tekstu jest we właściwym miejscu), a w wersji VPN następuje kolizja i część loginu zamazywana jest czymś innym.

Tak czy siak, PPPoE na wersji VPN nie działa.
Edytowany przez templar70 dnia 07-09-2019 13:01
 
Steel_Rat
Cieszę się, że mogłem pomóc.
WRT3200ACN (WRT32X) + OpenWRT 18.06+światełko 150/150 Mb/s
Asus RT-AC68UvE1 + RMerlin + Entware
Netgear WNR3500Lv2 + DDWRT
 
Obserwator
Czy nie bedzie juz softu freshtomato-K26USB_RT-N5x-MIPSR2-2019.3.220--MiniVPN.trx ?
Obecnie mam soft z kwietnia tj freshtomato-K26USB_RT-N5x-MIPSR2-2019.2-MiniVPN.trx
Chciałem cos nowszego wgrać. Mam Router asus RT-N10U z modemem Huawei E3372 z orange Smile

Ps przydała by sie walidacja w postaci wpisuje model routera oraz reszte wymaganych rzeczy a walidator podpowiada o moge wgrac.
 
pedro
@Up: Teraz się to nazywa freshtomato-K26USB-NVRAM32K_RT-N5x-MIPSR2-2019.3.220-beta-MiniVPN
Netowski 1Gb/1Gb
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
FreshTomato: Asus RT-AC3200 + RT-N18U + RT-N66U + RT-N12
 
Obserwator
DZieki. Gra buczy i spiewa Smile Pomyslisz szaleniec zmienia soft w swieto Grin Zeby zjadlem na zmianach softu. Teraz juz wiem co i jak. Na bledach sie nauczylem, wyciagnalem wnioski. Kazdy co chce sie bawic w piatek przed swietami itp w zmiane softu a slabo sie na tym zna ODRADZAM. Ostatnio pare godzin sie bawiłem. Dla bardziej ogarnietych miec w kompie ostatni działający soft a potem bawic sie w zmianySmile
 
local
2019.3.220-beta nie zapisuje ustawień na Tenda N60
"To comply with FCC RF exposure compliance requirements, this grant is applicable to only Mobile Configurations. The antennas used for this transmitter must be installed to provide a separation distance of at least 20 cm from all pe
 
pedro
Ponieważ @kille72 wycofał się z projektu i nie mam żadnej kontroli nad OP, a @shibby który mógłby to zmienić milczy, założony został nowy wątek TUTAJ

Ten zostanie zamknięty, a wszelkie merytoryczne dyskusje (proszę zwrócić uwagę na tytuł wątku), proszę prowadzić pod w/w linkiem.

Netowski 1Gb/1Gb
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
FreshTomato: Asus RT-AC3200 + RT-N18U + RT-N66U + RT-N12
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 13

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

tamtosiamto
19-03-2024 19:50
@Adooni 'Only one set is available for 1 band' i tak mam-1 set dla 2.4ghz i 1 dla 5ghz-czy czegos nie rozumiemW drugiej sieci goscinnej nie ma opcji wyboru Ruter only/ All nodes

Adooni
19-03-2024 19:14
no to przeczytaj to 2 pod - 1 stet z kazdego pasma jest dopuszczony na nody. zrob 2 siec jako goscinna na danym pasmie i wtedy sprawdz

71,216,194 unikalnych wizyt