21 Kwietnia 2024 10:46:53
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· konfiguracja router ...
· Szukam zaproszenia n...
· [Howto] Xpenology na...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· Jaki USB hub do syno...
Najpopularniejsze obecnie wątki
· [Howto] Xpenology... [21]
· Szukam zaproszeni... [16]
· dodatkowe złącz... [4]
· konfiguracja rout... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.238.71.155
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] FreshTomato-ARM
marekm
Witam ponownie, poszło bezpośrednio z czyszczeniem Nvram, konfig z palca, śmiga zajefajnie, dzięki za porady i szacun dla programistów za kawał ciężkiej roboty.
 
qrs
U mnie bez czyszczenia NVRAM Wink
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
Boczek
Na RT-N18U pojawia mi się proces blink_5g. Jeśli wierzyć w wyjaśnienie http://www.linksysinfo.org/index.php?...ost-271085 to nie jest on potrzebny.
Czy można to wyłączyć np. dla innych routerów niż Tenda czy Netgear?

Czy można wyłączyć NAT w tomato? RT-N18U działa teraz u mnie jego drugi router?
EdgeRouter X: EdgeOS
RT-AX56U: AsusWRT
EA6900: tbd
EA6350: tbd
 
Pawel_k77
Asus RT-N18U wersja freshtomato-RT-N18U-ARM-2018.2-AIO - Czy działa u was poprawnie qos ? W wersji tomato-RT-N18U-ARM-2018.1.031-beta-kille72-AIO było OK. Reset 30/30/30 nie pomaga. Nie te prędkości, nie przycina na pobieraniu.
 
kille72

Cytat

Pawel_k77 napisał(a):

Asus RT-N18U wersja freshtomato-RT-N18U-ARM-2018.2-AIO - Czy działa u was poprawnie qos ? W wersji tomato-RT-N18U-ARM-2018.1.031-beta-kille72-AIO było OK. Reset 30/30/30 nie pomaga. Nie te prędkości, nie przycina na pobieraniu.


Używasz tylko QOS czy QOS + BW Limiter na raz?
 
qrs
FreshTomato 2018.2 posiada Adminer w wersji 4.3.1 natomiast jest już dostępna wersja 4.6.2 więc prośba o update Wink
---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
kille72

Cytat

qrs napisał(a):

FreshTomato 2018.2 posiada Adminer w wersji 4.3.1 natomiast jest już dostępna wersja 4.6.2 więc prośba o update Wink


Ma najnowszy:
https://bitbucket.org/kille72/tomato-arm-kille72/commits/7b498e0f56794da458b8ee229107c1e93d6a9537
 
qrs
hmm... ciekawe bo nie wiem czemu widzę że Adminer powiadamia że jest nowsza wersja do pobrania
qrs załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

---
Netgear R7000Netgear WNR3500L v2MikroTik hAP ac^2TP-LINK M7650
 
overflow2
odśwież może stronę
Asus RT-AC56U FT-AIO
 
czeresnia
Witam ponownie.

Znalazłem następny problem z fresh tomato 2018.2 na R7000
Jak włączę DNSSEC to przestają działać DNS-y w lanie "Temporary failure in name resolution" i skokowo dnsmasq obciąża CPU do 10-45% tak co kilka sekund w kółko. Jak wyłączę DNSSEC to wszystko wraca do normy. Dziwne bo z firmwarem shibby 140 DNSSEC działa.

Zauważyłem dziwną rzecz mam dwa routery które mają 64KB NVRAM-u z identyczną konfiguracją (czyszczone do ustawień fabrycznych i konfigurowane od nowa) ale innym firmwar-em i na jednym jest ~10% wolnego NVRAM-u a na drugim ~28% dziwne. hmmm
1 - Asus RT-AC66U - shiby tomato v140 - 28,3%
2 - Netgear R7000 - fresh tomato 2018.2 - 10,5%

Po wyczyszczeniu do ustawień fabrycznych R7000 mam na nim 64K/27.48K (42,94%) wolnego NVRAMU czy to normalna wartość ?
Dlaczego jest aż ~18% różnicy skoro są identyczne ustawienia ?

Pozdrawiam
Netgear R7000: Freshtomato-R7000-ARM-2018.2-AIO-64K
Netgear WNR3500L v2: Tomato Firmware 1.28.0000 MIPSR2-140 K26RT-N USB AIO
Asus RT AC66U: Tomato Firmware 1.28.0000 MIPSR2-140 K26RT-AC USB AIO
 
qwerty321
DNSSEC nigdy nie działał dobrze i zawsze obciążał procesor aż do zawieszenia routera. Może shibbiego 140 miała checkboxa ale ta funkcja nie działała :-)
 
kille72

Cytat

qrs napisał(a):

hmm... ciekawe bo nie wiem czemu widzę że Adminer powiadamia że jest nowsza wersja do pobrania


Wyczyść może cache w przeglądarce?
kille72 załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.
 
Pawel_k77
Używam tylko QOS, w wersji beta było ok.
 
kille72

Cytat

Pawel_k77 napisał(a):

Używam tylko QOS, w wersji beta było ok.


Info z wątku Tomato bugi/problemy:

- Testujcie wszystko 3 razy zanim napiszecie (po wyczyszczeniu NVRAM i ustawieniu wszystkiego manualnie, nie z backup)
- Podajac problem piszcie dokladnie w jakich warunkach on zaistnial, a nie tylko "costam nie dziala..."

Logi, konfiguracja, model routera, wersja AIO czy VPN itp itd...
 
Boczek
Koledzy. Ustawiłem EdgeRouter jako główny a RT-N18U jaki drugi router. Podłączyłem eth2 z ER do WAN dla RT. Na RT ustawiłem statyczny adres IP z puli w ER. Na ER ustawiłem statyczny routing do RT. Działa to ale pingi s komputera podłączonego po kablu do RT rwą się.

Czym różnią się ustawienia Gateway od Router na Tomato?
Co mogę zrobić by się łączność była stabilna?

Na RT mam wifi + wifi dla gości oraz pena zamontowanego.
EdgeRouter X: EdgeOS
RT-AX56U: AsusWRT
EA6900: tbd
EA6350: tbd
 
tom1024
FreshTomato Firmware 2018.2 K26ARM USB AIO-64K-NOSMP
Asus RT-N18U

załączone dnscrypt-proxy
resolver: cisco czyli opendns
DNS1: 208.67.220.220
DNS2: brak

Zauważyłem następującą rzecz:

tcpdump -i vlan2 -s0 -n 'host 208.67.220.220 and port 53' -vvvv


Zapytania do serwera DNS wychodzą szyfrowane, port 443

Cytat

79.173.xxx.xxx.7605 > 208.67.220.220.443: [bad udp cksum 0x1cac -> 0x667b!] UDP, length 512
19:13:15.440300 IP (tos 0x0, ttl 59, id 32379, offset 0, flags [DF], proto UDP (17), length 396)
208.67.220.220.443 > 79.173.xxx.xxx.7605: [udp sum ok] UDP, length 368
19:13:47.363573 IP (tos 0x70, ttl 64, id 50335, offset 0, flags [none], proto UDP (17), length 540)
79.173.xxx.xxx.7605 > 208.67.220.220.443: [bad udp cksum 0x1cac -> 0x1331!] UDP, length 512


Ale czasami zdarza się przepuścić niezaszyfrowane zapytanie na porcie 53!

Cytat

19:11:23.572970 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 69)
79.173.xxx.xxx.52293 > 208.67.220.220.53: [bad udp cksum 0x1ad5 -> 0xfb65!] 17689+ A? officecdn.microsoft.com. (41)
19:11:23.825305 IP (tos 0x0, ttl 59, id 18692, offset 0, flags [DF], proto UDP (17), length 396)
208.67.220.220.443 > 79.173.xxx.xxx.7605: [udp sum ok] UDP, length 368
19:11:23.948880 IP (tos 0x0, ttl 59, id 35798, offset 0, flags [DF], proto UDP (17), length 281)
208.67.220.220.53 > 79.173.xxx.xxx.52293: [udp sum ok] 17689 q: A? officecdn.microsoft.com. 6/0/0 officecdn.microsoft.com. [2m16s] CNAME office.c2r.akadns.net., office.c2r.akadns.net. [5m] CNAME 2-01-3f20-0003.cdx.cedexis.net., 2-01-3f20-0003.cdx.cedexis.net. [1m18s] CNAME office-prod.edgekey.net., office-prod.edgekey.net. [5h8m40s] CNAME office-prod.edgekey.net.globalredir.akadns.net., office-prod.edgekey.net.globalredir.akadns.net. [15m] CNAME e1723.dscd.akamaiedge.net., e1723.dscd.akamaiedge.net. [20s] A 104.87.180.39 (253)
19:11:23.949073 IP (tos 0xc0, ttl 64, id 50319, offset 0, flags [none], proto ICMP (1), length 309)
79.173.xxx.xxx > 208.67.220.220: ICMP 79.173.xxx.xxx udp port 52293 unreachable, length 289
IP (tos 0x0, ttl 59, id 35798, offset 0, flags [DF], proto UDP (17), length 281)
208.67.220.220.53 > 79.173.xxx.xxx.52293: [udp sum ok] 17689 q: A? officecdn.microsoft.com. 6/0/0 officecdn.microsoft.com. [2m16s] CNAME office.c2r.akadns.net., office.c2r.akadns.net. [5m] CNAME 2-01-3f20-0003.cdx.cedexis.net., 2-01-3f20-0003.cdx.cedexis.net. [1m18s] CNAME office-prod.edgekey.net., office-prod.edgekey.net. [5h8m40s] CNAME office-prod.edgekey.net.globalredir.akadns.net., office-prod.edgekey.net.globalredir.akadns.net. [15m] CNAME e1723.dscd.akamaiedge.net., e1723.dscd.akamaiedge.net. [20s] A 104.87.180.39 (253)
19:11:23.951557 IP (tos 0x70, ttl 64, id 50320, offset 0, flags [none], proto UDP (17), length 540)
79.173.xxx.xxx.7605 > 208.67.220.220.443: [bad udp cksum 0x1cac -> 0xbe60!] UDP, length 512
19:11:24.028734 IP (tos 0x0, ttl 59, id 18739, offset 0, flags [DF], proto UDP (17), length 396)
208.67.220.220.443 > 79.173.xxx.xxx.7605: [udp sum ok] UDP, length 368
19:11:27.127767 IP (tos 0x70, ttl 64, id 50321, offset 0, flags [none], proto UDP (17), length 540)
79.173.xxx.xxx.7605 > 208.67.220.220.443: [bad udp cksum 0x1cac -> 0xbfac!] UDP, length 512
19:11:27.140994 IP (tos 0x0, ttl 59, id 19151, offset 0, flags [DF], proto UDP (17), length 204)
208.67.220.220.443 > 79.173.xxx.xxx.7605: [udp sum ok] UDP, length 176


Dlaczego tak się dzieje ?

Połączony z 24 kwiecień 2018 21:48:36:

Cytat

19:22:45.995023 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 60)
79.173.xxx.xxx.50851 > 208.67.220.220.53: [bad udp cksum 0x1acc -> 0x5e96!] 12013+ A? www.paypal.com. (32)
19:22:46.332343 IP (tos 0x0, ttl 59, id 41562, offset 0, flags [DF], proto UDP (17), length 229)
208.67.220.220.53 > 79.173.xxx.xxx.50851: [udp sum ok] 12013 q: A? www.paypal.com. 6/0/0 www.paypal.com. [4m28s] CNAME geo.paypal.com.akadns.net., geo.paypal.com.akadns.net. [30s] CNAME hotspot-www.paypal.com.akadns.net., hotspot-www.paypal.com.akadns.net. [30s] CNAME wlb.paypal.com.akadns.net., wlb.paypal.com.akadns.net. [30s] CNAME www.paypal.com.edgekey.net., www.paypal.com.edgekey.net. [1m45s] CNAME e3694.a.akamaiedge.net., e3694.a.akamaiedge.net. [20s] A 104.81.210.138 (201)


Połączony z 25 kwiecień 2018 17:10:26:
Wydaje mi się, że rozwiązaniem tego problemu jest załączenie opcji

Use dnscrypt-proxy
Priority: No-Resolv

Teraz sytuacja nie występuje, wszystkie zapytania DNS idą na porcie 443.

Wcześniej miałem
Priority: Strict-Order
Edytowany przez tom1024 dnia 25-04-2018 17:10
Mikrotik HAP AC3
Orange Światłowód 300
 
kille72
To całkiem normalne.
 
pedro
Tylko chciałem dać znać:


FreshTomato-MIPS Changelog
===========================



2018.1.064-beta 2018-04-27
--------------------------

- kernel: patch kernel against CVE-2016-10229
- kernel: disable router anycast address for /127 and /128 prefixes
- kernel: resolve force_igmp_version ignored when a IGMPv3 query received
- kernel: igmp: add a missing spin_lock_init()
- kernel: igmp: acquire pmc lock for ip_mc_clear_src()
- kernel: proc/sysctl: fix the int overflow for jiffies conversion
- kernel: net: ipv4: fix multipath RTM_GETROUTE behavior when iif is given
- flac: update to 1.3.2
- libxml2: update to 2.9.3
- libpng: update to 1.2.57
- libcurl: update to 7.59.0
- pcre: update to 8.42
- nano: update to 2.9.5
- libsodium: update to 1.0.15
- Tor: update to 0.3.2.10
- OpenVPN: update to 2.4.5
- dnscrypt-proxy: update to 1.9.5
- dnsmasq: update to 2.79
- adminer: update to 4.6.2 2018-02-20 (only English)
- uqmi: updated to uqmi-8ceeab6
- lzo: update to 2.10
- libcurl: update CA certificate bundle as of 2018-03-07
- libexif: update to 0.6.21
- libogg: update to 1.3.3
- libvorbis: update to 1.3.6
- libusb: update to 1.0.22
- pptpd: update to 1.4.0
- rp-pppoe: update to 3.12
- ntfs-3g: update to 2017.3.23
- sqlite: update to 3.23.1
- GUI: OpenVPN: add LZ4, NCP and auth digest support
- GUI: IP Traffic and Bandwith monitors: add possibility to change unit of displayed speeds (kbit/KB and Mbit/MB)
- GUI: QoS/BW Limiter: increase the maximum number of digits in speed fields to 8
- GUI: add possibility to select LTE band and roaming on 4G/LTE connection
- libcurl: size optimization (disable proxy and libcurl output options)
- OpenVPN: change configuration option 'tls-remote' to 'remote-cert-tls', because 'tls-remote' is deprecated or even removed in newest openvpn version
- OpenVPN client: fixed issue #136: added 'route-noexec' to client configuration to prevent DNS leaks
- OpenVPN: change default client's remote/local IPs, so each is different
- OpenVPN: change default remote/local IPs/subnet for servers, so each is different
- switch3g/4g, watchdog: fix modem recognition, logic of watchdog
- switch4g: improved/fixed QMI modem support
- busybox: drop modules.dep path hack, it doesn't required
- busybox: add hostname applet, required by some Entware packages
- minidlna: add persistent uuid based on router's mac
- Miniupnpd: [PATCH] Tomato Specific: Enable Miniupnpd portinuse check
- Makefile: disable RAID (mdadm binary) on AIO (z) and Mega-VPN (o) targets
- router/Makefile: remove dependencies from various install recipes, to reduce the amount of double (and triple) recompile duing build
- flac: fix compilation on Mint x64
- nfs-utils: PATCH exportfs: getexportent interprets -test-client- as default options
- rc/ppp.c: typo
- rc/pptp_client.c: add pptp-client user/pass quotation (fix issue #148)
- rc/services.c: [PATCH] REVERT: Do not write out 'no-dhcp-interface' in dnsmasq.conf
- rc/services.c: SIGINT seems to be issued too soon against dnsmasq - wait one second before doing so
- rc/services.c: correct val for unlink
- rc/services.c: avoid concurrent connections
- rc/tor.c: removed deprecated option from config (AllowUnverifiedNodes)
- rc/tor.c: add localhost ports and .onion support; disable IPv6 names resolution for onion domains by default;
  enable LAN pool for clients; add AvoidDiskWrites option to config
- rc/wan.c: fix typos, redial period for pppd
- rc/wan.c: move l2tp route fix to preset_wan
- rc/wan.c: don't terminate xl2tpd on every ppp start
- rc/wan.c: dnsmasq process was receiving a second SIGINT signal. Instead of triggering another DNSSEC time checking, it was killing process
- rc/wan.c: start adblock only when wan is up
- rc/wan.c: fix boot with only secondary/etc wan active (assume current wan is primary if previous is not up)
- rc/wan.c: adblock improvments, just start once
- rc/wan.c: cleanup
- rc/watchdog.c: changed one of connection checkers from wget to curl; now this is a recommended method for LTE connections
- fix "Enable DSCP Fix", and make it MultiWan aware *
- fix ntpc for mwan
- ipv4: Resolve force_igmp_version ignored when a IGMPv3 query received
- upnp: external and internal port arguments are swapped in miniupnpd's config file
- Code cleanup/improvements
- Make igmpproxy MWAN-friendly (It flooded logs when only secondary wan was connected)
- Improve vpnrouting and switch3g script logic, other small changes
- tinc: Add daemon poll option to check if the daemon is running, Similar to OpenVPN
- Revert: GUI: fix problem with passing Tagged/UNtagged on same port when using default vlan (Not working as intended/has problems)


2018.1.010-beta 2018-04-15
--------------------------
not public

- dnsmasq: update to 2.78
- nano: update to 2.8.1
- ncurses: update to 6.1
- transmission: update to 2.93
- php: update to 5.6.33
- GUI: fix issue with too short field for DNS 1/DNS 2
- GUI: fix problem with passing Tagged/UNtagged on same port when using default vlan
- E2500/3200: change nvram size to 32kB, to prevent the 5GHz radio from disappearing
- sqlite: update to 3.23.1



:D
pedro załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Netowski 1Gb/1Gb
Huawei E3372s-153 non-hilink + 2x15dBi MIMO
FreshTomato: Asus RT-AC3200 + RT-N18U + RT-N66U + RT-N12
 
djwujek
A gdzie można pobrać twój bulid pod mipsela ? czy będzie pasował do rutera rt-n12 vd1 ???
---- SIEĆ 1 -----

1.Modem Vectra 600/60 Mbps
2. Edgerouter X - Dom
3. Edgerouter X - Goście
4. Edgeswitch 24 Lite
5. Asus RT-N 12 d1 DD WRT 43012 - Goście
6. Nas QNAP TS-228A + 1 x 4TB
6. UPS 510W

------ SIEĆ 2 -------
1.Modem Livebox 3.0
 
jurekk
@pedro kawał dobrej roboty ;-)
ea6500v2 @Ac66u_B1 @1000 Aimesh
ea6700v cfe (custom) @AC66u_B1 node
node Aimesh,
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 11

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

tamtosiamto
19-03-2024 19:50
@Adooni 'Only one set is available for 1 band' i tak mam-1 set dla 2.4ghz i 1 dla 5ghz-czy czegos nie rozumiemW drugiej sieci goscinnej nie ma opcji wyboru Ruter only/ All nodes

Adooni
19-03-2024 19:14
no to przeczytaj to 2 pod - 1 stet z kazdego pasma jest dopuszczony na nody. zrob 2 siec jako goscinna na danym pasmie i wtedy sprawdz

71,216,518 unikalnych wizyt