20 Sierpień 2019 23:40:39
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [MOD] FreshTomato-MIPS
· asus rt-n10u problem...
· [K] Stojak od ASUS R...
· EA6700 - nie moge si...
· [K] pilot gm990 / am...
· Wybór następcy RT-N12D1
· Asus RT-N10U B + Hua...
· Filtr antyspamowy......
· [MOD] FreshTomato-ARM
· Optware Packages for...
· RT-N18U ucina transfer
· [S]Motorola Moto X S...
· [TOMATO] WRT54GL jak...
· Tomato - bugi/proble...
· Orange 1Gbit/300Mbit
· Multiroom N z wykorz...
· Wymiana Netgear 3500...
· [S] Asus rt-ac56u i ...
· Asus ac56u nie wykry...
· Asus RT-AC68U - Delu...
Najciekawsze tematy
· [MOD] FreshTomato... [399]
· asus rt-n10u prob... [19]
· Wybór następcy RT... [10]
· [K] Stojak od ASU... [4]
· EA6700 - nie moge... [0]
· [K] pilot gm990 /... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
38% [135 głosów]

Broadcom ARM
Broadcom ARM
50% [176 głosów]

Atheros
Atheros
6% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 352
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
18.232.53.231
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Tomato MultiWAN - otwarta dyskusja
Boczek
Chętnie wezmę udział w testach multiwana.

@Shibby
Mała sugestia. Rozważ możliwość dodania skryptów użytkownika reagujących na zdarzenia typu onFailoverUp i onFailoverDown. A może inaczej - używając numerków wanów: onWanXUp (X to numer wanu z konfiguracji "2210"Wink.

Chodzi o to, że mam 5GB limitu na mobilnym necie i chciałbym wiedzieć, kiedy się ograniczać. Czyli nie ciągnąć np. obrazów linuxów.
W takim skrypcie wysłałbym sobie maila, smsa lub zablokował w takim skrypcie pewne porty.
EA6900: ?
EA6350: dd-wrt
EdgeRouter X: ofw
RT-N18U: FreshTomato Firmware 2018.5 K26ARM USB AIO-64K-NOSMP
WRT54GL: FreshTomato
 
majkel152 Dziekuje za dotacje
wnet 64KB nvram będzie mało :E
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com..., dużo gratów, ups, światłowody, apeki i działa miło Smile
 
Gampers
shibby napisał(a):

w przyszłym tygodniu wydam publiczną wersję beta dla routerów ARM - ot taki prezent na święta Wink

Jak się spisze i przyjmie to zacznę portować zmiany do mipsela i prawdopodobnie już w nowym roku wyjdzie pełna wersja dla wszystkich routerów wraz ze zaktualizowanymi paczkami openssl, openvpn itd.


Shibby z chęcią bym przetestował opcję dual Wan na Linksysie EA6700. W robocie mam łączę od Orange i backup o T-Mobile.
 
shibby Dziekuje za dotacje
[RELEASE] Tomato-MultiWAN v132 Beta test

Kilka informacji dla osób chętnych potestować nową wersję.

1) koniecznie musicie wyczyścić nvram przed i po wgraniu nowego Tomato. Kategorycznie zabrania się odtwarzania backupu ustawień z pliku z poprzedniej wersji. Bardzo wiele zmiennych w nvram zostało zmodyfikowanych, przeorganizowanych oraz dodanych !

2) Zanim system pozwoli Wam skonfigurować nowy WAN musicie zdefiniować dla niego nowy VLAN. W tym celu należy udać się do podstrony Advanced->VLAN, ustawić nowy (kolejny) VID i przypisać go do nowego WANa. Jeżeli nowy WAN ma być kablowy to musicie wypiąć jeden z portów LAN i wpiąć do nowego WANa. Jeżeli zaś nowym WANem ma być modem LTE lub interfejs WiFi (Client) to nie ma konieczności przypinania do niego portu LAN. Po zapisaniu ustawień i restarcie routera pojawi się możliwość konfiguracji kolejnego WANa.

3) Waga (weight) mówi nam po jakiej ilości pakietów przesłanych pierwszym interfejsem ma nastąpić przeskok na kolejne łącze. Wagę można definiować w trybie Load Balance od 1 do 255. Ustawienie wagi na 0 (zero) spowoduje przestawienie WANa w tryb failover. Taki WAN nawiąże połączenie i będzie ono utrzymywane w trybie spoczynku (standby) i nie będzie brało udziału w normalnym routingu (load balance). Gdy system wykryje, że żadne z głównych łącz (z wagą > 0) nie funkcjonuje to wepnie łącze failover z wagą 1 do routingu. Łącze to będzie aktywne do czasu gdy system wykryje powrót choć jednego z łącz głównych. Wtedy znów przestawi łącze failover w tryb standby.

4) Wraz z funkcją MultiWAN doszła nowa zakładka Advanced->MutliWAN Routing. Dzięki niej możemy wymusić by ruch z/do danego hosta odbywał się zawsze wskazanym łączem

5) Pod opcją konfiguracji ilości interfejsów WAN doszła nowa opcja "Check Connections every". To swoisty watchdog, który sprawdza każde łącze z osobna co zadany interwał czasu i po wykryciu zmian w dostępności łącz aktualizuje politykę routingu MultiWAN. Jeżeli więc dane łącze padnie lub wznowi działanie to routing zostanie zmieniony dopiero po wykonaniu testu przez Watchdoga. Domyślny czas to 2 minuty. Test odbywa się przez sprawdzenie ruchu przychodzącego na danym interfejsie. sztuczny ruch generowany jest poprzez sprawdzenie trasy (traceroute) do dwóch zdefiniowanych w Targer hostów.

6) Dla osób dociekliwych (zaawansowanych) możliwy jest do włączenia tryb debug dla MutliWAN, który w logu wykaże dużo więcej informacji. Aktywacja polega na dopisaniu do nvram zmiennej:
nvram set mwan_degug=9

Limitacje:
- tylko jeden WAN może pracować w trybie 3G lub LTE. Nie ma możliwości by Tomato obsługiwało kilka modemów na USB
- QoS oraz BW Limiter działają tylko gdy zdefiniowany jest tylko jeden WAN

Zmiany względem v132:
- dodano funkcjonalność DualWAN (nvram < 64KB) oraz MultiWAN (nvram = 64KB)
- naprawiono obsługę PINu przy połączeniu LTE
- dodano opcję wymuszenia trybu pracy sieci dla modemów LTE non-Hilink

Proszę pamiętać, że to wersja Beta (testowa), która może zawierać pewne błędy i niedociągnięcia. Ilość zmian jest potężna (patch liczy blisko 11000 linii). Zalecam wykonanie backupu obecnych ustawień tak by w razie potrzeby ułatwić powrót do wersji bez MutliWAN.

Mile widziany feedback jak MutliWAN się spisuje, czy występują z nim problemy, jak tak to jakie (logi mile widziane), czy owe problemy występowały również na wersji v132 itd.

Tyle na chwilę obecną. Wesołych Świąt Smile
Edytowane przez kille72 dnia 24-12-2015 12:06
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 3B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
Steel_Rat
Wygląda na to, że multiwan działa dobrze. Mam na razie jedno zastrzeżenie.
Po instalacji multiwana przestaał działać radius w WIFI. W logach radiusa mam coś takiego
Pobierz kod źródłowy  Kod źródłowy

[peap] processing EAP-TLS
  TLS Length 134
[peap] Length Included
[peap] eaptls_verify returned 11
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 Handshake [length 0046], ClientKeyExchange
[peap]     TLS_accept: unknown state
[peap]     TLS_accept: unknown state
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 ChangeCipherSpec [length 0001]
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 Handshake [length 0010], Finished
[peap]     TLS_accept: unknown state
[peap] >>> Unknown TLS version [length 0005]
[peap] >>> TLS 1.0 ChangeCipherSpec [length 0001]
[peap]     TLS_accept: unknown state
[peap] >>> Unknown TLS version [length 0005]
[peap] >>> TLS 1.0 Handshake [length 0010], Finished
[peap]     TLS_accept: unknown state
[peap]     TLS_accept: unknown state
[peap]     (other): SSL negotiation finished successfully
SSL Connection Established
[peap] eaptls_process returned 13
[peap] EAPTLS_HANDLED




z innych ap (na starym tomato) jest coś takiego
Pobierz kod źródłowy  Kod źródłowy

[peap] processing EAP-TLS
[peap] eaptls_verify returned 7
[peap] Done initial handshake
[peap] <<< Unknown TLS version [length 0005]
[peap] eaptls_process returned 7
[peap] EAPTLS_OK
[peap] Session established.  Decoding tunneled attributes.
[peap] Peap state send tlv success
[peap] Received EAP-TLV response.
[peap] Success
[peap] Using saved attributes from the original Access-Accept




Nie wie czy to napewno przez to ale w nowym tomato nie działa logowanie przez Radius.

Połączony z 25 grudzień 2015 19:51:20:
Przestał działać także OpenVPN, FTP, i wszystko inne co miałem udostępnione na zewnątrz w internecie. Dokładnie nie działa otwarcie portów na zewnątrz regułką
Pobierz kod źródłowy  Kod źródłowy
iptables -A INPUT -p tcp --dport 443 -j ACCEPT


.
Na razie wróciłem do starego softu bo to jest mi potrzebne.
Edytowane przez Steel_Rat dnia 25-12-2015 19:51
WRT3200ACN (WRT32X) + OpenWRT 18.06+światełko 150/150 Mb/s
Asus RT-AC68UvE1 + RMerlin + Entware
Netgear WNR3500Lv2 + DDWRT
 
djwujek
U mnie działa ftp również z zewnątrz lecz nie działa Remonte Access na porcie 443 ( https ) na innym porcie np 8080 już działa.
1.Modem Vectra 600/30
2. Edgerouter X
3. Asus RT-N 12 d1 ddwrt - Goście
4.TP-LINK ARCHER C3150
5. Nas QNAP TS-228A + 2 x 2TB
6. UPS Micropower 1000VA Green Cell
 
Boczek
U mnie fiasko. Po aktualizacji do multivana nie działa wan z kablówki. Nie wyciągałem modemu 3g.

Goły multiwan nie podniósł w ogóle połączenia WAN.

Jan 1 01:01:00 unknown user.notice root: WAN Watchdog - Connection wan down - Reconnecting ...
Jan 1 01:01:01 unknown user.notice root: WAN Watchdog - another proces in action for wan
Jan 1 01:01:01 unknown user.notice root: WAN Watchdog - another proces in action for wan


Modem 3g udało mi się uruchomić jako podstawowe łącze ale kablówki nie.

Wyczyściłem nvram i uruchomiłem router bez podłączonego modemu 3g i to samo.

Załączam kopię nvram. http://pastebin.c...
EA6900: ?
EA6350: dd-wrt
EdgeRouter X: ofw
RT-N18U: FreshTomato Firmware 2018.5 K26ARM USB AIO-64K-NOSMP
WRT54GL: FreshTomato
 
dar3k
Mógłby ktoś przetestować (mam tylko jedno łącze nie mam też modemu USB) jak tomato zachowa się w sytuacji:
WAN1 - np Neostrada
WAN2 - modem USB
Router pracuje jako klient OpenVPN jak wiadomo Neostrada rozlacza się co 24h, czy drugi WAN utrzyma stałe połączenie VPN? Jaki będzie czas przestoju? oraz gdy przełączy VPN na GSM to czy po powrocie WAN1 utrzyma VPN@GSM czy wróci do WAN1?
Moj router RT-AC56U @ 1200,800 MHz
 
b3rok Dziekuje za dotacje
Zmienne IP w Neostradzie i OpenVPN imho zalatwi Ci usluga dyndns... Bez zabaw z multiwanem
I. Huawei HG8240 + 1x Netgear r7000 @kille72 Tomato +2x AP Netgear WNR3500L + Siemens Gigaset C610IP + Synology DS1512+
II. TP-Link TL-WDR4300 @Obsy OpenWRT Gargoyle + Linksys SPA-3102 + Synology DS110j
III. TP-Link TL-WDR3600 @Obsy OpenWRT Gargoyle + Huawei E3276

_________________________________
Ważne linki:
Firmware Tomato by Shibby
Skórki do Tomato
TomatoAnon
Regulamin forum
Jak zadawać pytania i prosić o pomoc
 
dar3k
Nie rozumiem po co ddns na klienta?
Moj router RT-AC56U @ 1200,800 MHz
 
Gampers
Dobra robota shibby.
Opcja MultiWAN działa świetnie tylko że po jej skonfigurowaniu i restarcie rutera wraca oryginalne oprogramowanie linksysa. Dopóki nie zrestartuje urządzenia wszystko działa świetnie.
Wcześnie na advancedtomato nie miałem takiego problemu.
Jestem nowy w Tomato, może czegoś nie wiem. Proszę o pomoc.
Urządzenie to Linksys EA6700.
Edytowane przez Gampers dnia 29-12-2015 15:04
 
sebikolo
Testowałem dual wan na OFW RT-N18U. Działa to słabo. Ale jest tam jedna fajna opcja. Można przyporządkować, urządzenia do WLAN'ów. Czyli definiuję które urządzenia mają korzystać z głównego WLAN'a a które z pomocniczego. Może warto taką opcję dodać w kolejnej odsłonie tomato :-)
 
shibby Dziekuje za dotacje
Przecież to już jest w tomato.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 3B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
sebikolo
Przepraszam, mój błąd.
 
wit3k
@Shiby, poprawki na nowy rok szykujesz?
 
shibby Dziekuje za dotacje
Na razie się urlopuję, świętuję i wypoczywam Smile na prace przyjdzie czas od nowego roku.
Edytowane przez shibby dnia 31-12-2015 15:25
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 3B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
najmar11
Shibby jesteś WIELKI Smile

MultiWAN działa i to jest to na co czekałem i na pewno jest to warte jakiegoś datku...

jeśli można mieć prośbę do kolejnych wersji:

- w Dynamic DNS powinna być możliwość wybrania z którego WANa chcemy pobrać adres IP
na głównym WANie mam stałe IP, a na zapasowym LTE zmienne i na nim potrzebowałbym ustawić DDNS.

- poza tym nie działa WAN Bandwidth monitor, a fajnie jakby był z podziałem na każdego WANa.

- może to tylko u mnie - modem Huawei E3372 co chwilę odnawia połączenie, Connection Uptime to najwyżej 2 min
 
shibby Dziekuje za dotacje
cieszę się Smile

Co do twoich uwag:

- prawda, muszę rzucić na to okiem

- Bandwidth Monitor działa i w real time pokazuje wszystkie WANy. Nie wiem tylko dlaczego w pozostałych zakładkach już one znikają. Walczyłem z problemem i niestety póki co problemu nie udało mi się rozwiązać. Mam do jednak na uwadze.

- u mnie E3372 działał bez problemu a połączenie potrafił utrzymywać przez kilka dni (USB3.0 w routerze RT-AC68u)

Pozdrawiam
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 3B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
najmar11
shibby napisał(a):

cieszę się Smile

Co do twoich uwag:

- prawda, muszę rzucić na to okiem

- Bandwidth Monitor działa i w real time pokazuje wszystkie WANy. Nie wiem tylko dlaczego w pozostałych zakładkach już one znikają. Walczyłem z problemem i niestety póki co problemu nie udało mi się rozwiązać. Mam do jednak na uwadze.

- u mnie E3372 działał bez problemu a połączenie potrafił utrzymywać przez kilka dni (USB3.0 w routerze RT-AC68u)

Pozdrawiam


też mam RT-AC68u, przełożyłem modem do USB3 ale nic to nie zmieniło, niestety.
w logach mam: "4G MODEM Signal Strength: -113 dBm" - może jest za słaby sygnał i go gubi?

załączyłem plik z logiem, może w wolnej chwili, rzuci Ci się coś w oczy co jest nie tak?

Połączony z 01 styczeń 2016 13:03:20:
jeszcze raz podam log, ten jest pełny od startu routera:
najmar11 dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez najmar11 dnia 01-01-2016 13:03
 
sebikolo
Ja dopiero przymierzam się do instalacji Tomato w RT-N18U. W związku z tym mam dwa krótkie pytania. Jaka jest przepustowość WAN-LAN pod Tomato? Taka jak w OFW? I czy w łatwy sposób mogę wrócić z Tomato do OFW.
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 9

· Użytkowników online: 0

· Łącznie użytkowników: 23,890
· Najnowszy użytkownik: rogal
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

mosfit
20-08-2019 22:22
Tak jak opisał to @shibby w podanym poniżej tutku

djwujek
20-08-2019 20:24
To w takim razie jak to działa ?

Adooni
20-08-2019 12:46
LACP nie daje 2Gb przy spieciu 2 LAN 1Gb tylko po 1 zabezpieczenie jak 1 lan padnie to 2 dziala, a po 2 to przy 2 podpietych urzadzeniach da kazdemu 1Gb

tamtosiamto
15-08-2019 09:42
potrzebuje pilota do gm990/amiko 8900hd, moze ktos ma na sprzedaz?

mosfit
09-08-2019 18:06
TAK,jak jest na obu stronach wsparcie dla LACP https://openlinks...ost_16
9060

djwujek
09-08-2019 14:32
i na dwóch lanach bedzie 2gb/s podłączonych równocześnie ?

majkel152
08-08-2019 14:52
wystarczy podpiąć dwa lany z modemu do kompa i po problemie, to skomplikowane jakoś ?

Steel_Rat
08-08-2019 07:58
I tak i nie. Co prawda każdy może mieć max 1Gb/s ale równocześnie maja tyle dwa urządzenia. Ew. dwa dodatkowe routery. Jeszcze możliwe że w tym modemie działa agregacja lanu Smile

djwujek
08-08-2019 01:02
Ale porty w modemie są gotowe dlatego zastanawiam się czemu dają 2 a nie jeden giga przecież to bez sensu.

overflow2
07-08-2019 20:30
10 Gbps karta ethernet i nie ma problemu. Inna kwestia czy w ogóle ten internet tyle idzie.

djwujek
07-08-2019 20:02
Inaczej uważam że reklamowanie tego internetu to kłamstwo bo nie uzyskam tych 2 GB na 1 kompie

djwujek
07-08-2019 20:01
Wytłumaczcie mi proszę jak uzyskać 2gb po lanie 1 GB wiem że można podłączyć 2 kompy każdy po 1 GB ale jak uzyskać 2gb na jednym kompie

majkel152
07-08-2019 12:17
ten modem obsługuje do 5gbps downstream i 1.5gbps upstream więc w czym problem?

Steel_Rat
07-08-2019 11:01
Możliwe jak dobry router to dwa kompy działają po 1Gb/s. Mój dostawca oferuje masz 1400/1200 Mb/s

djwujek
06-08-2019 20:38
https://www.vectra
.pl/oferta/1222/. Internet 2gb na lanie 1gb hmmmm jak to możliwe a może po wifi hehhehe

jurekk
31-07-2019 21:51
to tak samo na tomato działa ;-), ac3200 to jednak asus i go tak szybko nie uwalisz, bierz asusa

dupajasia
31-07-2019 18:14
Panowie do Huawei E3372s-153 lepiej Netgear R8000 czy Asus RT-AC3200? Co lepiej działa? Wink

38,777,481 unikalne wizyty