23 Kwietnia 2024 17:41:01
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· konfiguracja router ...
· Jaki router kupić? ...
· Szukam zaproszenia n...
· [Howto] Xpenology na...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Asus TUF-AX3000_V2 p...
· [MOD] Tomato64 (x86-64)
· Firewall nie zawsze ...
· [MOD] FreshTomato-AR...
· Optware na CIFS
· RT-AX56U - Status kl...
· [MOD] FreshTomato-MI...
· Multiroom N z wykorz...
· [S] Asus RT-AC68U E1
· [S] ASUS RT-AC68U
· Rozłączanie klient...
· serwer VPN za wan'em
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
Najpopularniejsze obecnie wątki
· Jaki router kupi... [551]
· Szukam zaproszeni... [16]
· konfiguracja rout... [8]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [216 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 416
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.230.143.213
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
Tomato MultiWAN - otwarta dyskusja
Boczek
Chętnie wezmę udział w testach multiwana.

@Shibby
Mała sugestia. Rozważ możliwość dodania skryptów użytkownika reagujących na zdarzenia typu onFailoverUp i onFailoverDown. A może inaczej - używając numerków wanów: onWanXUp (X to numer wanu z konfiguracji "2210").

Chodzi o to, że mam 5GB limitu na mobilnym necie i chciałbym wiedzieć, kiedy się ograniczać. Czyli nie ciągnąć np. obrazów linuxów.
W takim skrypcie wysłałbym sobie maila, smsa lub zablokował w takim skrypcie pewne porty.
EdgeRouter X: EdgeOS
RT-AX56U: AsusWRT
EA6900: tbd
EA6350: tbd
 
majkel152
wnet 64KB nvram będzie mało :E
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://i.imgur.com/IuB6Zwy.png, jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
Gampers

Cytat

shibby napisał(a):

w przyszłym tygodniu wydam publiczną wersję beta dla routerów ARM - ot taki prezent na święta Wink

Jak się spisze i przyjmie to zacznę portować zmiany do mipsela i prawdopodobnie już w nowym roku wyjdzie pełna wersja dla wszystkich routerów wraz ze zaktualizowanymi paczkami openssl, openvpn itd.


Shibby z chęcią bym przetestował opcję dual Wan na Linksysie EA6700. W robocie mam łączę od Orange i backup o T-Mobile.
 
shibby
[RELEASE] Tomato-MultiWAN v132 Beta test

Kilka informacji dla osób chętnych potestować nową wersję.

1) koniecznie musicie wyczyścić nvram przed i po wgraniu nowego Tomato. Kategorycznie zabrania się odtwarzania backupu ustawień z pliku z poprzedniej wersji. Bardzo wiele zmiennych w nvram zostało zmodyfikowanych, przeorganizowanych oraz dodanych !

2) Zanim system pozwoli Wam skonfigurować nowy WAN musicie zdefiniować dla niego nowy VLAN. W tym celu należy udać się do podstrony Advanced->VLAN, ustawić nowy (kolejny) VID i przypisać go do nowego WANa. Jeżeli nowy WAN ma być kablowy to musicie wypiąć jeden z portów LAN i wpiąć do nowego WANa. Jeżeli zaś nowym WANem ma być modem LTE lub interfejs WiFi (Client) to nie ma konieczności przypinania do niego portu LAN. Po zapisaniu ustawień i restarcie routera pojawi się możliwość konfiguracji kolejnego WANa.

3) Waga (weight) mówi nam po jakiej ilości pakietów przesłanych pierwszym interfejsem ma nastąpić przeskok na kolejne łącze. Wagę można definiować w trybie Load Balance od 1 do 255. Ustawienie wagi na 0 (zero) spowoduje przestawienie WANa w tryb failover. Taki WAN nawiąże połączenie i będzie ono utrzymywane w trybie spoczynku (standby) i nie będzie brało udziału w normalnym routingu (load balance). Gdy system wykryje, że żadne z głównych łącz (z wagą > 0) nie funkcjonuje to wepnie łącze failover z wagą 1 do routingu. Łącze to będzie aktywne do czasu gdy system wykryje powrót choć jednego z łącz głównych. Wtedy znów przestawi łącze failover w tryb standby.

4) Wraz z funkcją MultiWAN doszła nowa zakładka Advanced->MutliWAN Routing. Dzięki niej możemy wymusić by ruch z/do danego hosta odbywał się zawsze wskazanym łączem

5) Pod opcją konfiguracji ilości interfejsów WAN doszła nowa opcja "Check Connections every". To swoisty watchdog, który sprawdza każde łącze z osobna co zadany interwał czasu i po wykryciu zmian w dostępności łącz aktualizuje politykę routingu MultiWAN. Jeżeli więc dane łącze padnie lub wznowi działanie to routing zostanie zmieniony dopiero po wykonaniu testu przez Watchdoga. Domyślny czas to 2 minuty. Test odbywa się przez sprawdzenie ruchu przychodzącego na danym interfejsie. sztuczny ruch generowany jest poprzez sprawdzenie trasy (traceroute) do dwóch zdefiniowanych w Targer hostów.

6) Dla osób dociekliwych (zaawansowanych) możliwy jest do włączenia tryb debug dla MutliWAN, który w logu wykaże dużo więcej informacji. Aktywacja polega na dopisaniu do nvram zmiennej:
nvram set mwan_degug=9

Limitacje:
- tylko jeden WAN może pracować w trybie 3G lub LTE. Nie ma możliwości by Tomato obsługiwało kilka modemów na USB
- QoS oraz BW Limiter działają tylko gdy zdefiniowany jest tylko jeden WAN

Zmiany względem v132:
- dodano funkcjonalność DualWAN (nvram < 64KB) oraz MultiWAN (nvram = 64KB)
- naprawiono obsługę PINu przy połączeniu LTE
- dodano opcję wymuszenia trybu pracy sieci dla modemów LTE non-Hilink

Proszę pamiętać, że to wersja Beta (testowa), która może zawierać pewne błędy i niedociągnięcia. Ilość zmian jest potężna (patch liczy blisko 11000 linii). Zalecam wykonanie backupu obecnych ustawień tak by w razie potrzeby ułatwić powrót do wersji bez MutliWAN.

Mile widziany feedback jak MutliWAN się spisuje, czy występują z nim problemy, jak tak to jakie (logi mile widziane), czy owe problemy występowały również na wersji v132 itd.

Tyle na chwilę obecną. Wesołych Świąt Smile
Edytowany przez kille72 dnia 24-12-2015 12:06
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
Steel_Rat
Wygląda na to, że multiwan działa dobrze. Mam na razie jedno zastrzeżenie.
Po instalacji multiwana przestaał działać radius w WIFI. W logach radiusa mam coś takiego


[peap] processing EAP-TLS
  TLS Length 134
[peap] Length Included
[peap] eaptls_verify returned 11
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 Handshake [length 0046], ClientKeyExchange
[peap]     TLS_accept: unknown state
[peap]     TLS_accept: unknown state
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 ChangeCipherSpec [length 0001]
[peap] <<< Unknown TLS version [length 0005]
[peap] <<< TLS 1.0 Handshake [length 0010], Finished
[peap]     TLS_accept: unknown state
[peap] >>> Unknown TLS version [length 0005]
[peap] >>> TLS 1.0 ChangeCipherSpec [length 0001]
[peap]     TLS_accept: unknown state
[peap] >>> Unknown TLS version [length 0005]
[peap] >>> TLS 1.0 Handshake [length 0010], Finished
[peap]     TLS_accept: unknown state
[peap]     TLS_accept: unknown state
[peap]     (other): SSL negotiation finished successfully
SSL Connection Established
[peap] eaptls_process returned 13
[peap] EAPTLS_HANDLED

z innych ap (na starym tomato) jest coś takiego


[peap] processing EAP-TLS
[peap] eaptls_verify returned 7
[peap] Done initial handshake
[peap] <<< Unknown TLS version [length 0005]
[peap] eaptls_process returned 7
[peap] EAPTLS_OK
[peap] Session established.  Decoding tunneled attributes.
[peap] Peap state send tlv success
[peap] Received EAP-TLV response.
[peap] Success
[peap] Using saved attributes from the original Access-Accept

Nie wie czy to napewno przez to ale w nowym tomato nie działa logowanie przez Radius.

Połączony z 25 grudzień 2015 19:51:20:
Przestał działać także OpenVPN, FTP, i wszystko inne co miałem udostępnione na zewnątrz w internecie. Dokładnie nie działa otwarcie portów na zewnątrz regułką

iptables -A INPUT -p tcp --dport 443 -j ACCEPT
.
Na razie wróciłem do starego softu bo to jest mi potrzebne.
Edytowany przez Steel_Rat dnia 25-12-2015 19:51
WRT3200ACN (WRT32X) + OpenWRT 18.06+światełko 150/150 Mb/s
Asus RT-AC68UvE1 + RMerlin + Entware
Netgear WNR3500Lv2 + DDWRT
 
djwujek
U mnie działa ftp również z zewnątrz lecz nie działa Remonte Access na porcie 443 ( https ) na innym porcie np 8080 już działa.
---- SIEĆ 1 -----

1.Modem Vectra 600/60 Mbps
2. Edgerouter X - Dom
3. Edgerouter X - Goście
4. Edgeswitch 24 Lite
5. Asus RT-N 12 d1 DD WRT 43012 - Goście
6. Nas QNAP TS-228A + 1 x 4TB
6. UPS 510W

------ SIEĆ 2 -------
1.Modem Livebox 3.0
 
Boczek
U mnie fiasko. Po aktualizacji do multivana nie działa wan z kablówki. Nie wyciągałem modemu 3g.

Goły multiwan nie podniósł w ogóle połączenia WAN.

Cytat

Jan 1 01:01:00 unknown user.notice root: WAN Watchdog - Connection wan down - Reconnecting ...
Jan 1 01:01:01 unknown user.notice root: WAN Watchdog - another proces in action for wan
Jan 1 01:01:01 unknown user.notice root: WAN Watchdog - another proces in action for wan


Modem 3g udało mi się uruchomić jako podstawowe łącze ale kablówki nie.

Wyczyściłem nvram i uruchomiłem router bez podłączonego modemu 3g i to samo.

Załączam kopię nvram. http://pastebin.com/hhd3Jcaw
EdgeRouter X: EdgeOS
RT-AX56U: AsusWRT
EA6900: tbd
EA6350: tbd
 
dar3k
Mógłby ktoś przetestować (mam tylko jedno łącze nie mam też modemu USB) jak tomato zachowa się w sytuacji:
WAN1 - np Neostrada
WAN2 - modem USB
Router pracuje jako klient OpenVPN jak wiadomo Neostrada rozlacza się co 24h, czy drugi WAN utrzyma stałe połączenie VPN? Jaki będzie czas przestoju? oraz gdy przełączy VPN na GSM to czy po powrocie WAN1 utrzyma VPN@GSM czy wróci do WAN1?
ER-12 + 4x UAP-AC-PRO
 
b3rok
Zmienne IP w Neostradzie i OpenVPN imho zalatwi Ci usluga dyndns... Bez zabaw z multiwanem
I. Huawei HG8240 + 1x Netgear r7000 @FreshTomato + Synology DS1512+
II. TP-Link TL-WDR4300 @Obsy OpenWRT Gargoyle
III. TP-Link TL-WDR3600 @Obsy OpenWRT Gargyle
 
dar3k
Nie rozumiem po co ddns na klienta?
ER-12 + 4x UAP-AC-PRO
 
Gampers
Dobra robota shibby.
Opcja MultiWAN działa świetnie tylko że po jej skonfigurowaniu i restarcie rutera wraca oryginalne oprogramowanie linksysa. Dopóki nie zrestartuje urządzenia wszystko działa świetnie.
Wcześnie na advancedtomato nie miałem takiego problemu.
Jestem nowy w Tomato, może czegoś nie wiem. Proszę o pomoc.
Urządzenie to Linksys EA6700.
Edytowany przez Gampers dnia 29-12-2015 15:04
 
sebikolo
Testowałem dual wan na OFW RT-N18U. Działa to słabo. Ale jest tam jedna fajna opcja. Można przyporządkować, urządzenia do WLAN'ów. Czyli definiuję które urządzenia mają korzystać z głównego WLAN'a a które z pomocniczego. Może warto taką opcję dodać w kolejnej odsłonie tomato :-)
 
shibby
Przecież to już jest w tomato.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
sebikolo
Przepraszam, mój błąd.
 
wit3k
@Shiby, poprawki na nowy rok szykujesz?
 
shibby
Na razie się urlopuję, świętuję i wypoczywam Smile na prace przyjdzie czas od nowego roku.
Edytowany przez shibby dnia 31-12-2015 15:25
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
najmar11
Shibby jesteś WIELKI Smile

MultiWAN działa i to jest to na co czekałem i na pewno jest to warte jakiegoś datku...

jeśli można mieć prośbę do kolejnych wersji:

- w Dynamic DNS powinna być możliwość wybrania z którego WANa chcemy pobrać adres IP
na głównym WANie mam stałe IP, a na zapasowym LTE zmienne i na nim potrzebowałbym ustawić DDNS.

- poza tym nie działa WAN Bandwidth monitor, a fajnie jakby był z podziałem na każdego WANa.

- może to tylko u mnie - modem Huawei E3372 co chwilę odnawia połączenie, Connection Uptime to najwyżej 2 min
 
shibby
cieszę się Smile

Co do twoich uwag:

- prawda, muszę rzucić na to okiem

- Bandwidth Monitor działa i w real time pokazuje wszystkie WANy. Nie wiem tylko dlaczego w pozostałych zakładkach już one znikają. Walczyłem z problemem i niestety póki co problemu nie udało mi się rozwiązać. Mam do jednak na uwadze.

- u mnie E3372 działał bez problemu a połączenie potrafił utrzymywać przez kilka dni (USB3.0 w routerze RT-AC68u)

Pozdrawiam
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
najmar11

Cytat

shibby napisał(a):

cieszę się Smile

Co do twoich uwag:

- prawda, muszę rzucić na to okiem

- Bandwidth Monitor działa i w real time pokazuje wszystkie WANy. Nie wiem tylko dlaczego w pozostałych zakładkach już one znikają. Walczyłem z problemem i niestety póki co problemu nie udało mi się rozwiązać. Mam do jednak na uwadze.

- u mnie E3372 działał bez problemu a połączenie potrafił utrzymywać przez kilka dni (USB3.0 w routerze RT-AC68u)

Pozdrawiam


też mam RT-AC68u, przełożyłem modem do USB3 ale nic to nie zmieniło, niestety.
w logach mam: "4G MODEM Signal Strength: -113 dBm" - może jest za słaby sygnał i go gubi?

załączyłem plik z logiem, może w wolnej chwili, rzuci Ci się coś w oczy co jest nie tak?

Połączony z 01 styczeń 2016 13:03:20:
jeszcze raz podam log, ten jest pełny od startu routera:
najmar11 załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez najmar11 dnia 01-01-2016 13:03
 
sebikolo
Ja dopiero przymierzam się do instalacji Tomato w RT-N18U. W związku z tym mam dwa krótkie pytania. Jaka jest przepustowość WAN-LAN pod Tomato? Taka jak w OFW? I czy w łatwy sposób mogę wrócić z Tomato do OFW.
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 11

· Użytkowników online: 0

· Łącznie użytkowników: 24,117
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
23-04-2024 12:35
modem bez smilocka?

man1
22-04-2024 23:27
Czy próbował ktoś uzywac karty voice (z nolimit GB) od tmobile w modemie /routerze? Da się jakoś to zrobić? Bo u mnie neta brak. E3372 Sad

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

Adooni
24-03-2024 13:16
Guest network is currently designed to allow the first set of each band (2.4G, 5G, 5G-1) available to the AiMesh node

tamtosiamto
24-03-2024 03:03
ale w 1 jest opcja do wyboru - dla calej sieci albo rutera only i wlasnie o tym mowie, ze nie dziala

Adooni
23-03-2024 16:31
w dokumencie asusa jest ze wlasnie dla 1 ma dzialac na nodach tez

tamtosiamto
23-03-2024 15:39
tak, ale nie zmienia to faktu, ze w pierwszej nie dziala wylaczanie aimesh dla goscinnej( a powinno), czyli jest jakis bug. Mam start soft, bo to dsl-ac68 ktory nie jest juz updateowany

Adooni
22-03-2024 18:07
nie, 1 wsza bedzie wszedzie trzeba 2ga zrobic dla kazdego pasma te nie sa przenoszone

tamtosiamto
19-03-2024 19:57
czyli jak mam jedna siec goscinna to powinno dzialac separowanie gosci od noda -a nie dziala Smile

71,262,353 unikalnych wizyt