26 Marzec 2017 14:56:24
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Serwer "Składak"
· Asus RT-N56u - "diam...
· Kompilacje by @kille72
· blokowanie spamu po ...
· Który router? lte-a ...
· Jaka kamera IP z moż...
· AC66U - 3 diody i ma...
· [MOD] Tomato by shibby
· Modem sim jako zapas...
· Skrzynka mailowa?
· Tomato i Netgear R6400
· VLAN - testy poprawi...
· Asus RT-AC56U - "mał...
· Iptables tomato prze...
· openvpn Tomato-serwe...
· [S] Serwer QNAP TVS-...
· Netgear WNR3500Lv2 +...
· Blokada dostepu do d...
· Uwalony? Asus RT-n18...
· Uwierzytelnianie Act...
Najciekawsze tematy
· [MOD] Tomato by s... [13157]
· Kompilacje by @ki... [331]
· Asus RT-AC56U - "... [329]
· Serwer "Składak" [88]
· VLAN - testy popr... [52]
· router 3g - zagwo... [24]
· Tomato i Netgear ... [14]
· Netgear WNDR3700V... [13]
· Który router? lte... [9]
· Netgear WNR3500Lv... [7]
· Uwalony? Asus RT-... [7]
· Asus RT-N56u - "d... [6]
· AC66U - 3 diody i... [6]
· Modem sim jako za... [6]
· Skrzynka mailowa? [6]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
41% [118 głosów]

Broadcom ARM
Broadcom ARM
48% [137 głosów]

Atheros
Atheros
6% [16 głosów]

Marvell
Marvell
1% [3 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 286
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.157.210.33
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
[YT] Owncloud7 na Tomato z użyciem wbudowanego serwera WWW
mp3zenek
To jest poprawny wpis

Pobierz kod źródłowy  Kod źródłowy
<?php
$CONFIG = array (
  'instanceid' => 'oc44e6877c63',
  'passwordsalt' => 'ae89820e6fbe8299ff3525cb457870',
  'trusted_domains' =>
  array (
    0 => '192.168.1.1:85',
    1 => 'Tu wpisujesz drugi adres do twojej sieci/routera',
    2 => 'Tu wpisujesz trzeci adres do twojej sieci/routera',
    3 => 'Tu wpisujesz czwarty adres do twojej sieci/routera',
    4 => 'Tu wpisujesz piąty adres do twojej sieci/routera',
    5 => 'Tu wpisujesz szósty adres do twojej sieci/routera',
  ),
  'datadirectory' => '/opt/static/data',
  'dbtype' => 'sqlite3',
  'version' => '7.0.2.1',
  'installed' => true,
);




W polach gdzie chodzi o wpisanie adresu, to wpisujesz adres do swojego routera ale z sieci zewnętrznej.
Na przykład:
1 => 'owncloudtomato.pl:85',
2 => 'twoja.domena:85',
itd.

Jeśli nie używasz większej ilości domen niż jednej to resztę linii możesz usunąć.

Mam nadzieję że pomogłem.

Pozdrawiam
Edytowane przez mp3zenek dnia 10-09-2014 17:40
 
Maniek91PL
działa Grin
Asus N18U
Lenovo IdeaPad Y500
i7 3630QM
16 GB DDR3
SLI GT 750M
Vu+ Solo2
 
Snap
shibby próbowałeś już postawić Owncloud na Rt-n16 ??
 
mb36
Czu u Was też nie wyświetlają się wszystkie ikony na stronie owncloud, są to pliki *.svg ???
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
miceng
Witam

utknąłem przy instalacji na takim komunikacie This can usually be fixed by giving the webserver write access to the config directory. co mam zrobić ?

Połączony z 12 wrzesień 2014 12:03:27:
ok już sobie poradziłem Smile
Edytowane przez miceng dnia 12-09-2014 12:03
Asus RT-AC68R/U Tomato Firmware 1.28.0000 -122 K26ARM USB AIO-64K + Transmission + ReadyNAS 102
 
susser
Witam

wie ktos moze, jak dzielic pliki z wewnetrznego ip, ale zeby pokazal sie zewnetrzny link mojej domeny.

Overwritehost w config.php niestety nic nie daje.

Mowiac inaczej, nie jestem wstanie polaczyc sie z Owncloudem za pomoca zewnetrznego ip bedac wewnatrz mojej sieci.

Za kazdym razem musze wycinac i wklejac jak chce komus cos udostepnic.

Troche mnie to denerwuje, ma ktos jakis pomysl?

Pozdr.
 
mb36
Ponawiam pytanie o wyświetlanie ikon w owncloud.
Chodzi mi o ikony z rozszerzeniem *.svg
U mnie nie wyświetla wszystkich ikon, które mają to rozszerzenie np. ikony udostępnij czy usuń. Jak jest u Was ?
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
U mnie tez to nie dziala, a jak wyglada z plikami z rozszerzeniem jpg? U mnie nie dzialaja.Sad
Moge je dzielic oraz sciagac, ale nie przegladac...
 
mb36
U mnie jest problem z pobieraniem i synchronizacją dużych plików. Nie mogę np. pobrać przez www pliku o rozmiarze 150MB ale i windowsowy program do synchronizacji też go nie pobiera. I nie jest tu problem max_file_size bo to dotyczy uploadu. Jak jest u Was, może ktoś przetestować. Sprawdzę wieczorem jaki max rozmiar się pobierze.
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
a dziala tobie przegladanie plikow z rozszerzeniem jpg?
 
mb36
susser napisał(a):

a dziala tobie przegladanie plikow z rozszerzeniem jpg?


W zakładce zdjęcia pokazuje mi pliki *jpg

Połączony z 15 wrzesień 2014 12:07:03:
@susser, może sprawdzisz jak u Ciebie pobieranie i synchronizacja dużych pików np. 150MB

Połączony z 15 wrzesień 2014 12:51:00:
Dodam jeszcze, że w sieci lokalnej duże pliki poprzez WWW można pobrać.

Połączony z 15 wrzesień 2014 13:16:38:
Sprawdziłem, pliki powyżej 100MB nie są pobierane przez WWW, pewnie z synchronizacją będzie podobnie, synchronizację sprawdzę jutro.

Połączony z 15 wrzesień 2014 13:59:04:
Aplikacja na Androida:
plik 92MB - pobiera
plik 130MB - pobieranie nieudane

gdy połączony z siecią lokalną wszystko OK.
Edytowane przez mb36 dnia 15-09-2014 13:59
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
shibby Dziekuje za dotacje
spróbuj do pliku php.ini dopisać

max_execution_time = 300

domyślnie timeout wykonania skryptu PHP jest ustawiony na 30 sek.
Asus RT-AC3200 Tomato v1.28 K26ARM-136
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mb36
shibby napisał(a):

spróbuj do pliku php.ini dopisać

max_execution_time = 300

domyślnie timeout wykonania skryptu PHP jest ustawiony na 30 sek.


Nic nie pomogło, ale to chyba nie w tym problem skoro w sieci lokalnej nie ma problemu z pobieraniem plików większych niż 100MB
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
shibby Dziekuje za dotacje
miałem wczoraj chwilę czasu by wrócić do tematu owncloud na tomato i takie moje spostrzeżenia:

- początkowo nie byłem w stanie przesłać pliku powyżej 80MB. Problemem jest tu RAM. Pamiętajmy, że z połowy RAMu robiony jest /tmp tak więc średnio w routerze z 256MB ramu pozostaje nam jakieś 128MB do dyspozycji. Część zabierze system i pomimo limitu w PHP ustawionego na 100MB nie będziemy w stanie przesłać większego pliku. Rozwiązaniem jest tu podpięcie swapa.

- Po podpięciu swapa 256MB udało mi się przesłać pliki większe ale max jaki przesłał to 86MB. Przy próbie wysłania większego dostaję komunikat "bląd zapisu na dysk". Komunikat dziwny i niezrozumiały dla mnie. Dysk to pendrive 16GB sformatowany na ext2 i podmontowany pod /opt. Niestety tego problemu nie rozwiązałem jeszcze.

BTW tak na chwilę obecną wygląda "robocza" wersja nowych funcji web serwera w GUI:
shibby dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Asus RT-AC3200 Tomato v1.28 K26ARM-136
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mp3zenek
shibby napisał(a):

miałem wczoraj chwilę czasu by wrócić do tematu owncloud na tomato i takie moje spostrzeżenia:

- początkowo nie byłem w stanie przesłać pliku powyżej 80MB. Problemem jest tu RAM. Pamiętajmy, że z połowy RAMu robiony jest /tmp tak więc średnio w routerze z 256MB ramu pozostaje nam jakieś 128MB do dyspozycji. Część zabierze system i pomimo limitu w PHP ustawionego na 100MB nie będziemy w stanie przesłać większego pliku. Rozwiązaniem jest tu podpięcie swapa.

- Po podpięciu swapa 256MB udało mi się przesłać pliki większe ale max jaki przesłał to 86MB. Przy próbie wysłania większego dostaję komunikat "bląd zapisu na dysk". Komunikat dziwny i niezrozumiały dla mnie. Dysk to pendrive 16GB sformatowany na ext2 i podmontowany pod /opt. Niestety tego problemu nie rozwiązałem jeszcze.

BTW tak na chwilę obecną wygląda "robocza" wersja nowych funcji web serwera w GUI:


Witam

Ja mam ten sam problem z tym błędem (bląd zapisu na dysk) i jak na razie też go jeszcze nie rozwiązałem.
Jedyne co zauważyłem że błąd występuje przez strone WWW z aplikacji na windowsie wrzuca mi spokjnie pliki 200MB, co by oznaczało jakiś problem w konfiguracji serwera www na routerze.
Co web serwera w GUI to wygląda bardzo obiecująco Smile

Pozdrawiam
 
shibby Dziekuje za dotacje
mam też dla was ciekawostkę. Otóż skompilowałem pakiety optware php-5.6 dla mipsel i arm ale jeszcze ich nie miałem czasu przetestować. Patche podesłał @alllexx z forum linksysinfo.org Smile Tak więc jak ktoś zechce postawić apache lub lighttpd z php 5.6 z optware to będzie to możliwe Smile
Asus RT-AC3200 Tomato v1.28 K26ARM-136
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mp3zenek
Witam

Z tego co udało mi się ustalić, to przy wgrywaniu czegoś przez stronę WWW, wszystko na ten czas jest wrzucane do /tmp tylko nie wiem dokładnie gdzie.
U mnie wielkość tmp wygląda tak:
tmpfs 124.8M 2.4M 122.4M 2% /tmp

Myślę że jak by się udało /tmp zamontować/przenieść na dysk o większej pojemności to by wszystko zaczęło działać.

Niestety ta operacja mnie przewyższa : / bo na linuxie się tyle znam co tu wyczytałem.

Wiem że do podobnych wniosków doszedł już shibby i zapewne nic nowego nie odkryłem.

Jeszcze znalazłem to że nginx odwołuje się do tej ścieżki przy wgrywaniu:
/tmp/var/lib/nginx/client

Zrobiłem sobie dowiązanie do tej ścieżki i katalog umieściłem na dysku, co spowodowało że w czasie wgrywania pliku /tmp nie był ruszany do momentu jak się grał i wtedy zawartość z dowiązania z powrotem zaczyna być wgrywana do /tmp aż do momentu jak się nie skończy miejsce.
I pojawia się komunikat o błędzie zapisu.

Zapewne to dużo nie wniesie do tematu, ale kto wie.

Pozdrawiam

Połączony z 20 wrzesień 2014 11:16:10:
Witam

Udało mi się rozwiązać problem wgrywania dużych plików.
W skrypcie init wystarczy dopisać i zrestartować router:
Pobierz kod źródłowy  Kod źródłowy
echo "upload_tmp_dir = /nas/tmp" >> /etc/php.ini




Plus trzeba dopisać w pliku konfiguracyjnym nginx (nginx.conf) w sekcji http tej linijki:
Pobierz kod źródłowy  Kod źródłowy
client_body_temp_path /nas/tmp;




Gdzie /nas/tmp - to dowolna ścieżka prowadząca do przestrzeni na dysku lub pendrive. Ścieżka musi być identyczna dla tych dwóch wpisów.

Teraz zostało rozwiązanie problemu ze ściąganiem dużych plików przez WWW.

Pozdrawiam

Połączony z 20 wrzesień 2014 11:27:10:
Chyba przed wczesna radość, udało mi się grać plik 150 MB ale przy próbie 300 MB dalej to samo. Muszę szukać dalej.

Pozdrawiam

Połączony z 22 wrzesień 2014 20:45:04:
Witam

A jednak działa.
Dziś wgrałem plik 1GB, fakt że przy końcu wyskoczył komunikat "not found" ale po odświeżeniu strony plik się pojawił.
Dziś to przetestowałem wgrywając pliki od znajomego i z domu po lokalnej sieci.

Pozdrawiam
Edytowane przez mp3zenek dnia 22-09-2014 20:45
 
Staszek Dziekuje za dotacje
I to się nazywa dobra współpraca Open. Super koledzy. Ktoś 'pracuje' a drudzy 'wespół'. Ale tak jest, gdy niewielu zna się na Linux-ie a zwłaszcza na programowaniu. Dzięki chłopaki za to co robicie. Niektórzy nazywają to motywacja, inni wdzięcznością.Wink
Asus RT-AC56U Tomato K26ARM-138.12-AIO by Shibby Huawei E3372s non HiLink w zestawie
MikroTik RB951G-2HnD
Fritz!Box 7490 + Fiber 80
 
mp3zenek
Witam

Chyba udało mi się rozwiązać problem z pobieraniem plików przez WWW.

Zrobiłem to tym sposobem:

Tworzymy na dysku katalog w którym będą gromadzone pliki tymczasowe przez nginx, w moim przypadku jest to:

Pobierz kod źródłowy  Kod źródłowy
/nas/tmp/nginx



Po tym dopisujemy w tomato w sekcji Firewall:

Pobierz kod źródłowy  Kod źródłowy
#Zamiana lokalizacji nginx
rm -r /tmp/var/lib/nginx
ln -s /nas/tmp/nginx/ /tmp/var/lib/nginx

#Zatrzymanie i start nginx
/usr/sbin/nginx -s stop
/usr/sbin/nginx



Gdzie /nas/tmp/nginx to ścieżka gdzie stworzyliśmy katalog na pliki tymczasowe dla nginx.

Po tej operacji restartujemy router i nasz ownCloud powinien działać bez potrzeby ręcznego zatrzymywania i ponownego uruchamiania, a pliki powinny się ściągać bez problemów.

Ja tym sposobem ściągam pliki 1 GB i nie napotkałem problemu.

Pozdrawiam
 
Jabol
Kiedy 122 dla WNR3500Lv2 ?:>
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 9

· Użytkowników online: 3
tomek500, belliash, Steel_Rat

· Łącznie użytkowników: 23,457
· Najnowszy użytkownik: michal55
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

pedro
24-03-2017 00:07
Też testuję 138.13 i jak zwykle mam jedną prośbę: https://openlinks...os
t_162178

jachu
22-03-2017 21:21
juz pobralem zaraz bede instalowac

kille72
22-03-2017 21:15
v138.13 ARM gotowa do pobrania: https://openlinks.
..ost_159401

p4v3u
22-03-2017 01:15
rt-n18 wydaje się byc rozsadny.

PixelPL
22-03-2017 00:57
Czym zastąpić stary Asus RT-N16?

p4v3u
21-03-2017 20:52
czy dalej najlepszym modemem 3/4g dla tomato (ac68) bedzie 3372 nohilink?

jurekk
21-03-2017 16:56
otwórz watek bo tu nie ma miejsca by ci ktos pomógł i napisz cos wiecej jakie tomato jakie zrodlo neta , czy masz stale ip itd

Bolek01148
20-03-2017 15:44
Witam wszystkich i proszę o pomoc. Jestem pod ddos atakiem od ponad roku. Jestem zielony o linuxie ,uczę since i po instalacji Tomato na linxys E1550 niewiem Jak jego skonfigurowac .Potrzebuję wasze

RaTaJ
19-03-2017 16:58
priority wybierz highest

lolo2
18-03-2017 21:52
Mam, uruchomione Gre, zona wlacza seriale online to ping w grach wzrasta do 200 a wtedy ciezko grac.

lolo2
18-03-2017 21:51
bwlimit sluzy do limitu pasma. A jest gdzieś funkcja aby mieć niższe pingi w grze?

kille72
18-03-2017 16:42
Priority?

RaTaJ
18-03-2017 16:14
192.168.1.1/bwlimi
t.asp

lolo2
18-03-2017 15:21
Witam, ktora to opcja w tomato odpowiada aby nada IP priorytet do lepszego PING?

kille72
17-03-2017 06:39

VANT
10-03-2017 23:58
@krisan masz jakikolwiek domowy sprzęt który przetworzy taką ilość danych ? Na 100% nie, no chyba że w domu masz jakąś wydajną serwerową macierz z kartą 10Gb. W temacie piszesz o domu i tanim sprzęci

krisan
10-03-2017 22:15
Hejka, ktoś korzysta z infrastruktury 10GbE w swoim LANie? Jakie doświadczenia? https://openlinks.
..d_id=21077

31,412,971 unikalne wizyty