24 Październik 2017 05:49:19
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Asus RT-N18U ,DD-WRT...
· Asus RT-AC1200G+ bar...
· FON2100A
· OpenVPN klient na si...
· Urwana antena
· Multiroom N z wykorz...
· Konfiguracja Asusa R...
· pytanie o vlany w ac68
· DD-WRT Schedule Wi-F...
· [MOD] Tomato by shibby
· [Artykuł] Jakie toma...
· jaki router
· Asus RT-AC1200G+
· [TURTORIAL] Konfigur...
· RT-N66U + E3372h (od...
· Asus RT-AC3200 - rou...
· [MOD] Tomato by kille72
· Netgear WNR3500L v2 ...
· [S] Linksys EA8500
· Domowy serwer NAS - ...
Najciekawsze tematy
· [MOD] Tomato by s... [13571]
· Multiroom N z wyk... [885]
· [MOD] Tomato by k... [735]
· [Artykuł] Jakie t... [595]
· RT-N18U - ARM z j... [244]
· [TURTORIAL] Konfi... [141]
· Asus RT-AC3200 - ... [97]
· Asus RT-AC1200G+ [70]
· Asus RT-N18U ,DD-... [22]
· Domowy serwer NAS... [9]
· FON2100A [8]
· jaki router [8]
· RT-N66U + E3372h ... [4]
· pytanie o vlany w... [3]
· DD-WRT Schedule W... [3]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
41% [125 głosów]

Broadcom ARM
Broadcom ARM
48% [148 głosów]

Atheros
Atheros
6% [19 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 308
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
23.20.86.177
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
[YT] Owncloud7 na Tomato z użyciem wbudowanego serwera WWW
mp3zenek
To jest poprawny wpis

Pobierz kod źródłowy  Kod źródłowy
<?php
$CONFIG = array (
  'instanceid' => 'oc44e6877c63',
  'passwordsalt' => 'ae89820e6fbe8299ff3525cb457870',
  'trusted_domains' =>
  array (
    0 => '192.168.1.1:85',
    1 => 'Tu wpisujesz drugi adres do twojej sieci/routera',
    2 => 'Tu wpisujesz trzeci adres do twojej sieci/routera',
    3 => 'Tu wpisujesz czwarty adres do twojej sieci/routera',
    4 => 'Tu wpisujesz piąty adres do twojej sieci/routera',
    5 => 'Tu wpisujesz szósty adres do twojej sieci/routera',
  ),
  'datadirectory' => '/opt/static/data',
  'dbtype' => 'sqlite3',
  'version' => '7.0.2.1',
  'installed' => true,
);




W polach gdzie chodzi o wpisanie adresu, to wpisujesz adres do swojego routera ale z sieci zewnętrznej.
Na przykład:
1 => 'owncloudtomato.pl:85',
2 => 'twoja.domena:85',
itd.

Jeśli nie używasz większej ilości domen niż jednej to resztę linii możesz usunąć.

Mam nadzieję że pomogłem.

Pozdrawiam
Edytowane przez mp3zenek dnia 10-09-2014 17:40
 
Maniek91PL
działa Grin
Asus N18U
Rocket M5
APC BACK-UPS RS 1200
Lenovo IdeaPad Y500
i7 3630QM
16 GB DDR3
SLI GT 750M
Vu+ Solo2
 
Snap
shibby próbowałeś już postawić Owncloud na Rt-n16 ??
 
mb36
Czu u Was też nie wyświetlają się wszystkie ikony na stronie owncloud, są to pliki *.svg ???
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
miceng
Witam

utknąłem przy instalacji na takim komunikacie This can usually be fixed by giving the webserver write access to the config directory. co mam zrobić ?

Połączony z 12 wrzesień 2014 12:03:27:
ok już sobie poradziłem Smile
Edytowane przez miceng dnia 12-09-2014 12:03
Asus RT-AC68R/U Tomato Firmware 1.28.0000 -122 K26ARM USB AIO-64K + Transmission + ReadyNAS 102
 
susser
Witam

wie ktos moze, jak dzielic pliki z wewnetrznego ip, ale zeby pokazal sie zewnetrzny link mojej domeny.

Overwritehost w config.php niestety nic nie daje.

Mowiac inaczej, nie jestem wstanie polaczyc sie z Owncloudem za pomoca zewnetrznego ip bedac wewnatrz mojej sieci.

Za kazdym razem musze wycinac i wklejac jak chce komus cos udostepnic.

Troche mnie to denerwuje, ma ktos jakis pomysl?

Pozdr.
 
mb36
Ponawiam pytanie o wyświetlanie ikon w owncloud.
Chodzi mi o ikony z rozszerzeniem *.svg
U mnie nie wyświetla wszystkich ikon, które mają to rozszerzenie np. ikony udostępnij czy usuń. Jak jest u Was ?
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
U mnie tez to nie dziala, a jak wyglada z plikami z rozszerzeniem jpg? U mnie nie dzialaja.Sad
Moge je dzielic oraz sciagac, ale nie przegladac...
 
mb36
U mnie jest problem z pobieraniem i synchronizacją dużych plików. Nie mogę np. pobrać przez www pliku o rozmiarze 150MB ale i windowsowy program do synchronizacji też go nie pobiera. I nie jest tu problem max_file_size bo to dotyczy uploadu. Jak jest u Was, może ktoś przetestować. Sprawdzę wieczorem jaki max rozmiar się pobierze.
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
a dziala tobie przegladanie plikow z rozszerzeniem jpg?
 
mb36
susser napisał(a):

a dziala tobie przegladanie plikow z rozszerzeniem jpg?


W zakładce zdjęcia pokazuje mi pliki *jpg

Połączony z 15 wrzesień 2014 12:07:03:
@susser, może sprawdzisz jak u Ciebie pobieranie i synchronizacja dużych pików np. 150MB

Połączony z 15 wrzesień 2014 12:51:00:
Dodam jeszcze, że w sieci lokalnej duże pliki poprzez WWW można pobrać.

Połączony z 15 wrzesień 2014 13:16:38:
Sprawdziłem, pliki powyżej 100MB nie są pobierane przez WWW, pewnie z synchronizacją będzie podobnie, synchronizację sprawdzę jutro.

Połączony z 15 wrzesień 2014 13:59:04:
Aplikacja na Androida:
plik 92MB - pobiera
plik 130MB - pobieranie nieudane

gdy połączony z siecią lokalną wszystko OK.
Edytowane przez mb36 dnia 15-09-2014 13:59
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
shibby Dziekuje za dotacje
spróbuj do pliku php.ini dopisać

max_execution_time = 300

domyślnie timeout wykonania skryptu PHP jest ustawiony na 30 sek.
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mb36
shibby napisał(a):

spróbuj do pliku php.ini dopisać

max_execution_time = 300

domyślnie timeout wykonania skryptu PHP jest ustawiony na 30 sek.


Nic nie pomogło, ale to chyba nie w tym problem skoro w sieci lokalnej nie ma problemu z pobieraniem plików większych niż 100MB
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
shibby Dziekuje za dotacje
miałem wczoraj chwilę czasu by wrócić do tematu owncloud na tomato i takie moje spostrzeżenia:

- początkowo nie byłem w stanie przesłać pliku powyżej 80MB. Problemem jest tu RAM. Pamiętajmy, że z połowy RAMu robiony jest /tmp tak więc średnio w routerze z 256MB ramu pozostaje nam jakieś 128MB do dyspozycji. Część zabierze system i pomimo limitu w PHP ustawionego na 100MB nie będziemy w stanie przesłać większego pliku. Rozwiązaniem jest tu podpięcie swapa.

- Po podpięciu swapa 256MB udało mi się przesłać pliki większe ale max jaki przesłał to 86MB. Przy próbie wysłania większego dostaję komunikat "bląd zapisu na dysk". Komunikat dziwny i niezrozumiały dla mnie. Dysk to pendrive 16GB sformatowany na ext2 i podmontowany pod /opt. Niestety tego problemu nie rozwiązałem jeszcze.

BTW tak na chwilę obecną wygląda "robocza" wersja nowych funcji web serwera w GUI:
shibby dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mp3zenek
shibby napisał(a):

miałem wczoraj chwilę czasu by wrócić do tematu owncloud na tomato i takie moje spostrzeżenia:

- początkowo nie byłem w stanie przesłać pliku powyżej 80MB. Problemem jest tu RAM. Pamiętajmy, że z połowy RAMu robiony jest /tmp tak więc średnio w routerze z 256MB ramu pozostaje nam jakieś 128MB do dyspozycji. Część zabierze system i pomimo limitu w PHP ustawionego na 100MB nie będziemy w stanie przesłać większego pliku. Rozwiązaniem jest tu podpięcie swapa.

- Po podpięciu swapa 256MB udało mi się przesłać pliki większe ale max jaki przesłał to 86MB. Przy próbie wysłania większego dostaję komunikat "bląd zapisu na dysk". Komunikat dziwny i niezrozumiały dla mnie. Dysk to pendrive 16GB sformatowany na ext2 i podmontowany pod /opt. Niestety tego problemu nie rozwiązałem jeszcze.

BTW tak na chwilę obecną wygląda "robocza" wersja nowych funcji web serwera w GUI:


Witam

Ja mam ten sam problem z tym błędem (bląd zapisu na dysk) i jak na razie też go jeszcze nie rozwiązałem.
Jedyne co zauważyłem że błąd występuje przez strone WWW z aplikacji na windowsie wrzuca mi spokjnie pliki 200MB, co by oznaczało jakiś problem w konfiguracji serwera www na routerze.
Co web serwera w GUI to wygląda bardzo obiecująco Smile

Pozdrawiam
 
shibby Dziekuje za dotacje
mam też dla was ciekawostkę. Otóż skompilowałem pakiety optware php-5.6 dla mipsel i arm ale jeszcze ich nie miałem czasu przetestować. Patche podesłał @alllexx z forum linksysinfo.org Smile Tak więc jak ktoś zechce postawić apache lub lighttpd z php 5.6 z optware to będzie to możliwe Smile
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mp3zenek
Witam

Z tego co udało mi się ustalić, to przy wgrywaniu czegoś przez stronę WWW, wszystko na ten czas jest wrzucane do /tmp tylko nie wiem dokładnie gdzie.
U mnie wielkość tmp wygląda tak:
tmpfs 124.8M 2.4M 122.4M 2% /tmp

Myślę że jak by się udało /tmp zamontować/przenieść na dysk o większej pojemności to by wszystko zaczęło działać.

Niestety ta operacja mnie przewyższa : / bo na linuxie się tyle znam co tu wyczytałem.

Wiem że do podobnych wniosków doszedł już shibby i zapewne nic nowego nie odkryłem.

Jeszcze znalazłem to że nginx odwołuje się do tej ścieżki przy wgrywaniu:
/tmp/var/lib/nginx/client

Zrobiłem sobie dowiązanie do tej ścieżki i katalog umieściłem na dysku, co spowodowało że w czasie wgrywania pliku /tmp nie był ruszany do momentu jak się grał i wtedy zawartość z dowiązania z powrotem zaczyna być wgrywana do /tmp aż do momentu jak się nie skończy miejsce.
I pojawia się komunikat o błędzie zapisu.

Zapewne to dużo nie wniesie do tematu, ale kto wie.

Pozdrawiam

Połączony z 20 wrzesień 2014 11:16:10:
Witam

Udało mi się rozwiązać problem wgrywania dużych plików.
W skrypcie init wystarczy dopisać i zrestartować router:
Pobierz kod źródłowy  Kod źródłowy
echo "upload_tmp_dir = /nas/tmp" >> /etc/php.ini




Plus trzeba dopisać w pliku konfiguracyjnym nginx (nginx.conf) w sekcji http tej linijki:
Pobierz kod źródłowy  Kod źródłowy
client_body_temp_path /nas/tmp;




Gdzie /nas/tmp - to dowolna ścieżka prowadząca do przestrzeni na dysku lub pendrive. Ścieżka musi być identyczna dla tych dwóch wpisów.

Teraz zostało rozwiązanie problemu ze ściąganiem dużych plików przez WWW.

Pozdrawiam

Połączony z 20 wrzesień 2014 11:27:10:
Chyba przed wczesna radość, udało mi się grać plik 150 MB ale przy próbie 300 MB dalej to samo. Muszę szukać dalej.

Pozdrawiam

Połączony z 22 wrzesień 2014 20:45:04:
Witam

A jednak działa.
Dziś wgrałem plik 1GB, fakt że przy końcu wyskoczył komunikat "not found" ale po odświeżeniu strony plik się pojawił.
Dziś to przetestowałem wgrywając pliki od znajomego i z domu po lokalnej sieci.

Pozdrawiam
Edytowane przez mp3zenek dnia 22-09-2014 20:45
 
Staszek Dziekuje za dotacje
I to się nazywa dobra współpraca Open. Super koledzy. Ktoś 'pracuje' a drudzy 'wespół'. Ale tak jest, gdy niewielu zna się na Linux-ie a zwłaszcza na programowaniu. Dzięki chłopaki za to co robicie. Niektórzy nazywają to motywacja, inni wdzięcznością.Wink
Asus RT-AC56U Tomato K26ARM-138.12-AIO by Shibby Huawei E3372s non HiLink w zestawie
MikroTik RB951G-2HnD
Fritz!Box 7490 + Fiber 80
 
mp3zenek
Witam

Chyba udało mi się rozwiązać problem z pobieraniem plików przez WWW.

Zrobiłem to tym sposobem:

Tworzymy na dysku katalog w którym będą gromadzone pliki tymczasowe przez nginx, w moim przypadku jest to:

Pobierz kod źródłowy  Kod źródłowy
/nas/tmp/nginx



Po tym dopisujemy w tomato w sekcji Firewall:

Pobierz kod źródłowy  Kod źródłowy
#Zamiana lokalizacji nginx
rm -r /tmp/var/lib/nginx
ln -s /nas/tmp/nginx/ /tmp/var/lib/nginx

#Zatrzymanie i start nginx
/usr/sbin/nginx -s stop
/usr/sbin/nginx



Gdzie /nas/tmp/nginx to ścieżka gdzie stworzyliśmy katalog na pliki tymczasowe dla nginx.

Po tej operacji restartujemy router i nasz ownCloud powinien działać bez potrzeby ręcznego zatrzymywania i ponownego uruchamiania, a pliki powinny się ściągać bez problemów.

Ja tym sposobem ściągam pliki 1 GB i nie napotkałem problemu.

Pozdrawiam
 
Jabol
Kiedy 122 dla WNR3500Lv2 ?:>
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 4

· Użytkowników online: 0

· Łącznie użytkowników: 23,619
· Najnowszy użytkownik: aficio
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

PixelPL
21-10-2017 06:04
Ustaw IP na sztywno aby na router wbić, i sprawdź co tam jest nie tak, ustaw ręcznie adres IP w połączeniu karty sieciowej

PixelPL
21-10-2017 06:02
Brak DHCP po LAN lub brak internetu na WAN

pletik
21-10-2017 00:40
witam po wgraniu tomato do routra asus n66u adres ip z kosmosu czyli 169.254 itd kotos sie zna co zle robie

Obserwator
20-10-2017 11:08
Dwa pytania: 1. Jak w DD-WRT sprawdzic wersje DNSMASQ? 2. Czy taka konfiguracja jest podatka ? Router z tomato, wylaczony Wi-Fi. Do routera po kablu podlaczony router TP-Link z DD-WRT najnowszym.

mosfit
20-10-2017 00:57
zobacz PM

pletik
20-10-2017 00:12
witam moze mi ktos podpowiedzec jak wgrac tomato do 66u asus Grin

krisan
17-10-2017 13:28

pedro
16-10-2017 18:21

Steel_Rat
16-10-2017 12:02
Krytyczna luka w WPA2 https://www.krack.
..

Steel_Rat
06-10-2017 16:03
Routery też ma. Nawet testują ten router na eko.one.pl Całkiem ma fajne osiągi. Tylko bardzo skomplikowanie LEDE się wgrywa.

feszt
06-10-2017 15:26
Xiaomi to tylko telefony Smile jak juz

majkel152
04-10-2017 16:31
nie

dziubek
04-10-2017 09:35
wARTO BRAĆ Original Xiaomi WiFi Router 3G? https://www.gearb.
..42436.html

harryadr
26-09-2017 20:15
Debrick netgear R7000 proszę o pomoc. https://openlinksy
s.info/forum/viewt
hread.php?thread_i
d=21391&pid=165098#
post_165098

p4v3u
25-09-2017 10:09
pomocy... https://openlinksy
s.info/forum/viewt
hread.php?thread_i
d=21387

p4v3u
25-09-2017 10:06
zmiana na 138 nie pomogla

p4v3u
25-09-2017 10:03
Ostatnie tomato na ac68 i nagle WAN przestawal pobierac adres. Logi czyste. Czy mozliwa awaria tylko 1 portu ? Po restarcie do fabrycznych + nvram

33,688,076 unikalne wizyty