23 Czerwiec 2017 14:15:26
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· ASUS WL-520GU
· Jak odratować NETGEA...
· Dobry ruter TP-LINK ...
· Siła sygnału modem LTE
· Brak komunikacji rou...
· Asus RT-N12 a wersja...
· [MOD] Tomato by kille72
· access point WAP 300...
· Jakie 2 routery do 1...
· Wifi... zrywane połą...
· RT-N16 i modem LTE
· [MOD] Tomato by shibby
· Router do 300zł, 2,4...
· SMBv1 w Tomato
· [S]Ubiquiti Networks...
· [S] Router Netgear R...
· Blokada stron https
· oscam na openwrt (ar...
· OpenVPN - niski Donw...
· Tomato - bugi/proble...
Najciekawsze tematy
· [MOD] Tomato by s... [13429]
· oscam na openwrt ... [769]
· [MOD] Tomato by k... [578]
· Jak odratować NET... [148]
· RT-N16 i modem LTE [35]
· Brak komunikacji ... [8]
· Blokada stron https [8]
· Siła sygnału mode... [6]
· OpenVPN - niski D... [6]
· ASUS WL-520GU [5]
· Dobry ruter TP-LI... [4]
· Jakie 2 routery d... [4]
· Router do 300zł, ... [3]
· SMBv1 w Tomato [3]
· [S] Router Netgea... [3]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
40% [121 głosów]

Broadcom ARM
Broadcom ARM
49% [147 głosów]

Atheros
Atheros
6% [17 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 301
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.198.201.250
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
[YT] Owncloud7 na Tomato z użyciem wbudowanego serwera WWW
shibby Dziekuje za dotacje
Nginx

# vi /etc/nginx/nginx.conf

Dodaj następujący wiersz do http lub serwera

# set client body size to 100M #
client_max_body_size 100M;


spróbuj do okna Custom Configuration dopisać:
http {
client_max_body_size 100m;
}

Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
ekwadorczyk
Dalej bez rezultatów ....
Netgear R7000 + Tomato v1.28 K26ARM-122-64k
 
mp3zenek
Witam

Niestety u mnie to samo, szukam, kombinuje i jak na razie bez rezultatów.

Dodam że nie ma znaczenia czy wgrywam przez przeglądarkę czy też przez aplikację.
W obu przypadkach otrzymuję taki komunikat:
request entity too large
 
ekwadorczyk
To jesteśmy w tym samym punkcie. Kombinuje dalej. Pozdro
Netgear R7000 + Tomato v1.28 K26ARM-122-64k
 
susser
U mnie po wpisie do pliku konfiguracyjnego nginx.conf
http {
client_max_body_size 100m;
}
wszystko smiga...
Pozdrawiam
 
shibby Dziekuje za dotacje
@susser - czyli wpis do custom nginx + dodanie dwóch linijek do php.ini rozwiązuje problem?
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
susser
niestety nie do Custom, tylko bezposrednio w pliku /etc/nginx/nginx.conf.
Przez Custom nic nie szlo zrobic.
Po wylaczeniu routera plik niestety samoczynnie sie usuwa i wkleja pierwotna konfiguracje, nawet po wlaczeniu Keep Config Files.
W moim przypadku Netgear R7000
Jesli chodzi o dwie wczesniejsze linijki, najpierw dodalem je do System Commands w GUI a potem zapisalem, nie musialem wlaczac i wylaczac routera, poniewaz zainicjalizowal odrazu.
Wiec wszystko dziala zaj.... Gratuluje Softu, naprawde kawal dobrej roboty Shibby.
Pozdrawiam
 
mb36
Ja właśnie wgrałem Tomato do swojego nowego RT-AC56U, zainstalowałem owncloud i oba wpisy w init i configu ngix nie pomagają.

Log z ngix'a
2014/09/05 18:50:15 [error] 1121#0: *1 client intended to send too large body: 2573358 bytes, client: 192.168.1.20, server: tomato, request: "POST /index.php/apps/files/ajax/upload.php HTTP/1.1", host: "192.168.1.1:85", referrer: "http://192.168.1.1:85/index.php/apps/files/?dir=%2F"

A tak przy okazji, pytanie:
Czy w RT-AC56U z softem Tomato by Shibby świeci tylko dioda power, bo u mnie tak jest, firmware: tomato-RT-AC56U-ARM--122-AIO-64K.trx
 
susser
Skopiuj z init te dwa wpisy i wklej je bezposrednio do System Command i nacisnij EXecute.
Nie usuwaj tych wpisow z init.
Wylacz Serwer Nginx wcisnij Enable Server on Start, PHP, Keep Config File.
Zapisz.
Wejdz w etc/nginx/nginx.conf dodaj wpis

http {
client_max_body_size (iloscmega)m;

zapisz plik i potem jescze nacisnij save w tomato.
Wlacz serwer no i powinno smigac.
Pozdrawiam
 
mb36
No niestety robię tak jak piszesz i cały czas komunikat Request Entity Too Large
 
susser
Wklej prosze swoj caly nginx.conf to zobaczymy co da sie zrobic.

Pozdr.
 
mb36
# NGinX generated config file
user nobody;
worker_processes 1;
worker_cpu_affinity 0101;
master_process off;
worker_priority 10;
error_log /tmp/var/log/nginx/error.log;
pid /tmp/var/run/nginx.pid;
worker_rlimit_nofile 8192;
events {
worker_connections 512;
}
http {
include /tmp/etc/nginx/mime.types;
include /tmp/etc/nginx/fastcgi.conf;
default_type application/octet-stream;
log_format main '$remote_addr - $remote_user [$time_local] $status '
'"$request" $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';
sendfile on;
server {
listen 85;
server_name Tomato;
access_log /tmp/var/log/nginx/access.log main;
location / {
root /opt/owncloud;
index index.html index.htm index.php;
error_page 404 /404.html;
error_page 500 502 503 504 /50x.html;
location /50x.html {
root /opt/owncloud;
}
location ~ ^(?<script_name>.+?\.php)(?<path_info>/.*)?$ {
try_files $script_name = 404;
include /tmp/etc/nginx/fastcgi.conf;
fastcgi_param PATH_INFO $path_info;
fastcgi_pass 127.0.0.1:9000;
}
location ~ ^/(images|javascript|js|css|flash|media|static)/ {
root /opt/owncloud;
expires 10d;
}
}
}
}

http {
client_max_body_size 100m;
}
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
# NGinX generated config file
user nobody;
worker_processes 1;
worker_cpu_affinity 0101;
master_process off;
worker_priority 10;
error_log /tmp/var/log/nginx/error.log;
pid /tmp/var/run/nginx.pid;
worker_rlimit_nofile 8192;
events {
worker_connections 512;
}
http {
client_max_body_size 100m; TUTAJ NIE NA KONCU
include /tmp/etc/nginx/mime.types;
include /tmp/etc/nginx/fastcgi.conf;
default_type application/octet-stream;
log_format main '$remote_addr - $remote_user [$time_local] $status '
'"$request" $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';
sendfile on;
server {
listen 85;
server_name Tomato;
access_log /tmp/var/log/nginx/access.log main;
location / {
root /opt/owncloud;
index index.html index.htm index.php;
error_page 404 /404.html;
error_page 500 502 503 504 /50x.html;
location /50x.html {
root /opt/owncloud;
}
location ~ ^(?<script_name>.+?\.php)(?<path_info>/.*)?$ {
try_files $script_name = 404;
include /tmp/etc/nginx/fastcgi.conf;
fastcgi_param PATH_INFO $path_info;
fastcgi_pass 127.0.0.1:9000;
}
location ~ ^/(images|javascript|js|css|flash|media|static)/ {
root /opt/owncloud;
expires 10d;
}
}
}
}

Spojrz gdzie ja wkleilem a gdzie ty. Teraz musi chodzic...
Grin
Pozdrawiam
 
mb36
Dzięki @susser
OK działa, ale tylko do restartu, po restarcie routera brak wpisu Sad
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
susser
Tu ze tak powiem Shibby bedzie musial wkroczyc...
 
dar3k
mb36 napisał(a):

Dzięki @susser
OK działa, ale tylko do restartu, po restarcie routera brak wpisu Sad

To skopiuj ten plik na dysk i po zamontowaniu dysku zrób dowiązanie lub kopiuj go z dysku w skrypcie firewalla lub montowania dysku powinno pomóc.
Moj router RT-AC56U @ 1200,800 MHz
 
https://dar3k.no-ip.org
shibby Dziekuje za dotacje
susser napisał(a):

Tu ze tak powiem Shibby bedzie musial wkroczyc...


dodam trzy pola textarea do GUI dla nginx. Jedno do wprowadzania zmian w sekcji http {}, drugie w sekcji server {} i ostatnie dla zmiennych w php.ini Smile To powinno rozwiązać problem.
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
mb36
shibby napisał(a):

dodam trzy pola textarea do GUI dla nginx. Jedno do wprowadzania zmian w sekcji http {}, drugie w sekcji server {} i ostatnie dla zmiennych w php.ini Smile To powinno rozwiązać problem.


A kiedy można się spodziewać Smile
ASUS RT-AC56U + tomato-RT-AC56U-ARM--122-AIO-64K
 
mp3zenek
dar3k napisał(a):

mb36 napisał(a):

Dzięki @susser
OK działa, ale tylko do restartu, po restarcie routera brak wpisu Sad

To skopiuj ten plik na dysk i po zamontowaniu dysku zrób dowiązanie lub kopiuj go z dysku w skrypcie firewalla lub montowania dysku powinno pomóc.


Witam

Może zadam głupie pytanie, ale jak wykonać to dowiązanie lub jak dopisać kopiowanie pliku do skryptu firewall ?
 
dar3k
kopiowanie:
cp /źródło /przeznaczenie
dowiązanie:
ln -s /plik_istniejący /link_symboliczny

najlepiej całą scieżkę podawać do polecen tj:
/bin/cp i /bin/ln

przez cp też się da robić dowiązania (tylko nie próbowałem czy to działa):
-l,-s Create (sym)links
Moj router RT-AC56U @ 1200,800 MHz
 
https://dar3k.no-ip.org
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 11

· Użytkowników online: 0

· Łącznie użytkowników: 23,528
· Najnowszy użytkownik: maciej1993
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

kille72
23-06-2017 11:59
Nie wiem kiedy.

b3rok
23-06-2017 11:55
Nice Smile, a kiedy build 2017.2?

kille72
23-06-2017 11:48
Mam juz w repo 2.4.3: https://bitbucket.
..ommits/all

b3rok
23-06-2017 11:42
https://www.dobre.
..81781.html
najnowsze Tomato ma OpenVPN 2.4.1, a bezpieczne jest 2.4.3...

RaTaJ
23-06-2017 09:50
robili promocje i pewnie sie pomylili

overflow2
23-06-2017 08:50
strona została wciągnięta

mhc3600
22-06-2017 23:49
ASUS rt-n18u za 129zł +10 zł kurier na https://www.neonet
.pl/wyprzedaz-asus
-rt-n18u.html#opis
-produktu1

gabrychu
16-06-2017 14:16
https://niebezpiec
znik.pl/post/40-ro
uterow-asusa-jest-
powaznie-dziurawyc
h/

jurekk
11-06-2017 23:42
i tesciowa moze wydzwaniac w darmowe noce i poranki czy jak sie to zowie hehe

jurekk
11-06-2017 23:40
@cek149 tak pare lat temu staruszka fritza 7050 kupilem na aledrogo i smiga aczkolwiek teraz w tomato trzeba otwierać porty orz zaznaczać ptaszki w sekcji uPnP bo Shibby dla bezpieczeństwa trochę powy

servee
11-06-2017 13:09
@cek149 ja tak mam i śmiga aż miło od paru lat. Dodatkowo główny router za NAT-em. Jedynie z Halonet jakieś problemy miałem i tego operatora nie używam.

cek149
10-06-2017 17:44
jurekk, mówisz, że VOIP na Fritz! Box Fon może pracować wpięty do LAN ? i zachowa pełną funkcjonalność VOIP ?

jurekk
08-06-2017 17:58
a co szkodziło go zostawić i używać ekstra tylko do voip ja tak mam np. wpiety do lanu podstawowego routera

cek149
08-06-2017 11:19
p4v3u, Fritz'a odradzam. Trenowałem Fritz! Box Fon na neostradzie przez chyba ze 2 lata, ze względu na VOIP. Wywaliłem Fritz'a, niestety również VOIP. Teraz jest modem w bridge i do routera.

PanRatio
07-06-2017 13:27
Fakt. Dziękuję za pomoc.

DonMattheo
06-06-2017 18:14
@PanRatio: Musisz ustawić na WAN vlanid 35 a dalej to po PPPoE

Adooni
06-06-2017 12:55
szkoda ze nie uzyles wyszukiwarki na forum https://openlinks...ro
wstart=0

32,512,251 unikalne wizyty