17 Czerwca 2024 15:36:22
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [HOWTO] OpenVPN serv...
· [MOD] FreshTomato-AR...
· [S] edgerouter er-12
· [MOD] Tomato64 (x86-64)
· Dostęp do urządzen...
· Switch zasilany prze...
· Brak dostępu do ust...
· Takedown 2000
· [MOD] FreshTomato-MI...
· [Howto] Xpenology na...
· [HOWTO] Kompilacja "...
· nju swiatło pytania
· konfiguracja router ...
· Asus TUF-AX3000_V2 p...
· Jaki router kupić? ...
· Szukam zaproszenia n...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Firewall nie zawsze ...
· Optware na CIFS
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [881]
· [HOWTO] OpenVPN s... [16]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [217 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 417
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.236.143.154
Zobacz wątek
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj wątek
Multiroom N z wykorzystaniem openVPN
servee
Mam trzy lokalizacje: lokalizacja 1 - server VPN, lokalizacja 2 i 3 - klient VPN.
W lokalizacji 2 MR działa, a w 3 niestety nie.

Z 1 do 2 (pomiędzy routerami) nie otrzymuję odpowiedź na ping, a otrzymuję odpowiedzi na arping.
Z 1 do 3 (pomiędzy routerami) otrzymuję odpowiedź na ping, a nie otrzymuję odpowiedzi na arping.
Z 3 do 1 (pomiędzy routerami) otrzymuję odpowiedź na ping, a nie otrzymuję odpowiedzi na arping.

W 3 na routerze (FreshTomato) widać, że jest połączenie z serwerem i zwiększa się licznik przesłanych danych. Dlaczego więc w tej lokalizacji MR nie działa? Jakiś pomysł?

Scalony z 13 listopada 2022 23:56:06:
Aktualizacja:

ping/arping już działa z serwera do klientów i od klientów do serwera. Pisząc serwer/klienci mam na myśli routery na końcach sieci VPN. Arping z serwera (routera) dociera do wszystkich urządzeń końcowych (podpiętych do klientów VPN) i otrzymuję odpowiedź, więc na pierwszy rzut oka wszystko powinno być OK. Pomimo tego na jednym z klientów MR nie działa - brak informacji zwrotnej (RX=0), chociaż w GUI serwera jest informacja, że zarówno TX jak i RX "nabija" licznik danych - patrz zdjęcia (kliknij na nie, aby powiększyć).
Wygląda na to, że klient wysyła zapytanie do matki, matka to odbiera i odpowiada, ale odpowiedź nie dociera do urządzenia wysyłającego zapytanie, co widać na jednym ze zdjęć. Co może być nie tak?
Dopiszę, że wykresy na klientach dotyczą VLAN'ów od MR.

images92.fotosik.pl/632/55911e1373f78473m.png

images91.fotosik.pl/630/89827b3dfa51235am.png

images89.fotosik.pl/632/cb4f2addef982c7bm.png
Edytowany przez servee dnia 13-11-2022 23:56
 
overflow2
Przerabiał ktoś temat odpalenia internetu przez tunel na dekoderach od MR?
Wymieniłem dekodery na dualboxy (wszyscy mieli dość wifiboxów) i one nie chcą działać bez dostępu do internetu.

Będąc wpiętymi przez VPN nie mają dostępu i po prostu nie przechodzą testu sieci...
Asus RT-AC56U FT-AIO
 
pawel1987

overflow2 napisał:

Przerabiał ktoś temat odpalenia internetu przez tunel na dekoderach od MR?


Co znaczy internetu na dekoderach mr??
 
overflow2
Chodzi o to że nowe dekodery klienckie multiroomu wymajają dostępu do internetu.
Asus RT-AC56U FT-AIO
 
pawel1987
Zapewne podczas połączenia pierwszy raz.
Znajomy ma najnowsze dualboxy i wszystko działa ok
 
shibby
@overflow2, powinno działać. W sensie mój opis zakłada, że konfigurację IP dekoder dostaje z sieci marki (lub inaczej, tam gdzie jest serwer ovpn) i tunelem powinien wyjść do internetu.

Natomiast możesz zrobić tak, że wpiszesz ręcznie bramę IP routera przy dodatkowym dekoderze i też powinien wyjść. Ja w edgerouterze jedynie musiałem na DNSie dodać interfejs br0 by przyjmował na nim żądania DNS.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
overflow2
Właśnie chodzi o to że dekoder dostaje konfigurację, ale nie zaciąga bramy.
Sieć jest sprawdzana za każdym razem po restarcie dekodera i się wykłada test.
Jak wpiszę ręcznie konfigurację to działa, ale wolałbym z DHCP.

Najkorzystniej by było gdyby adres IP ciągnął z DHCP serwera OpenVPN, ale Internet (brama, DNS) ze swojej lokalnej.
Edytowany przez overflow2 dnia 19-11-2022 17:54
Asus RT-AC56U FT-AIO
 
pawel1987
A opcja przekazywania bramy włączona? Wink
Redirect default Gateway

overflow2 napisał:



Najkorzystniej by było gdyby adres IP ciągnął z DHCP serwera OpenVPN, ale Internet (brama, DNS) ze swojej lokalnej.


Przecież to żaden problem, powyższe ustawienie do tego służy. Wybierasz skąd ma być brama.
 
overflow2
Dodając do konfiguracji polecenie push "redirect-gateway def1" niestety nic nie osiągnąłem.
Asus RT-AC56U FT-AIO
 
pawel1987
Ja mam to wyklikane na ddwrt
Spróbuj
push "redirect-gateway def1 bypass-dhcp"
 
shibby

overflow2 napisał:


Jak wpiszę ręcznie konfigurację to działa, ale wolałbym z DHCP.


ja mam ręcznie bo wlaśnie dzięki temu mogę ustawić odpowiednią bramę. Oczywiście w DHCP dodałem dzierżawę by "zablokować" ten ip dla innych hostów.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
overflow2
Aktualnie mam zrobione właśnie tak samo.
Asus RT-AC56U FT-AIO
 
Maniek91PL
chce spiąć tak 2 lub 3 urządzenia

wpisuje na samym początku

root@Asus:/tmp# openvpn --genkey --secret static.key
2023-02-06 22:09:03 WARNING: Using --genkey --secret filename is DEPRECATED. Use --genkey secret filename instead.

i już mam żę jest przestarzały

* ciągle próbuje jak połączyć 2 konsole ps3, przez neta ,tak aby konsole widziały się w sieci Lan, abym mógł pograć po Lanie ze znajomym Angry
Asus RT-AC3200
Rocket M5
APC BACK-UPS RS 1200
Mini Itx ASUS Q87T+ i7-4770S
Alienware m15
Vu+ Solo2
 
shibby

Cytat

Using --genkey --secret filename is DEPRECATED. Use --genkey secret filename instead.


komunikat mówi by zamiast "--secret" wpisać "secret" Wink

Cytat

chce spiąć tak 2 lub 3 urządzenia


to przez static.key tego nie zrobisz bo on służy do łączenia tylko 2 stron (site-to-site). Jak chcesz połączyć więcej hostów to musisz użyć TLS i dla każdego hosta wygenerować certyfikaty, czyli najpierw generujesz CA, za jego pomocą generuję parę certyfikatów (cert i privkey) i podpisujesz głównym CA. Certyfikaty generujesz na określony czas więc polecam od razu dać z 5 lub 10 lat byś co roku nie musiał czynności powtarzać.
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
tamtosiamto
czy ta metoda polaczenia tunelem bedzie dzialac z netflixem, ktory podobno ma niedlugo wymagac , zeby kazdy klient logowal sie pod glownym adresem IP co jakis czas? Chodzi o wpoldzielenie konta UK<->PL
Edytowany przez tamtosiamto dnia 26-02-2023 21:17
nic nie mam
 
pawel1987
Oczywiście, jeśli puścisz ruch przez vpn
 
shibby

Cytat

pod glownym adresem IP co jakis czas?


Jestem ciekaw jak oni to będą weryfikować, co ze zmiennymi IP, przy load balance. Znam osoby, które taki tablet czy komórkę nigdy nie łączą się do sieci domowej wifi tylko jadą na LTE.

No i co to znaczy "główne IP". Które to jest główne IP skoro wszyscy łączą się na to samo konto, więc której osoby IP będzie tym głównym? Wink
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
ktosiiik

shibby napisał:

Cytat

Using --genkey --secret filename is DEPRECATED. Use --genkey secret filename instead.


komunikat mówi by zamiast "--secret" wpisać "secret" Wink

Cytat

chce spiąć tak 2 lub 3 urządzenia


to przez static.key tego nie zrobisz bo on służy do łączenia tylko 2 stron (site-to-site). Jak chcesz połączyć więcej hostów to musisz użyć TLS i dla każdego hosta wygenerować certyfikaty, czyli najpierw generujesz CA, za jego pomocą generuję parę certyfikatów (cert i privkey) i podpisujesz głównym CA. Certyfikaty generujesz na określony czas więc polecam od razu dać z 5 lub 10 lat byś co roku nie musiał czynności powtarzać.


Scalony z 06 maja 2023 14:26:57:
Cześć, static.key nie problem, ale czy możesz łopatologicznie wytłumaczyć jak zrobić certy dla matki i 3 klientów, bo nie bardzo mogę to ogarnąć.

shibby napisał:

Cytat

Using --genkey --secret filename is DEPRECATED. Use --genkey secret filename instead.


komunikat mówi by zamiast "--secret" wpisać "secret" Wink

Cytat

chce spiąć tak 2 lub 3 urządzenia


to przez static.key tego nie zrobisz bo on służy do łączenia tylko 2 stron (site-to-site). Jak chcesz połączyć więcej hostów to musisz użyć TLS i dla każdego hosta wygenerować certyfikaty, czyli najpierw generujesz CA, za jego pomocą generuję parę certyfikatów (cert i privkey) i podpisujesz głównym CA. Certyfikaty generujesz na określony czas więc polecam od razu dać z 5 lub 10 lat byś co roku nie musiał czynności powtarzać.

Edytowany przez ktosiiik dnia 06-05-2023 14:26
 
hermes-80
Nie musisz tego robić na ruterze:https://www.howtoforge.com/tutorial/h...-centos-8/
===============================================================
Netgear WNR3500L v1
Podziękowania dla administracji Openlinksys.info!
 
rako28
Czy to ten multiroom po vpn dalej dziala ok?
[Netgear WNR3500L v2 Tomato Firmware 1.28.0000 MIPSR2-137 K26 USB AIO
Netgear R8000 FreshTomato Firmware 2019.3.220 -beta K26ARM USB AIO-64K
Asus ax56u Merlin 386.1.2
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 20

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
03-06-2024 16:24
poszlo w koncu -najpierw przez restoration jakies stare ddwrt, potem z menu update plik ac66u z art o zmianie 868l->ac66u

tamtosiamto
02-06-2024 21:44
trx size 44560384 > memory size 33554432 nigdy czegos takiego nie widzialem podczas flashowania rutera

tamtosiamto
02-06-2024 21:37
wgrywanie ddwrt z opisu zmiany softu z dlinka na asusa nic nie daje, dalej startuje tomato, wgranie ddwrt dla ac66u wchodzi, ale z niego tez nie da sie wgrac ofw asusa i merlina, kicha

tamtosiamto
02-06-2024 19:57
Probowal ktos wrocic z tomata do OFW ASAUSa na przerowbionym DIR868l -> rt-ac66u ? Ni cholery nie moge dac sobie rady.

RaTaJ
10-05-2024 15:43
Czy intel n100 4x 3,40Ghz z Intel HD i DDR5 byłby dobry, widziałem za 550zł z 8gb ram i ssd 512gb?

Adooni
26-04-2024 14:41
jaki router RMerlin nie pociagne, tomato/ openwrt tak non hilink,

tamtosiamto
23-04-2024 12:35
modem bez smilocka?

man1
22-04-2024 23:27
Czy próbował ktoś uzywac karty voice (z nolimit GB) od tmobile w modemie /routerze? Da się jakoś to zrobić? Bo u mnie neta brak. E3372 Sad

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

73,141,944 unikalnych wizyt