17 Czerwca 2024 00:29:57
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [HOWTO] OpenVPN serv...
· [MOD] FreshTomato-AR...
· [S] edgerouter er-12
· [MOD] Tomato64 (x86-64)
· Dostęp do urządzen...
· Switch zasilany prze...
· Brak dostępu do ust...
· Takedown 2000
· [MOD] FreshTomato-MI...
· [Howto] Xpenology na...
· [HOWTO] Kompilacja "...
· nju swiatło pytania
· konfiguracja router ...
· Asus TUF-AX3000_V2 p...
· Jaki router kupić? ...
· Szukam zaproszenia n...
· dodatkowe złącza s...
· RT-N18U - nie można...
· Firewall nie zawsze ...
· Optware na CIFS
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [881]
· [HOWTO] OpenVPN s... [16]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [217 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 417
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
34.239.170.244
Zobacz wątek
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj wątek
[TURTORIAL] Podłączenie drukarki na Tomato
krott
Przy pierwszym podłączeniu drukarki, napotkałem drobny opór ze strony Windowsa 7 - nasunoł mi się pomysł by na przyszłość napisać tą mini instrukcję.

Przykład opiera się o :

Ruter Netgera 3500l v2 Tomato Firmware 1.28.0000 MIPSR2-083V K26 USB AIO
Drukarkę Samsung ML-1865
Windows 7




1. Podłączenie drukarki


Podłączenie drukarki po przez port USB do rutera umożliwi korzystanie z niej wszystkim użytkownikom podłączonych do sieci lokalnej - i na kablu i po przez WiFi.

2. Konfiguracja Tomato

Logujemy się na panel konfiguracji naszego rutera z wgramym Tomato, a następnie przechodzimy do zakładki USB and NAS -> USB Support

W moim przypadku mam uruchomione
- Core USB Support
- USB 2.0 Support
- USB Printer Support


Klikamy SAVE

www.remarke.pl/images/openlinksys/drukarka/drukarka1.jpg

Po zapisaniu u dołu w tabeli Attached Devices powinna pojawić się nam nasza podpięta drukarka.
Oznacza to, że poprawnie skonfigurowaliśmy naszą drukarkę.

3. Konfiguracja Windows 7

Aby móc korzystać z drukarki na wszystkich komputerach w sieci należy skonfigurować dostęp do naszej drukarki.

I. Nowa drukarka

a) przechodzimy do Panel sterowania \ Sprzęt i dźwięk \ Urządzenia i drukarki

www.remarke.pl/images/openlinksys/drukarka/drukarka2.jpg


b) u górnym menu Panelu uruchamiamy opcję Dodaj drukarkę

www.remarke.pl/images/openlinksys/drukarka/drukarka3.jpg
c) z okna które nam się ukaże wybieramy drukarkę sieciową.


www.remarke.pl/images/openlinksys/drukarka/drukarka4.jpg

d) raczej na pewno nie ukaże nam się drukarka na liści - o ile nie posiadamy innych drukarek w sieci lub udostępnianych przez inne komputery w sieci. Wybieramy opcję " Drukarki, której szukam na ma na liście"

www.remarke.pl/images/openlinksys/drukarka/drukarka5.jpg

e) W oknie wprowadzamy adres IP naszego rutera do którego wcześniej podpięliśmy wcześniej drukarkę na kablu USB.

www.remarke.pl/images/openlinksys/drukarka/drukarka6.jpg

f) Klikamy dalej

www.remarke.pl/images/openlinksys/drukarka/drukarka7.jpg

g) Jeżeli drukarka którą instalujemy jest na liście wybieramy ją. W moim przypadku drukarka nie jest wyróżniona. Pobrałem sterowniki ze strony producenta. Wybrałem instalację z dysku i wprowadziłem ścieżkę do pliku ze sterownikiem drukarki.

www.remarke.pl/images/openlinksys/drukarka/drukarka8.jpg

www.remarke.pl/images/openlinksys/drukarka/drukarka9.jpg

www.remarke.pl/images/openlinksys/drukarka/drukarka10.jpg

h) Wpisujemy nazwę drukarki aby później móc ją łatwo rozróżnić jeśli posiadamy dostęp do kilku urządzeń.

Po poprawnym przejściu tego procesu mamy popranie skonfigurowaną drukarkę i możemy z niej korzystać.

II. Zmiana portu USB na IP we wcześniej zainstalowanej drukarce w systemie Windows 7

a) z listy sprzętów wybieramy drukarkę, która wcześniej była podłączona do naszego komputera za pomocą kabla USB.
Klikamy prawym przyciskiem myszy z listy uruchamiamy "Właściwości drukarki" ( nie pomyl Właściwości) wybieramy zakładkę Porty

www.remarke.pl/images/openlinksys/drukarka/drukarka11.jpg

b) Dodaj port

www.remarke.pl/images/openlinksys/drukarka/drukarka12.jpg

c) Nowy port

www.remarke.pl/images/openlinksys/drukarka/drukarka13.jpg

d) postępujemy zgodnie z punktami e) f) g) h) z pierwszego opisu


Mam nadzieję, że opis będzie pomocny każdemu, kto zaczyna przygodę z Tomato.
Powodzenia Wink
Edytowany przez krott dnia 07-02-2012 16:50
Netgear WNR3500L v2 + Tomato 1.28.0000 MIPSR2-108 K26 USB AIO
Synology DS110j + 1TB Sasmung
(VPN)
Asus 500gP v2 + 1.28.0905 MIPSR1-079V K26 USB BT-VPN by shibby
Qnap TS101 + 750 GB Samsung
 
purgalm
Niestety ja mam problemu z instalacją drukarki wg opisu powyżej. Drukarka wcześniej zainstalowana pod portem USB. Gdy dodaję nowy port TCP/IP (tak robiłem z kilkoma innymi drukarkami w innych lokalizacjach i wszystko było ok) to nie wykrywa mi drukarki, a po dodaniu standardowego Generic portu niestety dokumenty puszczone do druku utykają w kolejce.
Jednak Tomato drukarkę wykrywa i w USB/NAS pokazuje ją na liście z hostem lp0.
O co może chodzić?
 
krisan

Cytat

purgalm napisał(a):
...
a po dodaniu standardowego Generic portu niestety dokumenty puszczone do druku utykają w kolejce.
...
O co może chodzić?


częstym powodem utykania dokumentów (nie piszesz jaki masz system zainstalowany) pod Windows jest zły Print Processor.

Zakładam że masz problem pod windowsem....
Zmieniasz to w właściwościach drukarki/Zaawansowane. Dla Win7 z podpiętą Lexmarką całość najlepiej działa mi na ustawieniach: winprint, data type: NT EMF 1.008. Jeśli te ustawienia nie działają - spróbuj najpierw 1.003 i RAW.

Czasem, aby wiszące zadania drukowania przepchać (po zmianie processora druku), najszybciej jest zrestartować lub zkillować odpowiednie usługi (różne ich nazwy w zależności od sterowników drukarki) w tym Print Spooler (spoolsv) windowsowy lub zrestartować system. Pozwala to uniknąć wiele frustracji z losowym nie-drukowaniem :-)
[small]Asus RT-N16: http://tomato.groov.pl/tomatoanon.php...0c5eb9d583
Tomato Firmware 1.28.0000 MIPSR2-12x K26 USB VPN

[b][color=#000099]Siemens Gigaset C475IP VoIP & Land
 
shibby

Cytat

c) z okna które nam się ukaże wybieramy drukarkę sieciową.


tu powinnismy wybrac drukarkę lokalną a w następnym oknie utwórz nowy port -> Standard TCP/IP port i dalej juz standard Generic, wskazujemy sterowniki i gotowe. Prościej poprostu Smile
Proxmox VE: i7-7700T, 64GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
purgalm
@up:
Chyba próbowałem z drukarką lokalną (inne drukarki sieciowe mam ustawiane właśnie jako lokalne) i coś nie poszło jak trzeba.
Spróbuję jeszcze raz dzisiaj wieczorem - dzięki! Smile
 
esem
Mam problem z HP DeskJet 3650 (USB 1.1 ?). I to zarówno spod win7 jak i Vista:
drukuje pół strony i wywala błąd. Nic nie da się zrobić do kolejnych drukowań do zrestartowania komputera. Próbowałem różnych ustawień procesora druku.
Co mogę jeszcze zrobić?
esem załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
buniaczek

Cytat

esem napisał(a):

Mam problem z HP DeskJet 3650 (USB 1.1 ?). I to zarówno spod win7 jak i Vista:
drukuje pół strony i wywala błąd. Nic nie da się zrobić do kolejnych drukowań do zrestartowania komputera. Próbowałem różnych ustawień procesora druku.
Co mogę jeszcze zrobić?

A jaki masz hub? Aktywny czy pasywny? Bo widzę że masz więcej urządzeń podpiętych do portu USB - może nie wyrabia prądowo?
-------------------------
Netgear WNR3500L || Tomato-K26USB-1.28 RT5x MIPSR2 101V Big-VPN ||
Asus RT-N56U || Asus firmware 3.0.0.3.135 - wygrania w konkursie na openlinksys.info||
[b]Asus RT-N10U v.B1 [small]
 
esem
HUB jest aktywny a problem to:
Mar 20 16:21:41 Netgear lpr.err p9100d[400]: write: Connection reset by peer
Mar 20 16:21:41 Netgear lpr.notice p9100d[400]: Finished job: 711244 bytes received, 1140 bytes sent

Połączony z 20 marzec 2012 18:12:11:
Rozwiązanie jest proste: należy zrezygnować z buforu wydruku = drukowanie bezpośrednio do drukarki. I chodzi Cool
Edytowany przez esem dnia 20-03-2012 18:12
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
sierars1
U mnie znów jest tego typu problem że mam bezposredni plik instalacyjny i nie mogę z niego wydobyć pliku inf a co za tym idzie zainstalować drukarki EPSON STYLUS OFFICE BX 300F.
Może ktoś ma instalkę z CD bo swoją gdzieś podziałem i stąd ten problem
Asus RT-N10U
TL-WR940N
 
esem
No i znowu zaczęła mi się jazda z drukowaniem hp3650):
1. Na vista x86 wszystko O.K. Ustawienie bez bufora wydruku.
2. Na win7 x64: Ustawienie bez bufora wydruku: strona testowa O.K. ale poza stroną testową nic nie wydrukuję > wchodzi na drukarkę i koniec. Z buforem wydruku drukuje tylko 1/2 strony i wisi (drukowanie).
Wszystkie testy (HP i M$) przechodzą bez problemu.
Co jest grane? Może by jednak spróbować ustawić print serwer spod Optware (?)
Sytuacja stała się po zmianie tusza czarnego. Ktoś coś podpowie?
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
m40l4t
A masz zaznaczone w sterowniku drukarki komunikacje dwukierunkową czasami pomaga wyłączenie tej opcji
____________________________________
TP-LINK TL-WR743ND + Gargoyle:1.5.4 (30752), by obsy
ASUS RT-N10U ver.A + Tomato K26USB-1.28.RT-N-MIPSR2-092V-Big-VPN by Shibby
 
esem
Wszystkie warianty przetestowane. Mogę wydrukować tylko stronę testową. Nic z żadnego programu użytkowego.
A wczoraj było jeszcze O.K.
W logach drukowanie się udało tylko, że poza ruchami głowicy nic się nie wydarzyło.Shock

Edit: Tu http://openlinksys.info/forum/viewthread.php?thread_id=14561 rozwiązanie mojego problemu.

Połączony z 25 maj 2012 12:36:29:
No niestety ale jest (u mnie) inna zdiagnozowana niedogodność: jak drukuję tylko z jednego kompa to jest wszystko O.K.
Jak chcę drukować z drugiego kompa to nie działa. Pomaga tylko reboot Netgeara. I jest O.K. dopuki nie zacznę drukować z poprzedniego kompa.
Pomysły ?
esem załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez esem dnia 25-05-2012 12:36
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
ludek1111

Cytat

sierars1 napisał(a):

U mnie znów jest tego typu problem że mam bezposredni plik instalacyjny i nie mogę z niego wydobyć pliku inf a co za tym idzie zainstalować drukarki EPSON STYLUS OFFICE BX 300F.
Może ktoś ma instalkę z CD bo swoją gdzieś podziałem i stąd ten problem



Mam podobny problem tylko że drukarka lexmark x1170, ma ktoś jakiś pomysł?
 
esem
A jak doinstalować skaner w drukarce? HP 1515.

Scalony z 17 sierpnia 2021 07:51:08:
Czy soft Asusa umożliwia instalowanie skanera? Drukarkę tak a skanera nie zdążyłem sprawdzić.
Edytowany przez esem dnia 17-08-2021 07:51
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
Adooni
pewnie sam bedziesz musial to potestowac. ja np nie uzywam drukarki w domu od ponad 20lat a jak mam scan zrobic to robie zdjecie smartfonem

cos maja do RMerlina
https://github.com/RMerl/asuswrt-merl...-With-Sane
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
kw
Poszukaj coś na temat SANE. Kiedyś próbowałem ale u mnie nie poszło.
WRT-54GL + memory mod + USB + Tomato -127 K26 USB
WRT-54G v5 + DD-WRT
WRT-54G v1.1 +DD-WRT
FreeNAS 9.2.1.7
 
esem
Zainstalowałem na tomato zgodnie z tutkiem dla Merlina pamiętając iż w tomato jest "root" a nie "admin".
Tak że widzi HP1515, testuje spod putty. Oczywiście, że dla HP jest hplip-full anie hplip.
Ale pojawił się inny problem dla ScanImage i (lub) SaneWin: tomato odmawia połączenia: 192.168.xx.1:6566
Jak sobie poradzić?

Scalony z 18 sierpnia 2021 11:08:42:

esem napisał:

Zainstalowałem na tomato zgodnie z tutkiem dla Merlina pamiętając iż w tomato jest "root" a nie "admin".
Tak że widzi HP1515, testuje spod putty. Oczywiście, że dla HP jest hplip-full anie hplip.
Ale pojawił się inny problem dla ScanImage i (lub) SaneWin: tomato odmawia połączenia: 192.168.xx.1:6566
Jak sobie poradzić?

Reguła

 iptables -I INPUT -p tcp --dport 6566 -j ACCEPT
nie działa> Dalej aktywnie odmawia połączenia.
Edytowany przez esem dnia 18-08-2021 11:08
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
Adooni
a co to za adress 192.168.xx.1?
jak routerka to jest 192.168.1.1 a jak urzadzenia to powinnien byc 192.168.1.X

jezeli masz inne IP niz 192.168.1.X to pewnie bedziesz musial robic przekierowanie tez przez iptables
Edytowany przez Adooni dnia 18-08-2021 14:05
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
esem
Nie rozumiem. Adres routera jest taki jak Ja ustawiłem. I nie zmienię go na pospolity. A poza tym co za różnica? XX załóż że jest to 13. I tak zostało ustawione tam gdzie trzeba. Pisałem że testy przechodzi , spod putty skanuje. Tylko z windy nie wchodzi w router.
Asus RT-AC56U @1000/666 + aktualne tomato
Fonera 2100/200 | DD-WRTv24sp2
W rezerwie:
ADB VV5822
Netgear WNR3500L/U/v2 (wg. tomato). Ale to jest WNR3500L v.1 Wink
 
Adooni
ma byc ta sama siec czyli ip router 192.168.1.1 i potem urzadzenia 192.168.1.2 itd
a nie router 192.168.1.1 a urzadzenie 192.168.2.1 np bo wlasnie to generuje problemy

a jak tak masz to trzeba iptables to przekierowac - masz jak to zroic na forum.
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 7

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

tamtosiamto
03-06-2024 16:24
poszlo w koncu -najpierw przez restoration jakies stare ddwrt, potem z menu update plik ac66u z art o zmianie 868l->ac66u

tamtosiamto
02-06-2024 21:44
trx size 44560384 > memory size 33554432 nigdy czegos takiego nie widzialem podczas flashowania rutera

tamtosiamto
02-06-2024 21:37
wgrywanie ddwrt z opisu zmiany softu z dlinka na asusa nic nie daje, dalej startuje tomato, wgranie ddwrt dla ac66u wchodzi, ale z niego tez nie da sie wgrac ofw asusa i merlina, kicha

tamtosiamto
02-06-2024 19:57
Probowal ktos wrocic z tomata do OFW ASAUSa na przerowbionym DIR868l -> rt-ac66u ? Ni cholery nie moge dac sobie rady.

RaTaJ
10-05-2024 15:43
Czy intel n100 4x 3,40Ghz z Intel HD i DDR5 byłby dobry, widziałem za 550zł z 8gb ram i ssd 512gb?

Adooni
26-04-2024 14:41
jaki router RMerlin nie pociagne, tomato/ openwrt tak non hilink,

tamtosiamto
23-04-2024 12:35
modem bez smilocka?

man1
22-04-2024 23:27
Czy próbował ktoś uzywac karty voice (z nolimit GB) od tmobile w modemie /routerze? Da się jakoś to zrobić? Bo u mnie neta brak. E3372 Sad

tamtosiamto
31-03-2024 12:54
Wesolego jajka wszytskim forumowiczom Grin

tamtosiamto
28-03-2024 23:24
tak, tak zgadza sie, ale ja pytam o wykluczenie noda na guest network w first set, i to nie dziala

73,112,897 unikalnych wizyt