17 Sierpień 2017 11:37:36
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Jak ustawić Tomato d...
· Instalacja Newcs na ...
· [MOD] Tomato by shibby
· [MOD] Tomato by kille72
· Netgear R6400 - tańs...
· netiaspot + Linksys ...
· (RT-AC66U) 1.28.0000...
· [S] Asus RT-AC56U
· Linksys EA3200 i pro...
· [S] Laptop ASUS R500...
· VLAN VID 102 Dla GPON
· OptWare - co to jest...
· Tomato upgrade z 1.1...
· Skrypt w zakładce fi...
· WNR3500L v2 + zyxel ...
· zakup routera do Net...
· Monitorownie odwiedz...
· Układy radiowe stoso...
· Uwalony EA6900 - czy...
· Komenda AT wymuszeni...
Najciekawsze tematy
· [MOD] Tomato by s... [13504]
· [MOD] Tomato by k... [653]
· OptWare - co to j... [527]
· Netgear R6400 - t... [85]
· Jak ustawić Tomat... [35]
· Skrypt w zakładce... [8]
· Instalacja Newcs ... [7]
· Monitorownie odwi... [7]
· WNR3500L v2 + zyx... [5]
· Linksys EA3200 i ... [4]
· zakup routera do ... [4]
· netiaspot + Links... [3]
· VLAN VID 102 Dla ... [3]
· Tomato upgrade z ... [2]
· [S] Laptop ASUS R... [1]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
41% [123 głosów]

Broadcom ARM
Broadcom ARM
49% [147 głosów]

Atheros
Atheros
6% [17 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 303
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.80.198.222
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Skrypt w zakładce firewall nie wykonuje się
hanto
Witam

Dodałem w skryptach w zakładce firewall skrypt blokujący logowanie się do ftp z innego kraju niż Polska jednak jak sprawdzam iptables - L to nie wykonuje się.
#montowanie dysku
/sbin/swapon /dev/sda1
/bin/mount /dev/sda2 /opt
/bin/mount /dev/sda3 /nas
iptables -I wanin -p tcp -d 192.168.1.1 --dport 21 -j DROP wget -qO- http://www.ipdeny.com/ipblocks/data/countries/pl.zone | awk '{system("iptables -I wanin -p tcp -s " $1 " -d 192.168.1.1 --dport 21 -j ACCEPT")}'

dodałem też wpis w skrypty -->init takie wpis bo czytałem takie sugestie Shibbiego:

service firewall restart

Co robię źle??
Tomato Firmware 1.28.0000 -3.4-140 K26ARM USB AIO-64K Asus RT-N18U
 
djwujek
co to jest wanin ?
1.Modem Vectra ( CISCO EPC3928 ) 150/15
2. Edgerouter X Frimware 1.9.7
3. ASUS RT-N18U Tomato 2017.2
4. 2 x Asus RT-N12 D1 - Tomato v140
5. Synology DS215j + 4TB + 500 GB

Masz uwalony ruter błędnym wgraniem firmware - pomogę SmileWink
 
hanto
Robiłem to wzorując się na:
http://www.linksysinfo.org/index.php?threads/country-block-allow-with-iptables.35548/

Połączony z 09 sierpień 2017 18:01:10:
A tak wygląda plik iptables:

*mangle
:PREROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-I FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
-A PREROUTING -i vlan2 -d 192.168.1.1/255.255.255.0 -j DROP
-A PREROUTING -i vlan2 -d 10.0.0.1/255.255.255.0 -j DROP
COMMIT
*nat
:PREROUTING ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:WANPREROUTING - [0:0]
-A PREROUTING -d (zewnętrzny adres IP) -j WANPREROUTING
-A WANPREROUTING -p icmp -j DNAT --to-destination 192.168.1.1
-A WANPREROUTING -p tcp --dport 21 -j DNAT --to-destination 192.168.1.1
-A POSTROUTING -o vlan2 -j MASQUERADE
-A POSTROUTING -o br0 -s 192.168.1.1/255.255.255.0 -d 192.168.1.1/255.255.255.0 -j SNAT --to-source 192.168.1.1
-A POSTROUTING -o br1 -s 10.0.0.1/255.255.255.0 -d 10.0.0.1/255.255.255.0 -j SNAT --to-source 10.0.0.1
COMMIT
*filter
:INPUT DROP [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state INVALID -j DROP
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-N shlimit
-A shlimit -m recent --set --name shlimit
-A shlimit -m recent --update --hitcount 4 --seconds 60 --name shlimit -j DROP
-A INPUT -p tcp --dport 22 -m state --state NEW -j shlimit
-A INPUT -i lo -j ACCEPT
-A INPUT -i br0 -j ACCEPT
-A INPUT -i br1 -j ACCEPT
-A INPUT -p tcp --dport 21 -j ACCEPT
:FORWARD DROP [0:0]
-A FORWARD -m account --aaddr 192.168.1.0/255.255.255.0 --aname lan
-A FORWARD -m account --aaddr 10.0.0.0/255.255.255.0 --aname lan1
-A FORWARD -i br0 -o br0 -j ACCEPT
-A FORWARD -i br1 -o br1 -j ACCEPT
-A FORWARD -m state --state INVALID -j DROP
:wanin - [0:0]
:wanout - [0:0]
-A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -i br0 -o br1 -j DROP
-A FORWARD -i br1 -o br0 -j DROP
-A FORWARD -i vlan2 -j wanin
-A FORWARD -o vlan2 -j wanout
-A FORWARD -i br0 -j ACCEPT
-A FORWARD -i br1 -j ACCEPT
COMMIT
 
djwujek
hanto napisał(a):

Witam

Dodałem w skryptach w zakładce firewall skrypt blokujący logowanie się do ftp z innego kraju niż Polska jednak jak sprawdzam iptables - L to nie wykonuje się.
#montowanie dysku
/sbin/swapon /dev/sda1
/bin/mount /dev/sda2 /opt
/bin/mount /dev/sda3 /nas
iptables -I wanin -p tcp -d 192.168.1.1 --dport 21 -j DROP wget -qO- http://www.ipdeny.com/ipblocks/data/countries/pl.zone | awk '{system("iptables -I wanin -p tcp -s " $1 " -d 192.168.1.1 --dport 21 -j ACCEPT"Wink}'

dodałem też wpis w skrypty -->init takie wpis bo czytałem takie sugestie Shibbiego:

service firewall restart

Co robię źle??
Tomato Firmware 1.28.0000 -3.4-140 K26ARM USB AIO-64K Asus RT-N18U


/sbin/swapon /dev/sda1
/bin/mount /dev/sda2 /opt
/bin/mount /dev/sda3 /nas

Dodawanie tego w zakładce firewall według mnie jest bez sensu bo to nic nie pomoże po drugie żeby takie coś wogule było możliwe musisz znać całą pulę ip która jest w Polsce i jej dać tylko prawa dostępu do ftp co jest dla mnie również bez sensu bo rok ci zajmie wpisywane tylu adresów ip gra nie warta świeczki.
1.Modem Vectra ( CISCO EPC3928 ) 150/15
2. Edgerouter X Frimware 1.9.7
3. ASUS RT-N18U Tomato 2017.2
4. 2 x Asus RT-N12 D1 - Tomato v140
5. Synology DS215j + 4TB + 500 GB

Masz uwalony ruter błędnym wgraniem firmware - pomogę SmileWink
 
hanto
djwujek a sprawdzałeś to http://www.ipdeny.com/ipblocks/data/countries/pl.zone ? O jakim roku wpisywania mówimy :-).Chodzi mi o pomoc w tym dlaczego wpis w zakładce firewall nie wykonuje się , co mam jeszcze sprawdzić ITP a nie czy to słuszne czy nie ;-)
 
jachu
hanto napisał(a):

djwujek a sprawdzałeś to http://www.ipdeny.com/ipblocks/data/countries/pl.zone ? O jakim roku wpisywania mówimy :-).Chodzi mi o pomoc w tym dlaczego wpis w zakładce firewall nie wykonuje się , co mam jeszcze sprawdzić ITP a nie czy to słuszne czy nie ;-)


Poczytaj troche o bashu i awk i przede wszystkim iptables . Jesli uzywasz skryptow staraj sie je zrozumiec a nie przepisujesz nie kumajac nic .
pozdrawiam
Jachu
Netgear WNR3500L v2 - Tomato
ALIX - OpenBSD
Netgear R7000 - v136 MULTIWAN Smile
 
www.pdaclub.pl
djwujek
Zeby to zadzialalo musisz kazde ip z tej listy zezwolic na ruch a pozostale zablokowac taka jest moja teoria jesli chce ci sie to robic twoja sprawa ale z drugiej strony czy ruter ktory posiadasz da rade wydajnosciowo przetrawic tyle regulek watpie.Poza tym nie wiem dlaczego chcesz wszystkie ip blokowac prucz polski myslisz ze nikt nie wejdzie z poza Polski nawet jak to zablokujesz to jestes w bledzie.Dlatego dla mnie to gra nie warta swieczki.
1.Modem Vectra ( CISCO EPC3928 ) 150/15
2. Edgerouter X Frimware 1.9.7
3. ASUS RT-N18U Tomato 2017.2
4. 2 x Asus RT-N12 D1 - Tomato v140
5. Synology DS215j + 4TB + 500 GB

Masz uwalony ruter błędnym wgraniem firmware - pomogę SmileWink
 
jachu
djwujek - jesli chce niech blokuje co chce ale niech najpierw zrozumie co chce robic i poczyta troche bo uzywajac skryptow znalezionych w necie bez ich analizy i zrozumienia to jak szukanie klopotow .
pozdrawiam
Jachu
Netgear WNR3500L v2 - Tomato
ALIX - OpenBSD
Netgear R7000 - v136 MULTIWAN Smile
 
www.pdaclub.pl
s_pol
Zrób to w oparciu o moduł xt_geoip.ko
i prostą formułę
iptables -I wanin -p tcp --dport 21 -m geoip ! --src-cc PL -j DROP

Szczegóły pod adresem http://www.linksy...les.35548/
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 11

· Użytkowników online: 1
djwujek

· Łącznie użytkowników: 23,572
· Najnowszy użytkownik: Zbigniew Chmielewski
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

Unpleasant
16-08-2017 18:48
Panowie, działają Wam regułki ebtables na nowszych wersjach AIO z multi WAN? (AC66U)

b3rok
12-08-2017 14:35
@djwujek i inni - ostrożnie z tym sklepem, więcej tutaj (komentarze) https://zaufanatrz
eciastrona.pl/post
/jak-bezkarnie-kra
sc-pieniadze-czyli
-o-bezradnosci-org
anow-scigania/

djwujek
12-08-2017 02:05
Po 210 Zł RT-N18U arendt-24 //usunąłem link poczytajcie komentarze o Arendt - b3rok

feszt
08-08-2017 16:38
NewCS to zabytek, napewno na ARM też go nie ma.

PanRatio
07-08-2017 21:39
Jest promocja i Router Xiaomi Mi Pro można mieć za 295 zł. Szkoda, że nie ma na niego Tomato Frown

scooby
07-08-2017 19:10
czesc, mam pytanie czy dałoby rade wykorzystac tutorial Cardserwer NewCS 1.67RC1 pod Tomato w sofcie RMerlin z optware ?

PixelPL
02-08-2017 16:46
na torrent trochę się zapycha i szału nie ma, w LAN -> Switch Control -> Enable Jumbo Frame

PixelPL
02-08-2017 16:44

PixelPL
02-08-2017 16:43
@ovner RT-N16 AsusWRT Merlin 378.50

ovner
02-08-2017 09:37
RT-N16 wyrabia na łączu +400Mb/s Smile No ładnie jak na staruszka, jaką dokładnie masz wersje wgrana bo ja mam Firmware:374.43_2-
26E3j9527 (Merlin LTS fork)

PixelPL
01-08-2017 23:26
http://beta.speed.
..597417.png
RT-N16 AsusWRT Merlin 378.50

ovner
01-08-2017 10:32
RT-N16_Discontinue
d Rmerlin zaprzestał rozwoju i wsparcia tomato dla rt-n16 To co mamy wgrane to jest fork na baziw jego softu

PixelPL
01-08-2017 10:30
no i jeszcze teraz łączy mi z routerem na wyższym adresie bo jeszcze używam PPPoE do ADSL

PixelPL
01-08-2017 10:27
RT-N16_3.0.0.4_378
.50_0 Dodali okienko CPU Usage Grin

PixelPL
01-08-2017 09:57
Panowie jest problem https://www.media.
..nw5wo8wrco
Wedle tej strony soft na samej górze nie jest najnowszy, dziś sprawdziłem po datach doda

PixelPL
30-07-2017 08:54
Nat DMZ itd. cmd ping, iperf, nie łączy. Skończyły mi się pomysły. Może Asus WRT Merlin jest jakieś pop... nie chcę mi się zmieniać już na coś innego

PixelPL
30-07-2017 08:52
Dziś spędziłem nad tym 4 godziny, jak kolega wspomniał adresacja 10.0.0.1 i 10.0.0.2 jest poprawna ponieważ ruch występuje a router w sekcji WAN widzi to poprawnie, nic jednak z przekierowania portu N

33,088,092 unikalne wizyty