02 Lutego 2023 18:38:59
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Problem z FreshTomat...
· Co kupić po uszkodz...
· Jaki router wybrać-...
· [S]QNAP TS-653B-4G
· [MOD] FreshTomato-AR...
· [S]Ubiquiti EdgeRout...
· [S] ER-6P | ER-12 |U...
· Zawieszony RT-AC56U
· RT-AC86U pod Merlina...
· [MOD] FreshTomato-MI...
· [S] ASUS :DSL N17U ,...
· Merlin na AC68U - Pr...
· Separacja urządzeń...
· Torrenty na tomato -...
· Powrot do oryginalne...
· RT-N16 reanimacja / ...
· Wsparcie dla nowych ...
· [HOWTO] Link Aggrega...
· Asus Merlin
· Linksys EA6400 cegła
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [769]
· Jaki router wybra... [73]
· Co kupić po uszk... [28]
· Problem z FreshTo... [2]
· [S]QNAP TS-653B-4G [0]
· [S]Ubiquiti EdgeR... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [150 głosów]

Broadcom ARM
Broadcom ARM
51% [210 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
3% [14 głosów]

Ogółem głosów: 408
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
34.225.194.102
Zobacz wątek
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj wątek
Huawei E3131s-2 + Aero na tomato
shibby
Opis powstał dzięki uprzejmości forumowicza @lazik, który zgodził się przesłać mi modem z kartą Aero na testy.
Tutorial wzorowany na opisie ze strony http://eko.one.pl/?p=openwrt-modemygs...eieshilink


Huawei E3131s-2 pomimo, że jest modemem 3G jest obsługiwany przez system w kompletnie inny sposób niż pozostałe dongle 3G. Cała obsługa APN, PIN, SMS oraz realizacja połączenia odbywa się po stronie modemu, zaś sam modem wykrywany jest w systemie jako karta sieciowa.

i607.photobucket.com/albums/tt151/eeycrstn/Huawei%20E3131/DSC01968.jpg


Samą konfigurację podzielić musimy na dwie części:
- przygotowanie modemu do pracy z Aero
- konfiguracja tomato

Zaczynajmy...


Przygotowanie modemu do pracy z Aero

Modem instalujemy w komputerze z systemem Windows i po chwili otwiera nam się strona konfiguracyjna modemu http://192.168.1.1. Ustawiamy tam automatyczne łączenie (w roamingu także), PIN oraz profil połączenia do APN "darmowy". Pola username oraz password pozostawiamy puste. Klikamy na Connect i jeżeli modem nam się połączy kończymy konfigurację modemu pod sieć Aero2.

Jeżeli zaś posiadamy modem z sieci Play musimy "odblokować" modem. Szczegóły tego procesu znajdziecie pod adresem: http://jdtech.pl/2011/08/aero2-na-czy...-e169.html


Konfiguracja Tomato

Tu od razu uczulę by bacznie czytać i przyglądać się swojej konfiguracji VLAN`ów. Zła konfiguracja może uniemożliwić wam połączenie do routera i wymusić na was konieczność przywrócenia ustawień domyślnych!

Sam modem działa na ip 192.168.1.1 z maską 255.255.255.0. Nie możemy więc takiej podsieci użyć jako naszą podsieć LAN. W sekcji -> Network ustawiamy LAN ip na np 192.168.2.1 z maską 255.255.255.0. Po czym zapisujemy ustawienia.

Potrzebujemy paczkę extras dla swojej wersji tomato. Z niej potrzebujemy trzy moduły:
- mii.ko
- usbnet.ko
- cdc_ether.ko

Zapisujemy je na dysku USB lub na JFFS. W moim przypadku użyłem JFFS.

Następnie tworzymy nowy plik np hilink z zawartością:

Cytat

DefaultVendor= 0x12d1
DefaultProduct=0x1f01

TargetVendor= 0x12d1
TargetProduct= 0x14db

MessageContent="55534243123456780000000000000a11062000000000000100000000000000"
NoDriverLoading=1


i zapisujemy tam gdzie zapisaliśmy moduły.

W zakładce USB and NAS -> USB Support -> Hotplug script wpisujemy (zwracając uwagę na popawność ścieżek):

Cytat

if [ "${PRODUCT:0:4}" = "12d1" ] && [ "${PRODUCT:5:4}" = "1f01" ]; then
logger "Huawei E3131s-2 modem attached"
insmod /jffs/mii.ko
insmod /jffs/usbnet.ko
insmod /jffs/cdc_ether.ko
usb_modeswitch -c /jffs/hilink -v 12d1 -p 1f01
fi


i zapisujemy ustawienia.

Możemy teraz zresetować router i sprawdzić czy nasze dotychczasowe kroki wykonują się poprawnie. Po restarcie routera wpisujemy komendę lsusb. Jedno z urządzeń powinno mieć identyfikator 12d1:14db. Oznaczać to będzie, że moduły poprawnie się załadowały a modem został przełączony (przed przełączeniem przedstawia się jako 12d1:1f01).

Ponadto w dmesg powinniśmy zobaczyć wpis podobny do tego:

Cytat

Jan 1 01:00:57 unknown user.info kernel: eth2: register 'cdc_ether' at usb-0000:01:03.2-1, CDC Ethernet Device, 58:2c:80:13:92:63


Jak widać u mnie urządzenie CDC Ethernet Device zostało odnalezione w systemie jako eth2. To bardzo ważna informacja dla nas. Prawdopodobnie w urządzeniach dual-band będzie to interfejs eth3.

Sprawdźmy czy w systemie taki interfejs nie jest czasem przypisany już do LAN:

Cytat

nvram show | grep eth2


W moim przypadku (testowy Asus WL500gP) znaleziony został wpis:

Cytat

lan_ifnames=vlan0 eth1 eth2 eth3


vlan0 to switch. eth1 to Wireless. Pozostałe interfejsy w moim przypadku to "pic na wodę" więc je kasujemy:

Cytat

nvram set lan_ifnames="vlan0 eth1"
nvram commit


W routerach dual-band prawdopodobnie poprawnym ustawieniem dla lan_ifnames będzie "vlan1 eth1 eth2".

Sprawdźmy i zanotujmy domyślny interfejs WAN:

Cytat

nvram show | grep wan_ifname


W moim przypadku był to vlan1.
Zanotowane? Idziemy dalej Smile

Teraz musimy wskazać Tomato nasz nowy interfejs WAN:

Cytat

nvram set wan_iface=eth2
nvram set wan_ifname=eth2
nvram set wan_ifnameX=eth2
nvram set wan_ifnames=eth2
nvram commit


Jeżeli będziemy w przyszłości chcieli na powrót używać dedykowanego portu WAN musimy wykonać powyższe komendy wpisująć zamiast eth2 zanotowany wcześniej domyślny interfejs vlan.

Wracamy do zakładki Basic -> Network i ustawiamy WAN na DHCP po czym zapisujemy. Interfejs WAN powinien domyślnie otrzymać adres IP 192.168.1.100 i powinniśmy być już w stanie serfować po internecie. Do strony konfiguracyjnej modemu możemy się dostać za pośrednictwem adresu http://192.168.1.1/.

Na koniec log od zainicjowania portów USB do nawiązania połączenia z Aero2 wraz z małym komentarzem na co zwracać uwagę:

Cytat

Jan 1 01:00:54 unknown user.info kernel: Initializing USB Mass Storage driver...
Jan 1 01:00:54 unknown user.info kernel: usbcore: registered new interface driver usb-storage
Jan 1 01:00:54 unknown user.info kernel: USB Mass Storage support registered.
Jan 1 01:00:55 unknown user.info kernel: ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Jan 1 01:00:55 unknown user.warn kernel: PCI: Enabling device 0000:01:03.2 (0000 -> 0002)
Jan 1 01:00:55 unknown user.info kernel: ehci_hcd 0000:01:03.2: EHCI Host Controller
Jan 1 01:00:55 unknown user.info kernel: ehci_hcd 0000:01:03.2: new USB bus registered, assigned bus number 1
Jan 1 01:00:55 unknown user.info kernel: ehci_hcd 0000:01:03.2: irq 12, io mem 0x40004000
Jan 1 01:00:55 unknown user.info kernel: ehci_hcd 0000:01:03.2: USB 2.0 started, EHCI 1.00
Jan 1 01:00:55 unknown user.info kernel: usb usb1: configuration #1 chosen from 1 choice
Jan 1 01:00:55 unknown user.info kernel: hub 1-0:1.0: USB hub found
Jan 1 01:00:55 unknown user.info kernel: hub 1-0:1.0: 4 ports detected
Jan 1 01:00:55 unknown user.info kernel: usb 1-1: new high speed USB device using ehci_hcd and address 2
Jan 1 01:00:55 unknown user.info kernel: usb 1-1: configuration #1 chosen from 1 choice
Jan 1 01:00:55 unknown user.info kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Jan 1 01:00:55 unknown user.debug hotplug[409]: Attached USB device 1-0:1.0 [INTERFACE=9/0/0 PRODUCT=1d6b/2/206]
Jan 1 01:00:56 unknown user.debug hotplug[428]: Attached USB device 1-1:1.0 [INTERFACE=8/6/80 PRODUCT=12d1/1f01/102]

// wykrycie nowego urządzenia USB

Jan 1 01:00:56 unknown user.debug kernel: vlan0: add 33:33:00:00:00:01 mcast address to master interface
Jan 1 01:00:56 unknown user.debug kernel: vlan0: add 01:00:5e:00:00:01 mcast address to master interface
Jan 1 01:00:56 unknown user.info kernel: vlan0: dev_set_allmulti(master, 1)
Jan 1 01:00:56 unknown user.info kernel: vlan0: dev_set_promiscuity(master, 1)
Jan 1 01:00:56 unknown user.info kernel: device eth0 entered promiscuous mode
Jan 1 01:00:56 unknown user.info kernel: device vlan0 entered promiscuous mode
Jan 1 01:00:56 unknown user.notice root: Huawei E3131s-2 modem attached
Jan 1 01:00:56 unknown user.info kernel: usbcore: registered new interface driver cdc_ether



Jan 1 01:00:56 unknown user.info kernel: device eth1 entered promiscuous mode
Jan 1 01:00:57 unknown user.info kernel: br0: port 2(eth1) entering forwarding state
Jan 1 01:00:57 unknown user.info kernel: br0: port 1(vlan0) entering forwarding state
Jan 1 01:00:57 unknown user.info kernel: usb 1-1: USB disconnect, address 2
Jan 1 01:00:57 unknown user.info kernel: usb 1-1: new high speed USB device using ehci_hcd and address 3
Jan 1 01:00:57 unknown user.info kernel: usb 1-1: configuration #1 chosen from 1 choice
Jan 1 01:00:57 unknown user.info kernel: scsi1 : SCSI emulation for USB Mass Storage devices
Jan 1 01:00:57 unknown user.info kernel: eth2: register 'cdc_ether' at usb-0000:01:03.2-1, CDC Ethernet Device, 58:2c:80:13:92:63
Jan 1 01:00:58 unknown user.debug hotplug[524]: Attached USB device 1-1:1.0 [INTERFACE=2/6/0 PRODUCT=12d1/14dc/102]

// wykrycie nowego interfejsu sieciowego

Jan 1 01:00:58 unknown user.debug hotplug[512]: Attached USB device 1-1:1.1 [INTERFACE=10/6/0 PRODUCT=12d1/14dc/102]
Jan 1 01:00:58 unknown user.debug hotplug[513]: Attached USB device 1-1:1.2 [INTERFACE=8/6/80 PRODUCT=12d1/14dc/102]
Jan 1 01:00:59 unknown authpriv.info dropbear[562]: Running in background
Jan 1 01:00:59 unknown daemon.info dnsmasq[573]: started, version 2.61 cachesize 1500
Jan 1 01:00:59 unknown daemon.info dnsmasq[573]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP no-conntrack
Jan 1 01:00:59 unknown daemon.info dnsmasq[573]: asynchronous logging enabled, queue limit is 5 messages
Jan 1 01:00:59 unknown daemon.info dnsmasq-dhcp[573]: DHCP, IP range 192.168.2.2 -- 192.168.2.51, lease time 1d
Jan 1 01:00:59 unknown daemon.warn dnsmasq[573]: failed to access /etc/resolv.dnsmasq: No such file or directory
Jan 1 01:00:59 unknown daemon.info dnsmasq[573]: read /etc/hosts - 2 addresses
Jan 1 01:00:59 unknown daemon.info dnsmasq[573]: read /etc/dnsmasq/hosts/hosts - 3 addresses
Jan 1 01:00:59 unknown daemon.info dnsmasq-dhcp[573]: read /etc/dnsmasq/dhcp/dhcp-hosts
Jan 1 01:00:59 unknown user.notice kernel: scsi 1:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
Jan 1 01:00:59 unknown user.notice kernel: sd 1:0:0:0: [sda] 15954944 512-byte hardware sectors (8169 MB)
Jan 1 01:00:59 unknown user.notice kernel: sd 1:0:0:0: [sda] Write Protect is off
Jan 1 01:00:59 unknown user.debug kernel: sd 1:0:0:0: [sda] Mode Sense: 0f 00 00 00
Jan 1 01:00:59 unknown user.err kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Jan 1 01:00:59 unknown user.err kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Jan 1 01:00:59 unknown user.info kernel: sda: sda1 sda2 sda3
Jan 1 01:00:59 unknown user.notice kernel: sd 1:0:0:0: [sda] Attached SCSI removable disk
Jan 1 01:01:00 unknown user.debug dhcpc-event[588]: 182: pptp peerdns disabled
Jan 1 01:01:00 unknown daemon.info dnsmasq[573]: reading /etc/resolv.dnsmasq
Jan 1 01:01:00 unknown daemon.info dnsmasq[573]: using nameserver 192.168.1.1#53

// konfiguracja dns`a

Jan 1 01:01:00 unknown user.debug init[1]: starting rstats.
Jan 1 01:01:00 unknown user.debug init[1]: starting cstats.
Jan 1 01:01:00 unknown user.info hotplug[582]: USB vfat fs at /dev/sda1 mounted on /tmp/mnt/MINISD
Jan 1 01:01:36 unknown user.warn kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
Jan 1 01:01:36 unknown user.info hotplug[586]: USB ext2 fs at /dev/sda3 mounted on /tmp/mnt/sda3
Jan 1 01:02:13 unknown user.notice root: Transmission daemon successfully stoped
Jan 1 01:02:13 unknown user.info init[1]: Asus WL-500gP: Tomato 1.28.0000 MIPSR1-101 K26 USB Tor-VPN
Sep 25 14:39:58 unknown cron.err crond[597]: time disparity of 22476277 minutes detected

// aktualizacja czasu routera zaraz po nawiązaniu połączenia internetowego



Uwagi na koniec

W nowym wydaniu tomato planuję dodać moduły i plik konfiguracyjny dla usb_modeswitch domyślnie w obraz tomato. Nie będzie więc konieczności wykonywania części z kroków.


Dziękuję i pozdrawiam
Edytowany przez shibby dnia 21-07-2013 08:21
Router: miniPC N5105, i226 (2.5g eth) + OpenWRT
Switch: Ubiquiti US-8-150W
Switch: Ubiquiti USW-Flex-mini - szt 2.
Wi-Fi: Ubiquiti U6-Lite - szt 2.
NAS: Xpenology DS920+
 
q2werty
Świetna robotaSmile, @lazik pewnie jest Ci wdzięcznySmile
 
lazik

Cytat

q2werty napisał(a):
Świetna robotaSmile, @lazik pewnie jest Ci wdzięcznySmile

Jeszcze nie bo nie mam modemu Wink Chociaż jak już przesyłka poszła to wiadomo, że shibby nie zawodzi. Sam byłem w swych krokach w jego uruchomieniu nie tak daleko celu, ale wiadomo zazwyczaj brakuje zacięcia, wiedzy i czasu.

Nie mniej jednak serdeczne dzięki.

A tak swoją drogą to przy pracy jako medem 3G czytnik karty jest także dostępny? To by załatwiło np. "problemy" z koniecznością używania huba usb dla optware.
 
arekbis
Jak dla mnie to jesteś magikiem ; )
Dzięki za kawał dobrej "roboty".
Muszę tylko jeszcze na spokojnie przeczytać to z 5 razy żeby zrozumieć Wink
Myślę że dla dużej rzeszy użytkowników mniej obeznanych z linuxem bardzo pomocnym będzie "wtłoczenie" co się da w obraz TOMATO.
Ja szukam asusa WL500gl i spróbuje podłączyć ten modem.
 
jack78
Świetna robota. Też posiadam od kilku dni ten modem i nie wiedziałem jak to ugryźć.
Na moje nieszczęście u mnie i tak nie ma zasięgu, ale może z czasem się doczekam. Pewnie wtedy obsługa tego modemu będzie już wkompilowana w Tomato.

Mikrotik hAP ac2
UniFi AP AC v2
-OFW, UniFi AP PRO- OpenWRT,
Linksys E1000v2 - Tomato-RT-N5x-MIPSR2-116-Hyzoom.4M-Mini
Tenda AC10 - AC1200 OFW
NAS - HP Microserver Gen8 i3-3220T, 8GB RAM 5x 3TB WD RED | Xpenology
 
lazik
no i sprzęt do mnie wrócił. I wiecie co? Nie działa! To znaczy modem jako taki jest OK, na windowsie zero problemu, ale już na tomato niby wszytko powinno być jak należy ale wan nie dostaje adresu po DHCP. Przypisanie z palca statycznego niestety tez nie pomaga. Hmmm....

btw Shibby na dwuzakresowcu modem dostaje eth3. Logi jakie są u mnie pokrywają się z tym co miałem wcześniej.
 
jarek7714

Cytat

lazik napisał(a):
I wiecie co? Nie działa!
Nie wiem czy zauważyłeś że od 1 października się wiele zmieniło (np. u mnie sieć Aero2 BDI jest identyfikowana jako Plus-wskazany włączony roaming), wczoraj uruchamiałem nową kartę na Ubuntu 12.04PL z E353 o ile wcześniej łączył szybko i bez problemów to teraz robi to długo, nie zawsze z powodzeniem. Sad
jareq
 
lazik

Cytat

jarek7714 napisał(a):

Cytat

lazik napisał(a):
I wiecie co? Nie działa!
Nie wiem czy zauważyłeś że od 1 października się wiele zmieniło (np. u mnie sieć Aero2 BDI jest identyfikowana jako Plus-wskazany włączony roaming), wczoraj uruchamiałem nową kartę na Ubuntu 12.04PL z E353 o ile wcześniej łączył szybko i bez problemów to teraz robi to długo, nie zawsze z powodzeniem. :(

Że zacytuje to co wcześniej napisałem "To znaczy modem jako taki jest OK, na windowsie zero problemu". Jutro powalczę z tematem.

Swoją drogą:

root@asus-router:/tmp/home/root# nvram show | grep vlan2
vlan2hwname=et0
vlan2ports=0 8
wan_iface=vlan2
wan_ifname=vlan2
wan_ifnameX=vlan2
wan_ifnames=vlan2
wandevs=vlan2

Do czego jest wandevs? Może to też trzebaby zamienić na eth3?
 
shibby
u mnie wandevs nie było na wl500gp a tylko ten miałem na testy pod ręką. Też go zmień. na eth3.
Router: miniPC N5105, i226 (2.5g eth) + OpenWRT
Switch: Ubiquiti US-8-150W
Switch: Ubiquiti USW-Flex-mini - szt 2.
Wi-Fi: Ubiquiti U6-Lite - szt 2.
NAS: Xpenology DS920+
 
REDBLUE
Witam

Czy ten manewr z modułem cdc_ether zadziała z e398? Pytanie czy ten moduł obsłuży ten że modem?
Edytowany przez REDBLUE dnia 04-10-2012 22:12
 
shibby
wg tego: http://eko.one.pl/?p=openwrt-huaweie398

E398 jest wykrywany przez moduł option ktory to jest domyślnie w moim tomato. Dane modeswitch do przełączania modemu są również w Tomato. Oznacza to ze skrypt autodetekcji powininien sam wykryć, przełączyć i przygotowaćdo pracy modem.

Pokaż logi jak to wygląda u ciebie.
Router: miniPC N5105, i226 (2.5g eth) + OpenWRT
Switch: Ubiquiti US-8-150W
Switch: Ubiquiti USW-Flex-mini - szt 2.
Wi-Fi: Ubiquiti U6-Lite - szt 2.
NAS: Xpenology DS920+
 
REDBLUE

Cytat

Oct 4 00:08:29 Router user.notice root: 3G MODEM ready - 12d1:1506
Oct 4 00:08:29 Router user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
Oct 4 00:08:29 Router user.info kernel: usbcore: registered new interface driver option
Oct 4 00:08:29 Router user.info kernel: drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.2
Oct 4 00:08:29 Router user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered for Sierra USB modem
Oct 4 00:08:29 Router user.info kernel: usbcore: registered new interface driver sierra
Oct 4 00:08:29 Router user.info kernel: drivers/usb/serial/sierra.c: USB Driver for Sierra Wireless USB modems: v.1.7.0
Oct 4 00:08:31 Router user.notice root: 3G MODEM not found by option and sierra module. Trying usbserial ...
Oct 4 00:08:31 Router user.info kernel: usbcore: deregistering interface driver sierra
Oct 4 00:08:31 Router user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial deregistering driver Sierra USB modem
Oct 4 00:08:31 Router user.info kernel: usbcore: deregistering interface driver option
Oct 4 00:08:31 Router user.notice root: 3G MODEM - loading module usbserial
Oct 4 00:08:31 Router user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial deregistering driver GSM modem (1-port)
Oct 4 00:08:31 Router user.notice root: 3G MODEM ready - using usbserial module


Według tych logów modem nie korzysta z modułu option tylko usbserial.Co zauważyłem znacząco wpływa na transfer. Przeglądając net natknąłem się na szczątkowe informacje na temat pracy modemu w trybie ndis na openwrt. Nic konkretnego. Może jakaś podpowiedź ?
Edytowany przez REDBLUE dnia 05-10-2012 18:13
 
shibby
Czyli modem dziala tak? Na stronie obsego mozna tez wyczytac ze

Cytat

Z powodu braku odpowiedniego sterownika (dostępny jest on od wersji 3.4-rc1 kernela linuksowego), modemy LTE działają w zwykłym trybie RAS (z wykorzystaniem demona pppd). Powoduje to, że na dzień dzisiejszy modem pozwala osiągnąć maksymalnie do 20-25Mbps pod OpenWrt i nie da się tej wartości przeskoczyć nawet jeżeli na zwykłym komputerze w tym samym miejscu osiąga się większe prędkości.


To ze akurat wykrywa go usbserial a nie option moze wynikac ze starszej wersji optiona
Router: miniPC N5105, i226 (2.5g eth) + OpenWRT
Switch: Ubiquiti US-8-150W
Switch: Ubiquiti USW-Flex-mini - szt 2.
Wi-Fi: Ubiquiti U6-Lite - szt 2.
NAS: Xpenology DS920+
 
lazik
Ten opis dla modelów hilink mogę potwierdzić, że działa. Sprawdzałem na jednozakresowym 3500L i nie ma najmniejszego problemu.

Na dwuzakresowym N66u jeszcze powalczę to zdam info.
 
acid_toxin
Mam problem. Po przestawieniu i commicie do nvram, po restarcie wan_iface, wan_ifname, wan_ifnames wracają do starej wartości eth1. Jedynie wan_ifnameX=eth2 Router wl500gP v1 więc wszystko było tak samo jak w tutku
Smile
 
shibby

Cytat

wracają do starej wartości eth1.


do eth1?? niemozliwe. eth1 w wl500gp to interfejs radiowy! Wifi nie masz czasem ustawionego jako wireless client??
Router: miniPC N5105, i226 (2.5g eth) + OpenWRT
Switch: Ubiquiti US-8-150W
Switch: Ubiquiti USW-Flex-mini - szt 2.
Wi-Fi: Ubiquiti U6-Lite - szt 2.
NAS: Xpenology DS920+
 
acid_toxin
Miałem ale WiFi było odznaczone...spróbuję jeszcze raz w weekend i dam znać...
Smile
 
bychol
U mnie nawet nie odpalałem jak narazie aero bo nie mam zasięgu, ale powiem tak mam huawei 3131 do tego kartę 4gb w czytniku i kartę playa/aero i z playem działa BDB jak się zdarzy z tego korzystać, ale ogólnie modem jest wykrywany jako kilka urżadzeń, napęd dvd/czytnik modem i coś tam jeszcze i trechę gmatwa w tomato wcześniej musiałem ruter resetnąć do fabrycznych ustawień bo coś się popsuło
 
jack78
Mam Asus WL-500gP v2 na najnowszym Tomato 104 K26 USB plus modem E3131 HiLink, modem skonfigurowany na laptopie i wszystko działa.

W zakładce USB and NAS -> USB Support -> Hotplug script mam wpisane


if [ "${PRODUCT:0:4}" = "12d1" ] && [ "${PRODUCT:5:4}" = "1f01" ] then
logger "Huawei E3131s-2 modem attached"
modprobe mii.ko
modprobe usbnet.ko
modprobe cdc_ether.ko
usb_modeswitch -c /etc/usb_modeswitch.d/12d1:1f01
fi


w logach widzę tylko


Jan  1 01:00:53 unknown user.debug hotplug[376]: Attached USB device 2-0:1.0 [INTERFACE=9/0/0 PRODUCT=1d6b/1/206]
Jan  1 01:00:53 unknown user.debug hotplug[382]: Attached USB device 1-1:1.0 [INTERFACE=9/0/0 PRODUCT=424/2502/1]
Jan  1 01:00:53 unknown user.info kernel: usb 1-1.1: new high speed USB device using ehci_hcd and address 3
Jan  1 01:00:53 unknown user.info kernel: usb 1-1.1: configuration #1 chosen from 1 choice
Jan  1 01:00:53 unknown user.debug hotplug[402]: Attached USB device 1-1.1:1.1 [INTERFACE=10/6/0 PRODUCT=12d1/14db/102]
Jan  1 01:00:53 unknown user.debug hotplug[400]: Attached USB device 1-1.1:1.0 [INTERFACE=2/6/0 PRODUCT=12d1/14db/102]
Jan  1 01:00:54 unknown user.debug kernel: vlan0: add 33:33:00:00:00:01 mcast address to master interface
Jan  1 01:00:54 unknown user.debug kernel: vlan0: add 01:00:5e:00:00:01 mcast address to master interface
Jan  1 01:00:54 unknown user.info kernel: vlan0: dev_set_allmulti(master, 1)
Jan  1 01:00:54 unknown user.info kernel: vlan0: dev_set_promiscuity(master, 1)
Jan  1 01:00:54 unknown user.info kernel: device eth0 entered promiscuous mode
Jan  1 01:00:54 unknown user.info kernel: device vlan0 entered promiscuous mode
Jan  1 01:00:54 unknown user.info kernel: br0: port 1(vlan0) entering forwarding state
Jan  1 01:00:57 unknown authpriv.info dropbear[499]: Running in background


nie ma nic na temat vlanów, i nie wiem co dalej, bo bez tego ani rusz. Ktoś jest w stanie mi coś podpowiedzieć? Mogę udostępnić zdalnie router jeśli to coś da.

Mikrotik hAP ac2
UniFi AP AC v2
-OFW, UniFi AP PRO- OpenWRT,
Linksys E1000v2 - Tomato-RT-N5x-MIPSR2-116-Hyzoom.4M-Mini
Tenda AC10 - AC1200 OFW
NAS - HP Microserver Gen8 i3-3220T, 8GB RAM 5x 3TB WD RED | Xpenology
 
pepe001
Witam koledzy, mam WNR3500L z Tomato version 102 oraz modem 3131 hilink i niestety nie potrafię zmusić tych dwóch urządzeń do współpracy w sieci Aero. Jak mógłbym prosić o uaktualnienie tego tutoriala dla versji Tomato 102. Byłbym bardzo wdzięczny.
Asus RT-N66U with Tomato ver.138
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 7

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

zakk87
31-12-2022 19:13
Życzę wszystkim Szczęśliwego Nowego Roku, oby był jeszcze lepszy niż poprzedni.

Maniek91PL
27-12-2022 18:35
Wesołych Grin Szczęśliwego Nowego Roku!

tamtosiamto
24-12-2022 17:17
Wesolych swiat wszytskim uzytkownikom ol

shibby
18-12-2022 23:02
potrzebuję czegoś z 2.5G

p1vo
16-12-2022 17:31
Na co zamieniasz?

shibby
14-12-2022 09:48
btw, przed świętami będę miał ER-12 na sprzedaż jakby ktoś był zainteresowany Wink

shibby
14-12-2022 09:15
@damianssj661 - tomato trzyma cały config w zmiennych nvram zaś sam firewall jest budowany "w locie" na podstawie tych zmiennych. Łatwiej ci będzie zrobić tunnel przez ssh do gui Smile

Adooni
07-12-2022 21:54
juz od pewnego czasu nie siedize na tomato osobscie tylko mam u innych postawione - jest taka sciezka prerouting/postrou
ting/nat//mangle ?

Adooni
07-12-2022 21:53
nie kumam why? przeciez mozesz latwo dodac i pozmienaic wszysko przez ssh - wpisz w google iptables commands.

damianssj661
07-12-2022 14:20
Gdzie tomato trzyma plik z konfiguracją firewall? Potrzebuje zmienić przekierowanie portu i wyłączyć hsts a mam dostęp tylko przez ssh

59,256,710 unikalnych wizyt