29 Lutego 2024 03:41:44
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· serwer VPN za wan'em
· Rozłączanie klient...
· Banana PI (BRI-R3)
· Przejscie z dyndns f...
· WDR3600 i problem z WAN
· [MOD] FreshTomato-AR...
· Jaki USB hub do syno...
· [S] Karta sieciowa Q...
· Asus rt-n18u port fo...
· Netflix dzielenie ko...
· Nextcloud konfigurac...
· Netgear WNR3500L
· [MOD] FreshTomato-MI...
· [MOD] Tomato64 (x86-64)
· [S] ASUS RT-AC68U
· [S]Banana PI (BRI-R3...
· [S] Płyta, Procek, ...
· Czy to atak hakerski ?
· Asus RT-N10U - znany...
· asus rt-n10u problem...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [865]
· Banana PI (BRI-R3) [21]
· serwer VPN za wan'em [14]
· Netflix dzielenie... [14]
· Jaki USB hub do s... [1]
· Rozłączanie kli... [0]
· Przejscie z dyndn... [0]
· WDR3600 i problem... [0]
· [S] Karta sieciow... [0]
· Asus rt-n18u port... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
36% [151 głosów]

Broadcom ARM
Broadcom ARM
52% [215 głosów]

Atheros
Atheros
5% [22 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [5 głosów]

Żaden z powyższych
Żaden z powyższych
4% [15 głosów]

Ogółem głosów: 415
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
34.239.154.201
Zobacz wątek
OpenLinksys » :: ROUTERY :: » Asus
 Drukuj wątek
RT-N10U+OpenVPN Windows 10
simadren
Cześć wszystkim,

chciałbym Was poprosić o pomoc w rozwiązaniu braku połączenia z serwerem VPN postawionym na ASUS RT-N10U i sofcie tommato by Shibby.
Sprawa wygląda tak, że przez lata z pełnym powodzeniem korzystałem z połączenia VPN z kluczem statycznym pod Win7. Po zmianie systemu na Win10 (tak, niestety przyszedł ten moment) nie mogę połączyć się z serwerem na ASUS...
Próbowałem zmieniać konfigurację, otworzyłem reguły firewalla dla OpenVPN pod Windows jednak nic to nie pomaga...

Poniżej konfiguracja mojego pliku klienta opnvpn:

dev tap
proto udp
comp-lzo
cipher AES-256-CBC
remote xxxx.xxxx 1194
resolv-retry infinite
nobind
mute-replay-warnings
secret "_sciezka_do_klucza_"
verb 3
float

Po uruchomieniu OpenVPN i próbie połaczenia mam następujący status:

Thu Nov 17 22:27:40 2022 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.
Thu Nov 17 22:27:40 2022 Cipher negotiation is disabled since neither P2MP client nor server mode is enabled
Thu Nov 17 22:27:40 2022 OpenVPN 2.5.7 [git:release/2.5/3d792ae9557b959e] Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Oct 28 2022
Thu Nov 17 22:27:40 2022 Windows version 10.0 (Windows 10 or greater) 64bit
Thu Nov 17 22:27:40 2022 library versions: OpenSSL 1.1.1o 3 May 2022, LZO 2.10
Thu Nov 17 22:27:40 2022 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25342
Thu Nov 17 22:27:40 2022 Need hold release from management interface, waiting...
Thu Nov 17 22:27:41 2022 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25342
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'state on'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'log on all'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'echo on all'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'bytecount 5'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'state'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'hold off'
Thu Nov 17 22:27:41 2022 MANAGEMENT: CMD 'hold release'
Thu Nov 17 22:27:41 2022 Outgoing Static Key Encryption: Cipher 'AES-256-CBC' initialized with 256 bit key
Thu Nov 17 22:27:41 2022 Outgoing Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Nov 17 22:27:41 2022 Incoming Static Key Encryption: Cipher 'AES-256-CBC' initialized with 256 bit key
Thu Nov 17 22:27:41 2022 Incoming Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Nov 17 22:27:41 2022 MANAGEMENT: >STATE:1668720461,RESOLVE,,,,,,
Thu Nov 17 22:27:41 2022 interactive service msg_channel=768
Thu Nov 17 22:27:41 2022 open_tun
Thu Nov 17 22:27:41 2022 tap-windows6 device [OpenVPN TAP-Windows6] opened
Thu Nov 17 22:27:41 2022 TAP-Windows Driver Version 9.24
Thu Nov 17 22:27:41 2022 Successful ARP Flush on interface [7] {5BD101C5-8EC3-4E81-AD74-A4624A1F3F66}
Thu Nov 17 22:27:41 2022 MANAGEMENT: >STATE:1668720461,ASSIGN_IP,,,,,,
Thu Nov 17 22:27:41 2022 TCP/UDP: Preserving recently used remote address: [AF_INET]xxxxxxxxxxxxx:1194
Thu Nov 17 22:27:41 2022 Socket Buffers: R=[65536->65536] S=[65536->65536]
Thu Nov 17 22:27:41 2022 UDP link local: (not bound)
Thu Nov 17 22:27:41 2022 UDP link remote: [AF_INET]xxxxxxxxxxxxx:1194


Dodaję że ta sama konfiguracja pod Win7 śmiga aż miło...

Proszę poradźcie co mogę sprawdzić/zrobić w tym przypadku,

Z góry dziękuję za pomoc.
 
Adooni
wgraj FreshTomato a potem dopiero zglaszaj problem. Firmware ktore uzywasz ma juz ponad 5 lat. https://openlinksys.info/forum/viewth...d_id=22082
Orange 300/50 Mb/s + ONT Terminal
HPE MS gen8 Proxmox 7.0-11 VMs: Router OPNsense 23.X-amd64 and OMV
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED
Asus RT-AC68U AccessPoint
 
simadren
tak, widzę że FreshTomato jest na dzisiejsze czasy... Jednak czy sam soft routera może mieć tutaj znaczenie jeżeli wszystko działa super na Win7, natomiast Win10 odmawia pracy?

I jeszcze proszę o podpowiedż który firmware w przypadku Fresh będzie właściwy dla RT-N10U?

Scalony z 18 listopada 2022 09:03:28:
I jeszcze pytanie:
dwa pierwsze wiersze wyświetlają się na czerwono w oknie GUI openVPN:

Thu Nov 17 22:27:40 2022 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.
Thu Nov 17 22:27:40 2022 Cipher negotiation is disabled since neither P2MP client nor server mode is enabled

Czy to jest normalny stan?
Pod Win7 nic takiego się nie dzieje... może tutaj należy coś zmienić lub szukać przyczyny?

dziękiWink
Edytowany przez simadren dnia 18-11-2022 09:03
 
hermes-80
Wiem. że nowa aplikacja OVPN wymagała przy certyfikatach mocniejszego szyfrowania 256bit-owego.
I klient nie łączył się ze starym serwerem - wystarczyło wymienić certyfikaty na mocniejsze. Może tutaj też jest podobnie.
===============================================================
Netgear WNR3500L v1
Podziękowania dla administracji Openlinksys.info!
 
simadren
Cześć,

Zaaktualizowałem fw na freshtomato i poprawiłem konf opnVpn. Samo polaczenie wystartowało, ale...

1) nie mam dostępu do siecie po połaczeniu przez VPN

Mam też problem w nowym sofcie ze szybką i skuteczną inicjalizcją modemu 3G na USB (e-173s-2)... na poprzednim sofcie startował on całkiem sprawnie, tutaj trzeba kilkukrotnie uruchamiać router żeby w końcu wystartował... Czy coś możecie poradzić jak zmusić go do efektywniejszej pracy?

Dziękuję!

Scalony z 20 listopada 2022 12:36:11:
Uzuepłniając, aktualnie mam następujący stan sieci OpenVPN:

Sun Nov 20 12:22:03 2022 Cipher negotiation is disabled since neither P2MP client nor server mode is enabled
Sun Nov 20 12:22:03 2022 OpenVPN 2.5.7 [git:release/2.5/3d792ae9557b959e] Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Oct 28 2022
Sun Nov 20 12:22:03 2022 Windows version 10.0 (Windows 10 or greater) 64bit
Sun Nov 20 12:22:03 2022 library versions: OpenSSL 1.1.1o 3 May 2022, LZO 2.10
Sun Nov 20 12:22:03 2022 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25342
Sun Nov 20 12:22:03 2022 Need hold release from management interface, waiting...
Sun Nov 20 12:22:04 2022 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25342
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'state on'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'log on all'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'echo on all'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'bytecount 5'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'state'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'hold off'
Sun Nov 20 12:22:04 2022 MANAGEMENT: CMD 'hold release'
Sun Nov 20 12:22:04 2022 Outgoing Static Key Encryption: Cipher 'AES-256-CBC' initialized with 256 bit key
Sun Nov 20 12:22:04 2022 Outgoing Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Nov 20 12:22:04 2022 Incoming Static Key Encryption: Cipher 'AES-256-CBC' initialized with 256 bit key
Sun Nov 20 12:22:04 2022 Incoming Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Sun Nov 20 12:22:04 2022 MANAGEMENT: >STATE:1668943324,RESOLVE,,,,,,
Sun Nov 20 12:22:04 2022 interactive service msg_channel=560
Sun Nov 20 12:22:04 2022 open_tun
Sun Nov 20 12:22:04 2022 tap-windows6 device [OpenVPN TAP-Windows6] opened
Sun Nov 20 12:22:04 2022 TAP-Windows Driver Version 9.24
Sun Nov 20 12:22:04 2022 Successful ARP Flush on interface [7] {5BD101C5-8EC3-4E81-AD74-A4624A1F3F66}
Sun Nov 20 12:22:04 2022 MANAGEMENT: >STATE:1668943324,ASSIGN_IP,,,,,,
Sun Nov 20 12:22:04 2022 TCP/UDP: Preserving recently used remote address: [AF_INET]xxxxxxxxxxxxxxx:1194
Sun Nov 20 12:22:04 2022 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Nov 20 12:22:04 2022 UDP link local: (not bound)
Sun Nov 20 12:22:04 2022 UDP link remote: [AF_INET]xxxxxxxxxxx:1194
Sun Nov 20 12:22:14 2022 Peer Connection Initiated with [AF_INET]xxxxxxxxxxx:1194
Sun Nov 20 12:22:20 2022 TEST ROUTES: 0/0 succeeded len=-1 ret=1 a=0 u/d=up
Sun Nov 20 12:22:20 2022 Initialization Sequence Completed
Sun Nov 20 12:22:20 2022 MANAGEMENT: >STATE:1668943340,CONNECTED,SUCCESS,,xxxxxxxxxxxx,1194,,

Niestety mimo aktywnego połączenia (zielona ikona) nie mam dostępu do sieci wewnętrznej...
Co należy dodatkowo skonfigurować?
Macie jakąś sugestię?

Odnośnie modemu: dla sprzętu E3131h-2 połaczenie następuje sprawnie, internet jednak kuleje (bardzo słabo działa); wybrałem opcję urządzenia na 4G/LTE

Scalony z 20 listopada 2022 17:36:11:
Wydaje się że chwilo problem jest rozwiązany. Uzyskałem dostęp do sieci po stronie VPN, jednak MUSIAŁEM ręcznie ustalić adres karty sieciowej TCP/IP 4 dla sterownika TAP pod Windows. W chwili gdy zdefiniowałem jego adres mogę dostać się do sieci po stronie VPN.

Jeżeli chodzi o modem 3G to zmieniłem opcję na 4G/LTE; pozostałe ustawienia pozostawiłem i urządzenie staruje szybko i bezproblemowo... Martwi mnie natomiast dlaczego takie ustawnienie było preferowane... Dodatkowo na modemie mam cały czas mocno świecącą diodę zieloną (wcześniej zminiała się na niebieską).

Ostatnia sprawa to taka że po połączeniu przez OpenVPN wyraźnie spowalnia mi internet, tak jakbym korzystał z sieci przez OpenVPN... Jak można to skorygować w Windows, lub sprawdzić dokłądniej jaka jest zależność źródła internetu wobec aktywnych połączeń...

Z góry dzięki!

Scalony z 20 listopada 2022 18:09:51:
Z tymi prędkościami to jest masakra...

Gdy jestem na sieci Tomato to mam następujące wyniki:

1) downlaod 0,25Mb/s
2) upload 0,11Mb/s


Przy uruchomieniu neta z modemu bezpoś↑rednio na kompie, mam niebieską diodę i prędkości:
1) download ok.11Mb/s
2) upload 3,5Mb/s

Czyli w zasadzie normalnie... Jak można na ten parametr wpłynąć przy łaczeniu się z tomato?

Scalony z 20 listopada 2022 18:17:11:
Wink uzupełniając: zmieniłem konfiguraćję modemu w aplikacji bezpośrednio przy podłączeniu z USB do kompa... terz parametry już normalne:

1) download 7Mb/s; upload 0,35 (nieważny dla mnie)

I dodatkowo niebieska dioda...

Tak więc chyba całościowo temat po dłuższym próbowaniu wystartował...

Dzięki
Edytowany przez simadren dnia 20-11-2022 18:17
 
shibby

simadren napisał:


Wydaje się że chwilo problem jest rozwiązany. Uzyskałem dostęp do sieci po stronie VPN, jednak MUSIAŁEM ręcznie ustalić adres karty sieciowej TCP/IP 4 dla sterownika TAP pod Windows. W chwili gdy zdefiniowałem jego adres mogę dostać się do sieci po stronie VPN.


a odpalasz openvpn gui jako administrator? Bo wygląda mi to na błąd przy dodawaniu pushowanego routingu - openvpn gui odpalony jako zwykły user nie ma praw do mieszkania w tablicy routingu.
Proxmox VE: i7-7700T, 48GB RAM, 3x2TB SSD, 1x1TB SSD, 512GB NVMe, Intel X710-DA2 SFP+
VM Router: OpenWRT 22.03.4
VM NAS: Synology DS920+
VM VPS: Debian, WWW, Home Assistant
Switch: Netgear MS510TXPP
Switch: Ubiquiti USW-Flex-mini - szt. 2
Wi-Fi: Ubiquiti U6-Lite - szt. 2
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 20

· Użytkowników online: 0

· Łącznie użytkowników: 24,115
· Najnowszy użytkownik: Ja
Czat
Musisz się zalogować, aby opublikować wiadomość.

shibby
12-02-2024 11:03
MTU zależy od typu połączenia. Inne jest dla połączenia kablowego inne dla wdzwanianego (pppoe)

PanRatio
11-02-2024 10:02
Jak podłączę Funboxa6 do światłowodu, to ma MTU 1540, a we FreshTomato max to MTU 1500 i samo zmienia na 1492. Tak ma być?

tamtosiamto
04-02-2024 10:36
jakby cos, to mam w dobrej cenie dir868l juz przerobiony na AC66U_B1 Grin i ac56u przerobiony na ac68u(dziala aimesh) tyle ze z wlacznikiem na zapalke Smile

Adooni
03-02-2024 10:36
widze ze oba sa na aledrogo i u nas mozesz sprawdzac w dziale sprzedam

Adooni
03-02-2024 10:34
zakladam że mowisz o używkach masz np Asus RT-AC56U, D-Link DIR-868L (jak go nie przerobisz na Asus RT-AC66U_B1) to FT ma specialny build nvram 32k)

vechio
01-02-2024 09:29
Cześć, czy istnieje jakiś 'odpowiednik'
; WNR3500Lv2 z 5GHz i z TYLKO wewnętrznymi antenami + ze wsparciem dla FreshTomato?

tamtosiamto
29-01-2024 21:59
to linux, raczej nie masz tak duzego, ktorego nie obsluzy

RaTaJ
28-01-2024 23:08
Dzień Dobry jaki max dysk USB można podłączyć pod NetGear WNRL3500Lv2?

Adooni
01-01-2024 09:44
Wszystkiego najlepszego w nowym roku. Jaka macie sprawdzoną antenkę do E3372S?

Adooni
25-12-2023 08:34
ja kupilem ale ostatecznie oddalem i wzialem Cudy WR3000. Bardzo dobrze dziala z OpenWRT zabawy jest z wi-fi aby znalesc kanal ktory dziala na 160. Nowyszy HW w porownaniu do x6 i 2 razy mniejszy

69,650,600 unikalnych wizyt