27 Stycznia 2021 20:11:24
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Openmediavault - DLNA
· Własny NAS na Xpenology
· instalacja entware [...
· EdgeRouter X - przek...
· [HOWTO] OpenVPN serv...
· Nowiutki RT-AC68U - ...
· [MOD] Tomato by shibby
· Instalacja Entware d...
· [MOD] FreshTomato-MI...
· wrt54g ver2 i dual w...
· Torrenty na tomato -...
· Problem z konfigurac...
· instalacja VPN na as...
· orange swiatlowd pom...
· Jakie serwery adbloc...
· Konfiguracja serwera...
· [MOD] FreshTomato-AR...
· Router - WAN i przek...
· Port forwarding z je...
· Problem z logowaniem...
Najciekawsze tematy
· [MOD] Tomato by s... [13742]
· Torrenty na tomat... [957]
· [MOD] FreshTomato... [452]
· [MOD] FreshTomato... [283]
· Instalacja Entwar... [88]
· Jakie serwery adb... [70]
· orange swiatlowd ... [28]
· Własny NAS na Xpe... [23]
· instalacja entwar... [20]
· [HOWTO] OpenVPN s... [11]
· Konfiguracja serw... [11]
· Problem z konfigu... [8]
· Nowiutki RT-AC68U... [6]
· Asus RT-AC3200 zw... [6]
· Skrętka (patchcor... [5]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
38% [144 głosów]

Broadcom ARM
Broadcom ARM
51% [194 głosów]

Atheros
Atheros
6% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 381
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
3.236.156.34
Reklama
Zobacz temat
OpenLinksys » :: ROUTERY :: » Asus
 Drukuj temat
RT-AC68U (E1) i OpenVPN - certyfikaty nie trybią.
posucha
Proszę o pomoc, jakieś wskazówki bo już pomysłów brak ...

Jest od lat działająca sieć VPN postawiona w całości na routerach RT-N16 (tryb TAP).
Jeden z nich robi za serwer (publiczny adres IP) a pozostali to podłączeni do niego trzej klienci.
Na wszystkich routerach Tomato w wersji MIPSR2-132 K26 USB AIO
Certyfikaty wygenerowane kilka lat temu na kompie z Win7 w OpenVPN v 2.1.4
Wszystko działa od paru lat stabilnie.
Teraz jednego klienta chcę podmienić z modelu RT-N16 na model RT-AC68U (ver. E1)
Ten nowy router już prze-flashowany na FreshTomato do najnowszej wersji 2020.8
Przenoszę metodą kopiuj-wklej certyfikaty z gui jednego z obecnych klientów (ca.crt, klient.crt, oraz klient.key) do gui nowego routera na FreshTomato, klikam przycisk start now i klapa klient się nie odpala (przycisk nie zmienia napisu ze start now na stop now).
Nowy router ma połączenie z internetem, pamięć nvram kilkukrotnie czyszczona, próbowałem na różnych wersjach począwszy od 2019.3 wzwyż i bez efektu.
Podłączam z powrotem starego RT-N16 i ten działa bez problemu.
Tak się zastanawiam czy przypadkiem problemem są stare certyfikaty generowane w 2014 roku ale skoro na jednym działają to dlaczego na drugim mają nie działać ...
Edytowane przez posucha dnia 09-01-2021 16:24
 
Gomi
Powiadasz tomato 132, lata temu to było i pewnie jakiś OpenVPN przed 2.4. Najlepiej jakbyś wgrał wszędzie to samo tomato 2020.8, zainstalował OpenVPN 2.5 na kompie i zrobił wszystkie certy od nowa - tak chyba będzie najprościej, niż szukać co gdzie i kiedy się pozmieniało i próbować aktualizować certy po kolei.
A pozmieniało się kilka rzeczy w kluczach, głównie z powodu wykrytych podatności.
Edytowane przez Gomi dnia 09-01-2021 16:49
 
posucha
I właśnie tego tak po cichu się obawiam i wolałbym unikąć ...
Z dwoma klientami nie ma problemu mogę podmienić na nich softy, z serwerem też nie będzie kłopotu, jak coś nie wypali to są w miarę blisko i można do nich podjechać ale jeden klient jest na łączu LTE (zdalny monitoring z działki) i to jeszcze 160 kilosów ode mnie.
Na tego to się zdalnie nie wbije po podmianie softu ale jak trzeba będzie (czytaj nie będzie innego rozwiązania obecnego problemu) to odżałuje jeden dzień z weekendu i się tam podjedzie i zmieni softa na nowszego z nowszymi certyfikatami.
 
shibby
Nowa wersja openVPN (we freshtomato) wymusza wyższy poziom bezpieczeństwa na certyfikatach, stąd problemy. Pewnie w logach znajdziesz coś w stylu "SSL_CTX_use_certificate:ca md too weak"

Rozwiązanie tymczasowe i w sumie niezalecane to obniżenie poziomu bezpieczeństwa nowego openVPN poprzez dodanie do konfiguracji wpisu
tls-cipher "DEFAULT:@SECLEVEL=0"


Da ci to czas na przygotowanie sobie nowych certyfikatów z lepszym szyfrowaniem.
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
 
posucha
Dzięki @shibby - pomogło.
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 6

· Użytkowników online: 0

· Łącznie użytkowników: 24,012
· Najnowszy użytkownik: szukacz3
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

salawalas
27-01-2021 18:08
Ok. Widzę,że wrzuciłeś 2.84rc2 do repo. Gratki Pfft

pedro
27-01-2021 17:50
Zawsze możesz sobie skompilować obraz z aktualnego repo Pfft

salawalas
26-01-2021 00:06
Hej.Pedro , przewidujesz jakiś emergency security patch do nowego dnsmasq? https://www.jsof-.
..s/dnspooq/

qrs
22-01-2021 16:06

Pakete-kiero
21-01-2021 13:44
Hi, I guess you know there is this NETGEAR page for developers: https://kb.netgear
.com/2649/NETGEAR-
Open-Source-Code-f
or-Programmers-GPL

tamtosiamto
12-01-2021 17:46
ja czytalem, ze wlamanie bylo na ich serwer, a to nie ma chyba wplywu na bezpieczenstwo urzadzen

Adooni
12-01-2021 09:25

bigl
11-01-2021 20:43
Czy Tomato jest na to odporne? https://www.thereg
ister.com/2020/11/
02/application_lev
el_gateway_flaw/

pedro
09-01-2021 13:04
A, myślałem że chodzi o l/p do inita.

Adooni
08-01-2021 18:40
no najnowsze tomato ma login/pass root/admin jak dobrze pamietam

pedro
08-01-2021 17:17
username: admin password: @newdig ???

maciekkoper
08-01-2021 17:07
Jest w stanie ktoś pomóc odnośnie wgrania Tomato na Netgear R7000 po wgraniu nie da się zalogować

Adooni
05-01-2021 20:54
hm przeciez to nic nie da, nie uruchomisz bezposrednio swojego routera

grzesiek1973
05-01-2021 15:59
Czy zna ktoś wartość VPI i VCI w vectrze.

shibby
02-01-2021 12:36
dobra, dodałem 2 tutoriale, na dziś wystarczy Grin

Adooni
02-01-2021 10:19
no widze ze masz wiecej czasu Smile

shibby
02-01-2021 09:58
mówisz i masz Smile pierwszy temat już jest. Kolejne mam nadzieję wkrótce

43,366,236 unikalne wizyty