18 Kwietnia 2021 01:30:09
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Asus RT-N18U nie moż...
· Fresh Tomato- kompat...
· docker 4 karty.
· Asus Wl-500W pytanie...
· Konfiguracja Tp-link...
· Problem z logowaniem...
· brak dostępu z zewną...
· Pi-Hole problem z dn...
· Dodanie kolejnej sie...
· [MOD] FreshTomato-AR...
· [S] Netgear R8000
· Jaki router wybrać-p...
· Router? Pod VPN w domu.
· Asus RT-AC56U mod to...
· cake QoS
· RT-AX86U vs AX88U vs...
· [S] Asus RT-AC58U v1
· Problem z rozłączani...
· Wstęp do migracji z ...
· RT-68U - działa tylk...
Najciekawsze tematy
· [MOD] FreshTomato... [523]
· Asus RT-AC56U mod... [84]
· Jaki router wybra... [16]
· RT-AX86U vs AX88U... [16]
· Asus RT-N18U nie ... [8]
· brak dostępu z ze... [7]
· Fresh Tomato- kom... [6]
· Pi-Hole problem z... [5]
· Dodanie kolejnej ... [5]
· Asus Wl-500W pyta... [3]
· Konfiguracja Tp-l... [3]
· Router? Pod VPN w... [3]
· docker 4 karty. [2]
· [S] Asus RT-AC58U v1 [2]
· Problem z logowan... [1]
· cake QoS [1]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
38% [144 głosów]

Broadcom ARM
Broadcom ARM
51% [197 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 384
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
18.207.129.82
Reklama
Zobacz temat
 Drukuj temat
Własny NAS na Xpenology
shibby
Przez wiele lat dzielnie służył mi ReadyNAS Pro4. Problemy z jego wydajnością zacząłem zauważać, gdy zainteresowałem się dockerem. Przyszedł zatem czasu poszukania sobie innego, wydajniejszego rozwiązania. Swoje poszukiwania skierowałem w stronę Synology, ponieważ bardzo przypadł mi do gustu jego interfejs i możliwości konfiguracji. Projekt Xpenology znalem już wcześniej ale bardziej od strony teoretycznej niż praktycznej. Przyszedł więc czas na ugryzienie tematu po raz kolejny.

Dobór sprzętu a kompatybilność

Dobór sprzętu to największa bolączka przy Xpenology. Sprawdziłem łączenie 7 płyt głównych i rozwiązań ITX i w połowie przypadków Xpenology nie działało w ogóle albo nie dało się uruchomić najnowszej wersji 6.2.x - działała co najwyżej wersja 6.1.x.

Zdecydowanie polecam dobór sprzętu od Coffee Lake w górę, czyli min. 6-ta generacja CPU od Intela. Wszystkie testowane przeze mnie zestawy (3 płyty) działały w najnowszej wersji.
Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.
Jeden zestaw na Sandy Bridge (2-gen) też zadziałał (z użyciem softu dla DS3615xs), co było sporym zaskoczeniem.

Jeszcze jeden argument przemawia za użyciem nowszej generacji procesora: od Haswella w górę można użyć obrazu dla DS918+, który jest na nowszym kernelu i wspiera SSD Cache oraz SHR (Synology-Hybrid-Raid).

Moje poszukiwania stanęły na dość ciekawej płycie LR-i5S62T2

[img]http://www.minicase.net/Files/UploadFiles/image/intel-core-T2/07.jpg[/img] is not a valid Image.



która znajdowała się komputerku o tajemniczej nazwie "EDI5-6200U-L1" zakupionej na stronie mini-komputery.pl - produkt nie jest już dostępny.

Płyta o tyle ciekawa, że posiada wlutowany procesor i5-6200u, dwa sloty SO-DIMM z obsługą pamięci do 32GB, port miniPCIE, port M.2, 2x Gigabit LAN oraz wbudowany układ zasilający (podpina się zasilacz laptopowy).
Największym mankamentem była obsługa tylko dwóch portów SATA. Tu z pomocą przyszedł Aliexpress, na którym to zakupiłem kontroler miniPCIE-2xSATA (koszt 35pln)

openlinksys.info/images/xpenology/1.jpg


Prawdziwym wyzwaniem okazał się dobór obudowy. Wymagania były w sumie niewielkie: obsługa 4-ch dysków 3.5" i niewielki rozmiar. Niestety, ceny dedykowanych rozwiązań np Inter-Tech IPC SC-4100 to koszt ponad 400pln za samą obudowę

images.morele.net/i1064/827764_0_i1064.jpeg


Docelowo zakupiłem obudowę Cooler Master Elite 110 (RC-110-KKN2) w cenie ~180pln. Zmodyfikowałem w niej jedynie sposób montażu dysków, które umieściłem pionowo by poprawić ich wentylację. Finalny efekt prezentuje się następująco

openlinksys.info/images/xpenology/2.jpg openlinksys.info/images/xpenology/3.jpg


openlinksys.info/images/xpenology/4.jpg openlinksys.info/images/xpenology/5.jpg


openlinksys.info/images/xpenology/6.jpg


Jak widać na ostatnim zdjęciu, zamontowałem również dysk SSD M.2 SATA. Niedługo po tym zamontowałem drugi dysk SSD 2.5" i z obu dysków utworzyłem SSD Cache Read-Write. Całość prezentuje naprawdę przyzwoitą wydajność.

openlinksys.info/images/xpenology/7.jpg openlinksys.info/images/xpenology/8.jpg


Jeżeli ktoś będzie miał pytania dotyczące Xpenology lub problemy z jego postawieniem, to służę pomocą.


O krok za daleko

Przyszedł raz moment gdy zapragnąłem 10GbE LAN w moim NASie Grin Tylko jak tu podpiąć kartę PCIE do komputera, który nie posiada portu PCIE Frown I znów Aliexpress nie zawiódł Wink Zakupiłem Riser PCIe x4 3.0 PCI-E 4x do M.2 NGFF NVMe

ae01.alicdn.com/kf/Hd7d0f84e6e394a7d83c55a75a023eda54.jpg


Wsadziłem kartę z portem SFP+ i o dziwo karta została rozpoznana.

bpccdn.fra1.digitaloceanspaces.com/original/3X/2/d/2d42e74e92540fe5eed75c152d07f4dbcd8e157d.png


Szybko jednak okazało się, że z niezrozumiałych dla mnie przyczyn NAS nie chciał trzeciej sieciówki podnieść. Rozwiązanie znalazłem go kilku godzinach... Otóż mam obraz z ds918+ która ma na sztywno wpisany limit 2 kart sieciowych. Przeedytowałem więc plik /etc/synoconfig.conf w w linii
maxlanport=2
zmieniłem na 4

Po restarcie karta śmigała aż miło. Wydajność jednak nie powalała a ograniczeniem okazała się macierz RAID - dobijałem do ~250MB/s.

Z racji kosztów tego rozwiązania (2x karta 10GbE, switch 10GbE, kable DAC, do łącznie daje kwotę ~1500pln) temat odpuściłem. Zamiast tego postanowiłem skorzystać z dobrodziejstw "SMB Multichannel", dzięki któremu można zsumować kilka linków LAN w jeden. Co ważne, nie wymaga to użycia żadnego specjalistycznego sprzętu - zwykły switch wystarczy.

Całość sprowadza się do lekkiej modyfikacji pliku smb.conf na synology a szczegółowy opis znajdziecie pod linkiem https://blog.azur...indows-10/
Efekt cieszy

bpccdn.fra1.digitaloceanspaces.com/original/3X/2/8/28939ae973d52911bf8092428a92baacb4dec2e5.png



Pozdrawiam
Edytowane przez shibby dnia 05-01-2021 09:29
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
Adooni
nastepny fajny artykul

czy nie myslales o dodaniu SSD z Zpool log i cache tak aby obejsc ograniczenie macierzy RAID HDD? - ok jak widac nie doczytalem :)

sry za taki pomieszany code ponizej robilem to pewien czas temu i wszystko zapisalem krok po kroku. wiec i komendy i sprawdzanie itd. Ja nie tak jak Ty jestem w stanie z palca to podac.
Pobierz kod źródłowy  Kod źródłowy
SWAP -The kernel will swap only to avoid an out of memory condition)
sysctl -w vm.swappiness=0 

create partitions on SSD
dev/sdf4 - log 8192M
dev/sdf5 - cache 81920M

reboot,

RAIDZ2: pool ( storage name) = HDD
zpool create -f -o ashift=12 <pool> raidz2 /dev/sda /dev/sdb /dev/sdd /dev/sde
zpool add -f <pool> log /dev/sdf4
zpool add -f <pool> cache /dev/sdf5

zpool status
zfs list

zfs set compression=lz4 <pool>
zfs get compression <pool>
zpool export <pool>
zpool import -d /dev/disk/by-id <pool>
zpool status





ja tak zrobilem na Proxmox i potem jako NAS uzywam OMV - wyciaga mi okolo 120MB na HPE MSgen8 wiec mozna powiedziec ze max lacza 1Gbit

a tak dodatkowo podpytam czy kiedys uzywales OMV? jak to ze strony expera widzisz w porownaniu to Xpenology. Mi pasuje OMV gdyz na youtube masz kanal "Techno Dad Life" i bardzo lopatologicznie, krok po kroku pokazuje co zrobic aby dockera wtyczki dodawac https://www.youtu...aMzhGFZ7PA
UPC 300/20 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.2_2 +amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), 4x4TB WD RED, SSD, SD grub | PROXMOX 5.2.1 | OMV 4.1.3-1
----------------------------------------------------------------------------------------------------------------------------------
Asus RT-AC66U_B1 (D-Link DIR-868L CFEmod) | AsusWRT-Merlin RT-AC68U_386.2_0 +amtm
Asus RT-AC56U @1200/800 (CFE 1.0.2.7) | Freshtomato-RT-AC56U-ARM_NG-2020.8-AIO-64K
Asus WL-500W | FreshTomato-K26USB_RT-MIPSR1-2020.5-VPN + Huawei E3372s-153 non-hilink + PLAY LTE
Asus RT-N12 | FreshTomato-RT-N12-K26-MIPSR2-2018.5-MiniIPv6
Asus RT-N16 | Tomato-K26USB-1.28.RT-MIPSR2-132-AIO + Huawei E3372s-153 non-hilink + PLAY LTE
 
shibby
OMV bawiłem się może 15min. Podobnie zresztą jak FreeNASem. Nic specjalnego by się wypowiadać w temacie.

Synology jest klasą samą w sobie, nawet obsługa dockera jest z poziomu GUI. Prostota a jednocześnie zaawansowane funkcje jakimi jest nafaszerowany dość trafnie przypomina mi Tomato Smile

Najgorsze zdanie mam odnośnie Qnapa - no nie polubiliśmy się raczej Grin
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
mosfit
Synology jest klasą samą w sobie


Dokładnie !
Świetne artykuły jak zawsze !

Głównie problemy z poprawnym wystartowaniem Loadera dotyczą zazwyczaj ustawień w bios-ie lub nie kompatybilną karta sieciową Lan (głównie w DS918+)
Router- Ubiquiti USG-Pro-4 (FTTH)
Lan- Ubiquiti Switch US-8-150W
Wifi- UniFi AP-AC-Pro + UAP + 2x Ap OpenWrt19.07
Nas- XPEnology DS918+ i5-6400, 16GB ram, 3x 2TB/RAID5, SSD-512gb cache _controller unifi_Pi-hole
 
shibby
właśnie na brak obsługi karty LAN widzę największy problem. Często jest tak, że loader startuje, Assistant widzi nowe urządzenie a po instalacji softu już NAS znika bezpowrotnie. Próbowałem też instalować extrasy ale na nic.

Probowałem też obrazy dla ds3615xd ale bez większych efektów, no chyba że mowa o starszych sprzętach, z którymi 918+ nie jest w ogóle kompatybilny. Miałem też jeden przypadek gdzie jedynie starszy loader i starszy soft 6.1.x zadziałał. Próba aktualizacji kończyła się fiaskiem. No i wisienka na torcie czyli poleasingowy Dell SFF, który mimo różnych kombinacji nawet na samym loaderze nie był widziany (brak sterów do LANu).

Zdecydowanie najmniej problemów miałem z Coffee Lake. 3 różne zestawy płyt+cpu i wszystkie 3 wystartowały.
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
majkel152
shibby napisał(a):

właśnie na brak obsługi karty LAN widzę największy problem. Często jest tak, że loader startuje, Assistant widzi nowe urządzenie a po instalacji softu już NAS znika bezpowrotnie. Próbowałem też instalować extrasy ale na nic.

Probowałem też obrazy dla ds3615xd ale bez większych efektów, no chyba że mowa o starszych sprzętach, z którymi 918+ nie jest w ogóle kompatybilny. Miałem też jeden przypadek gdzie jedynie starszy loader i starszy soft 6.1.x zadziałał. Próba aktualizacji kończyła się fiaskiem. No i wisienka na torcie czyli poleasingowy Dell SFF, który mimo różnych kombinacji nawet na samym loaderze nie był widziany (brak sterów do LANu).

Zdecydowanie najmniej problemów miałem z Coffee Lake. 3 różne zestawy płyt+cpu i wszystkie 3 wystartowały.


no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com..., jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
tamtosiamto
majkel152 napisał(a):



no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile


do syrenki ktos wlozyl silnik od porsche i smiga 300kmh, ale czy kazdy potrafi to zrobic?
nic nie mam
 
majkel152
tamtosiamto napisał(a):

majkel152 napisał(a):



no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile


do syrenki ktos wlozyl silnik od porsche i smiga 300kmh, ale czy kazdy potrafi to zrobic?


no tak, zapomniałem, że ludzie dzisiaj czytać nie umieją, a ze zrozumieniem to już w ogóle dramat :E
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com..., jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
shibby
trochę nie ładnie tak wpadać i najeżdżać na mnie że mam problemy z czytaniem ze zrozumieniem. Bo zgoła inaczej by wyglądało jakbyś zapytał "a odczekałeś 5min bo ten typ tak ma?".

Odpowiedziałbym: tak czekałem.

Więc proszę powstrzymaj się następnym razem od uszczypliwych uwag.

Jedyne co muszę sprostować to:
Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.


Jednak 2 zestawy nie ruszyły. Na jednym Haswellu mi działa.

~# cat /proc/cpuinfo | grep 'model name'
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
shibby dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez shibby dnia 07-01-2021 08:23
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
majkel152
shibby napisał(a):

trochę nie ładnie tak wpadać i najeżdżać na mnie że mam problemy z czytaniem ze zrozumieniem. Bo zgoła inaczej by wyglądało jakbyś zapytał "a odczekałeś 5min bo ten typ tak ma?".

Odpowiedziałbym: tak czekałem.

Więc proszę powstrzymaj się następnym razem od uszczypliwych uwag.

Jedyne co muszę sprostować to:
Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.


Jednak 2 zestawy nie ruszyły. Na jednym Haswellu mi działa.

~# cat /proc/cpuinfo | grep 'model name'
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz



Masz rację, przepraszam, będę się starał Smile

napisz jaki loader używasz
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com..., jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
liv6
Witam; czy mógł byś podać konkretnie jakie płyty główne działają ,oczywiście te które testowałeśWink
 
moorgan
Ja mam xpenology na płycie advantech mio-5272 z procesorem Intel Core i7 6600U. W pełni pasywne chłodzenie i ma 2 karty lan (GbE1: Intel i219, GbE2: Intel i210).
Udało mi się ją całkiem niedrogo dostać. Soft od DS918+
Synology RT2600
DS215+
 
aviko
moim zdaniem nie ma czegos takiego ze nie pojdzie, wszystko jest kwestia odpowiedniej konfiguracji. osobiscie postawilem kilkanascie xpeno na kadlubkach z laptopow ktore dostalem za darmo albo za przyslowiowe srubki, moze byc bez matrycy albo z wyrwanym zlaczem od klawiatury, czesto plyta ma wlutowany na stale procesor i/lub ram a jesli jeszcze ma haslo na biosie to jako czesc zamienna ktora da sie sprzedac jest kompletnie bezwatosciowe. np taki thinkpad t440s, wiadomo ze nie bedzie to jakis super nas a co najwyzej przydatne miejsce do zrzucania archiwum swoich zdjec czy innych plikow ktore chcemy miec poza pecetem, nawet nie musi byc publicznego ip, osobiscie uskuteczniam w polaczeniu z dropboxem w darmowej wersji, ustawiona synchronizacja z kontem dropboxa w jedna strone, to co sie pojawi na koncie dropboxa - np zrobione zdjecie telefonem od razu pojawia sie na dysku sieciowym, jak konto db sie robi pelne - usuwam z dropboxa a na xpenology zostaje bo tu raczej miejsca mi nie zabraknie. dzieki temu mieszcze sie w limicie 3 urzadzen podpietych na dropboxie, kiedys tego limitu nie bylo. bardzo ale to bardzo w pierwszej fazie konfiguracji przydaje sie port szeregowy, z chwila kiedy zaladuje sie loader z pendrajwa ekran komputera na kotrym postawione jest xpenology przestaje cokolwiek wyswietlac i kompletnie nie wiadomo co sie tam dzieje. a na konsoli widac wszystko, podobnie jak po podpieciu uarta do routera. jak poszlo i pojawil sie w synology asistant to super, jesli nie to dzialamy po omacku, moze to a moze tamto. jesli trafi sie plyta/procek ktoremu z jakiegos powodu jest kompletnie nie po drodze z dsm zostaje opcja wirtualki, np esxi, czy chocby dla proby zainstalowane xpenology na virtualboxie na swoim pececie, tak zaczynalem swoja przygode xpenology
oczywiscie apetyt rosnie w miare jedzenia, zeby miec serwer plex i transcoding musimy miec procesor ktory to wspiera - stad wiekszy problem z odpaleniem loadera ds918 na jakims byle parchu. ja np bardzo lubie "Fujitsu PRIMERGY TX120 S3" male, tanie, 2 porty lan + trzeci do zdalnego dostepu, mozemy zalogowac sie na wylaczona maszyne, sprawdzic cos w biosie, wlaczyc/wylaczyc. zeby nie marnowac portow na switchu mozna ustawic port od ipmi czy jak to sie nazywa jako wspoldzielony z jednym z lanow. wiadomo ze za 300zl szalu nie bedzie, trzeba dokupic ram i dobrze zmienic proca bo jest slaby ale dzialac bedzie, wszystkie przestarzale nasy ktorych wczesniej uzywalem np ds210j (nawet juz nie obslugiwal dsm v6.x, po wyedytowaniu modelu w konfigu przyjal soft od 211j ale proc jest tam tak mizerny ze chyba nawet na virtualboxie mi to smigalo o niebo lepiej), wszelakiej masci wd mybooki z siecia a fuj, jakies qnapy czy iomega kupiona pozniej przez lenovo to kompletnie nie ta liga nie wspominajac o lacie. teraz stoja sobie na polce jako kolekcja jak to kiedys bylo Smile https://xpenology.com/forum/forum/36-tutorials-and-guides/ tu masz na konkretnych konfiguracjach wszystko ladnie rozspisane, jest tam tez temat gdzie ludki wrzucaja swoje konfiguracje wraz z wersja loadera/dsm na ktorej poszlo.
prosze mnie zle nie zrozumiec, to nie moj sprzet i kompletnie nie mam interesu w jego sprzedazy, jesli ktos szuka czegos na serwerek i nie przeszkadza mu ze obudowa jest podniszczona albo plastik pekniety to moge ponegocjowac i wyrwac cos grubo ponizej cen z allegro
ja sam sie nawet boje ich odwiedzac bo niemal zawsze wracam z jakims sprzetem - nie moge sie powstrzymac Smile

obrazki.elektroda.pl/2856356400_1610405386_thumb.jpg obrazki.elektroda.pl/2257686700_1610405382_thumb.jpg obrazki.elektroda.pl/1361394300_1610405382_thumb.jpg obrazki.elektroda.pl/1445784200_1610405392_thumb.jpg obrazki.elektroda.pl/7628645500_1610405396_thumb.jpg
 
shibby
czy mógł byś podać konkretnie jakie płyty główne działają ,oczywiście te które testowałeś


Gigabyte GA-A170M-D3H
MSI Z87A-G43

Te dwie używam obecnie, loader najnowszy + extrasy + obraz dla DS918+. W obu też działa LAN 10GbE Edimax EN-9320TX-E i muszę powiedzieć że jest moc

bpccdn.fra1.digitaloceanspaces.com/original/3X/e/5/e556364999d1d97265d817f04398e0d5a5a12d60.png
kopiowanie z macierzy 6x SAS (RAID10) na iSCSI (Xpenology)

Z małych płyt to np Gigabyte GA-H61N-USB3 (dokładnie z tej recenzji https://openlinks...d_id=14668).

Testowałem też kilka poleasingów ale dokładnych modeli nie pamiętam. Najwięcej problemów miałem z Delle Optiplex 790 (takim małych, SFF). Na nim nic nie chciało mi wystartować. Ale podejmę może jeszcze raz temat. Może wsadzę inną sieciówką i zobaczę.
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
czarnydb
Cześć,

autor wątku zachęcił do proszenia o pomoc więc proszę :-)

Jakieś 2 lata temu postawiłem XPEnology na obrazie chyba DS3615xs (wersja DSM 5.2-5644) - (a przynajmniej tak model widzę po zalogowaniu do XPEnology).

Do budowy NASa użyłem płyty GA-J1900N-D3V (rev. 1.x)
[img]https://static.gigabyte.com/StaticFile/Image/Global/bf98e7066f46caaf6debaa11b4235f56/Product/9725/png/500[/img]
8GB RAMu + dysk WD Red 3TB i WD Red 2 TB

niestety powyższa płyta główna ma pewną wadę :-( ma tylko 2 wejścia SATA!
Zapragnąłem dołożyć do NASa przynajmniej jeden dysk... walają się po biurku to czemu ich nie wykorzystać :-)

dokupiłem zatem kartę rozszerzeń PCI&PCI Express Card z 4 dodatkowymi złączami SATA... i niestety system nie widzi podłączonych do niej dysków :-(
[img]https://a.allegroimg.com/s1024/0c8fa4/5d68984e44e3bb4c498466d5e0f3[/img]

Jakiś pomysł jak to rozwiązać?

Pozdrawiam
Daniel
 
Adooni
czy jak wpiszesz
Pobierz kod źródłowy  Kod źródłowy
lspci -k


to "widzi" Twoja karte PCI-E?
UPC 300/20 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.2_2 +amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), 4x4TB WD RED, SSD, SD grub | PROXMOX 5.2.1 | OMV 4.1.3-1
----------------------------------------------------------------------------------------------------------------------------------
Asus RT-AC66U_B1 (D-Link DIR-868L CFEmod) | AsusWRT-Merlin RT-AC68U_386.2_0 +amtm
Asus RT-AC56U @1200/800 (CFE 1.0.2.7) | Freshtomato-RT-AC56U-ARM_NG-2020.8-AIO-64K
Asus WL-500W | FreshTomato-K26USB_RT-MIPSR1-2020.5-VPN + Huawei E3372s-153 non-hilink + PLAY LTE
Asus RT-N12 | FreshTomato-RT-N12-K26-MIPSR2-2018.5-MiniIPv6
Asus RT-N16 | Tomato-K26USB-1.28.RT-MIPSR2-132-AIO + Huawei E3372s-153 non-hilink + PLAY LTE
 
shibby
@czarnydb - myślę, że trzeba by zacząć od aktualizacji... czyli nowy loader i skoczyć do 6.2.3. Do loadera dograć extrasy.

Oczywiście migrację trzeba wykonać krokowo, najpierw 6.1, później 6.2. Tu pierwszy step
https://xpenology...ns-loader/

oczywiście warto na wszelki wypadek zabezpieczyć wszystkie dane. Jak masz wolny dysk i pendrive to spróbowałbym na nich czystej instalacji 6.2.3 by upewnić się że ci sprzęt ruszy - miałem przypadek gdzie 6.1 + starszy loader działał a najnowszy loader już nie.

Ja Xpenology zacząłem się interesować jakiś rok temu i nie wiem jak z obsługą sprzętu było wcześniej na DSM 5.x

PS ja w dwoch przypadkach używam kontrolerów PERC H310 i H710, oczywiście przerobione na HBA (czyli karta sata a nie kontroler raid) i na najnowszym DSM6.2.3 z najnowszym loaderem śmigają jak głupie.

Połączony z 14 stycznia 2021 11:26:35:
dzisiejszy przypadek "walki" z Xpenology. Pacjent: HP EliteDesk 800 G1 z procesorem i5-4570.

Na pierwszy strzał loader 1.03b + extras + soft DS3615xd. Efekt: asystant nie wykrywa urządzenia. LAN w HPku to Intel I217-LN. Natrafiłem na taki post:

https://xpenology...ment=92294

I tryed some more times, and I'm sure the i217(i217-LM) is not working.


Wsadziłem jakiegoś Broadcoma dual-port ale też nie ruszyło. Następnie (z racji tego że to Haswell) spróbowałem loader 1.04b dla DS918+ + extrasy (wyraźnie większe, więc mają więcej modułów). Ruszyło... zarówno na intelu, jak i na Broadcomie.
shibby dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez shibby dnia 14-01-2021 11:26
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
czarnydb
Adooni napisał(a):

czy jak wpiszesz
Pobierz kod źródłowy  Kod źródłowy
lspci -k


to "widzi" Twoja karte PCI-E?


trudno mi to ocenić :-)
w załączeniu prtsc z wynikiem polecenia

Połączony z 14 stycznia 2021 19:03:20:
shibby napisał(a):

@czarnydb - myślę, że trzeba by zacząć od aktualizacji... czyli nowy loader i skoczyć do 6.2.3. Do loadera dograć extrasy.

Oczywiście migrację trzeba wykonać krokowo, najpierw 6.1, później 6.2. Tu pierwszy step
https://xpenology...ns-loader/

oczywiście warto na wszelki wypadek zabezpieczyć wszystkie dane. Jak masz wolny dysk i pendrive to spróbowałbym na nich czystej instalacji 6.2.3 by upewnić się że ci sprzęt ruszy - miałem przypadek gdzie 6.1 + starszy loader działał a najnowszy loader już nie.

Ja Xpenology zacząłem się interesować jakiś rok temu i nie wiem jak z obsługą sprzętu było wcześniej na DSM 5.x

PS ja w dwoch przypadkach używam kontrolerów PERC H310 i H710, oczywiście przerobione na HBA (czyli karta sata a nie kontroler raid) i na najnowszym DSM6.2.3 z najnowszym loaderem śmigają jak głupie.

Połączony z 14 stycznia 2021 11:26:35:
dzisiejszy przypadek "walki" z Xpenology. Pacjent: HP EliteDesk 800 G1 z procesorem i5-4570.

Na pierwszy strzał loader 1.03b + extras + soft DS3615xd. Efekt: asystant nie wykrywa urządzenia. LAN w HPku to Intel I217-LN. Natrafiłem na taki post:

https://xpenology...ment=92294

I tryed some more times, and I'm sure the i217(i217-LM) is not working.


Wsadziłem jakiegoś Broadcoma dual-port ale też nie ruszyło. Następnie (z racji tego że to Haswell) spróbowałem loader 1.04b dla DS918+ + extrasy (wyraźnie większe, więc mają więcej modułów). Ruszyło... zarówno na intelu, jak i na Broadcomie.


czyli nie pozostaje nic innego jak postawić XPEnology na nowo :-(
trochę się tego "boje"... dawno to robiłem, nie wiem czy pamiętam jak to zrobić :-)
poza tym jak pomyślę o całej ponownej konfiguracji wszystkiego...

a jak dyski wyjme i ponownie je włożę w "nowym" systemie to je wykryje? czy trzeb będzie je ponownie formatować i kopiować dane?
czarnydb dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez czarnydb dnia 14-01-2021 19:03
 
shibby
wydaje mi się że można z zachowaniem danych ale też nigdy z tak starej wersji nie aktualizowałem.
Router: Ubiquiti EdgeRouter ER-12 (FTTH + LTE/failover, OpenVPN, DPI, VLAN) - łącze 1000/1000mbps
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + UAP-AC-Lite
NAS: Xpenology DS918+ (i5-6200u, 8GB ram, 3x 4TB/RAID5, SSD cache, Unifi, Pi Hole/DNS Server, Home Assistant, NextCloud+onlyOffice)
UPS: Eaton Ellipse Eco 650
miniPC: DELL Optiplex 3040M i3-6100T, 8GB, 128GB SSD, Debian 10 buster
 
mosfit
Jeśli nowy loader wykryje że na dysku jest synology ,to będzie możliwość migracji przed instalacją więc nic nie szkodzi sprawdzić . Większość ustawień będzie zachowana po migracji
Router- Ubiquiti USG-Pro-4 (FTTH)
Lan- Ubiquiti Switch US-8-150W
Wifi- UniFi AP-AC-Pro + UAP + 2x Ap OpenWrt19.07
Nas- XPEnology DS918+ i5-6400, 16GB ram, 3x 2TB/RAID5, SSD-512gb cache _controller unifi_Pi-hole
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 11

· Użytkowników online: 0

· Łącznie użytkowników: 24,052
· Najnowszy użytkownik: Xylene
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

tkski
18-04-2021 00:19
może ktos mi podpowiedzieć jak dodać Temat do obserwowanych - przeglądnalem wszystkie opcje i nie mogę tego zaleźć

shibby
30-03-2021 08:25
1gbit będzie. Połączenia lokalne nie przechodzą przez router,

lolo2
29-03-2021 18:06
Pomiedzy Kompem a NASem powinna byc wymiana danych 1Gbit/s czy 100Mbit/s? (oczywiscie pomijamy wydajnosc systemu czy dyskow)

lolo2
29-03-2021 18:04
Pytanie techniczne. Jezeli mam router np. z wyjsciem LAN 100mbit, podlacze do niego switcha 1GBit. Do tego switcha podepne serwer Nas synology i Komputer PC. Pomiedzy Kompem i NAS-em powinna byc wym

Maniek91PL
27-03-2021 15:25
partycja exfat pod usb normalnie powinna działać z tomato ? czy lepiej ext3 czy ext4. Próbuje skopiować coś na dysk, zawiesza wszystko

pedro
25-03-2021 11:05
Dzięks!

shibby
25-03-2021 08:40
done Smile

pedro
25-03-2021 01:26
To @shibby jeszcze Tomatoanon prosimy Wink

shibby
24-03-2021 19:15
skończył się RAM na serwerze (php cały zjadł). Przeanalizuję logi.

tamtosiamto
24-03-2021 18:53
co sie znpow pitoli z forum, kolejny raz mam info Unable to establish connection to MySQL 2002 : Connection refused

Adooni
20-03-2021 08:33
do takich pytan to zaklada sie nowy watek i dokladnie opisuje sytuacje

Adooni
20-03-2021 08:27
jak na AC68U wlaczysz QoS na tomato to predkosc netu spadnie do okolo150Mbit. Qos czy VPN - VPN ponziej 100Mbit

man1
19-03-2021 09:48
Tomato 2020.6 na ac68. Wiem, że archaiczne, ale u mnie działa bezproblemowo. Pytanie, czy QoS na tym działa, bo chcę się za to zabrać po raz 1wszy w życiu. Potrzebuję do chińskich kamer, które nie wys

jurekk
19-03-2021 09:20
@rako28 bierz ax56u bo ma lepszy podstawowy porcesor : ma 1500 czteryrdzenie a ax58u ma trzy rdzenie. Ax58u ma ekstra procesor do vifi. Ax56u jest lepszym wyborem pod openvpn bo tam moc obliczeniowa p

Adooni
18-03-2021 13:59
why? 1x RT-AC66U + 2x Lyra Trio. widze ze maja duzo nowych a widac ze ASUS zmienia z AC na AX wszystkie routerki wiec niedlugo nie bedzie na AC supportu

PixelPL
18-03-2021 06:48
Czemu na olx jest pełno na sprzedaż asus rt-ac66u trio wifi 3-pack? Czy ten zestaw ma jakąś wadę?

Adooni
16-03-2021 10:56
trzeba wgrac RMerlin, ASUS ma swojego Smile

44,014,955 unikalne wizyty