24 Wrzesień 2018 18:28:45
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [MOD] FreshTomato-ARM
· 3500l cegła ?
· Mocny ruter pod tomato
· Orange IPTV - konfig...
· Tomato - bugi/proble...
· Router do 300 z
· Asus 4G-Ac68u
· [S] Routery
· OptWare - co to jest...
· Jaki router kupić? Z...
· Zmiana usługodawcy=b...
· WNR3500lv2 powrót na...
· WRT54g-TM
· DS110J
· [S] iConnect przerob...
· [MOD] FreshTomato-MIPS
· Netgear R7800 DDWRT/...
· Kilka VLANów na Tomato
· stream do serwera op...
· cos blokuje wyjscie ...
Najciekawsze tematy
· Tomato - bugi/pro... [975]
· OptWare - co to j... [539]
· Jaki router kupić... [505]
· [MOD] FreshTomato... [283]
· Router do 300 z [29]
· 3500l cegła ? [7]
· Mocny ruter pod t... [7]
· Zmiana usługodawc... [6]
· WNR3500lv2 powrót... [4]
· Orange IPTV - kon... [2]
· Asus 4G-Ac68u [2]
· [S] Routery [0]
· WRT54g-TM [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
40% [132 głosów]

Broadcom ARM
Broadcom ARM
49% [163 głosów]

Atheros
Atheros
6% [19 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 333
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.196.13.210
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
OpenVPN - problem z uruchomieniem
Radi
Cześć,
Chciałem poprosić o pomoc.
Korzystałem z Tomato 1.38 MultiWan miniVPN.
Używałem servera PPTP, chciałem zacząć korzystać z połączenia VPN. Wygenerowałem wszystkie klucze.
W konfiguracji OpenVPN zmieniałem ustawienia, konfiguracje.
Ciągle mam jednak problem z uruchomieniem.
W logu mam takie info:
"
Aug 11 21:56:26 unknown daemon.warn openvpn[806]: Could not determine IPv4/IPv6 protocol. Using AF_INET6
Aug 11 21:56:26 unknown daemon.err openvpn[806]: Cannot create TCP socket: Address family not supported by protocol (errno=124)
Aug 11 21:56:26 unknown daemon.notice openvpn[806]: Exiting due to fatal error
Aug 11 21:56:26 unknown daemon.notice openvpn[806]: Closing TUN/TAP interface
Aug 11 21:56:26 unknown daemon.notice openvpn[806]: /sbin/ifconfig tun21 0.0.0.0
Aug 11 21:56:27 unknown user.info kernel: device tap22 entered promiscuous mode
Aug 11 21:56:27 unknown user.info kernel: br0: port 3(tap22) entering forwarding state
Aug 11 21:56:27 unknown daemon.notice openvpn[825]: OpenVPN 2.4.1 mipsel-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on May 4 2017
Aug 11 21:56:27 unknown daemon.notice openvpn[825]: library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09
Aug 11 21:56:27 unknown daemon.warn openvpn[828]: NOTE: when bridging your LAN adapter with the TAP adapter, note that the new bridge adapter will often take on its own IP address that is different from what the LAN adapter was previously set to
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: Diffie-Hellman initialized with 1024 bit key
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: TUN/TAP device tap22 opened
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: TUN/TAP TX queue length set to 100
Aug 11 21:56:27 unknown daemon.warn openvpn[828]: Could not determine IPv4/IPv6 protocol. Using AF_INET6
Aug 11 21:56:27 unknown daemon.err openvpn[828]: Cannot create TCP socket: Address family not supported by protocol (errno=124)
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: Exiting due to fatal error
Aug 11 21:56:27 unknown daemon.notice openvpn[828]: Closing TUN/TAP interface
".

Zmieniałem firmware'y, ale na każdym jest to samo.
Czy komuś udało się jakoś z tym poradzić albo w którymś z firmware'ów dziala to poprawnie (router TENDA N60 - 8MB flash)?
Proszę o pomoc.
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
Steel_Rat
Pokaż jeszcze jak masz skonfigurowany ten vpn.
WRT3200ACN + OpenWRT 18.06+światełko 150/150 Mb/s
Asus RT-AC68UvE1 + RMerlin + Entware
Netgear WNR3500Lv2 + DDWRT
 
Radi
Próbuję wszystkiego, zawsze jest ten sam kłopot.
Zmieniłem na static key, ale też to samo (dla TLS'a ta sama sytuacja, zmiana z UDP na TCP nic nie daje).
Poniżej screeny konfiguracji i kawałek loga.
Proszę o pomoc.

Połączony z 12 sierpień 2018 10:54:49:
Jeszcze jedna sprawa.
Znalazłem taki post szukając rozwiązania:

https://community.openvpn.net/openvpn/ticket/821?cversion=0&cnum_hist=2#comment:1

Zamiana "proto udp" na "proto udp4".

Wszedłem konsolą na router, w folderze /etc/openvpn/server2 zmieniłem to co podano.
Następnie będąc w /etc/openvpn/server2 odpaliłem komendę " /etc/openvpn/vpnserver2 --config config.ovpn"
Tym razem chyba wystartował, w logu jest info:

"Aug 12 10:48:05 unknown daemon.warn openvpn[26122]: disabling NCP mode (--ncp-disable) because not in P2MP client or server mode
Aug 12 10:48:05 unknown daemon.notice openvpn[26122]: OpenVPN 2.4.1 mipsel-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on May 4 2017
Aug 12 10:48:05 unknown daemon.notice openvpn[26122]: library versions: OpenSSL 1.0.2k 26 Jan 2017, LZO 2.09
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: Outgoing Static Key Encryption: Cipher 'AES-128-CBC' initialized with 128 bit key
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: Outgoing Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: Incoming Static Key Encryption: Cipher 'AES-128-CBC' initialized with 128 bit key
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: Incoming Static Key Encryption: Using 160 bit message hash 'SHA1' for HMAC authentication
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: TUN/TAP device tap22 opened
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: TUN/TAP TX queue length set to 100
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: Socket Buffers: R=[112640->112640] S=[112640->112640]
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: UDPv4 link local (bound): [AF_INET][undef]:1195
Aug 12 10:48:05 unknown daemon.notice openvpn[26124]: UDPv4 link remote: [AF_UNSPEC]"

Z automatu nie pójdzie, tylko z "ręki".
Jest jakiś sposób, żeby to naprawić?
Dzięki.

Połączony z 12 sierpień 2018 11:14:17:
Wygląda na to, że należy zmienić protokół na udp4 i będzie działać.
Za każdym jednak razem gdy klikam w GUI na "START NOW" tworzy się folder openvpn z plikami konfiguracyjnymi i kluczami.
Dopiero wtedy mogę z ręki z zmienić "proto udp" na "proto udp4" i uruchomić komendą.
Jak na stałe dać korzystanie z ipv4 zamiast ipv6?
Radi dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez Radi dnia 12-08-2018 11:14
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
shibby Dziekuje za dotacje
a czemu udp4 skoro w gui masz wybrane TCP?
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AP-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
Radi
Tak jak pisałem, zmieniałem upd na upd4 i tcp-server na tcp4-server.
Na chwilę obecną sobie z tym poradziłem.
"nvram show" pokazuje 765 bytes free.
Z powodu minimalnej ilości pamięci klucze muszę wypchnąć do portu usb (włożę jakiś mały czytnik usb z kartą microsd, może pójdzie).
Czy z kluczem ssh też można tak zrobić? Jeśli tak - gdzie dać ściężkę?
Dzięki.
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
shibby Dziekuje za dotacje
Że co? Na screenie masz wybrane połączenie typu static key więc skąd u ciebie nagle tcp-sever. Mam wrażenie że bladzisz w konfiguracji, czytasz różne opisy na necie i trochę bezmyślnie je wklepujesz do swojej konfiguracji. Co ty w ogóle chcesz uzyskać? Jaki typ tunelu i kto jest klientem
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AP-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
Radi
Przepraszam, namieszałem trochę.
Ustawiłem już wszystko. Serwer OpenVPN działa.
Klientami są maszyny Windows i urządzenia z androidem.
Pozostało mi tylko umieszczenie kluczy na zewnętrznej pamięci w porcie USB.
Nie mieszczą się w NVRAMie.
Jak najlepiej to zrobić? Smile Wie ktoś? Smile
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
khain
Wrzucasz do Custom config tak jak to zrobił kille72 w tym poście (oprócz auth SHA256): https://openlinks...ost_161145
Jeśli używasz static key to dodaj tylko jedną linię:
Pobierz kod źródłowy  Kod źródłowy
static /sciezka/do/pliku/secret.key



Asus RT-N16 - Tomato ver. K26USB 1.28.RT-N MIPSR2 130 EN AIO
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Microsoft LifeCam VX-3000
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Logitech C270
RaspberryPi 2 - OMV Stone Burner 2.0.15 +Creative SB Play +Medion OR24V +DVB-T Media-Tech MT4163 +MP00202AC +3xDS18B20 +HIH-4000-002 +MPXHZ6115A
 
Radi
Bardzo Wam dziękuję.
Już jest ok z kluczami.
Jest jeszcze jedna sprawa.
Aplikacja na Win7 ładnie łączy się z routerem.
Jest tunel, po nim wychodzę na świat, mam dostęp do urządzeń w sieci (domowej).
Taki tunel działa WYŁĄCZNIE przy pierwszym połączeniu.
Jeżeli się rozłączę i połączę na nowo - tunel się zestawia, ale nie mam połączenia z urządzeniami w sieci domowej i nie wychodzę na świat przez ten tunel.
Macie pomysł, co może być tego przyczyną i jak to naprawić?
Dzięki.
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
khain
Zawsze uruchamiaj openvpn na Windowsie jako administrator.
Sprawdź czy zawsze odpalasz tunel z tym samym konfigiem na Windowsie./
Sprawdź w logach czy dostajesz trasy po ponownym zestawieniu tunelu.
Asus RT-N16 - Tomato ver. K26USB 1.28.RT-N MIPSR2 130 EN AIO
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Microsoft LifeCam VX-3000
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Logitech C270
RaspberryPi 2 - OMV Stone Burner 2.0.15 +Creative SB Play +Medion OR24V +DVB-T Media-Tech MT4163 +MP00202AC +3xDS18B20 +HIH-4000-002 +MPXHZ6115A
 
Radi
Dzięki, teraz po każdym rozłączeniu i uruchomieniu działa (z przywilejami administratora).
Teraz to samo połączenie chciałbym uzyskać przez telefon (android).
Czy mogę użyć tej samej konfiguracji (plik .ovpn) w androidzie, czy ustawić inaczej ręcznie?
Której aplikacji do tego użyć?
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
khain
Ja mam tun, więc używam tej aplikacji https://play.goog...&hl=pl
Należy ją skonfigurować ręcznie - nie działa z tap.
Asus RT-N16 - Tomato ver. K26USB 1.28.RT-N MIPSR2 130 EN AIO
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Microsoft LifeCam VX-3000
TP-Link TL-WDR3600 v1.5 - OpenWRT 15.05 with Luci +Logitech C270
RaspberryPi 2 - OMV Stone Burner 2.0.15 +Creative SB Play +Medion OR24V +DVB-T Media-Tech MT4163 +MP00202AC +3xDS18B20 +HIH-4000-002 +MPXHZ6115A
 
Radi
OK, dziękuję, spróbuję.
TENDA N60 - Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB miniVPN
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 8

· Użytkowników online: 0

· Łącznie użytkowników: 23,769
· Najnowszy użytkownik: dex80
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

djwujek
19-09-2018 13:06
man1 Niestety nie da się z tego co wiem.

Steel_Rat
18-09-2018 08:01
Ja do tej pory używam xmail + dovecot. Konfiguracja trudna ale nie niemożliwa.

Jacek5
17-09-2018 22:57
Posiada ktos manual dla laikow "jak skonfigurowac mail"? W tak rozwinietym swiecie, nawet qnapy nie maja serwera pocztowego.

man1
17-09-2018 19:17
Czy da sie miec dzialajace "Bandwith / Last 24hrs" z włączonym CTF na Tomato?

kille72
12-09-2018 21:50
Skopiuj a nie przerzucaj.

Jacek5
12-09-2018 20:17
Wczoraj stworzylem taki katalog, wlasnie w opt i do niego wrzucilem swoje, przerzucajac co bylo mozliwe z /www. Czesc katalogow byla niemozliwa do przeniesienia.. Dzieki

kille72
12-09-2018 17:02
Popatrz na Administration-Web
Admin-Directory with GUI files.

Jacek5
11-09-2018 20:19
Laickie ale coz.. Smile Chce wrzucic pliki do katalogu www na tomato, ale ma mozlwiosci zapisu. Zmiana atrybutow chmod nie jest mozliwa. Jak tego dokonac? Smile

p4v3u
28-08-2018 00:12
czy ktos probowal podlaczyc ddwrt jako klienta do sewrera openvpn na tomato ?

pedro
23-08-2018 19:06
@shibby: a co z moim problemem?

shibby
21-08-2018 08:31
poszło pw

sadamkusz
19-08-2018 14:41
How much is the fish? shibby - a może PW albo temat w dziale K/S?

shibby
17-08-2018 18:56
Sadamkusz, ja mam raspbiana na dysku 1.8" 250gb po USB. Jak chcesz to mam taki jeszcze jeden komplet. Obudowa wielkości rpi Smile

slawko
17-08-2018 16:51
Wystarczy do RPi podpiąć dysk ssd i będzie stabilna nic się nie wysypie, zainteresuj się też NetTemp

sadamkusz
17-08-2018 13:38
prościej ale czy możliwe do ogarnięcia przez zwykłego usera (czyt bez kompilowania) ? RPi mam ale chce weliminować bo i tak przecież router działa 24h a rozsypywanie się systemu plików na RPi mnie den

shibby
17-08-2018 13:18
nie używałem tego ale na forum był o tym temat. Z tego co pamiętam prościej postawić RPi.

sadamkusz
16-08-2018 14:06
shibby czy ty uruchomiłeś Domoticz u siebie na routerze? R7000 lub podobnym z tomato?

36,588,378 unikalne wizyty