24 Maj 2019 00:13:01
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· IFTOP
· router Ubiquiti pod ...
· Optware Packages for...
· Tomato MultiWAN - ot...
· Asus Merlin i Media ...
· LaFonera 2201 i Garg...
· Włam na rt-ac68u
· AsusWRT-Merlin i pro...
· Router >150MB/s, 5Gh...
· [MOD] FreshTomato-MIPS
· Dostęp do routera z ...
· LTE jako łącze zapas...
· N18U unbrick
· [S] Netgear R7000 Ni...
· Linksys Ea9500 boot ...
· [MOD] FreshTomato-ARM
· Problem z prędkością
· Odseparowanie sieci
· IP Traffic
· Problem z rozłączani...
Najciekawsze tematy
· [MOD] FreshTomato... [769]
· [MOD] FreshTomato... [390]
· Tomato MultiWAN -... [261]
· Optware Packages ... [38]
· Włam na rt-ac68u [12]
· Dostęp do routera... [12]
· Router >150MB/s, ... [8]
· N18U unbrick [8]
· IP Traffic [7]
· LaFonera 2201 i G... [6]
· Linksys Ea9500 bo... [4]
· Problem z prędkością [4]
· LTE jako łącze za... [3]
· IFTOP [2]
· AsusWRT-Merlin i ... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
39% [135 głosów]

Broadcom ARM
Broadcom ARM
50% [173 głosów]

Atheros
Atheros
6% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 349
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
34.207.82.217
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
[MOD] FreshTomato-ARM
marmez
Dzień dobry

Chciałbym zgłosić problem / prosić o pomoc. Zainstalowałem Freshtomato na Asus RT-AC56U i niestety nie działa sieć 5Ghz. Przez chwilę (po połączaniu nawet nie załadowałem rzadnej strony www) się pokazała, jak zmniejszyłem kanał na 20Mhz i wybrałem ręcznie kanał, ale potem i tak zniknęła.

Czyściłem NVRAM po instalacji (Version 2019.1 by FreshTomato team) i w zasadzie nic nie zmieniałem poza podaniem nazwy sieci wybraniu WPA2 Personal z AES, i mapowania WAN MAC.

Bardzo mi zależało na tej sieci 5G. Przy Asus-wrt-merlin działała bez problemu.

Jak ktoś ma jakiś pomysł, jak to uruchomić, byłbym bardzo wdzięczny.

Pozdrawiam, marmez
 
majkel152 Dziekuje za dotacje
zrób kilka razy reboot i zobacz, po wgraniu czasem znikało ale po 1-3 rebootach wracała
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense , dużo gratów, ups, światłowody, apeki i działa miło Smile
 
najmar11
Czy działa u Was na najnowszym FreshTomato sieć lokalna po SAMBIE?

Po aktualizacji do FreshToamto 2019.01 przestało mi działać wyszukiwanie grup roboczych w mojej sieci lokalnej.

Jak w przeglądarce wpiszę
smb://workgroup/
to wyskakuje błąd

Jak wpiszę bezpośrednio nazwę hosta np:
smb://tomatousb-02/
to łączy się bezproblemowo i pokazuje udostępnione katalogi.

Ustawienia standardowe jak na załączonym screenie.
Router ASUS AC-RT68U

Poprzednio miałem wgrane Tomato by Shibby i wszystko hulało
O co w tym chodzi? naprowadźcie mnie, gdzie szukać problemu?
najmar11 dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.
 
marmez
@najmar11

Mi samba działała pod Win 10. A pod Linux Mint też musiałem wpisywać bezpośrednią nazwę/adres. Tylko, że pod Windowsem zamiast wpisanej nazwy grupy roboczej miałem UNKNOWN i dopiero w niej dysk, bardzo możliwe, że chodziło o wpisaną domenę, albo nazwę urządzenia. To jest w innej zakładce, gdzie się ogólną nazwę urządzenia wpisuje, ale teraz już nie powiem w której, bo wróciłem do Merlina przez brak 5G.

Wracając do mojego tematu sieci 5GHz. Nie udało mi się jej uruchomić - tzn. żadne urządzenia jej nie widziały, mimo, że niby była włączona. Ani na wersji FW AIO ani na VPN. Wielokrotne rebootowanie nie pomagało.

Potem miałem problem, by narzędziem Firmware Restoration przywrócić OFW, albo Merlina, bo wyskakiwał pod koniec przesyłania błąd transfer canceled.

Mimo, że miałem wszystko poodpinane, przywrócone do ustawień fabrycznych. Dawał się wgrać tylko FreshTomato VPN (mały plik), i w końcu udało się wgrać najstarszą dostępną na RT-AC56U wersję Merlina RT-AC56U_378.55_0

Piszę to, bo może komuś się też kiedyś przyda.

Pozdrawiam, marmez
 
kille72 Dziekuje za dotacje
marmez napisał(a):

bo wróciłem do Merlina przez brak 5G.

Wracając do mojego tematu sieci 5GHz. Nie udało mi się jej uruchomić - tzn. żadne urządzenia jej nie widziały, mimo, że niby była włączona. Ani na wersji FW AIO ani na VPN. Wielokrotne rebootowanie nie pomagało.

Potem miałem problem, by narzędziem Firmware Restoration przywrócić OFW, albo Merlina, bo wyskakiwał pod koniec przesyłania błąd transfer canceled.

Mimo, że miałem wszystko poodpinane, przywrócone do ustawień fabrycznych. Dawał się wgrać tylko FreshTomato VPN (mały plik), i w końcu udało się wgrać najstarszą dostępną na RT-AC56U wersję Merlina RT-AC56U_378.55_0

Piszę to, bo może komuś się też kiedyś przyda.

Pozdrawiam, marmez


Mam dwa routery RT-AC56U i zero problemow z radiem 5 GHz na FT. Jakie ustawiasz kanały, pokaż prosze ustawienia.
 
amikot
Czy ktoś inny jeszcze wypuszcza uaktualnienia Tomato?
TomatoAnon podaje, że już jest kilka routerów pracujących na wersji 2019.2.
Jednak ani tutaj, ani na stronie freshtomato nie ma informacji o takiej wersji.
Nie ma jej też w repozytorium do pobrania.
Czy to fake, zrobiony przez kogoś fork, wersja nieoficjalna(płatna?), a może wewnętrzna-testowa?
Linksys EA6900 v1.1 - Fresh Tomato 2019.01 AIO
Netgear WNDR4500v1 - Fresh Tomato 2019.01-015 beta - AIO (miał być Wireless Ethernet Bridge - ale nie chce się połączyć z Linksysem)
 
pedro
A w jaki sposób deweloperzy mają testować zmiany?
Huawei E3372s-153 non-hilink + 2x15dBi MIMO

Asus RT-AC3200 + freshtomato-RT-AC3200-ARM-2019.x.xxx-beta-AIO-64K
Asus RT-N18U @1200,666 + freshtomato-RT-N18U-ARM-2019.x.xxx-beta-AIO-64K-NOSMP
Asus RT-N66U + freshtomato-RT-N66U_RT-AC6x-2019.x.xxx-beta-AIO-64K
Linksys WRT54G v3.1 + freshtomato-K26_RT-MIPSR1-2019.x.xxx-beta-Mini
[Repozytoria FreshTomato ARM i MIPS] ---- [Obrazy FreshTomato MIPS] ---- [Dotacje - dorzuć się do rachunku za prąd wykorzystany przy budowaniu obrazów]
 
amikot
No można wyłączyć anon, ale spoko - rozumiem, po prostu byłem lekko zmieszany gdy zobaczyłem 4 różne odmiany 2019.02, a nigdzie na ten temat ni słowa Smile
Linksys EA6900 v1.1 - Fresh Tomato 2019.01 AIO
Netgear WNDR4500v1 - Fresh Tomato 2019.01-015 beta - AIO (miał być Wireless Ethernet Bridge - ale nie chce się połączyć z Linksysem)
 
marmez
kille72 napisał(a):

marmez napisał(a):

Pozdrawiam, marmez


Mam dwa routery RT-AC56U i zero problemów z radiem 5 GHz na FT. Jakie ustawiasz kanały, pokaż prosze ustawienia.


Kanały miałem na auto większość czasu. Raz wybrałem jakiś na stałe. Próbowałem z szerokością kanału 20, 40 i z 80. Może jeszcze kiedyś spróbuję zaktualizować FW do FT, ale w najbliższych tygodniach nie. Teraz już szybciej powinno pójść, bo wczoraj i dziś, żeby wrócić do Merlina, to kilka godzin czytałem i próbowałem. Wink

Sorki, że nie miałem cierpliwości na poczekanie na pomoc na forum, ale nie chciałem, by mnie żona zastrzeliła, że jej drukarka czy "NAS" nie działają, lub Internet muli.

Pozdrawiam.
 
joks
pedro napisał(a):
A jaka wersja OpenVPN na Windowsie?

Na Windowsie rowniez najnowsza wersja openvpn 2.4.7 czyli taka jak w tomato i dlatego dziwi mnie ze nie rozpoznawana jest ta komenda crypt tls
 
Stripe
Chyba powinno być tls-crypt i to zamiast tls-auth.
 
joks
zauważyłem jeszcze jeden błąd związany z openvpn. w trakcie łączenia otrzymuje u klienta ostrzeżenie:

WARNING: No server certificate verification method has been enabled

chcąc naprawić te ostrzeżenie zawsze wystarczyło dodać po stronie klienta wpis:
remote-cert-tls server
niestety po dodaniu tego wpisu u klienta otrzymuje błędy:

Tue Mar 12 12:01:41 2019 Certificate does not have key usage extension
Tue Mar 12 12:01:41 2019 OpenSSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed

udało mi się znaleźć informację że błąd jest w easy-rsa i należy dodać do pliku openssl.cnf 2 linijki aby certyfikat się poprawnie generował i opcja "remote-cert-tls server" działała

niestety nie jestem w stanie znaleźć w tomato tego pliku openssl.cnf i go poprawić
rozwiązanie błędu jest tu:
https://openvpn.net/archive/openvpn-devel/2006-11/msg00024.html
Edytowane przez joks dnia 12-03-2019 12:57
 
Stripe
Link który podałeś tyczy się wersji z 2006 roku. Ja po wygenerowaniu kluczy w easy-rsa (openvpn 2.4.7) i wgraniu ich do Tomato mogę używać dyrektywy remote-cert-tle server i nie dostaję błędu, także wygląda, że błąd jest podczas generowania kluczy na Tomato.
 
joks
tak. teraz znalazłem jak wygląda ten plik w tomato:

https://bitbucket...ew-default

i faktycznie opcja keyUsage - podpis cyfrowy digitalSignature jest wyłączona w tomato

# This is typical in keyUsage for a client certificate.
# keyUsage = nonRepudiation, digitalSignature, keyEncipherment

więc dlatego remote-cert-tls server generuje błędy

jeśli dobrze zrozumiałem problem to pedro/killer musieliby poprawić plik openssl.cnf w tomato i wtedy generowany klucz tls byłby podpisany cyfrowo i można by używać funkcji "remote-cert-tls server" po stronie klienta ale dla jasności mógłbyś sprawdzić jeśli wygenerowałeś poprawne certyfikaty jak wygląda u Ciebie zawartość openssl.cnf ? podejrzewam że opcja KeyUsage jest włączona ?
Edytowane przez joks dnia 12-03-2019 13:14
 
Stripe
Sprawdzę oczywiście ale dopiero wieczorem jak wrócę do domu.

Połączony z 12 marzec 2019 21:24:04:
joks napisał(a):

# This is typical in keyUsage for a client certificate.
# keyUsage = nonRepudiation, digitalSignature, keyEncipherment

jeśli dobrze zrozumiałem problem to pedro/killer musieliby poprawić plik openssl.cnf w tomato i wtedy generowany klucz tls byłby podpisany cyfrowo i można by używać funkcji "remote-cert-tls server" po stronie klienta ale dla jasności mógłbyś sprawdzić jeśli wygenerowałeś poprawne certyfikaty jak wygląda u Ciebie zawartość openssl.cnf ? podejrzewam że opcja KeyUsage jest włączona ?


Tak, u mnie w easy-rsa opcja keyUsage jest włączona. Dodatkowo sprawdziłem, że w Tomato jest openssl w wersji 1.0.2q a u mnie po instalacji OpenVPN 2.4.7 openssl jest w wersji 1.1.0h
Edytowane przez Stripe dnia 12-03-2019 21:24
 
joks
ja teraz również wygenerowałem na windowsie certyfikaty przerzuciłem do tomato i klientów i "remote-cert-tls server" pięknie działa i niema żadnych błędów przy łączeniu.
udało mi się natomiast znaleźć w tomato plik /etc/openssl.cnf i niby w nim keyusage jest włączony ale brak w tym pliku jeszcze wpisu extendedKeyUsage=serverAuth
czyli prawdopodobnie żeby działało to muszą być jak w starym temacie który znalazłem z 2006 roku oba wpisy - identyczne są również na windows w najnowszym openssl. szkoda ze plik w tomato /etc/openssl.cnf jest tylko do odczytu i nie mogę go edytować by poprawic i sprawdzic późniejsze generowanie certyfikatów z tomato GUI

extendedKeyUsage=serverAuth
keyUsage = digitalSignature, keyEncipherment
 
sszpila
Zauwazyłem niepokojące objawy. Skompilowałem sobie wersję z ostatnich commitów w repozytorium kille72, aby mieć działające wykresy QOS. Działają. Ale przy pobieraniu torrentów z pełną prędkością mojego łącza (250Mbps) router dostaje obciążenia praktycznie 2.0 i staje się nieresponsywny. Bardzo wolno działa GUI oraz strony WWW, zrywa połączenie po ssh. Konfiguracja QOS jest identyczna jak w poprzednich wersjach 2018.5 czy 2019.1. I nie było takich problemów z routerem podczas pobierania torrentów z pełną prędkością łącza.
Torrent nie jest uruchomiony na routerze, mam go na NAS'ie.
Asus RT-AC56U Fresh-Tomato 2019.2 AIO
 
Tektrom
Czesc,
W wersji 2019.1 sformatowalem dysk pod konsoli w Tomato w ext4 i mialem ten sam problem co Overflow2:

https://openlinks...start=1300

Nie bede udawal ze sie na tym znam, ale do myslenia dal mi komunikat przy formatowaniu:

Pobierz kod źródłowy  Kod źródłowy
Suggestion: Use Linux kernel >= 3.18 for improved stability of the metadata and journal checksum features.



sprobowalem wiec sfomatowac w ext4 pod apka w win: MiniTool Partition Wizard, po tym bez problemu sie montuje.

Z ciekawosci sformatowal pod Tomato jeszcze w ext3, to GUI (po montowaniu przy starcie) pokazuje ext4, a pod kiedy odmontujemy recznie i podmontujemy ext3.
Sprawdze jeszcze dzis jak bedzie sie zachowywac jak sformatuje pod Ubuntu Mate, jak kogos to interesuje to moge dac znac.
Pisze jakby ktos z tym walczyl, bo nie jest to duzy problem - formatuje sie tylko raz - najwazniejsze zeby wiadomo bylo jak to obejsc.

Poza tym DNS dzialaja prawidlowo, R7000 wstaje bardzo szybko: o jakies 40s przed deklarowanym czasem, dziala tez jakby szybciej, wifi "dmucha" z parteru na pietro bez problemu - DZIEKUJE!.

W ciagu paru dni puszcze dotacje, bo nie mam konta na paypal, wiec przeleje z konta znajomego.

Połączony z 15 marzec 2019 16:49:57:
Sformatowalem na Ubuntu pod ext4 - Tomato rowniez ma problem z podmontowaniem.

Co do montowanie ze skryptu - moje przeoczenie bo zapomnialem zmienic z ext4 na ext3.
Zostaje przy ext3, ze wzgledu na ten komunikat:
Suggestion: Use Linux kernel >= 3.18 for improved stability of the metadata and journal checksum features.
Edytowane przez Tektrom dnia 15-03-2019 16:49
Netgear R7000 FreshTomato 2019.1 AIO.
Netgear EX3700 OpenWrt
Asus RT-N18U FreshTomato 2019.1 AIO
 
amikot
Odnośnie samby to u mnie zasób routera jest widziany zarówno jako workgroup oraz jako zasób bezpośrednio.
Z tego co pamiętam to MS w ogóle zrezygnował z koncepcji workgroups I już w windows10 ich nie ma jako takich. Oczywiście jeśli w sieci jest workgroup to windows to zobaczy ale własne zasoby się udostępnia bezpośrednio. A może coś pochrzanile .
Linksys EA6900 v1.1 - Fresh Tomato 2019.01 AIO
Netgear WNDR4500v1 - Fresh Tomato 2019.01-015 beta - AIO (miał być Wireless Ethernet Bridge - ale nie chce się połączyć z Linksysem)
 
joks
marmez napisał(a):

Dzień dobry

Chciałbym zgłosić problem / prosić o pomoc. Zainstalowałem Freshtomato na Asus RT-AC56U i niestety nie działa sieć 5Ghz. Przez chwilę (po połączaniu nawet nie załadowałem rzadnej strony www) się pokazała, jak zmniejszyłem kanał na 20Mhz i wybrałem ręcznie kanał, ale potem i tak zniknęła.

dzis meczylem sie na asus rt-ac56u strasznie. faktycznie jest problem z wifi. u mnie objawia sie tym ze gdy w glownej zakladce obojetnie co przestawie czy adres z dhcp na static czy wybiore z listy inny serwer dnscrypt to po zapisaniu zmian wifi znika. musze podpiac sie pod router kablem i w ogolnym widoku overview wlaczac wifi (enable). nie wiem dlaczego sie samo wylacza wifi po zapisaniu zmian. tez na poczatku myslalem jak Ty ze jakies kanaly itd. na poprzednich wersjach raczej tego nie bylo choc dawno nie aktualizowalem rt-ac56u

edit sprawdzilem rowniez na asus rt-n18u tam rowniez najmniejsza zmiana w glownej zakladce jak wylaczenie informacji o portach/zmiana hasla wifi czy zmiana adresu dns powoduje wylaczenie wifi. w logach czysto :/
Edytowane przez joks dnia 17-03-2019 19:48
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 5

· Użytkowników online: 0

· Łącznie użytkowników: 23,884
· Najnowszy użytkownik: mc1100
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

OpenDM
23-05-2019 14:20
AB-Solution ---> Diversion https://diversion.
ch/

OpenDM
23-05-2019 14:17
który cwaniak ma założony Ad-Blocker pod ruterem - czy vod.tvp.pl będzie z tym działać?

hermes-80
21-05-2019 19:11
prawda

pedro
15-05-2019 19:17
Dobrze że nie w FreshTomato Smile

Steel_Rat
14-05-2019 22:06
Ciągle jakieś luki w routerach https://www.dobre.
..01867.html

tamtosiamto
13-05-2019 18:47
czy jest freshtomato na wnr3500lv1 z BT gui?

Blacon
13-05-2019 13:18
@man1 FT2019.2 jest stabilne. U mnie bez problemów

man1
12-05-2019 15:29
Są tu jacyś userzy FT 2019.2 ? Jak ze stabilnością?

majkel152
02-05-2019 13:47
udanego weekendu majowego - zerowego packet loss i niskich opóźnień Wink

shibby
27-04-2019 18:25
PanRatio - https://trzepak.pl
/viewtopic.php?p=4
56270#p456270

PanRatio
24-04-2019 14:37
Udało się komuś uruchomić FTTH i telewizję od Orange na routerze z Tomato? Sam Internet daję radę odpalić ale TV nie Frown

dziubek
23-04-2019 10:51
Poszukuje osoby która pomoże mi na zaliczenie laboratorium skonfigurować na ubuntu/debian instalacje OPENNMS z ustawionym monitorongiem ruchu sieciowego http , dostepnosci drugiego serwera, monitori

majkel152
20-04-2019 23:10
tak ale tylko tcp

man1
19-04-2019 19:38
Czy da sie podlaczyć z mikrotika L3 openvpn klientem do sewera openvpn na tomato ?

pedro
13-04-2019 14:37
Dałeś się Wink Akurat w tym to jest chyba lepsza ode mnie Pfft

majkel152
12-04-2019 23:14
@pedro - kup córce słownik lepiej :E

curkapedro
12-04-2019 21:31
Tato, testowanie oprogramowania na córce jest niezgodne z wytycznymi UE Angry P.S. Włącz mi internet

38,134,110 unikalne wizyty