22 Kwiecień 2018 04:31:41
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [S] NanoStation M5 -...
· asus n66u i niedzial...
· [MOD] FreshTomato-ARM
· [S] Ruter
· [S] Tuner Quad DVB-S...
· logowanie adresow od...
· [S] Fritz 7390 Inter...
· DNS od cloudflare 1....
· [K] Karta SD z mozli...
· [MOD] Tomato by kille72
· Debrick netgear R7000
· [S] ASUS RT-N66U B1 ...
· [MOD] Tomato by shibby
· Netgear WNR3500L v2 ...
· Reanimacja routera o...
· Asus RT-N12. Button...
· ASUS GT-AC5300
· Jaki router kupić? Z...
· Ubiquiti Unifi AP AC...
· Asus RT-AC5300 reani...
Najciekawsze tematy
· [MOD] Tomato by k... [1346]
· [MOD] FreshTomato... [41]
· DNS od cloudflare... [39]
· asus n66u i niedz... [5]
· [K] Karta SD z mo... [5]
· [S] Tuner Quad DV... [4]
· [S] Ruter [1]
· logowanie adresow... [1]
· [S] Fritz 7390 In... [1]
· [S] NanoStation M... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
41% [132 głosów]

Broadcom ARM
Broadcom ARM
48% [157 głosów]

Atheros
Atheros
6% [19 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [9 głosów]

Ogółem głosów: 325
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.224.44.168
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
[MOD] FreshTomato-ARM
kille72 Dziekuje za dotacje
[FreshTomato-ARM]
(Projekt Tomato by kille72 zmienił nazwę na FreshTomato)

Fork Tomato-ARM by Shibby, obrazy kompilowane przez FreshTomato team
FreshTomato team: @kille72 @pedro

Najnowsza wersja: 2018.2 - 2018-04-17
Kod źródłowy: https://bitbucket...rm-kille72, https://bitbucket...tomato-arm
Downloads: https://exotic.se...omato-arm/

Kompilujemy obrazy dla wybranych routerów ARM: Asus N18U, AC56S, AC56U/AC56R, AC68U(A1,A2,B1)/R/P, AC3200, Netgear R6250, R6300v2, R6400, R7000, R8000, Linksys EA6300v1/EA6400, EA6500v2, EA6700, EA6900, Tenda AC15, Huawei WS880. Życzę udanego testowania :)

Podziękowania dla: @shibby @AndreDVJ @Jacky444 @koitsu @M_ars @Vindicator @Sean B. @Toastman @RMerlin @tsynik @tvlz @branetre @Steel_Rat @mosfit @NeoX @lancethepants @qrs @Elfew i wszystkim innym, którzy pomogli mi w projekcie.

UWAGA! Wgrywasz na własną odpowiedzialność. Nie ponosimy żadnej odpowiedzialności za ewentualne uszkodzenie sprzętu.

Najważniejsze zmiany vs Tomato 2017.3 by kille72:

- php: updated to 7.2.4
- php: 'mysql' option is no longer supported in PHP7, changed to 'mysqli'
- OpenVPN: updated to 2.4.5
- openssl: updated to 1.0.2o
- miniupnpd: updated to 2.0.20180412
- miniupnpd: changed the coding to use an interface name instead of an IP/netmask
- nginx: updated to 1.13.12
- Adminer: updated to 4.6.2
- dnsmasq: update to 2.80test1
http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=log
- dnscrypt: change update-resolvers script to process v2 resolvers format
- libncurses: updated to 6.1
- nettle: updated to 3.4
- sqlite: updated to 3.23.1
- MiniDLNA: updated to 1.2.1
- New wireless driver for SDK7 (Fixed KRACK vulnerability)
- e2fsprogs: updated to 1.44.1
- nano: updated to 2.9.5
- fixed FTP data connection fails from WAN side when port is not 21
- transmission: updated to 2.93
- ipset: updated to 6.36
- libcurl: updated to 7.59.0
- libcurl: updated CA certificate bundle as of 2018-03-07
- libusb: update to 1.0.22
- usb_modeswitch: updated to 2.52
- libvorbis: updated to 1.3.6
- tor: updated to 0.3.2.10
- dropbear: updated to 2018.76
- xl2tpd: updated to 1.3.11
- pcre: Updated to 8.42
- busybox: changed uname
- router/rc/wan.c: removed "bump wan state file on connect (don't wait watchdog result)"
- router/rc/wan.c: dnsmasq process was receiving a second SIGINT signal. Instead of triggering another DNSSEC time checking, it was killing process
- router/rc/init.c: R7000/R8000: enable Air Time Fairness by default
- router/rc/services.c: fixes issues with httpd
- router/rc/services.c: SIGINT seems to be issued too soon against dnsmasq - wait one second before doing so
- rc/services.c: Connect On Demand could no longer work as designed, due to address 1.1.1.1 becoming a legit recursive DNS server, so a different IP address was chosen for this purpose
- router/Makefile: enabled mini-gmp, saves 4KB
- router/Makefile: disable RAID (mdadm binary)
- Several kernel patches in SDK6 & SDK7
- Changed Tomato versioning
- kernel: updated drivers/net/ modules:
https://bitbucket.org/kille72/tomato-arm-kille72/commits/72befb92d9bf2671de800c2841a583e2c58e9374
https://bitbucket.org/kille72/tomato-arm-kille72/commits/fb421ca0b97e0dedd4e0a2360fd98a1761e80209
- LED: Preliminary support for 2nd 5Ghz LED on R8000
- multiwan: forgotten kernel updates for sdk7
- busybox: add CONFIG_FEATURE_NETSTAT_PRG to configuration, for netstat -p functionality
- GUI: Air Time Fairness support for R7000/R8000
- RT-AC3200: invert the default order of ports
- R8000: invert the default order of ports
- entware: updated installation script
- watchdog: increase curl timeout from 3 to 5 seconds in ckcurl function - on heavy loaded 3G connection it could make false positives
- GUI: fix channel scan function for WiFi
- GUI: fix problem with passing Tagged/UNtagged on same port when using default vlan
- GUI: basic-network.asp: LCP Echo (Interval|Link fail limit) is used also with PPTP, L2TP and PPP3G so let's make it possible to modify
- GUI: add possibility to change default IP (198.51.100.1) where DNS queries send to trigger connect-on-demand
https://bitbucket.org/kille72/tomato-arm-kille72/commits/6d47b63eae4e35f5cbf2375914a2113af61e8d6e
- cstats: fix excess I/O, reduce console spam
https://bitbucket.org/kille72/tomato-arm-kille72/commits/709e23e7f1d6cbb07f125a4227cbe995f2118f88
- libid3tag: fix build/link error on Ubuntu + some additional fixes
- Fixed TOR build on some systems
- Cleanup of unused components from the tree and Makefiles
- www: default theme - original 'usbblue'
- Rebranding to FreshTomato ;)

 
qrs
pięknie!
---
R7000 [FreshTomato]
 
kille72 Dziekuje za dotacje
P.S. @Pedro rozpoczął pracę/aktualizację branch'u MIPS ale musi kupić dowolny router MIPS który obsługuje obrazy AIO do testów, a najlepiej WiFi 2,4/5GHz. Jeśli chcesz wesprzeć jego pracę, przekaż proszę darowiznę. Link znajdziesz w jego podpisie. Z góry dziękuję!

Ja też pomogę w testach, mam do tego Netgear'a WNR3500Lv2 MIPS R2, który obsługuje obrazy AIO.
 
salawalas
O, właśnie interesuje mnie w końcu coś nowego na mipsela, bo mam jeszcze Netgeara WNR3500Lv1, który jak na złość nie chce się zepsuć Wink. AIO mi nie potrzebne, wersja mini-vpn do ok. 8MB mi wystarczy Smile.
P.S. @Pedro. Całą piątkę na darowiznę przekazałem Smile.
 
qwerty321
FreshTomato nie działa.

Najpierw po wgraniu z czyszczeniem nie chciał się zbudzić N18U.
Zresetowałem 30/30/30 wstał i ustawiłem od nowa z czyszczeniem NVRAM przez ssh. Wstał ale tak jakoś nie do końca, SSH działało ale nie było GUI. Po resecie wstał.
Przełączyłem coś w VLAN-ach i już się nie pingował.
Zrobiłem tę procedurę z VLAN-ami ponownie z tym, że VLANY przestawiłem do moich potrzeb od początku po 30/30/30 i RT-N18U ponownie martwy, nie pinguje się. Przekładałem kabel do wszystkich portów LAN i nic.

Wróciłem do bety .039 i wszystko działa.

Najnowszy FreshTomato jest skopany. Na RTN18U występują przypały już w czasie wgrywania.
 
SEpuLT
FreshTomato 2018.1 na R7000 z funkcjami jakie używam, działa jak na razie bez jakichkolwiek problemów. Jeden miał czyszczony NVRAM, a drugi nie. Puki co nie widzę różnicy.
Netgear R7000 Zawsze najnowsze FreshTomato AIO
QNAP TS-451 8GB ram QTS 4.3.4.0537
 
kille72 Dziekuje za dotacje
qwerty321 napisał(a):

FreshTomato nie działa.

Najpierw po wgraniu z czyszczeniem nie chciał się zbudzić N18U.
Zresetowałem 30/30/30 wstał i ustawiłem od nowa z czyszczeniem NVRAM przez ssh. Wstał ale tak jakoś nie do końca, SSH działało ale nie było GUI. Po resecie wstał.
Przełączyłem coś w VLAN-ach i już się nie pingował.
Zrobiłem tę procedurę z VLAN-ami ponownie z tym, że VLANY przestawiłem do moich potrzeb od początku po 30/30/30 i RT-N18U ponownie martwy, nie pinguje się. Przekładałem kabel do wszystkich portów LAN i nic.

Wróciłem do bety .039 i wszystko działa.

Najnowszy FreshTomato jest skopany. Na RTN18U występują przypały już w czasie wgrywania.


Badamy sprawę, @pedro nie ma problemow z VLAN + N18U. skompiluje obraz testowy dla Ciebie. Info na PM.
 
Rawi Dziekuje za dotacje
Netgear R7000 flashowany z checkboxem do czyszczenia nvram dziala bez problemu. Dzieki!
Netgear R7000 FreshTomato 2018.2 AIO
Poprzedni:
Netgear WNR3500L v1 Tomato K26USB-1.28.RT-MIPSR2-128-VPN
 
fenir
U mnie na R18U po wgraniu nowego FreshTomato router wstał bez problemu. Może dlatego ze przed flashowaniem robię czyszczenie nvramu komendą:
Pobierz kod źródłowy  Kod źródłowy
mtd-erase2 nvram
reboot



Na razie działa dobrze, nie mam żadnych problemów. Dzięki team za soft i za pracę włożoną w jego zrobienie.
ASUS RT-N18U + FreshTomato
 
pedro
qwerty321 napisał(a):

FreshTomato nie działa.

Najpierw po wgraniu z czyszczeniem nie chciał się zbudzić N18U.
Zresetowałem 30/30/30 wstał i ustawiłem od nowa z czyszczeniem NVRAM przez ssh. Wstał ale tak jakoś nie do końca, SSH działało ale nie było GUI. Po resecie wstał.
Przełączyłem coś w VLAN-ach i już się nie pingował.
Zrobiłem tę procedurę z VLAN-ami ponownie z tym, że VLANY przestawiłem do moich potrzeb od początku po 30/30/30 i RT-N18U ponownie martwy, nie pinguje się. Przekładałem kabel do wszystkich portów LAN i nic.

Wróciłem do bety .039 i wszystko działa.

Najnowszy FreshTomato jest skopany. Na RTN18U występują przypały już w czasie wgrywania.


Mógłbyś zrobić screena z ustawien VLANów, etc?
Muszę się dowiedzieć jak uzyskać ten błąd, bo testując na razie nie jestem w stanie go uzyskać.
Huawei E3372s-153 non-hilink + 2x15dBi MIMO + RBM5

Asus RT-AC3200 + freshtomato-RT-AC3200-ARM-2018.x.x-beta-AIO-64K
Asus RT-N18U @1200,666 + freshtomato-RT-N18U-ARM-2018.x.x-beta-AIO-64K-NOSMP
[Moje repozytorium FreshTomato ARM i MIPS] ---- [Buildy na ARM'a i MIPS'a] ---- [Dotacje]
 
qwerty321
Oto screen.
Ustawiam sobie niepodłączonego VLAN-a na 3 porty żeby użyć ich jako odizolowany switch.
LAN ustawiałem też wczoraj na VLAN = 1 i 4. I za każdym przestawieniem i zapisaniem router był od razu martwy.

Połączony z 16 kwiecień 2018 12:21:46:
Nie patrz na screena tylko na ustawienia. To jest screen z backupu jak ustawić ten konkretny router. Ustawiam tylko VLAN-y, bo reszty ustawień nie ma w Waszym Tomato.
qwerty321 dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez qwerty321 dnia 16-04-2018 12:25
 
mosfit Dziekuje za dotacje
Na rt-ac68u żadnych błędów nie widzę . Vlan działa bez problemu. Świetna robota chłopaki . Dotacja poszła !
==================================
Ubiquiti NanoBridge M5
AP- Linksys WRT1900ACSv2: OpenWrt/Lede SNAPSHOT r6693
AP- ASUS RT-AC68U: FreshTomato 2018.2
NAS- DiskStation 3615xs v.6.1.6 XPEnology
 
foooox Dziekuje za dotacje
@pedro
@kille72

Oferuję bezpłatną darowiznę routera MIPSR2 do testów. Szczegóły poszły wczoraj w PM.
 
kille72 Dziekuje za dotacje
foooox napisał(a):

@pedro
@kille72

Oferuję bezpłatną darowiznę routera MIPSR2 do testów. Szczegóły poszły wczoraj w PM.


Tak, bardzo dziękuje za PM. @pedro się do Ciebie odezwie. Dzięki!
 
foooox Dziekuje za dotacje
Nie zauważyłem PM od pedro. Jestem z nim w kontakcie.
 
kille72 Dziekuje za dotacje
Ok, bug VLAN znaleziony...Jutro wyjdzie poprawiona wersja 2018.2. Przepraszamy za wszelkie niedogodności!
 
qwerty321
A co było ? Nie ma za co przepraszać :-) To normalna sprawa, że się wszystkiego nie wyłapie :-)
Ja sobie używam czasem nieużywanych 3 portów jako switcha.
Edytowane przez qwerty321 dnia 16-04-2018 18:43
 
kille72 Dziekuje za dotacje


https://bitbucket...289495ae2e
 
qwerty321
Ale jeszcze jedno mnie niepokoi. Po wgraniu z zaznaczonym czyszczeniem nvram nie chciał się dobrze zbudzić. Przez SSH wszedłem wyczyściłem, reboot i wstał.
Wszedłem w administrację, Configuration i wyczyściłem nvram "thorough" i znowu nie wstał, tym razem tak mocno nie wstał, że musiałem zrobić 30/30/30.

Później zauważyłem, że VLAN-y powodują kolejny zwis ale nie dało się dobrze wgrać (upgrejdnąć) do FreshTomato na RT-N18U.
 
kobrawerde
Ooo ... a myślałem że mipsel to już przeszłość .... mała dotacja poszła .Mój leciwy Netgear WNR3500Lv2 może jeszcze dostanie drugie życie ;-) ..... ap-ropo fajnie by było żeby np. można było w jakiejś zakładce włączyć w w/w routerze opcję przyspieszenia net-u ...bo wiadomo standard to jakieś 120Mb/s w tomato no chyba że się wyda specjalne komendy itp....
Ps. ja jadę na leciwej wersji v 108-AIO ...bo najnowsze nie są polecane a stabilna wersja 130 u mnie dziwnie działa ... czasami brak możliwości zalogowania się przez przeglądarkę do gui tomato i chyba też jej daleko do stabilności :-)
pozdro!
Edytowane przez kobrawerde dnia 16-04-2018 21:26
Netgear WNR3500L v2 <> K26USB-1.28.RT-N5x-108-AIO / VOIP FritzBox Fon / LCD DE-LD021
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 7

· Użytkowników online: 0

· Łącznie użytkowników: 23,698
· Najnowszy użytkownik: marekm
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

kille72
20-04-2018 17:36
Witaj @dula12! Smile

dula12
20-04-2018 14:20
Witam wszystkich jestem tu nowy Napisze posta i jak sie uda to chetnie dorzuce sie na dalszy rozwoj :-)

b3rok
17-04-2018 15:44
Działa

mosfit
16-04-2018 20:13
działa

kw
16-04-2018 18:56
Działa

moorgan
16-04-2018 18:39
@kille72 strona działa

kille72
16-04-2018 17:46
Proszę sprawdźcie czy wam działa strona: http://freshtomat.
..

Max Monroe
16-04-2018 08:02
@nav niestety miałem tez problemy z kilkoma podstronami na youtubie ... więc nie jest tak różowo

tamtosiamto
15-04-2018 19:54
Nie mogebgeraz, ale dzialalo wczesnij, dioda 5ghz sie pali, jak sie loguje przez ssh tez niby widac

overflow2
15-04-2018 19:23
Zmieniałeś kanał?

tamtosiamto
15-04-2018 17:43
Jak w tomacie ( n66u)sprawdzic, czy dziala radio 5GHz? Mam zaznaczone w opcjach ale zadne urzadzenie w domu nie widzi tego radia, dziala tylko 2.4GHZ. Zdechlo fizycznie?

nav
15-04-2018 11:47
U mnie to samo, muszę drugi raz odświeżać, aby strona się załadowała, ale nie jest to zbyt uciążliwe - zdarza się raz na kilkadziesiąt razy.

pedro
14-04-2018 11:50
Zobacz co tam piszą na stronie w ich dokumentacji, pewnie coś filtrują...

Max Monroe
13-04-2018 12:25
np. http://www.thieye.
com/support.html po zmianie poszło ..

Max Monroe
13-04-2018 12:24
Czy ktoś z kolegów miał problemy z otwieraniem stron na DNS'ach Cloudflare ? Bo mi nie wszystko chodzi...

p4v3u
07-04-2018 22:33
oo, dziala.

p4v3u
07-04-2018 22:29
Czy w Tomato 126 na ac68 działa Wam SNMP? Nie mogę go niczym odczytać.

35,321,211 unikalne wizyty