24 Luty 2017 15:46:30
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Kompilacje by @kille72
· Uwalony? Asus RT-n18...
· rt-n18u tomato by sh...
· Problem z ea6700
· [K] ubnt mimo AMO 5G13
· Połączenie dwóch rou...
· strona ze statystykami
· [MOD] Tomato by shibby
· pendrive , hdd do to...
· Problem z OpenVpn
· Tuner satelitarny + ...
· wymiana ea6700 na ro...
· Multiroom N z wykorz...
· [S] Ruter Asus RT-N18U
· [K] Kupię ASUS RT-AC68U
· ASUS RT-AC87U - Kil...
· Asus ac56u overclock...
· Tomato i Netgear R6400
· Router do projektu n...
· [s] ASUS RT-AC68u Wr...
Najciekawsze tematy
· [MOD] Tomato by s... [13137]
· Multiroom N z wyk... [798]
· Kompilacje by @ki... [252]
· RT-N18U - ARM z j... [237]
· Zaufany certyfika... [88]
· Instalacja Entwar... [48]
· Step-by-step Open... [46]
· Tuner satelitarny... [41]
· Połączenie dwóch ... [28]
· wymiana ea6700 na... [20]
· Dysk sieciowy pod... [16]
· Router do projekt... [15]
· Asus ac56u overcl... [13]
· Tomato i Netgear ... [13]
· Problem z ea6700 [8]
· tani, stabilny ro... [8]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
42% [118 głosów]

Broadcom ARM
Broadcom ARM
48% [134 głosów]

Atheros
Atheros
5% [15 głosów]

Marvell
Marvell
1% [3 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
2% [7 głosów]

Ogółem głosów: 281
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.163.158.163
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Na jedną partycją dysku USB nie można wgrać plików, komunikat za mało miejsca
zawi_pl
Witam,
posiadam router Asus AC-3200 z Tomato Firmware 1.28.0000 -138 K26ARM USB AIO-64K.
do tego mam podpięty jakiśtam dysk Samsunga 1TB z USB 3.0.

Dysk sformatowany na dwie partycje pliki oraz zdjęcia, w systemie ext3.
Jest udostępniony. Działa Samba, odpalony jest też Transmission. Transmission pracuje w folderze TORRENTY na partycji pliki.


Do dzisiaj wszystko działało idealnie, natomiast nagle przestałem mieć możliwość wrzucenia jakichkolwiek plików na partycję pliki
Cokolwiek próbuję wrzucić dostaję komunikat, że brakuje miejsca (nawet kilkanaście kB), wolnego miejsca jest ponad 30GB.
Co ciekawe nie ma tego problemu na partycji zdjęcia, ponadto jak utworzyłem nowego torrenta to ten ściągnął się bezproblemowo i jest dostępny, więc samo Tomato (w sensie router) ma możliwość dorzucania na tę partycję.
Mogę również przenosić na tej partycji pliki, foldery z miejsca na miejsce.

Jedyne co to nie mogę wgrać niczego z poziomu otoczenia sieciowego.

Olbrzymia prośba o pomoc.
 
jurekk
a proste przyczyny sprawdzałeś?
masz zamontowane te "pliki"
mount poprzez LABEL ?
r6400 Tomato Multiwan
 
zawi_pl
mam zamontowane (z poziomu Tomato -> USB Support)
ja widzę partycję i jej zawartość, mogę pobierać z niej pliki, mogę z poziomu Eksploratora Windows czy tam TC, przenosić pomiędzy folderami itp.

nie mogę tylko wgrać żadnego pliku
co ciekawe jak klikam w partycji (z poziomu Eksploratora Windows) prawy -> nowy -> np. nowy skoroszy Excel to tworzy mi taki plik (7kb).

ale już jak utworzę go gdzie indzie i spróbuję przenieść do partycji (folderu) pliki to dostaję komunikat że za mało miejsca
 
kille72 Dziekuje za dotacje
Access Level w Samba File Sharing masz ustawiony na Read/Write dla tych folderow?
Asus RT-AC56U Tomato K26ARM-139-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato ARM
 
NeoX
pokaz wynik polecenia df -i

generalnie chodzi mi o to, ze na systemach ext komunikat brak wolnego miejsca gdy ono faktycznie jest, moze oznaczac brak wolnych i-node'ow.
Tym poleceniem sprawdzasz ilsoc wolnych inode

Ale u ciebie moze nie pomoc
Edytowane przez NeoX dnia 10-02-2017 15:16
 
zawi_pl
kille72 napisał(a):

Access Level w Samba File Sharing masz ustawiony na Read/Write dla tych folderow?


Auto-share all USB Partitions mam ustawione na Read/Write

pokaz wynik polecenia df -i

Pobierz kod źródłowy  Kod źródłowy
root@Kukulki:/tmp/home/root# df -T -h
Filesystem           Type            Size      Used Available Use% Mounted on
/dev/root            squashfs       18.9M     18.9M         0 100% /
devtmpfs             devtmpfs      124.8M         0    124.8M   0% /dev
tmpfs                tmpfs         124.8M    476.0K    124.3M   0% /tmp
devfs                tmpfs         124.8M         0    124.8M   0% /dev
/dev/sda2            ext3          246.1G     52.8G    180.7G  23% /tmp/mnt/ZDJECIA
/dev/sda1            ext3          670.8G    642.6G         0 100% /tmp/mnt/PLIKI





może chodzi o to co na czerwono zaznaczyłem?
Jak widać miejsce jest, ale pokazuje zajętość 100%, jak to naprawić?
 
NeoX
źle uruchomiłeś df, odpal df z parametrem -i (literka i)
Pobierz kod źródłowy  Kod źródłowy
df -i




odpal tez
Pobierz kod źródłowy  Kod źródłowy
dmesg | grep sda



i pokaz co wypluwa
 
zawi_pl
NeoX napisał(a):

źle uruchomiłeś df, odpal df z parametrem -i (literka i)
Pobierz kod źródłowy  Kod źródłowy
df -i




Próbowałem ale dostaję coś takiego:
Pobierz kod źródłowy  Kod źródłowy
root@Kukulki:/tmp/home/root# df -i
df: invalid option -- i
BusyBox v1.25.0 (2016-08-01 10:01:17 CEST) multi-call binary.

Usage: df [-PkmhT] [FILESYSTEM]...

Print filesystem usage statistics

        -P      POSIX output format
        -k      1024-byte blocks (default)
        -m      1M-byte blocks
        -h      Human readable (e.g. 1K 243M 2G)
        -T      Print filesystem type





odpal tez
Pobierz kod źródłowy  Kod źródłowy
dmesg | grep sda



i pokaz co wypluwa


niestety nic nie wypluwa nie pokazuje błędu ale nie ma też wyniku
 
kille72 Dziekuje za dotacje
Powinno pokazac dysk, u mnie widac 2 partycje sda: sda1 sda2:

Pobierz kod źródłowy  Kod źródłowy

# dmesg | grep sda
sd 0:0:0:0: [sda] Spinning up disk...
sd 0:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 47 00 10 08
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1 sda2
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Attached SCSI disk
EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)




Odmontuj partycje:

Pobierz kod źródłowy  Kod źródłowy
umount /dev/sda1




I zrob:

Pobierz kod źródłowy  Kod źródłowy
fsck.ext3 /dev/sda1 -pf



Asus RT-AC56U Tomato K26ARM-139-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato ARM
 
zawi_pl
niestety nic z tego :(

po komendzie umount /dev/sda1

dostaję odpowiedź
Pobierz kod źródłowy  Kod źródłowy
umount: can't unmount /dev/sda1: Invalid argument




a kiedy odmontowałem z poziomu tomato -> USB and NAS -> USB Support
i potem dałem komendę fsck.ext3 /dev/sda1 -pf

dostaję:
Pobierz kod źródłowy  Kod źródłowy
/dev/sda1 is in use.
e2fsck: Cannot continue, aborting.





no i dodatkowo padło Transmission, nie wiem czy to powód partycji (bo operowało właśnie na partycji pliki) ale nie mogę załadować Transmission Gui

Połączony z 15 luty 2017 02:12:24:
nie mogę już edytować postu powyżej więc dopiszę

co ciekawe właśnie zauważyłem, że z partycji pliki, uciekł mi folder TORRENTY z kilkuset GB zawartości. Jak to możliwe? Był i zniknął.
Edytowane przez zawi_pl dnia 15-02-2017 02:12
 
Steel_Rat
Ktoś skasował, bądź błędy na nośniku.
Asus RT-AC68U + Tomato Firmware K26ARM USB AIO-64K + Entware + Intenso 1TB + ADATA HV620
Asus RT-N18U + 380.62_HGG-FINAL + Entware + Intenso 1TB
Netgear WNR3500Lv2 + Tomato AT
Tenda N60 + Tomato Firmware MIPSR2 K26 USB
 
jurekk
No zawsze potrzeba diagnozy a ta masz w konsoli wydajac tak polecenie dmesg prawde ci powie bo bledy pewnie wyskoczą
dwa to co nasz (Stalowy ... ;'-)) pisze moze ktos ci kawaly robi
tu na forum ktos wlasnie pisał ze mu sie probuje wbic po ssh potwierdzam ze u mnie moze nie tak intensywnie ale tez to mialo miejsca , czyli wprowadzenia innego hasła niz admin to podstawa dwa zmiana portu z 22 SSh na jakis inny w Administration, tomato jest popularne a root:admin i port 22 ;;-) = klopoty

zdaje mi sie ze odpalałeś tak tanmission z opetware/entware
zakladajac ze to bledy na dysku to próbuj je leczyć spod linkusa właśnie fsck.ext3 ewentualnie po podpieciu do pc jakims specjlistycznym programem
no i skopiowac to c ojest sprobowac odzyskac skasowane i zaorac dysk od nowa postawic parytycje najlepiej

Połączony z 15 luty 2017 07:44:59:
ps. takie objawy jka piszesz mialem jak mi padał pendrive
Sciagało cos a potem kiszka i dysk sie odmonotowywal
Edytowane przez jurekk dnia 15-02-2017 07:44
r6400 Tomato Multiwan
 
zawi_pl
Steel_Rat napisał(a):

Ktoś skasował, bądź błędy na nośniku.


Nikt nie skasował bo nie zwolniło się miejsce na partycji.
Czyli błędy, czy sformatowanie dysku i postawienie partycji na nowo rozwiąże problem błędów?
 
jurekk
musisz sprobowac to sie dowiesz
https://openlinksys.info/forum/viewthread.php?thread_id=9015
uzyj w pewnym miejscu poradnika
mkfs.ext4 -L "dane" /dev/sda1 jezeli nie masz inego dysku podpietego i tylko jedna partycje będziesz zakładał
no system ext4 moze ci pomoże
r6400 Tomato Multiwan
 
ovner
Dlatego kosztem wydajności R/W przeszedłem na system plików z ext2/3 na ntfs, bo w razie problemów łatwo można przeskanować na kompie z windowsem dysk. Do odczytu ext2/3 używałem pluginu DiskInternals Reader w totalcommanderze.
www.my-navia.pl/images/signatures/6922773954991dec6ca370.gif
ASUS RT-N16 [Fork] Asuswrt-Merlin 374.43 LTS releases (V22E4)
www.speedtest.net/result/6009806828.png
Poprzednie Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB AIO
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 12

· Użytkowników online: 1
mosfit

· Łącznie użytkowników: 23,418
· Najnowszy użytkownik: kosmodron
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

Przemo
21-02-2017 01:14
@Dimson: Ostatniej. Smile (z lutego 2017), to mój drugi XWRTna R7000

Dimson
20-02-2017 19:03
@Przemo a z której wersji Vortexa korzystasz ?

jurekk
20-02-2017 14:31
wlasnie jak kto ma Xvrte na r7000 jakby porobil zapisy zmiennych i ktos w to luknał co sie zna bo zeby bylo ciekawie okolo 1/3 zmiennych inaczej sie nazywa niz w tomato wiec to nie takie proste nie d

Przemo
20-02-2017 14:07
@kille72: Ja zmieniłem na AsusWRT-Merlin XWRT-Vortex (R7000), dopiero teraz jestem zadowolony z WiFi.

Dimson
19-02-2017 21:24
R7000, tomato v1.36 żadnych problemów z WIFI 2.4/5Ghz

jachu
19-02-2017 19:16
Kille z 2,4 da sie zyc , z 5 bardzi i ogolnie bardzo Smile

kille72
19-02-2017 18:53
Wy z R7000 + Tomato, jesteście zadowoleni z WiFi 2.4/5 GHz?

miszeli
17-02-2017 09:26
wywaliłem wszystkie vlany i wprowadziłem od nowa i niby jest ok

jurekk
17-02-2017 09:03
to daj sobie na wstrzymanie ;-) trzymajmy kciuki ze shibby dotrzyma obietnicy i dzis lub no jutro wyda 139 wtedy spróbuj

miszeli
17-02-2017 08:40
wyczyściłem nvram , wpisuje to od nowa w advanced/vlan i dalej to samo , zostaje v132 i 137 to samo

jurekk
17-02-2017 07:43
wyczyść nvram i wpisuj ustawienia z palca i dopiero sprawdzaj

miszeli
16-02-2017 21:43
Dalej to samo v137

kille72
16-02-2017 21:19
Tak

miszeli
16-02-2017 21:15
wgrać i będzie działać ?

kille72
16-02-2017 21:12
v132 lub 137

miszeli
16-02-2017 21:11
asus rt-n12

kille72
16-02-2017 21:10
Jaki router?

31,052,533 unikalne wizyty