26 Maj 2018 08:17:27
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Multiroom N z wykorz...
· Podatność VPNFilter ...
· [S] Asus 4G-AC68U
· Sposób zamieszczania...
· Przetwarzanie i ochr...
· [MOD] FreshTomato-ARM
· Asus 5300 - pomoc w ...
· [S] Tuner Quad DVB-S...
· Optymalny router + k...
· Jak znaleźć przyczyn...
· e3372h-153 firmware ...
· Tomato jako Eternet ...
· [S] Router Asus RT-N16
· jaki NAS jako rejest...
· Asus RT-AC66U hw B0
· [S] Ruter
· [S] Router Linksys W...
· [S]Turris Omnia WiFi...
· [MOD] FreshTomato-MIPS
· DNS od cloudflare 1....
Najciekawsze tematy
· Multiroom N z wyk... [926]
· [MOD] FreshTomato... [86]
· e3372h-153 firmwa... [7]
· Optymalny router ... [6]
· [S] Asus 4G-AC68U [5]
· Asus 5300 - pomoc... [5]
· [S] Tuner Quad DV... [4]
· Podatność VPNFilt... [3]
· Jak znaleźć przyc... [2]
· Sposób zamieszcza... [0]
· Przetwarzanie i o... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
40% [132 głosów]

Broadcom ARM
Broadcom ARM
48% [158 głosów]

Atheros
Atheros
6% [19 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [9 głosów]

Ogółem głosów: 326
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.80.81.223
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Na jedną partycją dysku USB nie można wgrać plików, komunikat za mało miejsca
zawi_pl
Witam,
posiadam router Asus AC-3200 z Tomato Firmware 1.28.0000 -138 K26ARM USB AIO-64K.
do tego mam podpięty jakiśtam dysk Samsunga 1TB z USB 3.0.

Dysk sformatowany na dwie partycje pliki oraz zdjęcia, w systemie ext3.
Jest udostępniony. Działa Samba, odpalony jest też Transmission. Transmission pracuje w folderze TORRENTY na partycji pliki.


Do dzisiaj wszystko działało idealnie, natomiast nagle przestałem mieć możliwość wrzucenia jakichkolwiek plików na partycję pliki
Cokolwiek próbuję wrzucić dostaję komunikat, że brakuje miejsca (nawet kilkanaście kB), wolnego miejsca jest ponad 30GB.
Co ciekawe nie ma tego problemu na partycji zdjęcia, ponadto jak utworzyłem nowego torrenta to ten ściągnął się bezproblemowo i jest dostępny, więc samo Tomato (w sensie router) ma możliwość dorzucania na tę partycję.
Mogę również przenosić na tej partycji pliki, foldery z miejsca na miejsce.

Jedyne co to nie mogę wgrać niczego z poziomu otoczenia sieciowego.

Olbrzymia prośba o pomoc.
 
jurekk
a proste przyczyny sprawdzałeś?
masz zamontowane te "pliki"
mount poprzez LABEL ?
r8000 Tomato Multiwan
 
zawi_pl
mam zamontowane (z poziomu Tomato -> USB Support)
ja widzę partycję i jej zawartość, mogę pobierać z niej pliki, mogę z poziomu Eksploratora Windows czy tam TC, przenosić pomiędzy folderami itp.

nie mogę tylko wgrać żadnego pliku
co ciekawe jak klikam w partycji (z poziomu Eksploratora Windows) prawy -> nowy -> np. nowy skoroszy Excel to tworzy mi taki plik (7kb).

ale już jak utworzę go gdzie indzie i spróbuję przenieść do partycji (folderu) pliki to dostaję komunikat że za mało miejsca
 
kille72 Dziekuje za dotacje
Access Level w Samba File Sharing masz ustawiony na Read/Write dla tych folderow?
 
NeoX
pokaz wynik polecenia df -i

generalnie chodzi mi o to, ze na systemach ext komunikat brak wolnego miejsca gdy ono faktycznie jest, moze oznaczac brak wolnych i-node'ow.
Tym poleceniem sprawdzasz ilsoc wolnych inode

Ale u ciebie moze nie pomoc
Edytowane przez NeoX dnia 10-02-2017 15:16
 
zawi_pl
kille72 napisał(a):

Access Level w Samba File Sharing masz ustawiony na Read/Write dla tych folderow?


Auto-share all USB Partitions mam ustawione na Read/Write

pokaz wynik polecenia df -i

Pobierz kod źródłowy  Kod źródłowy
root@Kukulki:/tmp/home/root# df -T -h
Filesystem           Type            Size      Used Available Use% Mounted on
/dev/root            squashfs       18.9M     18.9M         0 100% /
devtmpfs             devtmpfs      124.8M         0    124.8M   0% /dev
tmpfs                tmpfs         124.8M    476.0K    124.3M   0% /tmp
devfs                tmpfs         124.8M         0    124.8M   0% /dev
/dev/sda2            ext3          246.1G     52.8G    180.7G  23% /tmp/mnt/ZDJECIA
/dev/sda1            ext3          670.8G    642.6G         0 100% /tmp/mnt/PLIKI





może chodzi o to co na czerwono zaznaczyłem?
Jak widać miejsce jest, ale pokazuje zajętość 100%, jak to naprawić?
 
NeoX
źle uruchomiłeś df, odpal df z parametrem -i (literka i)
Pobierz kod źródłowy  Kod źródłowy
df -i




odpal tez
Pobierz kod źródłowy  Kod źródłowy
dmesg | grep sda



i pokaz co wypluwa
 
zawi_pl
NeoX napisał(a):

źle uruchomiłeś df, odpal df z parametrem -i (literka i)
Pobierz kod źródłowy  Kod źródłowy
df -i




Próbowałem ale dostaję coś takiego:
Pobierz kod źródłowy  Kod źródłowy
root@Kukulki:/tmp/home/root# df -i
df: invalid option -- i
BusyBox v1.25.0 (2016-08-01 10:01:17 CEST) multi-call binary.

Usage: df [-PkmhT] [FILESYSTEM]...

Print filesystem usage statistics

        -P      POSIX output format
        -k      1024-byte blocks (default)
        -m      1M-byte blocks
        -h      Human readable (e.g. 1K 243M 2G)
        -T      Print filesystem type





odpal tez
Pobierz kod źródłowy  Kod źródłowy
dmesg | grep sda



i pokaz co wypluwa


niestety nic nie wypluwa nie pokazuje błędu ale nie ma też wyniku
 
kille72 Dziekuje za dotacje
Powinno pokazac dysk, u mnie widac 2 partycje sda: sda1 sda2:

Pobierz kod źródłowy  Kod źródłowy

# dmesg | grep sda
sd 0:0:0:0: [sda] Spinning up disk...
sd 0:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 47 00 10 08
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1 sda2
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Attached SCSI disk
EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)




Odmontuj partycje:

Pobierz kod źródłowy  Kod źródłowy
umount /dev/sda1




I zrob:

Pobierz kod źródłowy  Kod źródłowy
fsck.ext3 /dev/sda1 -pf



 
zawi_pl
niestety nic z tego :(

po komendzie umount /dev/sda1

dostaję odpowiedź
Pobierz kod źródłowy  Kod źródłowy
umount: can't unmount /dev/sda1: Invalid argument




a kiedy odmontowałem z poziomu tomato -> USB and NAS -> USB Support
i potem dałem komendę fsck.ext3 /dev/sda1 -pf

dostaję:
Pobierz kod źródłowy  Kod źródłowy
/dev/sda1 is in use.
e2fsck: Cannot continue, aborting.





no i dodatkowo padło Transmission, nie wiem czy to powód partycji (bo operowało właśnie na partycji pliki) ale nie mogę załadować Transmission Gui

Połączony z 15 luty 2017 02:12:24:
nie mogę już edytować postu powyżej więc dopiszę

co ciekawe właśnie zauważyłem, że z partycji pliki, uciekł mi folder TORRENTY z kilkuset GB zawartości. Jak to możliwe? Był i zniknął.
Edytowane przez zawi_pl dnia 15-02-2017 02:12
 
Steel_Rat
Ktoś skasował, bądź błędy na nośniku.
WRT3200ACN + LEDE
Asus RT-AC68UvE1 + RMerlin + Entware
Asus RT-N18U + Tomato
Netgear WNR3500Lv2 + DDWRT
 
jurekk
No zawsze potrzeba diagnozy a ta masz w konsoli wydajac tak polecenie dmesg prawde ci powie bo bledy pewnie wyskoczą
dwa to co nasz (Stalowy ... ;'-)) pisze moze ktos ci kawaly robi
tu na forum ktos wlasnie pisał ze mu sie probuje wbic po ssh potwierdzam ze u mnie moze nie tak intensywnie ale tez to mialo miejsca , czyli wprowadzenia innego hasła niz admin to podstawa dwa zmiana portu z 22 SSh na jakis inny w Administration, tomato jest popularne a root:admin i port 22 ;;-) = klopoty

zdaje mi sie ze odpalałeś tak tanmission z opetware/entware
zakladajac ze to bledy na dysku to próbuj je leczyć spod linkusa właśnie fsck.ext3 ewentualnie po podpieciu do pc jakims specjlistycznym programem
no i skopiowac to c ojest sprobowac odzyskac skasowane i zaorac dysk od nowa postawic parytycje najlepiej

Połączony z 15 luty 2017 07:44:59:
ps. takie objawy jka piszesz mialem jak mi padał pendrive
Sciagało cos a potem kiszka i dysk sie odmonotowywal
Edytowane przez jurekk dnia 15-02-2017 07:44
r8000 Tomato Multiwan
 
zawi_pl
Steel_Rat napisał(a):

Ktoś skasował, bądź błędy na nośniku.


Nikt nie skasował bo nie zwolniło się miejsce na partycji.
Czyli błędy, czy sformatowanie dysku i postawienie partycji na nowo rozwiąże problem błędów?
 
jurekk
musisz sprobowac to sie dowiesz
https://openlinksys.info/forum/viewthread.php?thread_id=9015
uzyj w pewnym miejscu poradnika
mkfs.ext4 -L "dane" /dev/sda1 jezeli nie masz inego dysku podpietego i tylko jedna partycje będziesz zakładał
no system ext4 moze ci pomoże
r8000 Tomato Multiwan
 
ovner
Dlatego kosztem wydajności R/W przeszedłem na system plików z ext2/3 na ntfs, bo w razie problemów łatwo można przeskanować na kompie z windowsem dysk. Do odczytu ext2/3 używałem pluginu DiskInternals Reader w totalcommanderze.
www.my-navia.pl/images/signatures/6922773954991dec6ca370.gif
www.speedtest.net/result/6386887502.png
[img]http://www.speedtest.pl/test/154041436[/img]
ASUS RT-N16 3.0.0.4.374.43_2-26E3j9527 (Merlin LTS fork)
Poprzednie Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB AIO
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 3

· Użytkowników online: 0

· Łącznie użytkowników: 23,703
· Najnowszy użytkownik: Matrikks
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

branetre
25-05-2018 22:04
Aktualizacja regulaminu w dziale K/S/Z/O

fenir
23-05-2018 21:15

branetre
23-05-2018 08:12

belliash
19-05-2018 14:06
Spoko kille72 Smile

Bourne55
18-05-2018 11:38
mikrotik to był ten sklep

Bourne55
18-05-2018 11:04
botland czy inny to był?

Bourne55
18-05-2018 10:59
sklep z elektroniką ktoś polecał można tam kupić rutery i nie tylko...

kille72
17-05-2018 09:19
@belliash, certyfikaty naprawione.

p4v3u
14-05-2018 14:08
komorkowych oczywiscie Smile

overflow2
14-05-2018 13:48
Mówimy o sieciach komórkowych oczywiście...

overflow2
14-05-2018 13:47
Nie sądzę, z tego co pamiętam to abonament plusa to jedyna opcja dla indywidualnych klientów.

p4v3u
14-05-2018 13:27
hm, a na numerach prepaid?

overflow2
14-05-2018 13:24
Musisz wykupić dodatkową usługę - wtedy tak.

p4v3u
14-05-2018 12:12
Czy na numerach z plusa dostajecie publiczne IP?

Jacek5
13-05-2018 13:52
Posiadam Asus RT-AC56U. Myslicie, ze bez problemu mozna podlaczyc do niefgo kieszen z dyskiem 2,5cala, oraz...wentylator pobierajacy ok 3watt? Smile Upaly, wie mysle nad schlodzeniem elektroniki Wink Opcjo

p4v3u
12-05-2018 12:15
@nav https://openlinksy
s.info/forum/viewt
hread.php?thread_i
d=21674&pid=168043#
post_168043

nav
11-05-2018 22:12
niektóre e3372 brandowane przez ruskie telekomy przedstawiają się inaczej (pid). Załóż temat, pomogę.

35,627,561 unikalne wizyty