23 Czerwiec 2017 14:13:45
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· ASUS WL-520GU
· Jak odratować NETGEA...
· Dobry ruter TP-LINK ...
· Siła sygnału modem LTE
· Brak komunikacji rou...
· Asus RT-N12 a wersja...
· [MOD] Tomato by kille72
· access point WAP 300...
· Jakie 2 routery do 1...
· Wifi... zrywane połą...
· RT-N16 i modem LTE
· [MOD] Tomato by shibby
· Router do 300zł, 2,4...
· SMBv1 w Tomato
· [S]Ubiquiti Networks...
· [S] Router Netgear R...
· Blokada stron https
· oscam na openwrt (ar...
· OpenVPN - niski Donw...
· Tomato - bugi/proble...
Najciekawsze tematy
· [MOD] Tomato by s... [13429]
· oscam na openwrt ... [769]
· [MOD] Tomato by k... [578]
· Jak odratować NET... [148]
· RT-N16 i modem LTE [35]
· Brak komunikacji ... [8]
· Blokada stron https [8]
· Siła sygnału mode... [6]
· OpenVPN - niski D... [6]
· ASUS WL-520GU [5]
· Dobry ruter TP-LI... [4]
· Jakie 2 routery d... [4]
· Router do 300zł, ... [3]
· SMBv1 w Tomato [3]
· [S] Router Netgea... [3]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
40% [121 głosów]

Broadcom ARM
Broadcom ARM
49% [147 głosów]

Atheros
Atheros
6% [17 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 301
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.198.201.250
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Entware problem z instalacja
wierch
Witam
Nie chce śmiecić w topiku Tutorial wiec zapytam tutaj .
Z Linuxa słabo jeszcze raczkuje wiec proszę o wyrozumiałość.
Mam router Asus RT-N18U wgrałem Tomato Firmware 1.28.0000 -136 K26ARM USB AIO-64K
podpiałem karte sd poprzez adapter usb
dając komende tak jak w tutorialu : entware-install.sh
wyskakuje mi taka lista
Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# entware-install.sh
Info: Checking for prerequisites and creating folders...
Warning: Folder /opt exists!
mkdir: can't create directory '/opt/bin': Read-only file system
mkdir: can't create directory '/opt/etc': Read-only file system
mkdir: can't create directory '/opt/include': Read-only file system
mkdir: can't create directory '/opt/lib': Read-only file system
mkdir: can't create directory '/opt/sbin': Read-only file system
mkdir: can't create directory '/opt/share': Read-only file system
mkdir: can't create directory '/opt/tmp': Read-only file system
mkdir: can't create directory '/opt/usr': Read-only file system
mkdir: can't create directory '/opt/var': Read-only file system
mkdir: can't create directory '/opt/lib/': Read-only file system
mkdir: can't create directory '/opt/var/': Read-only file system
mkdir: can't create directory '/opt/var/': Read-only file system
mkdir: can't create directory '/opt/var/': Read-only file system
Info: Opkg package manager deployment...
/usr/sbin/entware-install.sh: cd: line 27: can't cd to /opt/bin
wget: bad address 'qnapware.zyxmon.org'
chmod: /opt/bin/opkg: No such file or directory
/usr/sbin/entware-install.sh: cd: line 30: can't cd to /opt/etc
wget: bad address 'qnapware.zyxmon.org'
/usr/sbin/entware-install.sh: cd: line 32: can't cd to /opt/lib
wget: bad address 'qnapware.zyxmon.org'
chmod: ld-2.20.so: No such file or directory
wget: bad address 'qnapware.zyxmon.org'
Info: Basic packages installation...
/usr/sbin/entware-install.sh: line 40: /opt/bin/opkg: not found
/usr/sbin/entware-install.sh: line 41: /opt/bin/opkg: not found
wget: bad address 'qnapware.zyxmon.org'
Info: Congratulations!
Info: If there are no errors above then Entware.arm successfully initialized.
Info: Add /opt/bin & /opt/sbin to your PATH variable
Info: Add '/opt/etc/init.d/rc.unslung start' to startup script for Entware.arm services to start
Info: Found a Bug? Please report at https://github.com/zyxmon/entware-arm/issues
root@unknown:/tmp/home/root#


 
ovner
pokaż jak masz zamontowaną kartę poleceniem df
www.my-navia.pl/images/signatures/6922773954991dec6ca370.gif
www.speedtest.net/result/6386887502.png
ASUS RT-N16 [Fork] Asuswrt-Merlin 374.43 LTS releases (V22E4)
Poprzednie Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB AIO
 
wierch
Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                19968     19968         0 100% /
devtmpfs                127816         0    127816   0% /dev
tmpfs                   127816       200    127616   0% /tmp
devfs                   127816         0    127816   0% /dev
/dev/sda5              1865156         2   1768847   0% /tmp/mnt/ENTWARE




ENTWARE to mój sd
 
kille72 Dziekuje za dotacje
https://openlinks...d_id=14543

Nie czytales instrukcji.
Zaczynamy od zamontowania "czegos" pod /opt

Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
to czegoś pod /opt to prosze jaśniej bo nie wiem jaki gdzie to mam wpisac.
w routerze dałem Automount
 
kille72 Dziekuje za dotacje
Pokaz wynik z tych 2 koment to Ci pomoge:

Pobierz kod źródłowy  Kod źródłowy
df -T

blkid



Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# df -T
Filesystem           Type       1K-blocks      Used Available Use% Mounted on
/dev/root            squashfs       19968     19968         0 100% /
devtmpfs             devtmpfs      127816         0    127816   0% /dev
tmpfs                tmpfs         127816       200    127616   0% /tmp
devfs                tmpfs         127816         0    127816   0% /dev
/dev/sda5            ext2         1865156         2   1768847   0% /tmp/mnt/ENTWARE




Pobierz kod źródłowy  Kod źródłowy
/dev/sda5: LABEL="ENTWARE" UUID="fddfb282-483f-d201-70dd-b082483fd201"



 
kille72 Dziekuje za dotacje
1. Zostaw wlaczone automontowanie (plus taki ze mozesz miec skrypty po zamontowaniu usb i przed odmontowaniem)
2. Do Administration-Scripts-Init wpisz
Pobierz kod źródłowy  Kod źródłowy
echo "LABEL=ENTWARE /opt ext2 defaults 0 1" >> /etc/fstab



Save

3. Reboot routera

Po restarcie sprawdz czy karta SD jest zamontowana pod /opt komenda df
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                19968     19968         0 100% /
devtmpfs                127816         0    127816   0% /dev
tmpfs                   127816       200    127616   0% /tmp
devfs                   127816         0    127816   0% /dev
/dev/sda5              1865156         2   1768847   0% /opt



 
kille72 Dziekuje za dotacje
Super!
Pobierz kod źródłowy  Kod źródłowy
/dev/sda5              1865156         2   1768847   0% /opt




Teraz zainstaluj entware.
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
ok Dzieki tylko w opisie tego nie zauważyłemSmileno chyba ze podałeś jakąś skróconą wersje.
 
kille72 Dziekuje za dotacje
Inna troszke, prawie wszyscy wylaczaja automount, ale nie trzeba jak widac Smile

(@Steel_Rat mnie kiedys zainspirowal fstab, thx!)
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
kurcze chciałem jakoś sam załapać z opisu ale trochę musze się jeszcze nauczyć
 
kille72 Dziekuje za dotacje
Zainstalowal sie Entware?
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
Pobierz kod źródłowy  Kod źródłowy

root@unknown:/tmp/home/root# entware-install.sh
Info: Checking for prerequisites and creating folders...
Warning: Folder /opt exists!
Info: Opkg package manager deployment...
wget: bad address 'qnapware.zyxmon.org'
chmod: /opt/bin/opkg: No such file or directory
wget: bad address 'qnapware.zyxmon.org'
wget: bad address 'qnapware.zyxmon.org'
chmod: ld-2.20.so: No such file or directory
wget: bad address 'qnapware.zyxmon.org'
Info: Basic packages installation...
/usr/sbin/entware-install.sh: line 40: /opt/bin/opkg: not found
/usr/sbin/entware-install.sh: line 41: /opt/bin/opkg: not found
wget: bad address 'qnapware.zyxmon.org'
Info: Congratulations!
Info: If there are no errors above then Entware.arm successfully initialized.
Info: Add /opt/bin & /opt/sbin to your PATH variable
Info: Add '/opt/etc/init.d/rc.unslung start' to startup script for Entware.arm services to start
Info: Found a Bug? Please report at https://github.com/zyxmon/entware-arm/issues
root@unknown:/tmp/home/root#



 
kille72 Dziekuje za dotacje
Pobierz kod źródłowy  Kod źródłowy
opkg update


co daje?
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
Steel_Rat
@kille72 nie ma za co Smile
Tak czytając ten dialog. Zastanawiam się czy nie było by fajnie zrobić to na stałe w tomato. Tzn. jak przy starcie router wykryje partycje "opt" automatycznie podmontuje ją do folderu "opt", jak "jffs" to do "jffs", jak "nas" to do "nas". Chyba podobne coś działa teraz w DD-WRT.
Asus RT-AC68U + Tomato Firmware K26ARM USB AIO-64K + Entware + Intenso 1TB + ADATA HV620
Asus RT-N18U + 380.62_HGG-FINAL + Entware + Intenso 1TB
Netgear WNR3500Lv2 + Tomato AT
Tenda N60 + Tomato Firmware MIPSR2 K26 USB
 
kille72 Dziekuje za dotacje
Mozemy pomyslec nad skryptem i go dodac na stale jak bedzie dzialac.
Asus RT-AC56U Tomato K26ARM-2017.2.beta-AIO
Netgear WNR3500Lv2 Tomato K26RT-N-132-AIO
Asus PCE-AC68
Moje kompilacje Tomato-ARM
 
wierch
-sh: opkg: not found
root@unknown:/tmp/home/root#
 
Steel_Rat
wierch napisał(a):

-sh: opkg: not found
root@unknown:/tmp/home/root#

Chyba jednak nie zainstalwałeś jeszcze entware...
Asus RT-AC68U + Tomato Firmware K26ARM USB AIO-64K + Entware + Intenso 1TB + ADATA HV620
Asus RT-N18U + 380.62_HGG-FINAL + Entware + Intenso 1TB
Netgear WNR3500Lv2 + Tomato AT
Tenda N60 + Tomato Firmware MIPSR2 K26 USB
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 10

· Użytkowników online: 0

· Łącznie użytkowników: 23,528
· Najnowszy użytkownik: maciej1993
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

kille72
23-06-2017 11:59
Nie wiem kiedy.

b3rok
23-06-2017 11:55
Nice Smile, a kiedy build 2017.2?

kille72
23-06-2017 11:48
Mam juz w repo 2.4.3: https://bitbucket.
..ommits/all

b3rok
23-06-2017 11:42
https://www.dobre.
..81781.html
najnowsze Tomato ma OpenVPN 2.4.1, a bezpieczne jest 2.4.3...

RaTaJ
23-06-2017 09:50
robili promocje i pewnie sie pomylili

overflow2
23-06-2017 08:50
strona została wciągnięta

mhc3600
22-06-2017 23:49
ASUS rt-n18u za 129zł +10 zł kurier na https://www.neonet
.pl/wyprzedaz-asus
-rt-n18u.html#opis
-produktu1

gabrychu
16-06-2017 14:16
https://niebezpiec
znik.pl/post/40-ro
uterow-asusa-jest-
powaznie-dziurawyc
h/

jurekk
11-06-2017 23:42
i tesciowa moze wydzwaniac w darmowe noce i poranki czy jak sie to zowie hehe

jurekk
11-06-2017 23:40
@cek149 tak pare lat temu staruszka fritza 7050 kupilem na aledrogo i smiga aczkolwiek teraz w tomato trzeba otwierać porty orz zaznaczać ptaszki w sekcji uPnP bo Shibby dla bezpieczeństwa trochę powy

servee
11-06-2017 13:09
@cek149 ja tak mam i śmiga aż miło od paru lat. Dodatkowo główny router za NAT-em. Jedynie z Halonet jakieś problemy miałem i tego operatora nie używam.

cek149
10-06-2017 17:44
jurekk, mówisz, że VOIP na Fritz! Box Fon może pracować wpięty do LAN ? i zachowa pełną funkcjonalność VOIP ?

jurekk
08-06-2017 17:58
a co szkodziło go zostawić i używać ekstra tylko do voip ja tak mam np. wpiety do lanu podstawowego routera

cek149
08-06-2017 11:19
p4v3u, Fritz'a odradzam. Trenowałem Fritz! Box Fon na neostradzie przez chyba ze 2 lata, ze względu na VOIP. Wywaliłem Fritz'a, niestety również VOIP. Teraz jest modem w bridge i do routera.

PanRatio
07-06-2017 13:27
Fakt. Dziękuję za pomoc.

DonMattheo
06-06-2017 18:14
@PanRatio: Musisz ustawić na WAN vlanid 35 a dalej to po PPPoE

Adooni
06-06-2017 12:55
szkoda ze nie uzyles wyszukiwarki na forum https://openlinks...ro
wstart=0

32,512,169 unikalne wizyty