19 Sierpień 2019 02:33:42
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· asus rt-n10u problem...
· [K] Stojak od ASUS R...
· EA6700 - nie moge si...
· [K] pilot gm990 / am...
· Wybór następcy RT-N12D1
· Asus RT-N10U B + Hua...
· Filtr antyspamowy......
· [MOD] FreshTomato-ARM
· Optware Packages for...
· RT-N18U ucina transfer
· [S]Motorola Moto X S...
· [TOMATO] WRT54GL jak...
· Tomato - bugi/proble...
· Orange 1Gbit/300Mbit
· Multiroom N z wykorz...
· Wymiana Netgear 3500...
· [S] Asus rt-ac56u i ...
· [MOD] FreshTomato-MIPS
· Asus ac56u nie wykry...
· Asus RT-AC68U - Delu...
Najciekawsze tematy
· [MOD] FreshTomato... [835]
· asus rt-n10u prob... [18]
· Wybór następcy RT... [10]
· Asus RT-N10U B + ... [9]
· Filtr antyspamowy... [5]
· [K] Stojak od ASU... [4]
· EA6700 - nie moge... [0]
· [K] pilot gm990 /... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
38% [135 głosów]

Broadcom ARM
Broadcom ARM
50% [176 głosów]

Atheros
Atheros
6% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 352
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
3.227.235.71
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Pozostałe firmware
 Drukuj temat
Technicolor tc7200 i openswan IPsec VPN
man1
witajcie,

Chciałem dla testu ustawić tunel na poziomie sieci - tak by sieć 192.168.1.0 była osiągalna z drugiej sieci 192.168.0 i odwrotnie. Coś, co Cisco nazywa chyba site to site VPN.

Bazowałem na wielu tutorialach z netu i to chyba mój główny problem - nie wiem nawet czy podane dane są poprawne - więc od razu mam pierwsze pytanie - czy "Pre-shared key " w ustaiweniacch w Technicolorze nie powinno być podane w formie niezahashowanej? Jak takiego hasha uzyskać? (Tu używam jakiegoś hasha z netu, na obu rządzeniach).

Wybór padł na Ipsec jako jedyny natywnie wspierany przez router dostarczony przez netię, Technicolor TC-7200. Taki sam występuję w UPC ale oni mają fw bez zakładki VPN, która u mnie wygląda tak jak na załączonych plikach.

Nazwijmy ten site (z technicolorem)- 'right' co dalej wystąpi w konfiguracji openswan'a zainstalowanego na Centosie 7. Porty na routerze głównym/'brzegowym' sieci left - z centosem - 50,51,500 tcP/UDP przekierowane na IP VMa który ma int sieciowy w trybie bridge.

Konfig ipsec.conf:

Pobierz kod źródłowy  Kod źródłowy
config setup
#plutodebug=all
        plutostderrlog=/var/log/pluto.log
        protostack=netkey
        nat_traversal=yes
        virtual_private=%v4:10.0.0.0/8,%v4:192.168.0.0/16,%v4:172.16.0.0/12,%v4:192.168.1.0/24
        ## disable opportunistic encryption in Red Hat ##
        oe=off
 
## disable opportunistic encryption in Debian ##
## Note: this is a separate declaration statement ##
#include /etc/ipsec.d/examples/no_oe.conf
 
## connection definition in Red Hat ##
conn demo-connection-redhat
       
      authby=secret
        right=ip sieci z technicolorem #Azure VPN gateway IP address
        rightsubnet=192.168.0.0/24 #Azure network subnet defined in cloud
#        leftfirewall=no
        left=ip sieci z centosem #IP address of your on-premises gateway
        leftsubnet=192.168.1.0/24 #network subnet located on-premises
        type=tunnel
        keyexchange=ike
        ikelifetime=28800s
        keylife=3600s
#        lifebytes=102400000
        esp=aes256-sha1
        ike=aes256-sha1-modp1024
        rekey=yes
        keyingtries=1
#        mobike=no
#        dpdaction=none
        auto=start
        rekeymargin=3m
 




To co zakomentowane zgłaszało błedy przy restarcie ipsec w Centosie, a że to bardzo wczesna nauka, to zakomentowałem, by stwierdzić co się stanie.

Do tego plik ipsec.secrets
Pobierz kod źródłowy  Kod źródłowy
ip left ip right  : PSK "JHTg6u5euztuFMJ3tvKyB2OKWrztHWzd"




Wszystko to nie działa, nastpeuje chyba proba polaczenia, jednak finalnie polaczenie nie zostaje zestawione, a logi wskazują na problemy z kluczami:

log z technicolora:

Sat Oct 29 17:49:11 2016 IKE Phase 1 Negotiation FAILED wan_ip_right_(technicolor)==>wan_ip_left_(centos)
Sat Oct 29 17:49:11 2016 pha
Sat Oct 29 17:48:10 2016 IKE Phase 1 Negotiation Started wan_ip_right_(technicolor)==>wan_ip_left_(centos)

Mam prośbę o sprawdzenie konfiguracji, czy wszystkie ustawienia na pewno podaje prawidłowo


W sumie, im dłużej to robie, to bardziej mi zależy na uruchomieniu tego, po ogarnięciu chetnie przygotuje manual/tutorial.

Z tego co widziałem nie tylko ja mam taki problem - ostatnio jakoś ten temat pojawiał się w shoucie.

pozdrawiam
m

Połączony z 29 październik 2016 19:15:18:
Nie do końca dla mnie są jasne te funkcje szyfrujące i ich parametry. nigdy się tym nie bawiłem...
man1 dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Edytowane przez man1 dnia 29-10-2016 19:15
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 8

· Użytkowników online: 0

· Łącznie użytkowników: 23,890
· Najnowszy użytkownik: rogal
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

tamtosiamto
15-08-2019 09:42
potrzebuje pilota do gm990/amiko 8900hd, moze ktos ma na sprzedaz?

mosfit
09-08-2019 18:06
TAK,jak jest na obu stronach wsparcie dla LACP https://openlinks...ost_16
9060

djwujek
09-08-2019 14:32
i na dwóch lanach bedzie 2gb/s podłączonych równocześnie ?

majkel152
08-08-2019 14:52
wystarczy podpiąć dwa lany z modemu do kompa i po problemie, to skomplikowane jakoś ?

Steel_Rat
08-08-2019 07:58
I tak i nie. Co prawda każdy może mieć max 1Gb/s ale równocześnie maja tyle dwa urządzenia. Ew. dwa dodatkowe routery. Jeszcze możliwe że w tym modemie działa agregacja lanu Smile

djwujek
08-08-2019 01:02
Ale porty w modemie są gotowe dlatego zastanawiam się czemu dają 2 a nie jeden giga przecież to bez sensu.

overflow2
07-08-2019 20:30
10 Gbps karta ethernet i nie ma problemu. Inna kwestia czy w ogóle ten internet tyle idzie.

djwujek
07-08-2019 20:02
Inaczej uważam że reklamowanie tego internetu to kłamstwo bo nie uzyskam tych 2 GB na 1 kompie

djwujek
07-08-2019 20:01
Wytłumaczcie mi proszę jak uzyskać 2gb po lanie 1 GB wiem że można podłączyć 2 kompy każdy po 1 GB ale jak uzyskać 2gb na jednym kompie

majkel152
07-08-2019 12:17
ten modem obsługuje do 5gbps downstream i 1.5gbps upstream więc w czym problem?

Steel_Rat
07-08-2019 11:01
Możliwe jak dobry router to dwa kompy działają po 1Gb/s. Mój dostawca oferuje masz 1400/1200 Mb/s

djwujek
06-08-2019 20:38
https://www.vectra
.pl/oferta/1222/. Internet 2gb na lanie 1gb hmmmm jak to możliwe a może po wifi hehhehe

jurekk
31-07-2019 21:51
to tak samo na tomato działa ;-), ac3200 to jednak asus i go tak szybko nie uwalisz, bierz asusa

dupajasia
31-07-2019 18:14
Panowie do Huawei E3372s-153 lepiej Netgear R8000 czy Asus RT-AC3200? Co lepiej działa? Wink

majkel152
31-07-2019 12:04
warto to by wątek na forum założyć a nie w shoutboxie spamować...

OpenDM
31-07-2019 09:54
wartało by ustalić kolejność ---> czy jak zainstaluję Tomato na Merlinie to usunie mi entware ? Asus AC68U [beginner]

OpenDM
29-07-2019 17:38
poprawka - po wymianie karty do wifi transfer wrócił i jest 10-14 Mbps zależnie jaka przeglądarka mierzyć

38,762,566 unikalne wizyty