23 Lipiec 2018 15:44:33
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [MOD] FreshTomato-MIPS
· [S] karta wifi, adap...
· [S] trochę sprzętu s...
· Czy na Asus DSL-N66U...
· Multiroom N z wykorz...
· Asus AC RT68U Rev. E...
· [S] Ruter
· [S] Wyprzedaż sprzęt...
· [S] Laptop Lenovo Le...
· [MOD] Tomato by shibby
· DDWRT dla ovislink 1...
· DNS od cloudflare 1....
· Jak znaleźć przyczyn...
· Oscam instalacja na ...
· oscam na openwrt (ar...
· Zlecę naprawę router...
· TL-WR340G v3 nie włą...
· [S] ASUS DSL-AC87VG ...
· [MOD] FreshTomato-ARM
· [S] Asus RT-N18U
Najciekawsze tematy
· [MOD] Tomato by s... [13665]
· Multiroom N z wyk... [935]
· oscam na openwrt ... [772]
· [MOD] FreshTomato... [208]
· DNS od cloudflare... [52]
· Jak znaleźć przyc... [11]
· [S] Ruter [8]
· Zlecę naprawę rou... [8]
· TL-WR340G v3 nie ... [4]
· DDWRT dla ovislin... [3]
· [S] karta wifi, a... [2]
· Czy na Asus DSL-N... [1]
· [S] Laptop Lenovo... [1]
· [S] trochę sprzęt... [0]
· Asus AC RT68U Rev... [0]
· [S] Wyprzedaż spr... [0]
· Oscam instalacja ... [0]
· [S] ASUS DSL-AC87... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
40% [132 głosów]

Broadcom ARM
Broadcom ARM
48% [160 głosów]

Atheros
Atheros
6% [19 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 330
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.81.244.248
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Tomato MultiWAN - otwarta dyskusja
susser
iptables jakos nie chce dzialac, dostaje iptables: Input/output error.

Wczesniej(wersja 122) moje konfiguracje dzialaly, czy wie ktos, dlaczego tak jest?

Połączony z 01 marzec 2016 00:09:57:
podaje przyklad co mi nie dziala po zainstalowaniu wersji 133:

Pobierz kod źródłowy  Kod źródłowy
PROXY_IP=1.2.3.4
PROXY_PORT=3129
iptables -t mangle -A PREROUTING -j ACCEPT -p tcp --dport 80 -s $PROXY_IP
iptables -t mangle -A PREROUTING -j MARK --set-mark 3 -p tcp --dport 80
ip rule add fwmark 3 table 2
ip route add default via $PROXY_IP dev br0 table 2



Edytowane przez susser dnia 01-03-2016 00:09
 
Steel_Rat
To ja dorzucę do niedziałającego uwierzytelniania przez radius, że nie działa opcja "Route Modem IP". Nie da się zalogować do modemu.
WRT3200ACN + LEDE
Asus RT-AC68UvE1 + RMerlin + Entware
Asus RT-N18U + Tomato
Netgear WNR3500Lv2 + DDWRT
 
djwujek
u mnie w asusie rt-n10u po włączeniu qos pojawia się taki wpis w zakładce Access Restriction Overview " iptables-restore: line 7 failed "w logach natomiast widnieje

Mar 1 01:15:22 unknown user.crit init[1]: Error while loading rules. See /etc/iptables.error file.
Mar 1 01:18:46 unknown user.crit init[1]: Error while loading rules. See /etc/iptables.error file.

ruter po tym fakcie traci połączenie z internetem. Bandwidth Limiter natomiast nie ogranicza pasma dla całej sieci br0 tylko jak się wpisze ip i jemu przypisze limit to działa

Mar 1 01:27:15 unknown user.warn kernel: HTB: quantum of class 10001 is big. Consider r2q change.
Mar 1 01:28:56 unknown user.warn kernel: HTB: quantum of class 10001 is big. Consider r2q change.

jak na razie drugi ruter asus rt-ac68u działa z włączonym qos i nie ma tego błędu

oczywiście czyszczenie było robione parę razy.
Edytowane przez djwujek dnia 01-03-2016 01:33
1.Modem Vectra 600/30
2. Edgerouter router POE FV 1.10.3
3. Asus RT-N18U DD-WRT v 3.0 r36006 the best
4. Synology DS718 1x4TB

Masz uwalony ruter błędnym wgraniem firmware - pomogę SmileWink
 
shibby Dziekuje za dotacje
susser napisał(a):

iptables jakos nie chce dzialac, dostaje iptables: Input/output error.

Wczesniej(wersja 122) moje konfiguracje dzialaly, czy wie ktos, dlaczego tak jest?

Połączony z 01 marzec 2016 00:09:57:
podaje przyklad co mi nie dziala po zainstalowaniu wersji 133:

Pobierz kod źródłowy  Kod źródłowy
PROXY_IP=1.2.3.4
PROXY_PORT=3129
iptables -t mangle -A PREROUTING -j ACCEPT -p tcp --dport 80 -s $PROXY_IP
iptables -t mangle -A PREROUTING -j MARK --set-mark 3 -p tcp --dport 80
ip rule add fwmark 3 table 2
ip route add default via $PROXY_IP dev br0 table 2




faktycznie coś przekombinowałem z modułem "mark". Z tego też powodu bw limiter nie działa. Spróbuję namierzyć problem.
 
jax
Te błędy i pojawiające się komunikaty iptables zauważyłem już we wcześniejszych wersjach i pisałem już o tym. Nie wiem na ile to rozwiązuje problem, ale u mnie znikają po wyłączeniu TCP Limit w zakładce Bandwidth Limiter. Oczywiście nie wiem, czy rozwiązuje to inne problemy. Można też spróbować wyłączyć cały Bandwidth Limiter.
 
shibby Dziekuje za dotacje
TCP limit został juz naprawiony. Tu problemem jest sam moduł mark, który został bardzo mocno zmodyfikowany na potrzeby multiwan. Samo włączenie bw limitera juz powoduje ten błąd. Do poprawki.
 
Tasiorsa
Czy jak wyjdzie poprawiona wersja 133 to będzie można zrobić upgrade czy trzeba będzie i tak ustawiać wszystko z palca?
 
shibby Dziekuje za dotacje
@Tasiorsa - wystarczy upgrade. Tu nie będzie żadnych zmian w nvramie (a nawet jak będą to nieznaczne) więc czyszczenie nie będzie potrzebne.
 
Gampers
W wersji MultiWAN 132 jak i nowej 133 po skonfigurowaniu opcji MultiWAN w Linksysie EA6700 router restartuje się ze 3 razy i wraca do oryginalnego softu Linksysa. Dopóki nie skonfiguruje opcji MultiWAN (wybiorę z 1WAN na 2WAN) dopóty wszystko działa jak należy. Jak wybieram dwa porty WAN i zrestartuje urządzenie to wraca do oryginalnego softu. Czyściłem NVRAM przed i po wgraniu, dalej to samo. Tomato bez opcji MultiWAN działa świetnie.

Podłączyłem ruter do portu rs232 i w konsoli pojawia się straszny komunikat:
Pobierz kod źródłowy  Kod źródłowy
284: Kernel panic - not syncing: Attempted to kill init!




Cały log na http://www.wklej....7b8366f9cd
 
shibby Dziekuje za dotacje
http://www.dd-wrt.com/phpBB2/viewtopic.php?p=914084


wygląda na to, że ten model ma problem z obsługą nvramu 64KB. Gdy przekroczy się 32KB nvramu to router się restartuje a że ma dual boota, to z drugiej kości odtwarza oryginalny system.

Pytanie zatem jak u ciebie z nvramem i czy wgrywasz wersję AIO czy VPN?

Połączony z 03 marzec 2016 09:15:07:
susser napisał(a):

iptables jakos nie chce dzialac, dostaje iptables: Input/output error.

Wczesniej(wersja 122) moje konfiguracje dzialaly, czy wie ktos, dlaczego tak jest?

Połączony z 01 marzec 2016 00:09:57:
podaje przyklad co mi nie dziala po zainstalowaniu wersji 133:

Pobierz kod źródłowy  Kod źródłowy
PROXY_IP=1.2.3.4
PROXY_PORT=3129
iptables -t mangle -A PREROUTING -j ACCEPT -p tcp --dport 80 -s $PROXY_IP
iptables -t mangle -A PREROUTING -j MARK --set-mark 3 -p tcp --dport 80
ip rule add fwmark 3 table 2
ip route add default via $PROXY_IP dev br0 table 2




z tego co sprawdziłem na problem jest tylko na ARMach. Na Mipselach jest ok. Zgadza się?
Edytowane przez shibby dnia 03-03-2016 09:15
 
Gampers
shibby napisał(a):

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=914084


wygląda na to, że ten model ma problem z obsługą nvramu 64KB. Gdy przekroczy się 32KB nvramu to router się restartuje a że ma dual boota, to z drugiej kości odtwarza oryginalny system.

Pytanie zatem jak u ciebie z nvramem i czy wgrywasz wersję AIO czy VPN?



Masz rację. To problem z obsługą NVRAM. Wyczytałem to samo tutaj: https://www.linke...en-faelens

Wgrywałem AIO ale jak wrócę do domciu spróbuje czegoś lżejszego.
 
andy12
Hej

A ja mam linksysa EA6900 i załączone multiwan z modemem e3372 i podobnych objawów nie zaobserwowałem

pozdrawiam





Gampers napisał(a):

W wersji MultiWAN 132 jak i nowej 133 po skonfigurowaniu opcji MultiWAN w Linksysie EA6700 router restartuje się ze 3 razy i wraca do oryginalnego softu Linksysa. Dopóki nie skonfiguruje opcji MultiWAN (wybiorę z 1WAN na 2WAN) dopóty wszystko działa jak należy. Jak wybieram dwa porty WAN i zrestartuje urządzenie to wraca do oryginalnego softu. Czyściłem NVRAM przed i po wgraniu, dalej to samo. Tomato bez opcji MultiWAN działa świetnie.

Podłączyłem ruter do portu rs232 i w konsoli pojawia się straszny komunikat:
Pobierz kod źródłowy  Kod źródłowy
284: Kernel panic - not syncing: Attempted to kill init!




Cały log na http://www.wklej....7b8366f9cd
 
Staszek Dziekuje za dotacje
Czytam i czytam i mam wątpliwości: Czy jeżeli korzystam jedynie z LTE, czy muszę konfigurować WAN1 w zakładce Advanced>>VLAN ? VID 1 mam LAN (br0), VID 2 mam WAN. W kolumnie "WAN" Port mam 'Yes'
Asus RT-AC56U Tomato K26ARM-138.12-AIO by Shibby Huawei E3372s non HiLink w zestawie
MikroTik RB951G-2HnD
Fritz!Box 7490 + Fiber 80
 
shibby Dziekuje za dotacje
jeżeli używasz LTE to możesz nawet wypiąć port WAN z VID WAN i wpiąć go sobie do br0. W ten sposób będziesz miał 5-portowy switch LAN Smile

Jeżeli nie zależy ci na piątym porcie LAN to nic nie musisz robić, ponieważ pierwszy WAN jest domyślnie skonfigurowany. Utworzyć trzeba nowy (WAN2 i kolejne) dopiero gdy chce się używać wielu WANów.

Pozdrawiam
 
Staszek Dziekuje za dotacje
Dzięki
Asus RT-AC56U Tomato K26ARM-138.12-AIO by Shibby Huawei E3372s non HiLink w zestawie
MikroTik RB951G-2HnD
Fritz!Box 7490 + Fiber 80
 
roger7
Router: Asus RT-N18U
Tomato: v133
Używam w tomato ssh do łączenia się z pracy do routera za pomocą putty i firefox i wyjścia na świat.
W tomato zaznaczona opcja "Remote Access", port 443 i "Remote Forwarding", port 22.
Konfiguruję w Firefox w łączenie się przez port tunelu, Socks v5, zaznaczam opcję "Remote DNS", żeby rozwiązywanie DNS działało przez mój router.
Ale od najnowszej wersji v133 mam problem z niektórymi stronami jak google.pl, czy gmail.com. Nie działają przy włączonej w Firefox opcji "Remote DNS".
Komunikat: "The connection was reset" albo "Secure Connection Failed"
Za to działają gdy ta opcja (Remote DNS) w Firefox jest wyłączona. Potrzebny jest też restart Firefox
 
Pre100n
Tomato v133 (Netgear WNR3500L v.2) Taka mała pierdoła, mało ważne, ale we wcześniejszych wersjach nie było tego - na stronie Status/Overview wkradł się mały bug - przy CPU Freq wyświetla się 480MHz) - da radę wywalić ten ) ?
 
kpietrek
Aktualizując do najnowszej wersji R7000 muszę czyścić nvram jeśli obecnie mam wersję: 132 K26ARM USB AIO-64K-MultiWAN
Netgear R7000 + Tomato Firmware 1.28.0000 -2017.3-kille72- K26ARM USB AIO-64K
Asus RT-N18U + Tomato Firmware 1.28.0000 -2017.2-kille72- K26ARM USB AIO-64K
Asus RT-AC56U + Tomato Firmware 1.28.0000 -138 K26ARM USB AIO-64K
 
ovner
właśnie wgrałem v133 multi na rtn16 i przy po ustawieniu nowego vlanu dla WAN2 i zaznaczeniu w BASIC --> WAN2 settings modemu 3g przy próbie zapisu ustawień wywala błąd The field "wan2_ppp_redialperiod" is invalid. Please report this problem. , domyślnie pole Redial interval jest puste
www.my-navia.pl/images/signatures/6922773954991dec6ca370.gif
www.speedtest.net/result/6386887502.png
[img]http://www.speedtest.pl/test/154041436[/img]
ASUS RT-N16 3.0.0.4.374.43_2-26E3j9527 (Merlin LTS fork)
Poprzednie Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB AIO
 
przemasisko
kpietrek napisał(a):

Aktualizując do najnowszej wersji R7000 muszę czyścić nvram jeśli obecnie mam wersję: 132 K26ARM USB AIO-64K-MultiWAN


Nie, nie musisz.

Połączony z 12 marzec 2016 00:00:06:
ovner napisał(a):

właśnie wgrałem v133 multi na rtn16 i przy po ustawieniu nowego vlanu dla WAN2 i zaznaczeniu w BASIC --> WAN2 settings modemu 3g przy próbie zapisu ustawień wywala błąd The field "wan2_ppp_redialperiod" is invalid. Please report this problem. , domyślnie pole Redial interval jest puste


Redial Interval ustaw na 10 sekund (to ustawienie jest domyślne).
Edytowane przez przemasisko dnia 12-03-2016 00:00
Asus RT-AC56U | Asuswrt-Merlin 380.61
Synology DS215J | DSM 6.0
Raspberry Pi 2 B | Raspbian Jessie Lite
APC Back-UPS ES 700
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 8

· Użytkowników online: 2
kobrawerde, sadamkusz

· Łącznie użytkowników: 23,726
· Najnowszy użytkownik: r3vr3n
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

p4v3u
22-07-2018 01:05
jest jakies narzedzie w ipkg ktore pokazywalo by zasieg raportowany przez modem lte USB ? Mam e3372-153

Blacon
20-07-2018 17:52
Mój R7000 kupiłem w Q1 2014r i trudno powiedzieć, żeby był stary...w 2018 spokojnie daje radę.

overflow2
20-07-2018 10:27
Sprzęt sieciowy się tak szybko nie starzeje. Coś postawisz to działa kilka lat zazwyczaj.

PixelPL
20-07-2018 08:26
Dziwi mnie to że router z 2016 w 2018r kosztuje tyle samo albo i więcej, telefony kom tanieją, karty graficzne, procesory, wszystko tylko routery nie tracą na cenie.

Blacon
19-07-2018 15:16
@PixelPL - to Synology RT1900, około 500zł. Mam jego mocniejszego brata RT2600 i działa rewelacyjnie.

PixelPL
19-07-2018 15:06
@Blacon Tomato nie jest koniecznością, nie uzywam ani QoS ani Bandwitch, jedynie dla dzieci wyłączenie internetu wedle godzin i dni.

Blacon
19-07-2018 14:44
@PixelPL - pod tomato to tylko Netgear R7000. Cena jest mało ważna Wink

PixelPL
17-07-2018 10:11
Co się obecnie opłaca kupić w świecie routerów z WAN 1Gb i LAN 1GB z dual band i odkrecanymi antenami ? tak w budżecie 300-400PLN ? NET 400/40

pedro
14-07-2018 17:30
No bez przesady Pfft Wink

grz3si3k
13-07-2018 19:55
aha jeśli @pedro nie ma to nikt nie ma ? OK ;p

pedro
13-07-2018 17:46
Nikt nie ma Pfft

PanRatio
07-07-2018 19:59
Nie mam takiego Internetu i dysk SATA II Pfft

grz3si3k
07-07-2018 09:25
to słabo bo ja mam na tej samej karcie 70 MBs, czyli masz ledwo połowę jej osiągów Grin Pfft

PanRatio
03-07-2018 20:40
Cofam co pisałem. Zmieniłem kartę w laptopie na Intel 9260, zrobiłem czyszczenie nvram i po WiFi z Tomato mam 292 Mb/s Grin

rosentine
01-07-2018 11:09
Zamach stanu w wykonaniu Linuxów: Server ARCHSERVER at IP 172.28.0.211 is announcing itself as a local master browser for workgroup WORKGROUP and we think we are master. Forcing election.

grz3si3k
30-06-2018 10:21
@PanRatio, a myślisz że z jakiego powodu od dawna używam OFW ? Ale, każdy musi dojść do tego sam Pfft

fr3sh
28-06-2018 22:08
jest ok! działa po przerzuceniu kluczy oraz firewolla do jifs Smile

36,049,349 unikalne wizyty