23 Kwiecień 2014 18:57:44
Nawigacja
· Strona Główna
· Artykuły
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· modem + tomato net upc
· [S] HDD Samsung HD20...
· [MOD] Tomato 1.28 EN...
· Bandwidth Limiter bl...
· router do intel widi?
· kupie Intel Centrino...
· (kupie) asus rt 65 l...
· Man - Unix manual pa...
· TL-WR740N w trybie C...
· Logowanie się przez ssh
· Multiroom N z wykorz...
· Free DDNS
· Router do NEO z możl...
· [Fotorecenzja] Gigab...
· : Linksys WRT1900AC
· Tomato - bugi/proble...
· Asus RT-N66u - powró...
· Blokowanie dostępu d...
· RT-AC68U tomato - ma...
· [s] asus ac66
Najciekawsze tematy
· [MOD] Tomato 1.28... [8986]
· Asus RT-N66u - po... [727]
· Tomato - bugi/pro... [462]
· Multiroom N z wyk... [200]
· [Fotorecenzja] Gi... [80]
· Jak odratować NET... [76]
· Free DDNS [21]
· : Linksys WRT1900AC [15]
· [s] asus ac66 [14]
· Tomato + modem ADSL [12]
· Bandwidth Limiter... [9]
· Router do vdsl z ... [9]
· Net na 100m [8]
· modem + tomato n... [7]
· Tani dysk sieciow... [6]
Ankieta
Jakiej wersji tomato używasz?

VPN
VPN
11% [50 głosów]

BT-VPN
BT-VPN
13% [59 głosów]

Big-VPN
Big-VPN
9% [42 głosów]

TOR-VPN
TOR-VPN
2% [11 głosów]

Mega-VPN
Mega-VPN
1% [7 głosów]

AIO
AIO
50% [235 głosów]

Max
Max
2% [8 głosów]

Std
Std
4% [21 głosów]

SD-MOD
SD-MOD
1% [7 głosów]

Inna
Inna
6% [27 głosów]

Ogółem głosów: 467
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 17/11/2012 11:17

Archiwum ankiet
Reklama
Twoje IP
54.211.27.61
Reklama
Zobacz temat
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj temat
Tomato DLNA
Diego962
Witam!
Mam pewien problem. Ostatnio skonfigurowałem sobie router (NetGEAR WLN3500L) tak aby działało DLNA i udało mi się, wszystko działa. Jest tylko jeden problem, nie uruchamia się ono przy autostarcie, tylko trzeba ręcznie wchodzić na router i klikać Start. Chodzi mi o to DLNA, które jest dostępne od razu po instalacji firmware'a. Czy jest jakaś możliwość aby DLNA uruchamiało się automatycznie?
Z góry dziękuję!
 
Pirek Dziekuje za dotacje
zaznaczyłeś w media server->media/dlna server -> enable i dodałeś media diretory add i na końcu save ?
Asus RT-N16 [B4] Tomato v1.28 K26 USB K26 109 EN-AIO+Stealth Mode Sunset
 
Diego962
Tak, ale żeby włączyć serwer trzeba nacisnąć Start Now czy coś takiego, a chciałbym aby przy starcie routera sam się włączał.
 
orcad
Diego962 napisał(a):

Tak, ale żeby włączyć serwer trzeba nacisnąć Start Now czy coś takiego, a chciałbym aby przy starcie routera sam się włączał.



Właśnie naciś "Start Now"
zaznacz :
Scan Media at Startup
TiVo Support
Strictly adhere to DLNA standards

i daj zapisz (save) !!!!
po restarcie uruchomi się automatycznie "DLNA"
Linksys E4200 1.28.RT-N5x-MIPSR2-092-AIO
 
Diego962
Mam wszystko zaznaczone jak wyżej napisałeś i nadal muszę ręcznie uruchamiać DLNA.
 
j3ryw
DLNA startuje przy takich ustawieniach tylko jest problem z tym, że dyski są montowane później niż startuje DLNA jeśli są montowane automatycznie przez opcje w menu i nie widzi ono dysków. Problem był już poruszany na forum i dostałem odpowiedź aby montować dysk skryptem to wtedy zamontuje się przed startem DLNA i będzie ono działać.
Netgear WNR3500L v2 tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x--099-AIO+NSA310 ffp0.7
 
Diego962
Jakim skryptem? Bo ja mam tak:

sleep 15
#montowanie dysku
/bin/mount /dev/sda2 /nas
 
j3ryw
Nie wiem jakim skryptem ja nie znam linuxa i mam dysk montowany z menu tomato, a w temacie wcześniejszym o problemach z DLNA po starcie routera nie napisano jak ma wyglądać skrypt. Sprawdź w logach po starcie routera jaką masz kolejność uruchamiania czy czasem DLNA nie startuje wcześniej niż są zamontowane partycje. Wg mnie skoro w menu tomato jest opcja montowania dysków i są usługi korzystające z tych zamontowanych dysków to kolejność startu dysków i usług powinna być tak dobrana aby po restarcie nie było problemu z usługami spowodowanego tym, że dysk jest jeszcze nie zamontowany jak uruchamia się dana usługa. Bo jeśli to ma tak wyglądać jak teraz, że wszytko najlepiej uruchamiać skryptami ustawionymi w odpowiedniej kolejności jeszcze dodatkowo z opóźnieniami to po co w tomato jest menu może wystarczyła by konsola i załączony opis, że jak chcesz uruchomić daną usługę to wpisz taki skrypt , a jak inną to inny.
Netgear WNR3500L v2 tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x--099-AIO+NSA310 ffp0.7
 
edoos
Zrob screeny jak masz i Ci dziala, albo wklej ten skrypt ... chyba ze nie skrypt a automatyczne montowanie z menu usb .
Asus RT 16N Oprogramowanie Tomato PL 1.28.0000 MIPSR2-102-PL K26 USB AIO
 
j3ryw
Ja montuje automatycznie przez menu i po każdym restarcie tomato muszę skanować od nowa bo DLNA nie widzi dysku w momencie startu. Jak na razie czekam aż ktoś łopatologicznie wytłumaczy jak zamontować dysk skryptem aby zastartował przed DLNA albo na wersję tomato ,w której będzie to działało jak należy. Na szczęście nie resetuje często rutera i zaników prądu też nie mam więc nie jest to dla mnie dużym utrudnieniem.
Netgear WNR3500L v2 tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x--099-AIO+NSA310 ffp0.7
 
orcad
menu tomato :
administrator >-scripts > init

i tam wklepujesz :

#montowanie dysku
sleep 10
/bin/mount /dev/sda1 /opt
Linksys E4200 1.28.RT-N5x-MIPSR2-092-AIO
 
edoos
A na dysku masz ntfs czy fat czy ext?, 1 partycje czy 2 ?? i na ktorej sa media ( filmy, muzyka, zdjecia)

Orcad dysk lepiej wklejac w firewall shinbby cos o tym pisal ze init za szybko rusza i moze nie zalapac .

2 sprawa ze dales przyklad montowania OPT, a z tego co widze to j3ryw chyba nawet nie napisal czy ma opt czy ma transmission, gdzie to wszystko sie znajduje..... jak te media sie tam dostaja na ten dysk.
Mi dlna startowalo za kazdym razem ale skanowanie mediow juz nie .

j3rywtTam gdzie automatycznie montujesz dysk tam masz scieszke do dysku.
Asus RT 16N Oprogramowanie Tomato PL 1.28.0000 MIPSR2-102-PL K26 USB AIO
 
j3ryw
Dysk jest NTFS z jedną partycją, nie mam opt, mam tranmission ale on jest już w sofcie, a tak wygląda menu usb u mnie co mam wpisać jako ścieżkę do montowania dysku. DLNA startuje za każdym razem tylko nie skanuje mediów bo jak już wcześniej napisałem jest ono uruchomione zanim zamontowane są dyski (możesz to sobie sprawdzić w logach po starcie routera, że DLNA szuka ścieżek do mediów i ich nie znajduje) i aby to działało trzeba tak dobrać uruchamianie aby dyski były już zamontowane zanim wystartuje DLNA, ale nie wiem jak to zrobić, nie wiem czy pomoże montowanie dysku skryptem, czy będzie miał wystarczająco czasu przed startem DLNA, aby był dla niego widoczny.
j3ryw dodał/a następującą plik:
Nie masz uprawnień to pobierania załączników w tym temacie.

Netgear WNR3500L v2 tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x--099-AIO+NSA310 ffp0.7
 
edoos
http://openlinksys.info/forum/viewthread.php?thread_id=7651
http://openlinksys.info/forum/viewthread.php?thread_id=7607

Cyztałeś to ??? tam sa podstawowe komendy i odpowiedzi na twoje pytania.
Ale co do samego dlna to ciezko mi powiedziec co zrobic zeby za kazdym razem skanowalo media przy podniesieniu demona dlna.

POCZYTAJ CO TAM PISZE NTFS nie jest dobrym rozwiązaniem.
Asus RT 16N Oprogramowanie Tomato PL 1.28.0000 MIPSR2-102-PL K26 USB AIO
 
j3ryw
Co do NTFS to miałem ten dysk zanim go podpiąłem do routera i było na nim trochę danych których nie mam gdzie przegrać aby go sformatować, a co do DLNA ja na razie nie będę nic u siebie zmieniać u mnie router pracuje już ponad dwa miesiące bez restartu więc nie jest to dla mnie uciążliwe, że po restarcie trzeba przeskanować media do udostępnienia, moje wypowiedzi były bardziej w celu pomocy osobom które mają problem i wywołaniu dyskusji która może coś zmieni w tomato aby działało lepiej konfigurowane przez interfejs, a nie skryptami.
Netgear WNR3500L v2 tomato-Netgear-3500Lv2-K26USB-1.28.RT-N5x--099-AIO+NSA310 ffp0.7
 
maniac08
Witam mam ten sam problem. Może rozwiązaniem byłoby dodanie w firewallu linijki skryptu(jako ostatnią po zamontowaniu partycji) uruchamiającą serwer dlna i skanowanie zasobów do udostępnienia? Może ktoś pomóc w rozwiązaniu tego problemu?
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 4

· Użytkowników online: 0

· Łącznie użytkowników: 21,816
· Najnowszy użytkownik: hasek72
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

dudijack
22-04-2014 20:37
Wtrącę swoje 3 grosze.Prawie kazdy producent zostawia furtkę naprawy "uwalonego" biosu.Za pomocą crisis recovery wgraj poprostu nowy bios i po kłopocie.Robiłem tak ostatnio w laptopie Acera.

1jaa
22-04-2014 19:49
dokładnie, w starych starych jeszcze szło, w nowych kicha - tylko programator

moorgan
22-04-2014 16:18
w laptopach najczęściej bios jest trzymany w eepromie i wyjecie baterii nie resetuje ustawień. przerabiałem to w kilku sztukach-tylko programator

shibby
22-04-2014 12:12
a czemu nie wypali? Jak wyjmie bateryjkę to nie będzie co miało podtrzymywać pamięci biosy i mimowolnie się zrestartuje.

1jaa
21-04-2014 21:51
z bateryjką raczej nie wypali Smile daj do serwisu niech wylutują kość od biosu, zaprogramują od nowa i wlutują Smile

shibby
18-04-2014 20:04
zworka może i tak ale wyjęcie bateryjki na kilka godzin i bios się sam zresetuje Wink

tamtosiamto
18-04-2014 18:06
w internetach troche drogo, za free tylko na stare modele, w lapku zworka to raczej rzadkość.

urbek
18-04-2014 17:53
Poszukaj na internecie uniwersalnych (serwisowych). Reset biosu (zworka - bateria) nie wchodzi w gre?

tamtosiamto
18-04-2014 17:43
Czy ktos z forumowiczów zna się na odzyskiwaniu haseł bios? Mam od kumpla Vaio pcg-41213m i ustawił hasło-i sie mu zapomniało. Mile widziane niekomercyjne rozwiazania, ale niekoniecznie.

urbek
18-04-2014 14:50
Witam, mozna samo openssl zaktualizowac?

shibby
15-04-2014 19:27
za wcześnie na to pytanie. Na razie komppiluję EN w pocie czoła.

morlinek
15-04-2014 18:29
@shibby Będziesz kompilował v117 PL?

shibby
15-04-2014 12:10
na N16 już jest opublikowany (K26). Reszta powinna być jeszcze dziś.

majkel152
14-04-2014 22:25
shibby zapodaj na n16 i ac66u

shibby
14-04-2014 18:43
poszo pw

b3rok
14-04-2014 18:33
np. ja - routery do wyboru do koloru Smile (Netgear WNR3500L V1, Tenda W1800R, Asus RT-N66u)

shibby
14-04-2014 18:12
kto chętny na szybko sprawdzić tomato v117 K26 pod względem heartbleed?

18,804,821 unikalne wizyty