17 Sierpień 2017 11:30:45
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· Jak ustawić Tomato d...
· Instalacja Newcs na ...
· [MOD] Tomato by shibby
· [MOD] Tomato by kille72
· Netgear R6400 - tańs...
· netiaspot + Linksys ...
· (RT-AC66U) 1.28.0000...
· [S] Asus RT-AC56U
· Linksys EA3200 i pro...
· [S] Laptop ASUS R500...
· VLAN VID 102 Dla GPON
· OptWare - co to jest...
· Tomato upgrade z 1.1...
· Skrypt w zakładce fi...
· WNR3500L v2 + zyxel ...
· zakup routera do Net...
· Monitorownie odwiedz...
· Układy radiowe stoso...
· Uwalony EA6900 - czy...
· Komenda AT wymuszeni...
Najciekawsze tematy
· [MOD] Tomato by s... [13504]
· [MOD] Tomato by k... [653]
· OptWare - co to j... [527]
· Netgear R6400 - t... [85]
· Jak ustawić Tomat... [35]
· Skrypt w zakładce... [8]
· Instalacja Newcs ... [7]
· Monitorownie odwi... [7]
· WNR3500L v2 + zyx... [5]
· Linksys EA3200 i ... [4]
· zakup routera do ... [4]
· netiaspot + Links... [3]
· VLAN VID 102 Dla ... [3]
· Tomato upgrade z ... [2]
· [S] Laptop ASUS R... [1]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
41% [123 głosów]

Broadcom ARM
Broadcom ARM
49% [147 głosów]

Atheros
Atheros
6% [17 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
0% [1 głos]

Intel/AMD/VIA
Intel/AMD/VIA
1% [3 głosów]

Żaden z powyższych
Żaden z powyższych
3% [8 głosów]

Ogółem głosów: 303
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.80.198.222
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
Modem 3G Huawei na tomato
shibby Dziekuje za dotacje
Temat ostatnio popularny, nigdzie dokładnie nie opisany, chociaż na naszym forum można znaleźć o nim wzmianki i pewne rozwiązania.

Użyty przeze mnie sprzęt to:
- Linksys Cisco WRT610Nv2 z Tomato K26USB build54 031HPL
- modem Huawei E220
- sim ERA bluconnect

Opis zakłada konfigurację modemu 3G tak by po podpięciu modemu do USB, zostało nawiązanie połączenie 3G i udostepnione na sieć LAN.
Nie jest to jeszcze klaster niezawodnościowy, który z automatu podnosi nam połączenie 3G gdy nie ma internetu od głównego dostawcy i rozłącza 3G w przypadku powrotu internetu na głównym łączu.
Z czasem może i takie rozwiązanie się oskryptuje ;)

PRZYGOTOWANIE

Najważniejsze to zdiagnozować adres modemu.
W tym celu włączamy w tomato obsługę USB 2.0 oraz USB1.1 OHCI. Zapisujemy i podpinamy modem.
W logu zauważymy wykryte urządzenie. U mnie było tak:
Dec 29 15:53:56 tomato user.info kernel: scsi6 : SCSI emulation for USB Mass Storage devices
Dec 29 15:53:56 tomato user.debug hotplug[855]: Attached USB device 2-1:1.0 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Dec 29 15:53:56 tomato user.debug hotplug[856]: Attached USB device 2-1:1.1 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Dec 29 15:53:56 tomato user.debug hotplug[857]: Attached USB device 2-1:1.2 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Dec 29 15:53:58 tomato user.notice kernel: scsi 6:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2


Nas interesuje urządzenie na interfejsie 255/255/255 oraz z zerem w adresie (te dane pogrubiłem).
Warto sobie zapisać adres device. U was może być np 1-1:1-0 lub 1-2:1-0. Wszystko zależy od tego jak router wykryje modem.

Potrzebujemy trochę miejsca na jffs. Jeżeli go nie mamy to aktywujemy. Ew można użyć do tego celu /opt jeżeli mamy podpięty dysk lub pendrive. Pamiętać wtedy trzeba o zmianach w skryptach
Przechodzimy do Tools -> System i wpisujemy
Pobierz kod źródłowy  Kod źródłowy
echo "/dev/ttyUSB0
debug
921600
connect \"/usr/sbin/chat -V -t 60 -f /jffs/connect.chat\"
persist
holdoff 1
usepeerdns
defaultroute
noipdefault
noaccomp
nopcomp
novj
nobsdcomp
noauth
lock
crtscts
modem
ipcp-accept-local
lcp-echo-interval 30
lcp-echo-failure 6
" > /jffs/3g.connect





i wykonujemy

Nastepny plik:
Pobierz kod źródłowy  Kod źródłowy
echo \"ABORT "NO CARRIER\"
ABORT \"NO DIALTONE\"
ABORT \"NO ERROR\"
ABORT \"NO ANSWER\"
ABORT \"BUSY\"
REPORT CONNECT
\"\" \"AT\"
TIMEOUT 60
OK \"AT+CPIN=1234\"
TIMEOUT 10

OK \"AT&FE0V1X1&D2&C1S0=0\"
OK \"AT\"
OK \"ATS0=0\"
OK \"AT\"
OK \"AT&FE0V1X1&D2&C1S0=0\"
OK \"AT\"
OK 'AT+CGDCONT=1,\"IP\",\"erainternet\"'
OK \"ATDT*99***1#\"
CONNECT \c
" > /jffs/connect.chat




UWAGA Jeżeli nie musimy podawać PINu to usuwany trzy pogrubione linie. Jeżeli mamy PIN to wpisujemy poprawny zamiast 1234.

i znów wykonujemy

Na koniec nadajemy uprawnienie execute
Pobierz kod źródłowy  Kod źródłowy
chmod +x /jffs/3g.connect




i wykonujemy

Odłączamy na chwilę modem.

Przechodzimy do zakładki USB and NAS -> USB Support i do hotpluga wpisujemy:
Pobierz kod źródłowy  Kod źródłowy
case "$ACTION" in
   add)
      # Huawei 3G USB modem
      if [ "$INTERFACE" = "255/255/255" ] && [ "${PRODUCT:0:4}" = "12d1" ] && [ "$DEVICENAME" = "2-1:1.0" ]; then
         sleep 2
         logger "Huawei 3G USB modem attached (${PRODUCT:0:4}:${PRODUCT:5:4})"
         insmod usbserial vendor=0x${PRODUCT:0:4} product=0x${PRODUCT:5:4} maxSize=4096
         sleep 2
         if [ -c /dev/ttyUSB0 ]; then
            mkdir /tmp/ppp/
            touch /tmp/ppp/resolv.conf
            ln -f /tmp/ppp/resolv.conf /etc/resolv.dnsmasq
            sleep 2
            pppd file /jffs/3g.connect
            iptables -A FORWARD -i br0 -o ppp0 -j ACCEPT
            iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
         fi
      fi     
   ;;
   remove)
      # 3G USB modem
      if [ "$INTERFACE" = "255/255/255" ] && [ "$DEVICENAME" = "2-1:1.0" ]; then
         logger "3G USB modem removed (${PRODUCT:0:4}:${PRODUCT:5:4})"
         killall -INT pppd
      fi
esac




W pogrubione pola wpisujemy swój adres device, który zapisaliśmy wyżej. Zapisujemy i podpinamy modem.
Czekamy z niecierpliwościa parenaście sekund po czym zaglądamy w logi.

Log nawiązania połączenia:
Dec 29 16:37:03 tomato user.notice root: Huawei 3G USB modem attached (12d1:1003)
Dec 29 16:37:07 tomato daemon.notice pppd[5018]: pppd 2.4.5 started by root, uid 0
Dec 29 16:37:10 tomato daemon.info pppd[5018]: Serial connection established.
Dec 29 16:37:10 tomato daemon.info pppd[5018]: Using interface ppp0
Dec 29 16:37:10 tomato daemon.notice pppd[5018]: Connect: ppp0 <--> /dev/ttyUSB0
Dec 29 16:37:30 tomato daemon.warn pppd[5018]: Could not determine remote IP address: defaulting to 10.64.64.64
Dec 29 16:37:30 tomato daemon.err pppd[5018]: not replacing existing default route via 10.10.0.1
Dec 29 16:37:30 tomato daemon.notice pppd[5018]: local IP address 10.112.39.255
Dec 29 16:37:30 tomato daemon.notice pppd[5018]: remote IP address 10.64.64.64
Dec 29 16:37:30 tomato daemon.notice pppd[5018]: primary DNS address 213.158.199.1
Dec 29 16:37:30 tomato daemon.notice pppd[5018]: secondary DNS address 213.158.199.5
Dec 29 16:37:30 tomato daemon.info dnsmasq[4370]: reading /etc/resolv.dnsmasq
Dec 29 16:37:30 tomato daemon.info dnsmasq[4370]: using nameserver 213.158.199.5#53
Dec 29 16:37:30 tomato daemon.info dnsmasq[4370]: using nameserver 213.158.199.1#53


Od tego momentu cieszymy się działającym internetem 3G :)

Jeżeli z jakiegoś powodu nie mamy połączenia 3G, sprawdzić nalezy czy w ogóle podniósł się interfejs ppp0. Można to sprawdzić wpisując w konsoli komendę ifconfig.
Żeby zdiagnozować problem można dopisać do pliku 3g.connect opcję debug. Dzięki niej log będzie bardziej szczegółowy i łatwiej nam bedzie zdiagnozować problem braku połączenia 3G.

Pozdrawiam
Edytowane przez shibby dnia 21-08-2011 11:09
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
SynC
Pomału zbliża się do mnie 3500l, więc tomato z działającą "w razie w" obsługą modemu 3g na pewno się przyda,

dzięki
 
krzak21
witam

Posiadam Asusa RT-N16 z Tomato-K26USB-1.28.8054RAF-PL-MIPSR2-beta-032H-Ext (jakoś poradziłem sobie z wgraniem).
Mój problem polega na tym ze nie mogę uruchomić modemu 3G. A dokładnie nie wiem jaki sposób mam wrzucić skrypty do jffs routera. Był bym wdzięczny za opisanie jak to zrobić. Krok po kroku żebym miał jakieś odniesienie co i jak. Jak na razie linux to czarna magia dla mnie.

Pozdrawiam

Po dodaniu drugiego skryptu w konsoli wyskakuje mi coś takiego
http://www.aukcjo...7-.html#I1
o co chodzi ???
Edytowane przez krzak21 dnia 23-01-2011 17:20
 
zabolchomicka
a masz włączone i sformatowane jffs?
.............................................................
[b]ASUS RT-N16 Tomato PL 1.28.0000 MIPSR2-110-PL K26 USB AIO OSCAM 1.10rc build #6000
dysk 500Giga
WRT54GL 2xRS Tomato Firmware v1.28.0006 PL
2xovislink WL-5460AP
2xvoip FritzBox
bullet 2hp
 
shibby Dziekuje za dotacje
zainstaluj sobie wiec optware i edytor nano. Nim bez problemu wkleisz skopiowany tekst do pliku na router.

Ew w tomato masz edytor vi. Poczytaj jak sie go uzywa.

plik tworzysz komenda touch np
touch /jffs/3g.connect
i pozniej edytujesz
vi /jffs/3g.connect

pozniej naciskasz a
pozniej shitf + insert (to wklei ci skopiowany tekst)

na koniec zapisujesz
:wq!

wiem ze vi jest dziwne ale lepsze to niz nic ;P
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
szalikmars
mozesz wejść na router programem winscp

i z tego programu edytować pliki ,wgrywać ,usuwać ,
to najwygodniejsze
 
numalek Dziekuje za dotacje
Witam Szanownych Kolegów :)

Jestem posiadaczem WNR3500L z wgrałem Tomato v1.28.9054 MIPSR2-beta-034H K26 USB VPN by shibby (thx shibyy :]).

W ostatnich dniach próbowałem uruchomić modem 3g jako zapasowy net wg powyższego opisu.
Mam dostęp do 3 różnych modemów Huawei (E220, E180, E156G).

Zrobiłem wszystko wg opisu, zmodyfikowałem tylko connect.chat wg info
znalezionego w necie, ponieważ posiadam kartę iPlus.
I tutaj pojawił się problem, a mianowicie:
1. Jak mam podpięty kabel do portu WAN, po podłączeniu modemu w logach wszystko
wygląda tak jak w opisie, ale netu brak. Widzę, że E220 się łączy, dioda świeci
cały czas na niebiesko. Po zalogowaniu przez ssh i próby pingowania dostaję komunikat:

Pobierz kod źródłowy  Kod źródłowy
ping: bad address 'www.wp.pl'




Jak wykonam dokładnie te same czynności, ale przy odłączonym kabelku do WAN wszystko śmiga
aż miło, net z iPlusa jest.

2. Co należałoby zmodyfikować w powyższym opisie, by net był rozdzielany z 3g, po podłączeniu modemu do huba usb
aktywnego (hub podpięty do wnr3500l)?
Spróbowałem podłączyć, po wcześniejszej modyfikacji hotpluga (zmiana
Pobierz kod źródłowy  Kod źródłowy
$DEVICENAME" = "2-1:1.0"



na
Pobierz kod źródłowy  Kod źródłowy
$DEVICENAME" = "1-1:1.0"


bo tak wykrywany jest modem) ale modem nie łączy się. Okazuje się, że nie jest ładowany moduł usbserial i brak jest /dev/ttyUSB*.


3. Jak 'resetuje' się usługi sieciowe, bez potrzeby restartu urządzenia, tak by ustawienia sieci wróciły do
stanu zaraz po uruchomieniu?

4. Próbowałem też odpalić net na E180. Doszedłem do tego, że jak robię wszystko ręcznie przez ssh to pięknie się łączy
(ale kabel od portu WAN też musiał być odłączony).
Natomiast jak próbuję wrzucić skrypt do hotplug'a to nie działa.
Odłączyłem nawet, programem top_netinfo, urządzenia pamięci masowej, tak, że został sam modem. Nie pomogło.

Co robię źle?

5. Mały OT, gdzie mam wrzucić
Pobierz kod źródłowy  Kod źródłowy
wl radio off


tak aby przy starcie routera wifi było domyślnie wyłączone. Wrzuciłem do firewalla, ale przy zmianach ustawień, albo jak kabel do WAN jest odłączony przy starcie routera, to wifi nie jest domyślnie wyłączone (co jest pewnie normalne, bo skrypty firewalla nie są odpalane?)

Dzięki z góry :)
Pozdrawiam!
Edytowane przez numalek dnia 06-02-2011 17:11
 
shibby Dziekuje za dotacje
jezeli w basic -> network wylaczysz wireless to nie bedzie ono startowało domyslnie.

wracajac do tematu to rozumiem ze jak WAN jest odlaczony to wszystko dziala a jak jest podlaczony to nie dziala.

Sprobuj wiec w skrypcie w sekcji add przed
mkdir /tmp/ppp/

dodac
service wan stop

analigicznie by wan startowal po odlaczeniu modemu, dodaj w sekcji remowe po killall -INT pppd
service wan start
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
numalek Dziekuje za dotacje
Wielkie dzięki shibby, pomysł z zatrzymaniem i starowaniem WAN działa wyśmienicie, o to chodziło! Smile

Zapomniałem uściślić, mój błąd Smile. Korzystam sporadycznie z wifi, z tego względu pod przycisk SES, mam podpięte przełączanie wifi (włączone/wyłączone).
Jeżeli w Basic > Wireless odznaczę wifi, to wyłączę całkiem radio i przełączanie nie będzie działać. Nic to, na razie zostawię w firewall i się przyzwyczaję.

EDIT:
Ok, punkty 1 i 5 rozwiązane.

Teraz pozostałe punkty.
Próbuję uruchomić net z iPlus na drugim modemie Huawei E180. Przy zastosowaniu skryptu shibby'ego nie jest ładowany moduł usbserial.
Logując się przez ssh i ręcznie ładując usbserial i wykonując pozostałe polecenia ze skryptu udaje mi się uruchomić net z iPlusa.


Ma ktoś może pomysł co jest nie tak, że usbserial nie jest automatycznie ładowany po podłączeniu modemu?
Edytowane przez numalek dnia 08-02-2011 08:01
 
pawelxx
ja mam problem
zrobilem wszystko wg. opisu i nie startuje. mam modem nie 220 a hawei 170 i internet z paly . zmienilem erainternet na internet i lipa.
Pobierz kod źródłowy  Kod źródłowy


Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: hub 1-1:1.0: 2 ports detected
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.debug hotplug[399]: Attached USB device 2-0:1.0 [INTERFACE=9/0/0 PRODUCT=1d6b/1/206]
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.debug hotplug[402]: Attached USB device 1-1:1.0 [INTERFACE=9/0/0 PRODUCT=424/2502/1]
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: usb 1-1.1: new full speed USB device using ehci_hcd and address 3
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: usb 1-1.1: new high speed USB device using ehci_hcd and address 4
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: br0: starting userspace STP failed, starting kernel STP
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.debug kernel: vlan0: add 33:33:00:00:00:01 mcast address to master interface
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.debug kernel: vlan0: add 01:00:5e:00:00:01 mcast address to master interface
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: vlan0: dev_set_allmulti(master, 1)
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: vlan0: dev_set_promiscuity(master, 1)
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: device eth0 entered promiscuous mode
Jan  1 01:00:13 RT-E0CB4EED2DE1 user.info kernel: device vlan0 entered promiscuous mode
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.info kernel: usb 1-1.1: configuration #1 chosen from 1 choice
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.warn kernel: usb-storage: probe of 1-1.1:1.0 failed with error -5
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.warn kernel: usb-storage: probe of 1-1.1:1.1 failed with error -5
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.info kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.info kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.debug hotplug[448]: Attached USB device 1-1.1:1.0 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.debug hotplug[456]: Attached USB device 1-1.1:1.2 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.debug hotplug[449]: Attached USB device 1-1.1:1.1 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.debug hotplug[454]: Attached USB device 1-1.1:1.3 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.info kernel: br0: topology change detected, propagating
Jan  1 01:00:14 RT-E0CB4EED2DE1 user.info kernel: br0: port 1(vlan0) entering forwarding state
Jan  1 01:00:15 RT-E0CB4EED2DE1 authpriv.info dropbear[479]: Running in background
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: started, version 2.55 cachesize 1500
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP TFTP
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: asynchronous logging enabled, queue limit is 5 messages
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq-dhcp[482]: DHCP, IP range 10.0.0.2 -- 10.0.0.3, lease time 18h
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.warn dnsmasq[482]: failed to access /etc/resolv.dnsmasq: No such file or directory
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: read /etc/hosts - 2 addresses
Jan  1 01:00:15 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: read /etc/hosts.dnsmasq - 1 addresses
Jan  1 01:00:16 RT-E0CB4EED2DE1 user.notice kernel: scsi 2:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Jan  1 01:00:16 RT-E0CB4EED2DE1 user.notice kernel: scsi 3:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
Jan  1 01:00:16 RT-E0CB4EED2DE1 user.notice kernel: sd 3:0:0:0: [sda] Attached SCSI removable disk
Jan  1 01:00:16 RT-E0CB4EED2DE1 user.info init[1]: Asus WL-500gP v2: Tomato 1.28.8054 MIPSR1-beta-031H K26 USB Ext
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: reading /etc/resolv.dnsmasq
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.warn dnsmasq[482]: ignoring nameserver 10.0.0.1 - local interface
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: using nameserver 192.168.0.2#53
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: using nameserver 192.168.0.1#53
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[482]: exiting on receipt of SIGTERM
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: started, version 2.55 cachesize 1500
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP TFTP
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: asynchronous logging enabled, queue limit is 5 messages
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq-dhcp[521]: DHCP, IP range 10.0.0.2 -- 10.0.0.3, lease time 18h
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: reading /etc/resolv.dnsmasq
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.warn dnsmasq[521]: ignoring nameserver 10.0.0.1 - local interface
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: using nameserver 192.168.0.2#53
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: using nameserver 192.168.0.1#53
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: read /etc/hosts - 2 addresses
Jan  1 01:00:19 RT-E0CB4EED2DE1 daemon.info dnsmasq[521]: read /etc/hosts.dnsmasq - 1 addresses







 
shibby Dziekuje za dotacje
bo ci nie widzi modemu tylko naped i czytnik kart. Musisz najpierw przestawic modem w tryb modemu narzedziem usb_modeswitch
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
pawelxx
rozumiem ze w ten sposób:
usb_modeswitch -H
 
shibby Dziekuje za dotacje
usb_modeswitch -v 12d1 -p 1003 -d 1
usb_modeswitch -v 12d1 -p 1003 -H 1


i popatrz w logi co ci pokaze
Asus RT-AC3200 Tomato v1.28 K26ARM-140
Netgear ReadyNAS Pro4 OS6
-----------
http://tomato.gro... - moje kompilacje Tomato
 
http://tomato.groov.pl
tristan
Wygląda OK, na które /dev/ttyUSB próbujesz się podłączać? Ile ich widzisz w /dev/ ?
Był: Asus RT-N16 + Tomato PL v1.28.9054 MIPSR2 116PL K26 USB VPN mod shibby
Jest: Asus RT-AC68U + AsusWRT-Merlin 380.62_1 DualWAN+ Huawei E1820 + 2.5" HDD 500GB Lenovo + Brother HL-1430
 
AaaA
Wygląda na to, że mam ten sam problem z E156G na Asus WL500gPv1 z tomato-K26USB-1.28.9054MIPSR1-beta-vpn3.6.trx:

Pobierz kod źródłowy  Kod źródłowy
Dec 31 16:01:28 unknown user.info kernel: usb 1-1: new high speed USB device using ehci_hcd and address 2
Dec 31 16:01:28 unknown user.info kernel: usb 1-1: configuration #1 chosen from 1 choice
Dec 31 16:01:28 unknown user.info kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Dec 31 16:01:28 unknown user.info kernel: usb 1-1: USB disconnect, address 2
Dec 31 16:01:28 unknown user.debug hotplug[593]: Attached USB device 1-1:1.0 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Dec 31 16:01:35 unknown user.info kernel: usb 1-1: new high speed USB device using ehci_hcd and address 3
Dec 31 16:01:35 unknown user.info kernel: usb 1-1: configuration #1 chosen from 1 choice
Dec 31 16:01:35 unknown user.warn kernel: usb-storage: probe of 1-1:1.0 failed with error -5
Dec 31 16:01:35 unknown user.warn kernel: usb-storage: probe of 1-1:1.1 failed with error -5
Dec 31 16:01:35 unknown user.info kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Dec 31 16:01:35 unknown user.info kernel: scsi4 : SCSI emulation for USB Mass Storage devices
Dec 31 16:01:35 unknown user.debug hotplug[628]: Attached USB device 1-1:1.3 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Dec 31 16:01:36 unknown user.debug hotplug[632]: Attached USB device 1-1:1.0 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Dec 31 16:01:36 unknown user.debug hotplug[634]: Attached USB device 1-1:1.1 [INTERFACE=255/255/255 PRODUCT=12d1/1003/0]
Dec 31 16:01:36 unknown user.debug hotplug[637]: Attached USB device 1-1:1.2 [INTERFACE=8/6/80 PRODUCT=12d1/1003/0]
Dec 31 16:01:37 unknown user.notice kernel: scsi 3:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Dec 31 16:01:37 unknown user.notice kernel: scsi 4:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
Dec 31 16:01:37 unknown user.notice kernel: sd 4:0:0:0: [sda] Attached SCSI removable disk
Dec 31 16:01:38 unknown user.notice root: Huawei 3G USB modem attached (12d1:1003)
Dec 31 16:01:38 unknown user.info kernel: usbcore: registered new interface driver usbserial
Dec 31 16:01:38 unknown user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
Dec 31 16:01:38 unknown user.info kernel: usbserial_generic 1-1:1.0: generic converter detected
Dec 31 16:01:38 unknown user.info kernel: usb 1-1: generic converter now attached to ttyUSB0
Dec 31 16:01:38 unknown user.info kernel: usbserial_generic 1-1:1.1: generic converter detected
Dec 31 16:01:38 unknown user.info kernel: usb 1-1: generic converter now attached to ttyUSB1
Dec 31 16:01:38 unknown user.info kernel: usbcore: registered new interface driver usbserial_generic
Dec 31 16:01:38 unknown user.info kernel: drivers/usb/serial/usb-serial.c: USB Serial Driver core
Dec 31 16:01:42 unknown daemon.notice pppd[679]: pppd 2.4.5 started by root, uid 0
Dec 31 16:01:46 unknown daemon.warn dnsmasq[476]: no servers found in /etc/resolv.dnsmasq, will retry
Dec 31 16:02:43 unknown daemon.debug pppd[679]: Script /usr/sbin/chat -V -t 60 -f /jffs/connect.chat finished (pid 683), status = 0x3
Dec 31 16:02:43 unknown daemon.err pppd[679]: Connect script failed





Jak mogę sobie z tym poradzić? Wszystkie ustawienia wydają się byc OK.
Edytowane przez AaaA dnia 10-04-2011 21:32
--
Karol Stilger
http://stilger.eu
 
http://stilger.eu
tristan
Dodaj do pliku 3g.connect czy jak tam się u Ciebie nazywa linijkę

nodetach

To włącza prawdziwy debugging i będzie widać co się wysypuje.
Był: Asus RT-N16 + Tomato PL v1.28.9054 MIPSR2 116PL K26 USB VPN mod shibby
Jest: Asus RT-AC68U + AsusWRT-Merlin 380.62_1 DualWAN+ Huawei E1820 + 2.5" HDD 500GB Lenovo + Brother HL-1430
 
AaaA
tristan napisał(a):
Dodaj do pliku 3g.connect czy jak tam się u Ciebie nazywa linijkę

nodetach

To włącza prawdziwy debugging i będzie widać co się wysypuje.


Dodałem, teraz plik 3g.connect wygląda tak:

Pobierz kod źródłowy  Kod źródłowy
/dev/ttyUSB0
debug
nodetach
921600
connect "/usr/sbin/chat -V -t 60 -f /jffs/connect.chat"
persist
holdoff 1
usepeerdns
defaultroute
noipdefault
noaccomp
nopcomp
novj
nobsdcomp
noauth
lock
crtscts
modem
ipcp-accept-local
lcp-echo-interval 30
lcp-echo-failure 6




W logu systemowym nie ma nic bardziej szczegółowego.
--
Karol Stilger
http://stilger.eu
 
http://stilger.eu
pawelxx
ja niestety nie dałem rady z tym na tomato. na innym sofcie smia bez problemu. narazie sobie odpuściłem to. jak ktos bedzie miał jakis pomysł to chetnie do tego powróce
 
tristan
AaaA napisał(a):
W logu systemowym nie ma nic bardziej szczegółowego.


Puść "z palca" ten skrypt i zobacz co będzie po kolei wyświetlać. Nodetach powoduje że nie idzie w tle tylko wyrzuca na konsolę poszczególne kroki połączenia.
Był: Asus RT-N16 + Tomato PL v1.28.9054 MIPSR2 116PL K26 USB VPN mod shibby
Jest: Asus RT-AC68U + AsusWRT-Merlin 380.62_1 DualWAN+ Huawei E1820 + 2.5" HDD 500GB Lenovo + Brother HL-1430
 
AaaA
Zrobię to trochę późniejWink Potrzebowałem działającego rozwiązania od zaraz i chwilowo wrzuciłem niezawodny pod tym względem firmware z koppel.cz.
--
Karol Stilger
http://stilger.eu
 
http://stilger.eu
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 8

· Użytkowników online: 0

· Łącznie użytkowników: 23,572
· Najnowszy użytkownik: Zbigniew Chmielewski
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

Unpleasant
16-08-2017 18:48
Panowie, działają Wam regułki ebtables na nowszych wersjach AIO z multi WAN? (AC66U)

b3rok
12-08-2017 14:35
@djwujek i inni - ostrożnie z tym sklepem, więcej tutaj (komentarze) https://zaufanatrz
eciastrona.pl/post
/jak-bezkarnie-kra
sc-pieniadze-czyli
-o-bezradnosci-org
anow-scigania/

djwujek
12-08-2017 02:05
Po 210 Zł RT-N18U arendt-24 //usunąłem link poczytajcie komentarze o Arendt - b3rok

feszt
08-08-2017 16:38
NewCS to zabytek, napewno na ARM też go nie ma.

PanRatio
07-08-2017 21:39
Jest promocja i Router Xiaomi Mi Pro można mieć za 295 zł. Szkoda, że nie ma na niego Tomato Frown

scooby
07-08-2017 19:10
czesc, mam pytanie czy dałoby rade wykorzystac tutorial Cardserwer NewCS 1.67RC1 pod Tomato w sofcie RMerlin z optware ?

PixelPL
02-08-2017 16:46
na torrent trochę się zapycha i szału nie ma, w LAN -> Switch Control -> Enable Jumbo Frame

PixelPL
02-08-2017 16:44

PixelPL
02-08-2017 16:43
@ovner RT-N16 AsusWRT Merlin 378.50

ovner
02-08-2017 09:37
RT-N16 wyrabia na łączu +400Mb/s Smile No ładnie jak na staruszka, jaką dokładnie masz wersje wgrana bo ja mam Firmware:374.43_2-
26E3j9527 (Merlin LTS fork)

PixelPL
01-08-2017 23:26
http://beta.speed.
..597417.png
RT-N16 AsusWRT Merlin 378.50

ovner
01-08-2017 10:32
RT-N16_Discontinue
d Rmerlin zaprzestał rozwoju i wsparcia tomato dla rt-n16 To co mamy wgrane to jest fork na baziw jego softu

PixelPL
01-08-2017 10:30
no i jeszcze teraz łączy mi z routerem na wyższym adresie bo jeszcze używam PPPoE do ADSL

PixelPL
01-08-2017 10:27
RT-N16_3.0.0.4_378
.50_0 Dodali okienko CPU Usage Grin

PixelPL
01-08-2017 09:57
Panowie jest problem https://www.media.
..nw5wo8wrco
Wedle tej strony soft na samej górze nie jest najnowszy, dziś sprawdziłem po datach doda

PixelPL
30-07-2017 08:54
Nat DMZ itd. cmd ping, iperf, nie łączy. Skończyły mi się pomysły. Może Asus WRT Merlin jest jakieś pop... nie chcę mi się zmieniać już na coś innego

PixelPL
30-07-2017 08:52
Dziś spędziłem nad tym 4 godziny, jak kolega wspomniał adresacja 10.0.0.1 i 10.0.0.2 jest poprawna ponieważ ruch występuje a router w sekcji WAN widzi to poprawnie, nic jednak z przekierowania portu N

33,087,989 unikalne wizyty