12 Grudzień 2018 07:36:17
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [S] HDD WD Red WD10E...
· DNS od cloudflare 1....
· Belkin F7D3302 + Hua...
· Asus ac56u overclock...
· dodatkowa karta eth ...
· Zakup routera VPN TAP
· AsusWRT-Merlin i pro...
· [MOD] FreshTomato-MIPS
· Mocny ruter pod tomato
· [MOD] Tomato by shibby
· [S] ASUS RT-AC3200
· [MOD] FreshTomato-ARM
· Multiroom N z wykorz...
· Asus RT-AC68U
· Jaki router kupić? Z...
· Asus RT-AC56U - "mał...
· [S] ASUS RT-N66U B1 ...
· Qnap TS-251+ i Trans...
· R8000
· WAN Bandwidth - Monthly
Najciekawsze tematy
· [MOD] Tomato by s... [13700]
· Multiroom N z wyk... [951]
· [MOD] FreshTomato... [400]
· [MOD] FreshTomato... [300]
· DNS od cloudflare... [55]
· Asus ac56u overcl... [28]
· Mocny ruter pod t... [17]
· Belkin F7D3302 + ... [12]
· dodatkowa karta e... [4]
· Zakup routera VPN... [3]
· AsusWRT-Merlin i ... [1]
· [S] HDD WD Red WD... [0]
· [S] ASUS RT-AC3200 [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
39% [132 głosów]

Broadcom ARM
Broadcom ARM
49% [166 głosów]

Atheros
Atheros
6% [20 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 338
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.82.10.219
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
oscam na openwrt (ar71xx) i tomato k2.6
shibby Dziekuje za dotacje
W sumie rzecz sie tyczy 4 popularnych routerów
- openwrt - tplink 1043nd oraz linksys wrt160nl
- tomato - asus rt-n16 oraz netgear 3500l (na ddwrt też może działać, wszystko zależy od dostepności modułów)

Openwrt
Openwrt backfire dziala bezproblemu z czytnikami korzystajacymi z modulu ftdi_sio. Na chwile obecną moduł pl2303 stwarza problemy i oscam nie potrafi wykryć czytnika.
Testowane na tplinku + backfire 10.3.1-RC3

Download - http://openwrt.groov.pl/WR1043NDv1/backfire-10.3.1-RC3/packages/oscam_0.99.4svn-r2847-8_ar71xx.ipk

Paczka zawiera:
- oscam 0.99.4svn-r2847 dla architektury ar71xx
- wbudowany webif
- libusb (Adding smartreader support)
- domyslną konfigurację dla cyfry
- skrypt startowy


Instalacja
cd /tmp
wget http://openwrt.groov.pl/WR1043NDv1/backfire-10.3.1-RC3/packages/oscam_0.99.4svn-r2847-8_ar71xx.ipk
opkg install oscam_0.99.4svn-r2847-8_ar71xx.ipk
opkg update
opkg install kmod-usb-serial-ftdi


Tomato k2.6
Moduły ftdi_sio oraz pl2303 działają poprawnie od wersji beta20!
Testowane na Asusie RT-N16 + Tomato k2.6 beta20

Download - http://tomato.groov.pl/repo/oscam_0.99.4-svn2967-3_mipsel.ipk

Paczka zawiera:
- oscam 0.99.4svn, build #2967
- wbudowany webif
- domyslną konfigurację dla cyfry
- skrypt startowy


Instalacja
cd /tmp
ipkg update
wget http://tomato.groov.pl/repo/oscam_0.99.4-svn2967-3_mipsel.ipk
ipkg install oscam_0.99.4-svn2967-3_mipsel.ipk


Domyslne ustawienia

dostep do www:
- port 8989
- login admin
- haslo admin

port naslugu dla karty cyfry - 10100

UPDATE
Dla chetnych na testy wersja 1.0-unstable rev3849
Tomato: http://tomato.gro...mipsel.ipk
Openwrt: http://openwrt.gr...ar71xx.ipk
Edytowane przez shibby dnia 08-11-2010 08:29
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
jolero1000
a pliki conf oscama znajdują się w obrazie, czy są w pełni konfigurowalne ?
WRT54GL_ Kamikaze 7.09_2xRS232
TL-WR1043ND Gargoyle PL (by obsy)
 
shibby Dziekuje za dotacje
domyslna konfiguracja jest w obrazie, ustawiona pod cyfre oraz skonfigurowany webif. Wszystko po to by zaraz po instalacji odpalal sie oscam i mozna bylo zarzadzac nim np przez webif. Ale oczywiscie pliki sa w pelni konfigurowalne.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Czy paczka dla k2.6 zawiera moduły dla phoenixa pod usb?

Czy należy go zamontować?
Edytowane przez krystianman dnia 09-09-2010 14:47
 
shibby Dziekuje za dotacje
jezeli masz tomato beta20 to on ma juz w sobie odpowiedni modul a w skrypcie startowym jest jego zaladowanie.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Podłączyłem do aktywnego huba phoenixa i oscam go nie widzi, spowodowane jest to że skrypt oscam nie startuje.

funkcja insmod wyświetla mi taki komunikat:

Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# insmod ftdi_sio
insmod: can't insert '/lib/modules/2.6.22.19/kernel/drivers/usb/ftdi_sio.ko': unknown symbol in module, or unknown parameter




Edytowane przez krystianman dnia 09-09-2010 19:47
 
kinh
było wcześniej insmod usbserial ?
 
krystianman
kinh napisał/a:
było wcześniej insmod usbserial ?


poradziłem sobie takFrownsbin/modprobe -v ftdi_sio
 
shibby Dziekuje za dotacje
nie czytasz tego co napisalem. W skrypcie startowym jest juz ladowanie modulow, zobacz sobie

cat /opt/etc/init.d/oscam


Najwazniejsze to miec tomato beta20 i wlaczyc obsluge usb1.1!!
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Skrypt u mnie nie działa do końca dobrze, po uruchomieniu oscam nie działą w tle. Uruchamiam sobie go przez skrypt ini oscam -b
 
shibby Dziekuje za dotacje
oczywiscie wpisujesz
/opt/etc/init.d/oscam start
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
tylko jak tak wpiszę to skrypt nie chce działać w tle muszę ręcznie program uruchomić z parametrem -b
Edytowane przez krystianman dnia 10-09-2010 15:50
 
shibby Dziekuje za dotacje
jakis blad? komunikat cokolwiek?

u mnie bez problemu startuje

[root@groov /]$ /opt/etc/init.d/oscam start
Starting oscam...

[root@groov /]$ ps | grep oscam
15407 root 2744 S N oscam -b
15408 root 2720 S N oscam -b
15410 root 2744 S N oscam -b
15411 root 2744 S N oscam -b
15412 root 2744 S N oscam -b
15413 root 2744 S N oscam -b
15418 root 1224 R grep oscam
[root@groov /]$/opt/etc/init.d/oscam stop
Stopping oscam...Terminated
[root@groov /]$

Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
payo22
Hej,

mam problem z obsługą czytnika ftdi na Tomato K26 (b20) i Asusie WL-500W.
Przy starcie oscama dostaje błąd: Error activating card.
Wydaje mi się, że problem może być związany z tym, że nie mam włączonej obsługi ohci dla usb (tylko uhci).
A nie mam, bo ładowanie tego modułu powoduje, że router zalicza restart :/

Może któryś z was sprawdzić czy oscam i czytnik ftdi u was też się tak zachowuje przy włączonym tylko uhci?

@Shibby: wspominałeś w innym wątku, że kompilowałeś moduły sam. Kompilowałeś też może moduł uhci-hcd.ko? Chciałbym spróbować modułu z innego źródła niż dołączony do tomato.
Edytowane przez payo22 dnia 12-09-2010 22:29
 
shibby Dziekuje za dotacje
nie da sie. Jezeli modul juz jest w tomato to nie mozna zmusic go by zaladowal inny z podanej sciezki. To byl powod dla ktorego musialem zrezygnowac z beta10 i przejsc na beta20.

U mnie wlaczenie wszystkich modulow usb nie wplywa negatywnie na router. Moze czyszczenie nvram u ciebie jest wymagane...?

Odlacz czytnik i zaladuj modul i zobacz czy bez czytnika tez zaliczy restart.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Witam

Jest możliwość podmiany pliku oscama na starszą wersję w tej skompilowanej co jakiś czas występuje błąd:

Pobierz kod źródłowy  Kod źródłowy
c05 request_cw() failed on reader cyfra (0) errno=11, Resource temporarily unavailable




Problem jest znany i opisanyhttp://streamboar...ticket/649, występuje od wersji 2711.

Na tunerze mam wersję build 1881 i ten problem nie występuje.
Edytowane przez krystianman dnia 14-09-2010 22:58
 
shibby Dziekuje za dotacje
mowimy o oscamie pod openwrt czy tomato?
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
shibby napisał/a:
mowimy o oscamie pod openwrt czy tomato?


Pod tomato
 
shibby Dziekuje za dotacje
pozniej zrobie ci wersje 1881
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
shibby napisał/a:
pozniej zrobie ci wersje 1881


Ok dzięki

Czy binarki pod DD-WRT z tego http://streamboar...oardid=236wątku będą działać na tomato?
Edytowane przez krystianman dnia 15-09-2010 13:52
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 6

· Użytkowników online: 0

· Łącznie użytkowników: 23,816
· Najnowszy użytkownik: unuresy
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

Blacon
11-12-2018 22:23
Asus RT-AC 3200. Czy ten ruter dziala bez zadnych problemow z Tomato?

lulo
10-12-2018 04:53
...failover zarówno z drugim WAN czy to po kablu, czy mieszane z kluczem usb na LTE - działa bez zarzutu

lulo
10-12-2018 04:48
faileover działa spoko

lulo
10-12-2018 04:47
u mnie to działa na UPC/Orange po 1 Gb - jest moc - z wiadomych względów zewnętrznych sumowanie działa różnie, w zależności od usługi/itd.

lulo
10-12-2018 04:43
...wtedy nie tracisz nic z mocy sterów, a i dzięki Merlinowi/entware da się ogarnąć większość popularnych niuansów/dodatków/
itd.

lulo
10-12-2018 04:32
@bigl np. RT-AC88U (pięknie śmiga wszystko, łącznie z dual-band - właśnie sobie sprawiłem niedawno) - styka Asus Merlin z ewentualnym dograniem softu na entware/dodania własnych skryptów/zapis na jffs

bigl
04-12-2018 20:23
qrs - dziękuję więc kupię go. Jest akurat na Amazonie po 99 funtów więc okazja :-)

qrs
04-12-2018 13:15
bigl, R7000 to kozak - z nim nie ma problemów

bigl
03-12-2018 23:11
Czy jest jakiś router z FreshTomato i z dobrze działającym dual band? Szukam i widzę że większość na FreshTomato ma problem z 5GHz. Albo z zasięgiem, albo z wydajności i zostaje oryginalny soft.

bigl
03-12-2018 21:05
Przepraszam za zamieszanie - działa. Ale testowałem na profilu "tenda_red" i ten pomimo pozytywnych opinii nie ładuje się. Inne są OK (np. linksysred).

kille72
03-12-2018 06:35
@bigl: mi działa bez problemow. Napisz więcej info na forum.

bigl
02-12-2018 16:05
Na FreshTomato nie działa ładowanie tematów z TTB. Jest pobierany plik zip do katalogu /www ale nie jest ładowany. Coś da się z tym zrobić?

RaTaJ
02-12-2018 00:01
Przepraszam, na myśli miałem już dostępne Pine64. https://forum.pin.
..p?tid=2021
tylko to znalazłem o HDMI-CEC

Steel_Rat
01-12-2018 20:23
A gdzie już można kupić? Narazie tylko czytałem, że będzie Smile

RaTaJ
01-12-2018 13:15
Athlon 200GE a o tym słyszeliście? Procesor PEREŁKA 4x 3,2Ghz i Vega 3 TDP35 wat za 250zł

RaTaJ
01-12-2018 13:14
Tak Proszę Pana Steel_Rat, a nie wiesz czy działa HDMI_CEC? Bo komuś działa trochę z nielicznymi telewizorami

Steel_Rat
25-11-2018 17:28
A ma się tez pojawić Rock Pi. https://forbot.pl.
..pi-id29663

37,128,342 unikalne wizyty