22 Luty 2019 08:24:21
Nawigacja
· Strona Główna
· Galeria
· Forum
· Linki

· Tomato by Shibby

· Wiki-OpenWrt
· Wiki-DD-WRT
· Emulatory sprzętu

Darowizna
Ostatnio na forum
Najnowsze tematy
· [MOD] FreshTomato-ARM
· Netgear R7000
· [K]ASUS RT-AC3200
· [MOD] FreshTomato-MIPS
· Konfiguracja Ubiquit...
· [S] Netgear R7000
· Co na iPhone 7 gener...
· R7000 made in Vietna...
· Jaki router kupić? Z...
· TL-WDR3500
· [MOD] Tomato by shibby
· problem z USB
· Alternatywa TPlink W...
· DualWAN i 2xPPPoE, F...
· TP-LINK AC7 i WiFi
· Problem z DNS i otwi...
· Router pod łącze 600...
· modem Huawei e3372 j...
· Homebrew na Mac
· ZTE F623 + Linksys W...
Najciekawsze tematy
· [MOD] Tomato by s... [13721]
· [MOD] FreshTomato... [619]
· Jaki router kupić... [542]
· [MOD] FreshTomato... [346]
· R7000 made in Vie... [23]
· Konfiguracja Ubiq... [14]
· TL-WDR3500 [10]
· Problem z DNS i o... [9]
· Co na iPhone 7 ge... [8]
· Alternatywa TPlin... [7]
· problem z USB [1]
· Netgear R7000 [0]
· [K]ASUS RT-AC3200 [0]
· [S] Netgear R7000 [0]
· DualWAN i 2xPPPoE... [0]
· TP-LINK AC7 i WiFi [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
39% [134 głosów]

Broadcom ARM
Broadcom ARM
49% [170 głosów]

Atheros
Atheros
6% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [2 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [10 głosów]

Ogółem głosów: 345
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38

Archiwum ankiet
Reklama
Twoje IP
54.235.55.253
Reklama
Zobacz temat
OpenLinksys » :: PORTAL :: » Tutoriale
 Drukuj temat
oscam na openwrt (ar71xx) i tomato k2.6
shibby Dziekuje za dotacje
W sumie rzecz sie tyczy 4 popularnych routerów
- openwrt - tplink 1043nd oraz linksys wrt160nl
- tomato - asus rt-n16 oraz netgear 3500l (na ddwrt też może działać, wszystko zależy od dostepności modułów)

Openwrt
Openwrt backfire dziala bezproblemu z czytnikami korzystajacymi z modulu ftdi_sio. Na chwile obecną moduł pl2303 stwarza problemy i oscam nie potrafi wykryć czytnika.
Testowane na tplinku + backfire 10.3.1-RC3

Download - http://openwrt.groov.pl/WR1043NDv1/backfire-10.3.1-RC3/packages/oscam_0.99.4svn-r2847-8_ar71xx.ipk

Paczka zawiera:
- oscam 0.99.4svn-r2847 dla architektury ar71xx
- wbudowany webif
- libusb (Adding smartreader support)
- domyslną konfigurację dla cyfry
- skrypt startowy


Instalacja
cd /tmp
wget http://openwrt.groov.pl/WR1043NDv1/backfire-10.3.1-RC3/packages/oscam_0.99.4svn-r2847-8_ar71xx.ipk
opkg install oscam_0.99.4svn-r2847-8_ar71xx.ipk
opkg update
opkg install kmod-usb-serial-ftdi


Tomato k2.6
Moduły ftdi_sio oraz pl2303 działają poprawnie od wersji beta20!
Testowane na Asusie RT-N16 + Tomato k2.6 beta20

Download - http://tomato.groov.pl/repo/oscam_0.99.4-svn2967-3_mipsel.ipk

Paczka zawiera:
- oscam 0.99.4svn, build #2967
- wbudowany webif
- domyslną konfigurację dla cyfry
- skrypt startowy


Instalacja
cd /tmp
ipkg update
wget http://tomato.groov.pl/repo/oscam_0.99.4-svn2967-3_mipsel.ipk
ipkg install oscam_0.99.4-svn2967-3_mipsel.ipk


Domyslne ustawienia

dostep do www:
- port 8989
- login admin
- haslo admin

port naslugu dla karty cyfry - 10100

UPDATE
Dla chetnych na testy wersja 1.0-unstable rev3849
Tomato: http://tomato.gro...mipsel.ipk
Openwrt: http://openwrt.gr...ar71xx.ipk
Edytowane przez shibby dnia 08-11-2010 08:29
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
jolero1000
a pliki conf oscama znajdują się w obrazie, czy są w pełni konfigurowalne ?
WRT54GL_ Kamikaze 7.09_2xRS232
TL-WR1043ND Gargoyle PL (by obsy)
 
shibby Dziekuje za dotacje
domyslna konfiguracja jest w obrazie, ustawiona pod cyfre oraz skonfigurowany webif. Wszystko po to by zaraz po instalacji odpalal sie oscam i mozna bylo zarzadzac nim np przez webif. Ale oczywiscie pliki sa w pelni konfigurowalne.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Czy paczka dla k2.6 zawiera moduły dla phoenixa pod usb?

Czy należy go zamontować?
Edytowane przez krystianman dnia 09-09-2010 14:47
 
shibby Dziekuje za dotacje
jezeli masz tomato beta20 to on ma juz w sobie odpowiedni modul a w skrypcie startowym jest jego zaladowanie.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Podłączyłem do aktywnego huba phoenixa i oscam go nie widzi, spowodowane jest to że skrypt oscam nie startuje.

funkcja insmod wyświetla mi taki komunikat:

Pobierz kod źródłowy  Kod źródłowy
root@unknown:/tmp/home/root# insmod ftdi_sio
insmod: can't insert '/lib/modules/2.6.22.19/kernel/drivers/usb/ftdi_sio.ko': unknown symbol in module, or unknown parameter




Edytowane przez krystianman dnia 09-09-2010 19:47
 
kinh
było wcześniej insmod usbserial ?
 
krystianman
kinh napisał/a:
było wcześniej insmod usbserial ?


poradziłem sobie takFrownsbin/modprobe -v ftdi_sio
 
shibby Dziekuje za dotacje
nie czytasz tego co napisalem. W skrypcie startowym jest juz ladowanie modulow, zobacz sobie

cat /opt/etc/init.d/oscam


Najwazniejsze to miec tomato beta20 i wlaczyc obsluge usb1.1!!
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Skrypt u mnie nie działa do końca dobrze, po uruchomieniu oscam nie działą w tle. Uruchamiam sobie go przez skrypt ini oscam -b
 
shibby Dziekuje za dotacje
oczywiscie wpisujesz
/opt/etc/init.d/oscam start
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
tylko jak tak wpiszę to skrypt nie chce działać w tle muszę ręcznie program uruchomić z parametrem -b
Edytowane przez krystianman dnia 10-09-2010 15:50
 
shibby Dziekuje za dotacje
jakis blad? komunikat cokolwiek?

u mnie bez problemu startuje

[root@groov /]$ /opt/etc/init.d/oscam start
Starting oscam...

[root@groov /]$ ps | grep oscam
15407 root 2744 S N oscam -b
15408 root 2720 S N oscam -b
15410 root 2744 S N oscam -b
15411 root 2744 S N oscam -b
15412 root 2744 S N oscam -b
15413 root 2744 S N oscam -b
15418 root 1224 R grep oscam
[root@groov /]$/opt/etc/init.d/oscam stop
Stopping oscam...Terminated
[root@groov /]$

Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
payo22
Hej,

mam problem z obsługą czytnika ftdi na Tomato K26 (b20) i Asusie WL-500W.
Przy starcie oscama dostaje błąd: Error activating card.
Wydaje mi się, że problem może być związany z tym, że nie mam włączonej obsługi ohci dla usb (tylko uhci).
A nie mam, bo ładowanie tego modułu powoduje, że router zalicza restart :/

Może któryś z was sprawdzić czy oscam i czytnik ftdi u was też się tak zachowuje przy włączonym tylko uhci?

@Shibby: wspominałeś w innym wątku, że kompilowałeś moduły sam. Kompilowałeś też może moduł uhci-hcd.ko? Chciałbym spróbować modułu z innego źródła niż dołączony do tomato.
Edytowane przez payo22 dnia 12-09-2010 22:29
 
shibby Dziekuje za dotacje
nie da sie. Jezeli modul juz jest w tomato to nie mozna zmusic go by zaladowal inny z podanej sciezki. To byl powod dla ktorego musialem zrezygnowac z beta10 i przejsc na beta20.

U mnie wlaczenie wszystkich modulow usb nie wplywa negatywnie na router. Moze czyszczenie nvram u ciebie jest wymagane...?

Odlacz czytnik i zaladuj modul i zobacz czy bez czytnika tez zaliczy restart.
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
Witam

Jest możliwość podmiany pliku oscama na starszą wersję w tej skompilowanej co jakiś czas występuje błąd:

Pobierz kod źródłowy  Kod źródłowy
c05 request_cw() failed on reader cyfra (0) errno=11, Resource temporarily unavailable




Problem jest znany i opisanyhttp://streamboar...ticket/649, występuje od wersji 2711.

Na tunerze mam wersję build 1881 i ten problem nie występuje.
Edytowane przez krystianman dnia 14-09-2010 22:58
 
shibby Dziekuje za dotacje
mowimy o oscamie pod openwrt czy tomato?
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
shibby napisał/a:
mowimy o oscamie pod openwrt czy tomato?


Pod tomato
 
shibby Dziekuje za dotacje
pozniej zrobie ci wersje 1881
Router: Ubiquiti EdgeRouter ER-4 (FTTH + LTE/failover, OpenVPN, DPI, VLAN)
Wi-Fi: Ubiquiti UAP-AC-Pro
LAN: Netgear GS110TP (8x GbE, 2x SFP, PoE, LACP, VLAN)
NAS: Netgear ReadyNAS Pro4 (2x 4TB/RAID1, 1x 1TB, LACP 2Gbit)
Controler: Raspberry Pi 2 Model B + HDD 1,8" 160GB (Unifi, NUT, CUPS, Pi Hole/DNS Server)
UPS: Eaton Ellipse Eco 650
 
krystianman
shibby napisał/a:
pozniej zrobie ci wersje 1881


Ok dzięki

Czy binarki pod DD-WRT z tego http://streamboar...oardid=236wątku będą działać na tomato?
Edytowane przez krystianman dnia 15-09-2010 13:52
 
Przejdź do forum:
Logowanie
Nazwa użytkownika

Hasło



Nie masz jeszcze konta?
Zarejestruj się

Nie możesz się zalogować?
Poproś o nowe hasło
Aktualnie online
· Gości online: 6

· Użytkowników online: 0

· Łącznie użytkowników: 23,856
· Najnowszy użytkownik: ageneral
Shoutbox
Musisz zalogować się, aby móc dodać wiadomość.

overflow2
21-02-2019 22:15
zaznaczasz w advanced "manage client-specific options" i ci się pokaże "allow only these clients"

man1
21-02-2019 16:11
@bigl - we freshtomato ? Ja tego nie widze Sad Moze to jest konfigurowane w jakims pliku konfiguracyjnym?

bigl
19-02-2019 15:30
Oczywiście że jest opcja wyblokowania pojedynczego useda w VPN - w Advanced jest opcja Allow Only These Clients

man1
03-02-2019 20:24
jest jakas opcja by tymczasowo zablokowac jednego z klientow openvpn ? Nie mam jak zrobic revoke dla jego klucza. Nie mam autoryzacji haslem.

mosfit
03-02-2019 19:29
a od czego masz samba lub ftp

man1
03-02-2019 12:40
Smile lubię się bawić w muzeum Grin

sszpila
03-02-2019 08:58
Dokładnie, skrosowane są linie TxD , RxD i pewnie któreś od potwierdzeń. To było jakjeszcze żyły dinozaury kiedy łączyłem ostatni raz komputery portem szeregowym

man1
02-02-2019 19:57
@sszpila - super, bardzo dziekuje Smile zakladam ze to jest cos w rodzaju skretki crossover?

sszpila
02-02-2019 18:43
Null modem

man1
02-02-2019 13:31
jesli chcialbym polaczyc dwa komputery przez rs232 to potrzebuje kabla NULL-MODEM, czy zwyklego ? Tak, wiem, zabawa w muzeum nie zwiazana z trescia serwisu. Ale sobota jest w koncu... Wink

majkel152
27-01-2019 11:39
@Adooni - zdziwił byś się jakie jaja potrafią w bloku się dziać z 2.4 - ba sam nie wierzyłem dopóki nie zbadałem sprawy , 5g jak ręką odjął Grin

Adooni
26-01-2019 19:55
co Wy tak wszyscy o tym 5Ghz - potrzebujecie tranfery ponad 450/600Mbit czy tak jak ja macie w eterze kilkadziesiat sieci 2.4 i slabo wam dziala. Przeciez 5GHz ma nawet gorszy zasieg

tamtosiamto
26-01-2019 11:29

urbek
26-01-2019 07:59
Posiadam WNR3500v1 tomato+optware. Nie narzekam ale chce się przesiąść na coś z 5ghz. Co polecacie ważne abym mogł optware zainstalowac

jurekk
20-01-2019 19:08
np. 2.4 np. Singapur a 5 - np Botswana

bigl
20-01-2019 17:47
Jaką kraj ustawić w R7000 na FreshTomato żeby zasięg sieci był największy? Chodzi mi o tryb dualny (2.4+5GHz)

Steel_Rat
19-01-2019 18:41
I kolejna luka w WIFI https://www.dobre.
..99814.html

37,652,643 unikalne wizyty