17 Maja 2022 15:49:57
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· Asus RT-AC56U mod to...
· EdgeRouter zamiast O...
· [MOD] FreshTomato-AR...
· [MOD] FreshTomato-MI...
· Własny NAS na Xpeno...
· [K] Unifi UAP-AC-PRO
· WNR3500Lv2 jako AP i...
· wi-fi, LTE/5G a foli...
· [S] Netgear Nighthaw...
· Jak wgrac FreshTomat...
· Jaki router i AP pod...
· Nowy router z transm...
· Router Asus RTU-N18U
· [K] skretka 50m
· Poptop PPTP - Statyc...
· Separate LAN + separ...
· AC56U - jak zrobić ...
· Zmiana na Ubiquiti
· UAP-AC-PRO podłącz...
· GT AC5300 podobno ni...
Najpopularniejsze obecnie wątki
· [MOD] FreshTomato... [691]
· [MOD] FreshTomato... [374]
· Asus RT-AC56U mod... [129]
· Własny NAS na Xp... [56]
· WNR3500Lv2 jako A... [7]
· EdgeRouter zamias... [6]
· wi-fi, LTE/5G a f... [2]
· [K] Unifi UAP-AC-PRO [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [147 głosów]

Broadcom ARM
Broadcom ARM
52% [209 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [13 głosów]

Ogółem głosów: 401
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.236.50.79
Zobacz wątek
OpenLinksys » :: ROUTERY :: » TP-Link
 Drukuj wątek
[Solved] Karta muzyczna USB i MPD - odtwarzanie muzyki z routera.
PawelW
Właśnie zakupiłem TL-1043ND wrzuciłem do niego firmware by Obsy z dnia 2010-06-01.
W miarę poradziłem sobie z konfiguracją dysku twardego ale teraz utknąłem przy poradniku uruchomienia dźwięku http://eko.one.pl/?p=openwrt-audio.
Karta muzyczna jest oparta na chipie Burr-Brown PCM 2702 i wygląda że się dobrze zainstalowała.
MPD też się zainstalowało podanym tam poleceniem bez błędów ale teraz po wpisaniu

/etc/init.d/mpd start
dostaje


root@OpenWrt:~# /etc/init.d/mpd start
/etc/rc.common: line 78: amixer: not found
/usr/bin/mpd: can't load library 'libdns_sd.so'

i nie wiem co dalej zrobić :-( Szukałem w google ale znalazlem tylko jeden temat traktująca o tym problemie ale nic mi to nie dało.
Proszę o pomoc.

Edit 1
Udało mi się naprawić ten błąd przez instalacje pakietu mDNSresponder ale teraz kolejny bład:

mpd: can't load library 'libavformat.so.52'


Czy jest jakieś inne repo dla MPD? W oryginalnym jest stara wersja 15.8-2 a najnowsza to 15.10 być może to by rozwiązało problem.

Edit 2
Znalazłem nowsze repo w którym są pakiety z trunka i tam jest nowsza wersja 15.8-3
http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/
Do pliku /etc/opkg.conf należy dodać na początku ten adres w takiej formie:


src/gz trunk http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages
src/gz packages http://downloads.openwrt.org/backfire/10.03/ar71xx/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay


Teraz należy usunąć MPD "opkg remove mpd" zrobić "opkg update" i "opkg install mpd"

wpisać "mpd" w linii komend, możliwe że dostaniemy taki komunikat:

mpd: can't load library 'libspeex.so.1'

więc robimy jeszcze "opkg install libspeex"

Po ponownym wpisaniu "mpd" wyskoczyło:


root@OpenWrt:~# mpd
Failed to load database: Failed to open database file "/mnt/dane/muzyka/mpd/database": No such file or directory
output: line 189: No such audio output plugin: oss
Aborted


Edit 3
Aby naprawić pierwszy błąd związany z brakiem bazy danych należy wpisać:

mpd --create-db

Jeżeli po wpisaniu tego polecenia pojawia się:


listen: Failed to listen on *:6600: Address already in use
Aborted

to znaczy że mpd jest już uruchomione i polecenie nie zostało wykonane.
Trzeba zabić mpd przez kill a numer PID można odczytać z polecenia top z pierwszej kolumny.

Aby naprawić drugi błąd trzeba zamiast OSS wybrać Alse w pliku konfiguracyjnym.

Teraz mpd uruchamia się bez błędów ale jeszcze nie udało mi się odtworzyć dźwięku.
Kolejny problem to mpc który nie może dodać pliku do odtwarzania mimo ustawienia w mpd.conf "Music directory" na /mnt/dane/muzyka gdzie znajduje się plik test.mp3:



root@OpenWrt:~# mpc add test.mp3
error: ACK [50@0] {add} directory or file not found


Edit 4
Uruchomienie mpd przez "/etc/init.d/mpd start" a nie samo mpd zwracało błąd braku amixer rozwiązaniem jest doinstalowanie Alsy


opkg install alsa-lib
opkg install alsa-utils


Teraz powstał kolejny problem: uruchomienie "/etc/init.d/mpd start" daje komunikat "amixer: Unable to find simple control 'PCM',0"

W alsamixer jest tylko jeden suwak o nazwie "Master" a nie PCM, zmieniłem już plik konfiguracyjny w sekcji alsa na:

# An example of an ALSA output:
#
audio_output {
   type      "alsa"
   name      "My ALSA Device"
   device      "hw:0,0"   # optional
##   format      "44100:16:2"   # optional
   mixer_device   "Master"   # optional
   mixer_control   "Master"   # optional
   mixer_index   "0"      # optional
}

jednak nadal mam ten sam komunikat.

Edit 4a
Należy edytować plik /etc/init.d/mpd
tam jest linia "amixer set PCM 40" w moim przypadku należy zmienić na "amixer set Master 40"
Linia ta ustawia początkową głośność odtwarzania przy starcie mpd.

Edit 5
Aby naprawić problem z dodawaniem plików należy wpisać polecenie:


root@OpenWrt:~# mpc update


Udało się osiągnąć taki stan:


root@OpenWrt:~# mpc add test.mp3
root@OpenWrt:~# mpc play
test.mp3
[playing] #1/1   0:00/2:51 (0%)
volume:100%   repeat: off   random: off   single: off   consume: off

ale nadal brak dźwięku z karty muzycznej.

Edit 5a
W pliku konfiguracyjnym mpd.conf w linii "name" trzeba wpisać nazwę karty dzwiękowek.
Nazwę pozyskamy uruchamiając alsamixer i odczytując pierwsza linię która zaczyna się od "Card: " , w moim przypadku będzie to tak:
"Card: Burr-Brown Japan PCM2702" i to wpisuje w tym miejscu


audio_output {
   type      "alsa"
   name      "Burr-Brown Japan PCM2702"


teraz kolejny komunikat błędu:


root@OpenWrt:~# mpc play
test.mp3
[playing] #1/1   0:00/2:51 (0%)
volume:100%   repeat: off   random: off   single: off   consume: off
root@OpenWrt:~# ALSA lib pcm_direct.c:1605:(snd1_pcm_direct_parse_open_conf) The field ipc_gid must be a valid group (create group audio)


Edit 6
No tak niby komunikat "The field ipc_gid must be a valid group (create group audio)" jest oczywisty należy stworzyć grupę użytkowników o nazwie audio.
Najpierw znalazłem opis wykonania tej czynności za pomocą "addgroup" jednak ten sposób nie działa ponieważ BusyBox w OpenWRT nie ma wkompilowanego tego polecenia.
Pomocny okazał się ten opis gdzie dowiedziałem się o braku adduser ale też o możliwości edycji pliku /etc/group
Plik należny edytować dodając audio:x:555: będzie to tak wyglądało:


root:x:0:
audio:x:555:
nogroup:x:65534:


I w końcu się udało karta zagrała ale bardzo cicho.
W moim przypadku zbędne jest ustawianie poziomu głośności przez "amixer set Master 40" na poziom 40.
W pliku /etc/init.d/mpd wykomentowałem tą linię wstawiając # przed tekstem.
Uruchomiłem alsamixer i ustawiłem poziom głośności na 100. I teraz słychać ok.

Kosztowało mnie to około 5 godzin szukania rozwiązań, mam nadzieje że przyda się komuś taki poradnik.
Edytowany przez PawelW dnia 03-06-2010 21:09
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 6

· Użytkowników online: 0

· Łącznie użytkowników: 24,087
· Najnowszy użytkownik: waldix
Czat
Musisz się zalogować, aby opublikować wiadomość.

Adooni
19-04-2022 05:48
CTF (Cut-Through Forwarding) w /Advanced/Miscella
neous/

Maniek91PL
11-04-2022 20:40
przypomni mi ktoś szybko co ustawić aby nie dławiło mi prędkości łącza po kablu ? w tomato

pedro
22-02-2022 15:54
Pytaj w odpowiednim temacie, podając namiary co za FW, jaki router, jakie dokładnie ustawienia, itd. Nikt nie ma kryształowej kuli...

djwujek
19-02-2022 13:04
Czemu w zakładce device list przy trybie ap pokazuje adres ip i nazwę hosta tylko pierwszego podłączonego komputera a reszty nie ??

TheWB
07-02-2022 11:48
Witam tak się zastanawiam czy w tomato można się zabezpieczyć przed takimi atakami https://www.youtub
e.com/watch?v=dI-O
rlUulkU&ab_chan
nel=Nicek

tamtosiamto
05-02-2022 19:24
rozlacza w pewnych konfiguracjach, pisalem kiedys o tym. Ale dalej bede sie upierac, ze wtracanie opensense w temacie aimesh asus jest bez sensu :-D

Adooni
04-02-2022 20:33
rozlacza czyli nie stabilny FW. FW Asusa nie jest stabilny a Asus nie potrafi rozwiazac problemu AiMesh od poczatku. Na SNB forum mzoesz znalesc scrypty na nody gdyz czasami rozlacza co kilka godz.

tamtosiamto
04-02-2022 13:11
ok, tylko co ma piernik bo nie rozumiem? Grin

Adooni
03-02-2022 12:19
co tu duzo gadac ja np tomato mialem przez 4lata nie resetowne a RMerlin czy ori nie wytrzyma wiecej niz kilka tyg. OPNsense co pol roku update a tak jak skala.

tamtosiamto
02-02-2022 20:25
kiedys nie bylo Smile btw mam juz guest network w aimesh, ale aimesh i tak jest jaki byl, tzn do doopy, dalej rozlacza

51,469,288 unikalnych wizyt