29 Listopada 2021 09:40:35
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [DIY] NAS bez kompro...
· Jaki router wybrać-...
· [S] Sprzedam Asus SC...
· AiMESH Asusa.
· Merlin/transmission ...
· Jaki Router ? PILNE !
· WNR3500Lv2
· Przekierowanie użyt...
· Debrick netgear R7000
· [S] Unifi U6-LITE
· Przepustowość łą...
· Błąd nr 13 - insta...
· Multiroom N z wykorz...
· Słaby transfer po W...
· reverse proxy nginx ...
· OMV priorytet aplikacji
· Konfiguracja serwera...
· Nie mogę dodawać s...
· rt-ac87u maksymanla ...
· Nastepca RT18
Najpopularniejsze obecnie wątki
· WNR3500Lv2 [727]
· Jaki router wybra... [63]
· Debrick netgear R... [60]
· AiMESH Asusa. [36]
· Przekierowanie u... [11]
· [DIY] NAS bez kom... [10]
· Jaki Router ? PIL... [6]
· [S] Unifi U6-LITE [6]
· Merlin/transmissi... [4]
· [S] Sprzedam Asus... [2]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [146 głosów]

Broadcom ARM
Broadcom ARM
52% [205 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 395
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
3.89.204.127
Zobacz wątek
OpenLinksys » :: OPROGRAMOWANIE :: » Tomato - firmware
 Drukuj wątek
[MOD] Tomato 1.28 ND USB na kernelu 2.6
shibby
Rozpocznę nowy temat gdyż oba projekty są rozwijane równolegle.

Nimniejszy mod to EKSPERYMENTALNA wersja tomato na kernelu 2.6 posiadająca wszystkie zalety wcześniejszego USB MOD oraz wspierająca dodatkowo nowe urządzenia broadcoma.

Obecna wersja: build54

Wszelkie informacje takie jak wspierany sprzęt, changelog, wersje znajdziecie na stronie domowej projektu:
http://tomatousb.org/

Download:
http://sourceforge.net/projects/tomat...28beta%29/

Źródło:http://www.linksysinfo.org/forums/sho...hp?t=63587

Instrukcja step-by-step instalacji na asusie RT-N1x oraz Netgearze (mozliwe ze na innych tez tak nalezy wgrywac)
http://www.linksysinfo.org/forums/sho...tcount=278

To jest wczesna wersja BETA, więc proszę nie wymagać za dużo. Wgrywasz na własną odpowiedzialność. Nie wgrywaj jeżeli obawiasz sie uwalenia routera i nie wiesz jak go odratować!!
Edytowany przez shibby dnia 10-01-2011 15:28
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
shibby
Jak wgrac tomato K2.6 - instrukcja w 7 krokach:
1) przywrocic ustawienia domyslne routera
2) wgrac ddwrt mini przez www (link: http://www.dd-wrt.com/dd-wrtv2/downloads/others/eko/BrainSlayer-V24-preSP2/01-16-10-r13637/broadcom_K26/dd-wrt.v24-13637_NEWD-2_K2.6_mini_RT-N16.trx) oczywiscie dla innych routerow np netgear bedzie to odpowiednio inny plik
3) wrzywrocic ustawienia domyslne ddwrt, zalogowac sie na www i ustawic jakies haslo np root/root
4) polaczyc sie telnetem do ddwrt i wydac komende: nvram get http_passwd. Zapisac wynik. To bedzie nasze haslo pierwszego logowania do tomato!
5) Zmienic rozszerzenie obrazu tomato z trx na bin i wgrac przez gui ddwrt.
6) zalogowac sie do tomato podajac wczesniej zapisane haslo i koniecznie zrobic erase all data in NVRAM memory.
7) gotowe, teraz mozemy zalogowac sie do tomato na domyslne dane admin/admin.

Czasami po wgraniu tomato mozna napotkac na problem z niemozliwoscia otrzymania adresu ip dla WAN. Ja tak np mialem. Jezeli tak sie zdarzy to przy wlaczonym routerze nalezy przytrzymac na pare sekund przycisk RESTORE z tylu obudowy i jak dioda PWR zaczeni mrugach lub zgasnie to puscic. Czynnosc powtarzac parukrotnie az WAN dostanie ip. U mnie meczylem sie z tym z dobre 15min az zadzialalo. Pozniej warto jeszcze raz wyczyscic nvram i gotowe.

Sposob zalecany do Asusa RT-N1x oraz Netgeara WNR3500L przy przechodzeniu z oryginalnego softu. C odo innych routerów to wgrywamy najpierw standartowe tomato i później upgrade do K26. Nalezy pamiętać koniecznie o wyczyszczeniu nvram po flashu.
Edytowany przez shibby dnia 08-04-2010 13:40
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
obsy
OT: Było "oh i ah" jakie to openwrt jest niedobre, bo tyle tplinków uwaliło. Ciekawe ile teraz netgearów zostanie uwalonych Smile
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
Noo i jeden asus rt-n16 Smile
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
obsy
No i po co to napisałeś. Teraz już wiedzą że tego nie wolno robić.... (a może ktoś się złapie jednak?)
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
@bosiak monituj bledy odrazu na linksysinfo
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
Adik
Wgrałem do WNR3500L wersję tomato-1.27-NDUSB-9044MIPSR2-beta05u-Ext. Mile zaskoczenie, WAN ruszył, komunikacja z Siemensem SpeedStream 4100 poprawna. Zobaczymy czy nie Netgear nie będzie zrywał połączenia.
ITX-Sklep.pl - miniPC - komputery jutra | DeltaKOMP - us?ugi informatyczne - Lubicz, Brzoz?wka, Toru?
 
Adik
Niestety disconnect co kilkanaście minut. Obciążenie routera i łącza zerowe.



Feb 19 22:49:18 unknown daemon.info pppoe[385]: Sending LCP Termination-Request
Feb 19 22:49:18 unknown daemon.info pppoe[385]: Received LCP Termination-Ack
Feb 19 22:49:18 unknown daemon.info pppoe[385]: Connection terminated.
Feb 19 22:49:18 unknown daemon.notice pppoe[385]: Disconnected.
Feb 19 22:49:18 unknown daemon.notice pppoe[385]: Connect time 45.1 minutes.

Feb 19 23:11:57 unknown daemon.info pppoe[971]: Sending LCP Termination-Request
Feb 19 23:11:57 unknown daemon.info pppoe[971]: Received LCP Termination-Ack
Feb 19 23:11:57 unknown daemon.info pppoe[971]: Connection terminated.
Feb 19 23:11:57 unknown daemon.notice pppoe[971]: Disconnected.
Feb 19 23:11:57 unknown daemon.notice pppoe[971]: Connect time 22.6 minutes.

Feb 19 23:32:05 unknown daemon.info pppoe[1234]: Sending LCP Termination-Request
Feb 19 23:32:05 unknown daemon.info pppoe[1234]: Received LCP Termination-Ack
Feb 19 23:32:05 unknown daemon.info pppoe[1234]: Connection terminated.
Feb 19 23:32:05 unknown daemon.notice pppoe[1234]: Disconnected.
Feb 19 23:32:05 unknown daemon.notice pppoe[1234]: Connect time 20.1 minutes.

Edytowany przez Adik dnia 19-02-2010 23:35
ITX-Sklep.pl - miniPC - komputery jutra | DeltaKOMP - us?ugi informatyczne - Lubicz, Brzoz?wka, Toru?
 
Adik
Jeśli ktoś chce firmware beta05 z poprawiona obsługą PPPoE to mogę podesłać. Od kilku godzin router połączenia nie zrywa. Smile
Edytowany przez Adik dnia 20-02-2010 11:14
ITX-Sklep.pl - miniPC - komputery jutra | DeltaKOMP - us?ugi informatyczne - Lubicz, Brzoz?wka, Toru?
 
shibby
a co teddy podeslal ci inna? Problem wystepowal tylko w netgearach czy w innych routerach tez?
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
obsy
Netgeat WNDR3500L + Tomato Firmware v1.27.9044 MIPSR2-beta05u ND USB Ext

Dysk vfat, ten sam co zawsze, plik 2.2G. Odczyt z ftp (anonymus) tego pliku:


$ wget ftp://192.168.40.1/sda1/a.bin -O /dev/null
--2010-02-20 12:30:41--  ftp://192.168.40.1/sda1/a.bin
           => `/dev/null'
Łączenie się z 192.168.40.1:21... połączono.
Logowanie się jako anonymous ... Zalogowano się!
==> SYST ... zrobiono.    ==> PWD ... zrobiono.
==> TYPE I ... zrobiono.  ==> CWD (1) /sda1 ... zrobiono.
==> SIZE a.bin ... 2347244018
==> PASV ... zrobiono.    ==> RETR a.bin ... zrobiono.
Długość: 2347244018 (2,2G) (nie autorytatywne)

100%[===================================>] 2.347.244.018 4,87M/s   w  6m 40s   

2010-02-20 12:37:21 (5,60 MB/s) - zapisano `/dev/null' [2347244018]


5,60MB/s średnia prędkość odczytu.

I jeszcze dla ciekawskich dmesg


# dmesg 
Linux version 2.6.22.19 (root@tomato) (gcc version 4.2.4) #1 Wed Feb 17 22:53:08 EST 2010
CPU revision is: 00019740
Found a 8MB ST compatible serial flash
Determined physical RAM map:
 memory: 04000000 @ 00000000 (usable)
Entering add_active_range(0, 0, 16384) 0 entries of 256 used
Zone PFN ranges:
  Normal          0 ->    16384
  HighMem     16384 ->    16384
early_node_map[1] active PFN ranges
    0:        0 ->    16384
On node 0 totalpages: 16384
  Normal zone: 0 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 16384 pages, LIFO batch:3
  HighMem zone: 0 pages used for memmap
Built 1 zonelists.  Total pages: 16384
Kernel command line: root=/dev/mtdblock2 noinitrd console=ttyS0,115200
Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, linesize 32 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
PID hash table entries: 512 (order: 9, 2048 bytes)
CPU: BCM4716 rev 1 pkg 10 at 453 MHz
Using 226.500 MHz high precision timer.
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 61256k/65536k available (2074k kernel code, 4220k reserved, 441k data, 116k init, 0k highmem)
SLUB: Genslabs=17, HWalign=32, Order=0-1, MinObjects=4, CPUs=1, Nodes=1
Calibrating delay loop... 225.28 BogoMIPS (lpj=112640)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
PCI: Using membase 8000000
PCI: Disabled
PCI: Fixing up bus 0
PCI: Fixing up bus 1
Time: MIPS clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
squashfs: version 3.0 (2006/03/15) Phillip Lougher
io scheduler noop registered (default)
HDLC line discipline: version $Revision: 4.8 $, maxframe=4096
N_HDLC line discipline registered.
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0x0 (irq = 8) is a 16550A
PPP generic driver version 2.4.2
PPP BSD Compression module registered
NET: Registered protocol family 24
pflash: found no supported devices
Creating 6 MTD partitions on "sflash":
0x00000000-0x00040000 : "pmon"
0x00040000-0x007e0000 : "linux"
0x00118fcc-0x00540000 : "rootfs"
0x00540000-0x007e0000 : "jffs2"
0x007f0000-0x00800000 : "nvram"
0x007e0000-0x007f0000 : "board_data"
GACT probability NOT on
Mirror/redirect action on
netem: version 1.2
u32 classifier
    Performance counters on
    input device check on
    Actions configured
Netfilter messages via NETLINK v0.30.
nf_conntrack version 0.5.0 (512 buckets, 4096 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 1
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear
All bugs added by David S. Miller
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 116k freed
Warning: unable to open an initial console.
et: module license 'unspecified' taints kernel.
PCI: Setting latency timer of device 0000:00:02.0 to 64
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.10.56.46
PCI: Setting latency timer of device 0000:00:01.0 to 64
eth1: Broadcom BCM4329 802.11 Wireless Controller 5.10.56.46
net/ipv4/netfilter/tomato_ct.c [Feb 17 2010 22:59:09]
Algorithmics/MIPS FPU Emulator v1.5
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
SCSI subsystem initialized
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
PCI: Setting latency timer of device 0000:00:04.1 to 64
ehci_hcd 0000:00:04.1: EHCI Host Controller
ehci_hcd 0000:00:04.1: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:04.1: irq 5, io mem 0x18004000
ehci_hcd 0000:00:04.1: USB 0.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
vlan1: add 01:00:5e:00:00:01 mcast address to master interface
usb 1-1: new high speed USB device using ehci_hcd and address 2
vlan1: dev_set_promiscuity(master, 1)
device eth0 entered promiscuous mode
device vlan1 entered promiscuous mode
device eth1 entered promiscuous mode
br0: port 2(eth1) entering learning state
br0: port 1(vlan1) entering learning state
br0: topology change detected, propagating
br0: port 2(eth1) entering forwarding state
br0: topology change detected, propagating
br0: port 1(vlan1) entering forwarding state
vlan2: Setting MAC address to  00 26 f2 ba d6 ff.
vlan2: add 01:00:5e:00:00:01 mcast address to master interface
usb 1-1: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 0:0:0:0: Direct-Access     Generic  USB Disk         9.02 PQ: 0 ANSI: 2
sd 0:0:0:0: [sda] 117304992 512-byte hardware sectors (60060 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] 117304992 512-byte hardware sectors (60060 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00
sd 0:0:0:0: [sda] Assuming drive cache: write through
 sda: sda1
sd 0:0:0:0: [sda] Attached SCSI disk
usb-storage: device scan complete

Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
na asusie z dyskiem z ext2 mam deczko ponad 7MB/s (odczyt).

Sprawdzales z jumbo frame?
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
obsy
Tak, jest bez zmian. O ile ta opcja w tomato działa i switch to wspiera. Ale i tak jest bez zmian.
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
shibby
u mnie wlaczenie jumbo frame zwiekszynie nieznacznie transfer. Bez tego mialem ok 6MB/s.

Ale to ma beta04. Nie wgrywam bety05 poki adik nie odpowie na moje pytanie w sprawie pppoe, bo na becie04 nie mam z tym problemow.
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
obsy
Ja bez pppoe jadę, tylko na zwykłym połączeniu, wiec Ci tego też nie powiem.

Natomiast ciekawostka: przestał piszczeć. Albo mi na słuch padło.
Masz niepotrzebny ruter, uszkodzony czy nie - ch?tnie przygarn? go.
http://eko.one.pl - prawie wszystko o OpenWrt
http://openrouter.info
 
Adik

Cytat

shibby napisał/a:
a co teddy podeslal ci inna? Problem wystepowal tylko w netgearach czy w innych routerach tez?


Raczej we wszystkich, winny był patch Linksys GPL PPPoE fix, teddy skompilował firmware bez niego.

WNR3500L u mnie od początku nie piszczał, na pewno bym wyłapał. Kilka lat temu Asmax nieźle dawał mi po uszach. Smile Generalnie tego sprzętu nie polecę nikomu.

@shibby możesz przetestować czy zmiana mocy sygnału WiFi zrywa Ci połączenie poprzez WAN?
Edytowany przez Adik dnia 20-02-2010 20:34
ITX-Sklep.pl - miniPC - komputery jutra | DeltaKOMP - us?ugi informatyczne - Lubicz, Brzoz?wka, Toru?
 
shibby
na beta03 i 04 zmienialem moc i nie mialo to wplywu na WAN.

nadal nie wiem czy ta beta05 z linku to ta juz poprawiona czy nie. Mam polaczenie pppoe i nie moge sobie pozwolic na ekperymenty bo mnie w sieci zatluka Smile
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
SynC
może już śpią wszyscy Smile
 
Adik
Poprawiony firmware jak narazie działa bez zarzutu.

img29.imageshack.us/img29/3046/wnr3500lwantomato.jpg
ITX-Sklep.pl - miniPC - komputery jutra | DeltaKOMP - us?ugi informatyczne - Lubicz, Brzoz?wka, Toru?
 
shibby
@Adik ze tak powiem moglbys przeczytac to co pisze i odpowiedziec? Bo juz 2gi dzien czekam na odpowiedz na zadane pytanie.

Cytat

nadal nie wiem czy ta beta05 z linku to ta juz poprawiona czy nie.


Jak nie ma i dostales jakas wersje od teddiego na priv to zamiesc tu link.
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 5

· Użytkowników online: 0

· Łącznie użytkowników: 24,053
· Najnowszy użytkownik: jas7o
Czat
Musisz się zalogować, aby opublikować wiadomość.

maxikaaz
21-11-2021 17:35
@man1 to puść sobie to światło do piwnicy, stamtąd wypuść skrętkę jakimś pionem wentylacyjnym do mieszkania.

man1
21-11-2021 12:55
juz mam odpowiedz - w przypadku uslugi ftth 900/300 na laczach Orange nie moga tego puscic oficjalnie konwerterem na skretke.

man1
19-11-2021 20:25
czy są tu posiadacze ftth od tmobile? Mieszkam w starym bloku i nie moge wprowadzic swiatlowodu do lokalu, wiec chcialbym by uzyli konweretra na skretke. A tego zrobic podobno nie mogą...

jurekk
05-11-2021 14:27
Ponoć ax82u ma mieć port RMerlina, sam Merlin o tym mowil to mzoe byc najbardziej ekonomiczna wersja

AdrianAdi
05-10-2021 23:03
Przymierzam się do kupna takiego i mam kilka pytań z tym zwoązanych

AdrianAdi
05-10-2021 23:02
Jest tu kto?

AdrianAdi
05-10-2021 22:59
Witam mam pytanie odnośnie routerów gamingowych do ps4 czyli konsoli

Maniek91PL
04-09-2021 10:34
Wink super ! Dzięki ! Adooni ! już testuje co i jak

Adooni
04-09-2021 06:31
sprawdzasz w status - overview, a zmieniasz w Basic - Network

Maniek91PL
03-09-2021 22:37
jak sprawdzić i zmienić kanał w wifi 2.4 w tomato ? Shock

46,266,680 unikalnych wizyt