07 Grudnia 2021 04:56:03
Nawigacja
· Strona Główna
· Forum

· Tomato by Shibby
· FreshTomato


Wątki na forum
Najnowsze dyskusje
· [MOD] FreshTomato-AR...
· [S] ASUS RT-AC66U
· Jaki Router ? PILNE !
· WNR3500Lv2
· AiMESH Asusa.
· Współpraca Tomato ...
· niepoprawny timestam...
· [MOD] FreshTomato-MI...
· Błąd nr 13 - insta...
· ASUS RT-AX86U+świat...
· [DIY] NAS bez kompro...
· Jaki router wybrać-...
· [S] Sprzedam Asus SC...
· Merlin/transmission ...
· Przekierowanie użyt...
· Debrick netgear R7000
· [S] Unifi U6-LITE
· Przepustowość łą...
· Multiroom N z wykorz...
· Słaby transfer po W...
Najpopularniejsze obecnie wątki
· WNR3500Lv2 [738]
· [MOD] FreshTomato... [640]
· [MOD] FreshTomato... [343]
· AiMESH Asusa. [37]
· Błąd nr 13 - in... [10]
· Jaki Router ? PIL... [9]
· [S] ASUS RT-AC66U [4]
· niepoprawny times... [2]
· Współpraca Toma... [0]
Ankieta
Jaki procesor posiada twój router?

Broadcom MIPSEL
Broadcom MIPSEL
37% [146 głosów]

Broadcom ARM
Broadcom ARM
52% [205 głosów]

Atheros
Atheros
5% [21 głosów]

Marvell
Marvell
1% [4 głosów]

Ralink
Ralink
1% [3 głosów]

Intel/AMD/VIA
Intel/AMD/VIA
1% [4 głosów]

Żaden z powyższych
Żaden z powyższych
3% [12 głosów]

Ogółem głosów: 395
Musisz zalogować się, aby móc zagłosować.
Rozpoczęto: 02/02/2015 09:38
Twoje IP
54.227.97.219
Zobacz wątek
 Drukuj wątek
Własny NAS na Xpenology
shibby
Przez wiele lat dzielnie służył mi ReadyNAS Pro4. Problemy z jego wydajnością zacząłem zauważać, gdy zainteresowałem się dockerem. Przyszedł zatem czasu poszukania sobie innego, wydajniejszego rozwiązania. Swoje poszukiwania skierowałem w stronę Synology, ponieważ bardzo przypadł mi do gustu jego interfejs i możliwości konfiguracji. Projekt Xpenology znalem już wcześniej ale bardziej od strony teoretycznej niż praktycznej. Przyszedł więc czas na ugryzienie tematu po raz kolejny.

Dobór sprzętu a kompatybilność

Dobór sprzętu to największa bolączka przy Xpenology. Sprawdziłem łączenie 7 płyt głównych i rozwiązań ITX i w połowie przypadków Xpenology nie działało w ogóle albo nie dało się uruchomić najnowszej wersji 6.2.x - działała co najwyżej wersja 6.1.x.

Zdecydowanie polecam dobór sprzętu od Coffee Lake w górę, czyli min. 6-ta generacja CPU od Intela. Wszystkie testowane przeze mnie zestawy (3 płyty) działały w najnowszej wersji.
Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.
Jeden zestaw na Sandy Bridge (2-gen) też zadziałał (z użyciem softu dla DS3615xs), co było sporym zaskoczeniem.

Jeszcze jeden argument przemawia za użyciem nowszej generacji procesora: od Haswella w górę można użyć obrazu dla DS918+, który jest na nowszym kernelu i wspiera SSD Cache oraz SHR (Synology-Hybrid-Raid).

Moje poszukiwania stanęły na dość ciekawej płycie LR-i5S62T2

www.minicase.net/Files/UploadFiles/image/intel-core-T2/07.jpg



która znajdowała się komputerku o tajemniczej nazwie "EDI5-6200U-L1" zakupionej na stronie mini-komputery.pl - produkt nie jest już dostępny.

Płyta o tyle ciekawa, że posiada wlutowany procesor i5-6200u, dwa sloty SO-DIMM z obsługą pamięci do 32GB, port miniPCIE, port M.2, 2x Gigabit LAN oraz wbudowany układ zasilający (podpina się zasilacz laptopowy).
Największym mankamentem była obsługa tylko dwóch portów SATA. Tu z pomocą przyszedł Aliexpress, na którym to zakupiłem kontroler miniPCIE-2xSATA (koszt 35pln)

openlinksys.info/images/xpenology/1.jpg


Prawdziwym wyzwaniem okazał się dobór obudowy. Wymagania były w sumie niewielkie: obsługa 4-ch dysków 3.5" i niewielki rozmiar. Niestety, ceny dedykowanych rozwiązań np Inter-Tech IPC SC-4100 to koszt ponad 400pln za samą obudowę

images.morele.net/i1064/827764_0_i1064.jpeg


Docelowo zakupiłem obudowę Cooler Master Elite 110 (RC-110-KKN2) w cenie ~180pln. Zmodyfikowałem w niej jedynie sposób montażu dysków, które umieściłem pionowo by poprawić ich wentylację. Finalny efekt prezentuje się następująco

openlinksys.info/images/xpenology/2.jpg openlinksys.info/images/xpenology/3.jpg


openlinksys.info/images/xpenology/4.jpg openlinksys.info/images/xpenology/5.jpg


openlinksys.info/images/xpenology/6.jpg


Jak widać na ostatnim zdjęciu, zamontowałem również dysk SSD M.2 SATA. Niedługo po tym zamontowałem drugi dysk SSD 2.5" i z obu dysków utworzyłem SSD Cache Read-Write. Całość prezentuje naprawdę przyzwoitą wydajność.

openlinksys.info/images/xpenology/7.jpg openlinksys.info/images/xpenology/8.jpg


Jeżeli ktoś będzie miał pytania dotyczące Xpenology lub problemy z jego postawieniem, to służę pomocą.


O krok za daleko

Przyszedł raz moment gdy zapragnąłem 10GbE LAN w moim NASie Grin Tylko jak tu podpiąć kartę PCIE do komputera, który nie posiada portu PCIE Frown I znów Aliexpress nie zawiódł Wink Zakupiłem Riser PCIe x4 3.0 PCI-E 4x do M.2 NGFF NVMe

ae01.alicdn.com/kf/Hd7d0f84e6e394a7d83c55a75a023eda54.jpg


Wsadziłem kartę z portem SFP+ i o dziwo karta została rozpoznana.

bpccdn.fra1.digitaloceanspaces.com/original/3X/2/d/2d42e74e92540fe5eed75c152d07f4dbcd8e157d.png


Szybko jednak okazało się, że z niezrozumiałych dla mnie przyczyn NAS nie chciał trzeciej sieciówki podnieść. Rozwiązanie znalazłem go kilku godzinach... Otóż mam obraz z ds918+ która ma na sztywno wpisany limit 2 kart sieciowych. Przeedytowałem więc plik /etc/synoconfig.conf w w linii
maxlanport=2
zmieniłem na 4

Po restarcie karta śmigała aż miło. Wydajność jednak nie powalała a ograniczeniem okazała się macierz RAID - dobijałem do ~250MB/s.

Z racji kosztów tego rozwiązania (2x karta 10GbE, switch 10GbE, kable DAC, do łącznie daje kwotę ~1500pln) temat odpuściłem. Zamiast tego postanowiłem skorzystać z dobrodziejstw "SMB Multichannel", dzięki któremu można zsumować kilka linków LAN w jeden. Co ważne, nie wymaga to użycia żadnego specjalistycznego sprzętu - zwykły switch wystarczy.

Całość sprowadza się do lekkiej modyfikacji pliku smb.conf na synology a szczegółowy opis znajdziecie pod linkiem https://blog.azureinfra.com/2018/09/1...indows-10/
Efekt cieszy

bpccdn.fra1.digitaloceanspaces.com/original/3X/2/8/28939ae973d52911bf8092428a92baacb4dec2e5.png



Pozdrawiam
Edytowany przez shibby dnia 05-01-2021 09:29
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
Adooni
nastepny fajny artykul

czy nie myslales o dodaniu SSD z Zpool log i cache tak aby obejsc ograniczenie macierzy RAID HDD? - ok jak widac nie doczytalem :)

sry za taki pomieszany code ponizej robilem to pewien czas temu i wszystko zapisalem krok po kroku. wiec i komendy i sprawdzanie itd. Ja nie tak jak Ty jestem w stanie z palca to podac.

SWAP -The kernel will swap only to avoid an out of memory condition)
sysctl -w vm.swappiness=0 

create partitions on SSD
dev/sdf4 - log 8192M
dev/sdf5 - cache 81920M

reboot,

RAIDZ2: pool ( storage name) = HDD
zpool create -f -o ashift=12 raidz2 /dev/sda /dev/sdb /dev/sdd /dev/sde
zpool add -f log /dev/sdf4
zpool add -f cache /dev/sdf5

zpool status
zfs list

zfs set compression=lz4
zfs get compression
zpool export
zpool import -d /dev/disk/by-id
zpool status


ja tak zrobilem na Proxmox i potem jako NAS uzywam OMV - wyciaga mi okolo 120MB na HPE MSgen8 wiec mozna powiedziec ze max lacza 1Gbit

a tak dodatkowo podpytam czy kiedys uzywales OMV? jak to ze strony expera widzisz w porownaniu to Xpenology. Mi pasuje OMV gdyz na youtube masz kanal "Techno Dad Life" i bardzo lopatologicznie, krok po kroku pokazuje co zrobic aby dockera wtyczki dodawac https://www.youtube.com/channel/UCX2V...aMzhGFZ7PA
UPC 300/20 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.3_2+amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED, SSD,
 
shibby
OMV bawiłem się może 15min. Podobnie zresztą jak FreeNASem. Nic specjalnego by się wypowiadać w temacie.

Synology jest klasą samą w sobie, nawet obsługa dockera jest z poziomu GUI. Prostota a jednocześnie zaawansowane funkcje jakimi jest nafaszerowany dość trafnie przypomina mi Tomato Smile

Najgorsze zdanie mam odnośnie Qnapa - no nie polubiliśmy się raczej Grin
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
mosfit

Cytat

Synology jest klasą samą w sobie


Dokładnie !
Świetne artykuły jak zawsze !

Głównie problemy z poprawnym wystartowaniem Loadera dotyczą zazwyczaj ustawień w bios-ie lub nie kompatybilną karta sieciową Lan (głównie w DS918+)
Router- Ubiquiti USG-Pro-4 (FTTH)
Lan- Ubiquiti Switch US-8-150W
Wifi- UniFi AP-AC-Pro + UAP + 2x Ap OpenWrt 21.02
Nas- XPEnology DS918+ i5-6400, 16GB ram, 3x 2TB/RAID5, SSD-512gb cache _controller unifi_Pi-hole_Home Asistan
 
shibby
właśnie na brak obsługi karty LAN widzę największy problem. Często jest tak, że loader startuje, Assistant widzi nowe urządzenie a po instalacji softu już NAS znika bezpowrotnie. Próbowałem też instalować extrasy ale na nic.

Probowałem też obrazy dla ds3615xd ale bez większych efektów, no chyba że mowa o starszych sprzętach, z którymi 918+ nie jest w ogóle kompatybilny. Miałem też jeden przypadek gdzie jedynie starszy loader i starszy soft 6.1.x zadziałał. Próba aktualizacji kończyła się fiaskiem. No i wisienka na torcie czyli poleasingowy Dell SFF, który mimo różnych kombinacji nawet na samym loaderze nie był widziany (brak sterów do LANu).

Zdecydowanie najmniej problemów miałem z Coffee Lake. 3 różne zestawy płyt+cpu i wszystkie 3 wystartowały.
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
majkel152

Cytat

shibby napisał(a):

właśnie na brak obsługi karty LAN widzę największy problem. Często jest tak, że loader startuje, Assistant widzi nowe urządzenie a po instalacji softu już NAS znika bezpowrotnie. Próbowałem też instalować extrasy ale na nic.

Probowałem też obrazy dla ds3615xd ale bez większych efektów, no chyba że mowa o starszych sprzętach, z którymi 918+ nie jest w ogóle kompatybilny. Miałem też jeden przypadek gdzie jedynie starszy loader i starszy soft 6.1.x zadziałał. Próba aktualizacji kończyła się fiaskiem. No i wisienka na torcie czyli poleasingowy Dell SFF, który mimo różnych kombinacji nawet na samym loaderze nie był widziany (brak sterów do LANu).

Zdecydowanie najmniej problemów miałem z Coffee Lake. 3 różne zestawy płyt+cpu i wszystkie 3 wystartowały.


no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com/I4Li5lr, jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
tamtosiamto

Cytat

majkel152 napisał(a):



no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile


do syrenki ktos wlozyl silnik od porsche i smiga 300kmh, ale czy kazdy potrafi to zrobic?
nic nie mam
 
majkel152

Cytat

tamtosiamto napisał(a):

Cytat

majkel152 napisał(a):



no czytanie forum się kłania :E przy zmodzonym loaderze ze sterownikami ekstra i lanem realteka, wystarczy być ciut bardziej cierpliwym i poczekać ok 5min i się pojawia w asystencie Smile asrock j3455-itx dyski hdd i ssd nvme cache śmigajo, świetnie działa z serwami supermicro /asus / dell r220 np i tez na ibm x3650 m4 Smile


do syrenki ktos wlozyl silnik od porsche i smiga 300kmh, ale czy kazdy potrafi to zrobic?


no tak, zapomniałem, że ludzie dzisiaj czytać nie umieją, a ze zrozumieniem to już w ogóle dramat :E
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com/I4Li5lr, jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
shibby
trochę nie ładnie tak wpadać i najeżdżać na mnie że mam problemy z czytaniem ze zrozumieniem. Bo zgoła inaczej by wyglądało jakbyś zapytał "a odczekałeś 5min bo ten typ tak ma?".

Odpowiedziałbym: tak czekałem.

Więc proszę powstrzymaj się następnym razem od uszczypliwych uwag.

Jedyne co muszę sprostować to:

Cytat

Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.


Jednak 2 zestawy nie ruszyły. Na jednym Haswellu mi działa.

Cytat

~# cat /proc/cpuinfo | grep 'model name'
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
shibby załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez shibby dnia 07-01-2021 08:23
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
majkel152

Cytat

shibby napisał(a):

trochę nie ładnie tak wpadać i najeżdżać na mnie że mam problemy z czytaniem ze zrozumieniem. Bo zgoła inaczej by wyglądało jakbyś zapytał "a odczekałeś 5min bo ten typ tak ma?".

Odpowiedziałbym: tak czekałem.

Więc proszę powstrzymaj się następnym razem od uszczypliwych uwag.

Jedyne co muszę sprostować to:

Cytat

Najwięcej problemów miałem z Haswellem (4-gen CPU). Trzy zestawy i żaden nie ruszył w najnowszej wersji.


Jednak 2 zestawy nie ruszyły. Na jednym Haswellu mi działa.

Cytat

~# cat /proc/cpuinfo | grep 'model name'
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz
model name : Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz



Masz rację, przepraszam, będę się starał Smile

napisz jaki loader używasz
nie znam się na tym ^^

kupię coś fajnego
sieć domowa:
router z pfsense https://imgur.com/I4Li5lr, jakieś dziwne urządzenia , ups, światłowody, apeki i działa miło Smile
 
liv6
Witam; czy mógł byś podać konkretnie jakie płyty główne działają ,oczywiście te które testowałeśWink
 
moorgan
Ja mam xpenology na płycie advantech mio-5272 z procesorem Intel Core i7 6600U. W pełni pasywne chłodzenie i ma 2 karty lan (GbE1: Intel i219, GbE2: Intel i210).
Udało mi się ją całkiem niedrogo dostać. Soft od DS918+
Synology RT2600
DS215+
 
aviko
moim zdaniem nie ma czegos takiego ze nie pojdzie, wszystko jest kwestia odpowiedniej konfiguracji. osobiscie postawilem kilkanascie xpeno na kadlubkach z laptopow ktore dostalem za darmo albo za przyslowiowe srubki, moze byc bez matrycy albo z wyrwanym zlaczem od klawiatury, czesto plyta ma wlutowany na stale procesor i/lub ram a jesli jeszcze ma haslo na biosie to jako czesc zamienna ktora da sie sprzedac jest kompletnie bezwatosciowe. np taki thinkpad t440s, wiadomo ze nie bedzie to jakis super nas a co najwyzej przydatne miejsce do zrzucania archiwum swoich zdjec czy innych plikow ktore chcemy miec poza pecetem, nawet nie musi byc publicznego ip, osobiscie uskuteczniam w polaczeniu z dropboxem w darmowej wersji, ustawiona synchronizacja z kontem dropboxa w jedna strone, to co sie pojawi na koncie dropboxa - np zrobione zdjecie telefonem od razu pojawia sie na dysku sieciowym, jak konto db sie robi pelne - usuwam z dropboxa a na xpenology zostaje bo tu raczej miejsca mi nie zabraknie. dzieki temu mieszcze sie w limicie 3 urzadzen podpietych na dropboxie, kiedys tego limitu nie bylo. bardzo ale to bardzo w pierwszej fazie konfiguracji przydaje sie port szeregowy, z chwila kiedy zaladuje sie loader z pendrajwa ekran komputera na kotrym postawione jest xpenology przestaje cokolwiek wyswietlac i kompletnie nie wiadomo co sie tam dzieje. a na konsoli widac wszystko, podobnie jak po podpieciu uarta do routera. jak poszlo i pojawil sie w synology asistant to super, jesli nie to dzialamy po omacku, moze to a moze tamto. jesli trafi sie plyta/procek ktoremu z jakiegos powodu jest kompletnie nie po drodze z dsm zostaje opcja wirtualki, np esxi, czy chocby dla proby zainstalowane xpenology na virtualboxie na swoim pececie, tak zaczynalem swoja przygode xpenology
oczywiscie apetyt rosnie w miare jedzenia, zeby miec serwer plex i transcoding musimy miec procesor ktory to wspiera - stad wiekszy problem z odpaleniem loadera ds918 na jakims byle parchu. ja np bardzo lubie "Fujitsu PRIMERGY TX120 S3" male, tanie, 2 porty lan + trzeci do zdalnego dostepu, mozemy zalogowac sie na wylaczona maszyne, sprawdzic cos w biosie, wlaczyc/wylaczyc. zeby nie marnowac portow na switchu mozna ustawic port od ipmi czy jak to sie nazywa jako wspoldzielony z jednym z lanow. wiadomo ze za 300zl szalu nie bedzie, trzeba dokupic ram i dobrze zmienic proca bo jest slaby ale dzialac bedzie, wszystkie przestarzale nasy ktorych wczesniej uzywalem np ds210j (nawet juz nie obslugiwal dsm v6.x, po wyedytowaniu modelu w konfigu przyjal soft od 211j ale proc jest tam tak mizerny ze chyba nawet na virtualboxie mi to smigalo o niebo lepiej), wszelakiej masci wd mybooki z siecia a fuj, jakies qnapy czy iomega kupiona pozniej przez lenovo to kompletnie nie ta liga nie wspominajac o lacie. teraz stoja sobie na polce jako kolekcja jak to kiedys bylo Smile https://xpenology.com/forum/forum/36-tutorials-and-guides/ tu masz na konkretnych konfiguracjach wszystko ladnie rozspisane, jest tam tez temat gdzie ludki wrzucaja swoje konfiguracje wraz z wersja loadera/dsm na ktorej poszlo.
prosze mnie zle nie zrozumiec, to nie moj sprzet i kompletnie nie mam interesu w jego sprzedazy, jesli ktos szuka czegos na serwerek i nie przeszkadza mu ze obudowa jest podniszczona albo plastik pekniety to moge ponegocjowac i wyrwac cos grubo ponizej cen z allegro
ja sam sie nawet boje ich odwiedzac bo niemal zawsze wracam z jakims sprzetem - nie moge sie powstrzymac Smile

obrazki.elektroda.pl/2856356400_1610405386_thumb.jpg obrazki.elektroda.pl/2257686700_1610405382_thumb.jpg obrazki.elektroda.pl/1361394300_1610405382_thumb.jpg obrazki.elektroda.pl/1445784200_1610405392_thumb.jpg obrazki.elektroda.pl/7628645500_1610405396_thumb.jpg
 
shibby

Cytat

czy mógł byś podać konkretnie jakie płyty główne działają ,oczywiście te które testowałeś


Gigabyte GA-A170M-D3H
MSI Z87A-G43

Te dwie używam obecnie, loader najnowszy + extrasy + obraz dla DS918+. W obu też działa LAN 10GbE Edimax EN-9320TX-E i muszę powiedzieć że jest moc

bpccdn.fra1.digitaloceanspaces.com/original/3X/e/5/e556364999d1d97265d817f04398e0d5a5a12d60.png
kopiowanie z macierzy 6x SAS (RAID10) na iSCSI (Xpenology)

Z małych płyt to np Gigabyte GA-H61N-USB3 (dokładnie z tej recenzji https://openlinksys.info/forum/viewth...d_id=14668).

Testowałem też kilka poleasingów ale dokładnych modeli nie pamiętam. Najwięcej problemów miałem z Delle Optiplex 790 (takim małych, SFF). Na nim nic nie chciało mi wystartować. Ale podejmę może jeszcze raz temat. Może wsadzę inną sieciówką i zobaczę.
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
czarnydb
Cześć,

autor wątku zachęcił do proszenia o pomoc więc proszę :-)

Jakieś 2 lata temu postawiłem XPEnology na obrazie chyba DS3615xs (wersja DSM 5.2-5644) - (a przynajmniej tak model widzę po zalogowaniu do XPEnology).

Do budowy NASa użyłem płyty GA-J1900N-D3V (rev. 1.x)
[img]https://static.gigabyte.com/StaticFile/Image/Global/bf98e7066f46caaf6debaa11b4235f56/Product/9725/png/500[/img]
8GB RAMu + dysk WD Red 3TB i WD Red 2 TB

niestety powyższa płyta główna ma pewną wadę :-( ma tylko 2 wejścia SATA!
Zapragnąłem dołożyć do NASa przynajmniej jeden dysk... walają się po biurku to czemu ich nie wykorzystać :-)

dokupiłem zatem kartę rozszerzeń PCI&PCI Express Card z 4 dodatkowymi złączami SATA... i niestety system nie widzi podłączonych do niej dysków :-(
[img]https://a.allegroimg.com/s1024/0c8fa4/5d68984e44e3bb4c498466d5e0f3[/img]

Jakiś pomysł jak to rozwiązać?

Pozdrawiam
Daniel
 
Adooni
czy jak wpiszesz

lspci -k
to "widzi" Twoja karte PCI-E?
UPC 300/20 Mb/s + Connect Box(bridge)
Asus RT-AC68U (RT-AC56U CFEmod) @1200/800 (CFE 1.0.2.0) | AsusWRT-Merlin RT-AC68U_386.3_2+amtm
HPE MicroServer gen8: Xeon E3-1265Lv2, 16GB (2x KTH-PL316E/8G), HP 331T, 4x4TB WD RED, SSD,
 
shibby
@czarnydb - myślę, że trzeba by zacząć od aktualizacji... czyli nowy loader i skoczyć do 6.2.3. Do loadera dograć extrasy.

Oczywiście migrację trzeba wykonać krokowo, najpierw 6.1, później 6.2. Tu pierwszy step
https://xpenology.com/forum/topic/797...ns-loader/

oczywiście warto na wszelki wypadek zabezpieczyć wszystkie dane. Jak masz wolny dysk i pendrive to spróbowałbym na nich czystej instalacji 6.2.3 by upewnić się że ci sprzęt ruszy - miałem przypadek gdzie 6.1 + starszy loader działał a najnowszy loader już nie.

Ja Xpenology zacząłem się interesować jakiś rok temu i nie wiem jak z obsługą sprzętu było wcześniej na DSM 5.x

PS ja w dwoch przypadkach używam kontrolerów PERC H310 i H710, oczywiście przerobione na HBA (czyli karta sata a nie kontroler raid) i na najnowszym DSM6.2.3 z najnowszym loaderem śmigają jak głupie.

Połączony z 14 stycznia 2021 11:26:35:
dzisiejszy przypadek "walki" z Xpenology. Pacjent: HP EliteDesk 800 G1 z procesorem i5-4570.

Na pierwszy strzał loader 1.03b + extras + soft DS3615xd. Efekt: asystant nie wykrywa urządzenia. LAN w HPku to Intel I217-LN. Natrafiłem na taki post:

https://xpenology.com/forum/topic/126...ment=92294

Cytat

I tryed some more times, and I'm sure the i217(i217-LM) is not working.


Wsadziłem jakiegoś Broadcoma dual-port ale też nie ruszyło. Następnie (z racji tego że to Haswell) spróbowałem loader 1.04b dla DS918+ + extrasy (wyraźnie większe, więc mają więcej modułów). Ruszyło... zarówno na intelu, jak i na Broadcomie.
shibby załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez shibby dnia 14-01-2021 11:26
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
czarnydb

Cytat

Adooni napisał(a):

czy jak wpiszesz

lspci -k
to "widzi" Twoja karte PCI-E?


trudno mi to ocenić :-)
w załączeniu prtsc z wynikiem polecenia

Połączony z 14 stycznia 2021 19:03:20:

Cytat

shibby napisał(a):

@czarnydb - myślę, że trzeba by zacząć od aktualizacji... czyli nowy loader i skoczyć do 6.2.3. Do loadera dograć extrasy.

Oczywiście migrację trzeba wykonać krokowo, najpierw 6.1, później 6.2. Tu pierwszy step
https://xpenology.com/forum/topic/797...ns-loader/

oczywiście warto na wszelki wypadek zabezpieczyć wszystkie dane. Jak masz wolny dysk i pendrive to spróbowałbym na nich czystej instalacji 6.2.3 by upewnić się że ci sprzęt ruszy - miałem przypadek gdzie 6.1 + starszy loader działał a najnowszy loader już nie.

Ja Xpenology zacząłem się interesować jakiś rok temu i nie wiem jak z obsługą sprzętu było wcześniej na DSM 5.x

PS ja w dwoch przypadkach używam kontrolerów PERC H310 i H710, oczywiście przerobione na HBA (czyli karta sata a nie kontroler raid) i na najnowszym DSM6.2.3 z najnowszym loaderem śmigają jak głupie.

Połączony z 14 stycznia 2021 11:26:35:
dzisiejszy przypadek "walki" z Xpenology. Pacjent: HP EliteDesk 800 G1 z procesorem i5-4570.

Na pierwszy strzał loader 1.03b + extras + soft DS3615xd. Efekt: asystant nie wykrywa urządzenia. LAN w HPku to Intel I217-LN. Natrafiłem na taki post:

https://xpenology.com/forum/topic/126...ment=92294

Cytat

I tryed some more times, and I'm sure the i217(i217-LM) is not working.


Wsadziłem jakiegoś Broadcoma dual-port ale też nie ruszyło. Następnie (z racji tego że to Haswell) spróbowałem loader 1.04b dla DS918+ + extrasy (wyraźnie większe, więc mają więcej modułów). Ruszyło... zarówno na intelu, jak i na Broadcomie.


czyli nie pozostaje nic innego jak postawić XPEnology na nowo :-(
trochę się tego "boje"... dawno to robiłem, nie wiem czy pamiętam jak to zrobić :-)
poza tym jak pomyślę o całej ponownej konfiguracji wszystkiego...

a jak dyski wyjme i ponownie je włożę w "nowym" systemie to je wykryje? czy trzeb będzie je ponownie formatować i kopiować dane?
czarnydb załączono następujące plik:
Nie masz uprawnień, by zobaczyć załączniki w tym wątku.

Edytowany przez czarnydb dnia 14-01-2021 19:03
 
shibby
wydaje mi się że można z zachowaniem danych ale też nigdy z tak starej wersji nie aktualizowałem.
Router: EdgeRouter ER-12
Switch: Ubiquiti US-8-150W
Wi-Fi: Ubiquiti UAP-AC-Pro + U6-Lite
NAS: Xpenology DS918+
Serwer: Dell 3040M
 
mosfit
Jeśli nowy loader wykryje że na dysku jest synology ,to będzie możliwość migracji przed instalacją więc nic nie szkodzi sprawdzić . Większość ustawień będzie zachowana po migracji
Router- Ubiquiti USG-Pro-4 (FTTH)
Lan- Ubiquiti Switch US-8-150W
Wifi- UniFi AP-AC-Pro + UAP + 2x Ap OpenWrt 21.02
Nas- XPEnology DS918+ i5-6400, 16GB ram, 3x 2TB/RAID5, SSD-512gb cache _controller unifi_Pi-hole_Home Asistan
 
Przejdź do forum
Zaloguj
Wprowadź adres e-mail lub nazwę użytkownika

Hasło



Nie masz jeszcze konta? Zarejestruj się.

Zapomniałeś/aś hasła?
Aktualnie online
· Gości online: 5

· Użytkowników online: 0

· Łącznie użytkowników: 24,053
· Najnowszy użytkownik: jas7o
Czat
Musisz się zalogować, aby opublikować wiadomość.

maxikaaz
21-11-2021 17:35
@man1 to puść sobie to światło do piwnicy, stamtąd wypuść skrętkę jakimś pionem wentylacyjnym do mieszkania.

man1
21-11-2021 12:55
juz mam odpowiedz - w przypadku uslugi ftth 900/300 na laczach Orange nie moga tego puscic oficjalnie konwerterem na skretke.

man1
19-11-2021 20:25
czy są tu posiadacze ftth od tmobile? Mieszkam w starym bloku i nie moge wprowadzic swiatlowodu do lokalu, wiec chcialbym by uzyli konweretra na skretke. A tego zrobic podobno nie mogą...

jurekk
05-11-2021 14:27
Ponoć ax82u ma mieć port RMerlina, sam Merlin o tym mowil to mzoe byc najbardziej ekonomiczna wersja

AdrianAdi
05-10-2021 23:03
Przymierzam się do kupna takiego i mam kilka pytań z tym zwoązanych

AdrianAdi
05-10-2021 23:02
Jest tu kto?

AdrianAdi
05-10-2021 22:59
Witam mam pytanie odnośnie routerów gamingowych do ps4 czyli konsoli

Maniek91PL
04-09-2021 10:34
Wink super ! Dzięki ! Adooni ! już testuje co i jak

Adooni
04-09-2021 06:31
sprawdzasz w status - overview, a zmieniasz w Basic - Network

Maniek91PL
03-09-2021 22:37
jak sprawdzić i zmienić kanał w wifi 2.4 w tomato ? Shock

46,458,894 unikalnych wizyt